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This guide describes the interface between Baan data and Hyperion Enterprise,
and Hyperion Pillar.

The guide is divided into the following sections:

n About HyperionReady Interface for Baan
n Export Data from Baan
n Importing Data to Hyperion Enterprise
n Importing Data to Hyperion Pillar
n Transferring Data From Hyperion Pillar to Baan
n Appendix A ASCII file formats

About this document
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The HyperionReady™ Interface for Baan application integrates Hyperion
Software’s® core products with Baan’s financial applications. Baan offers a
transaction-based ERP package and Hyperion Software offers several financial
solutions for reporting, consolidation, budgeting, and financial analysis that
compliment Baan Finance.

The goal of HyperionReady Interface for Baan is to provide predefined data
extracts from Baan that can be used by Hyperion Software applications.
Specifically, with HyperionReady Interface for Baan Release 2.8 you can
perform the following tasks:

n Export actual and budget data from Baan’s General Ledger (GLD) and
Financial Budget System (FBS) modules and import the data into Hyperion
Enterprise. Hyperion Enterprise performs financial data consolidation and
reporting.

n Export actual and budget account balances, as well as dimension information,
from Baan’s GLD and FBS modules and import the data into Hyperion Pillar.
Hyperion Pillar uses this financial data for advanced budgeting and planning.

n After you complete your budget processing within Hyperion Pillar, you can
transfer the final budget data back into Baan’s Financial Budget System for
further use within the Baan system.

You can also consolidate, report, budget, and analyze your data on your
Hyperion Software product, while continuing to process transactions in Baan
Finance.

This document covers the steps that you perform to export data from Baan for
import into Hyperion Enterprise, and Hyperion Pillar, and to transfer data from
Hyperion Pillar back to Baan.

1 About HyperionReady Interface for
Baan
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Baan Finance Features
Baan Exchange is capability within the Baan ERP suite that enables you to
extract data from Baan. In HyperionReady Interface for Baan, you use the
exchange tools to export Baan financial data in the form of sequential ASCII
files that can then be loaded into your Hyperion Software products.

The interface utilizes both the General Ledger (GLD) and the Financial Budget
System (FBS) modules within Baan. The GLD module is the core of Baan
Finance. All ledger accounts and balances are stored in this module. The FBS
module allows for maintenance of budget information in Baan Finance.

Hyperion Software Product Features
The following sections describe the core products available from Hyperion
Software to which you can import your Baan data.

Hyperion Enterprise

You can use Hyperion Enterprise to enhance the financial consolidation and
reporting available from within Baan Finance. Hyperion Enterprise allows for
flexibility in performing partial or full consolidations. The product supports
complex consolidations, and easily handles issues such as partial ownership,
eliminations, and currency translations. Hyperion Enterprise has a built-in
financial intelligence concerning accounting rules and financial standards to offer
your customers additional consolidation capabilities not currently offered by
Baan.

Hyperion Pillar

Hyperion Pillar manages the enterprise-wide budgeting and planning process.
Hyperion Pillar complements the existing financial systems in your company and
completes the financial management cycle of planning, acting, and analyzing. It
supports the budget process and permits top-down and bottom-up capabilities not
currently offered in Baan Finance.
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Data Export
You perform the export of the Baan data in Baan Exchange. After you define
your exchange schemes, you specify the financial data for which you want to
export, and then you use Baan Exchange to perform the export. Financial data
available for export from Baan includes metadata, such as the chart of accounts,
dimensions, currency codes, and budget codes, and actual data, such as account
balances from the General Ledger module and budget data from the FBS module.
You can also use HyperionReady Interface for Baan to bring your budget data
from Hyperion Pillar into the Baan FBS module.

Data Import
Hyperion Software products support different tools to import financial data from
Baan. Hyperion Enterprise uses LedgerLink. Hyperion Pillar does not require a
specific tool. You can import files directly to Hyperion Pillar.

About This Document
This document includes instructions on how to install and export your actual,
budget, and metadata from Baan.

System Requirements
This section provides the general system requirements for running Baan with
Hyperion Software products. HyperionReady Interface for Baan Release 2.8
exchange scripts work with the following versions of Baan:

n Triton 3.1b, Baan IVa - UNIX
n Baan IVb, Baan IVc – UNIX and Windows NT
n BaanIVc4 – UNIX and Windows NT
n BaanERP V.0b – UNIX and Windows NT
n BaanERP V.0c – UNIX and Windows NT

HyperionReady Interface for Baan Release 2.8 requires the system
configurations shown in the following table.
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Hyperion Software requirements
Hyperion Software Product Hyperion Link Hyperion Platform

Hyperion Enterprise SE 4.2.2 + LedgerLink 1.2 Windows 3.1,
Windows 95, or
Windows NT

Hyperion Enterprise XA 4.6.1 + LedgerLink 1.2 Windows 95,
or Windows NT

Hyperion Pillar Release 3 + Not Applicable Windows 3.1,
Windows 95, or
Windows NT

Required Files

The following files are required to install the hypgen, HYPENT, HYPPIL, and
HYPIMP exchange schemes in Baan.

For Triton 3.1B and Baan IVa install:
n HYPGEN31B_4A_4B_4C.ZIP or HYPGEN31B_4A_4B_4C.TAR

n EXC31B_4A.ZIP or EXC31B_4A.TAR

For BaanIVb and BaanIVc install:
n HYPGEN31B_4A_4B_4C.ZIP or HYPGEN31B_4A_4B_4C.TAR

n EXC4B_4C.ZIP or EXC4B_4C.TAR

For BaanIVc4 install:
n HYPGEN4C4.ZIP or HYPGEN4C4.TAR

n EXC4C4.ZIP or EXC4C4.TAR

For BaanV.0b install:
n HYPGEN50B.ZIP or HYPGEN50B.TAR

n EXC50B.ZIP or EXC50B.TAR

For BaanV.0c install:
n HYPGEN50C.ZIP or HYPGEN50C.TAR

n EXC50C.ZIP or EXC50C.TAR
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Conversion Files

The conversion files transfer the data files from the server to a specified local
drive, rename the files with the appropriate extension, and remove the invalid
characters.

Windows NT Server

Window NT Conversion Files
Hyperion Product Conversion Files

Hyperion Enterprise HYPENTNT.BAT

FTPENTNT.DAT

Hyperion Pillar Hyppillarnt.bat

Ftppillarnt.dat

Unix server

UNIX Conversion Files
Hyperion Product Conversion Files

Hyperion Enterprise HYPENTUNIX.BAT

FTPENTUNIX.DAT

Hyperion Pillar HyppillarUNIX.bat

FtppillarUNIX.dat
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Introduction
The export of Baan data to Hyperion Enterprise, and Hyperion Pillar requires
exchange schemes. The exchange scheme codes you use are:

n To extract the financial data from Baan to Hyperion Enterprise: HYPENT
n To extract the financial data from Baan to Hyperion Pillar: HYPPIL
n To transfer budget data from Hyperion Pillar to the Baan FBS

module:HYPIMP

The exchange schemes contain the required ASCII files, ASCII file formats, and
condition scripts for transferring data between Baan and your Hyperion Software
products.

You load the hypgen exchange scheme into Baan first. After you load the hypgen
exchange scheme, it is used to import the product-specific exchange schemes
into Baan Exchange. After the schemes are loaded into Baan Exchange, you can
run data exports as often as required.

Here are the steps required for setting up exchange schemes and exporting data
in Baan:

1 Install HyperionReady Interface for Baan.
2 Specify your base company ID.
3 Load the hypgen exchange scheme.
4 Import the product-specific exchange schemes.
5 Create import and export scripts.
6 Run the exchange scheme.

You install and set up the exchange schemes once. For subsequent exports, you
can update the data parameters and then run the export.

2 Export Data from Baan
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Install HyperionReady Interface for Baan
You receive a CD-ROM that contains the software required to set up your
exchange schemes. The HYPGEN.* and EXC.* files contain the parameters and
exchange schemes that you load into the Baan Exchange module.

If you previously installed the hypgen exchange scheme, you must delete it from
the system before you attempt to reinstall the scheme. Similarly, if you encounter
any errors during the setup of any of the exchange schemes, we recommend that
you delete the schemes and then start from the beginning of the exchange scheme
setup. To delete exchange schemes, see the Deleting Exchange Schemes topic in
this chapter.

You define several directories on the server before you copy the compressed
*.ZIP or *.TAR files. The following table shows the directories that are required
for standard exchange scheme processing.

Exchange Scheme Directories
Description Directory

Exchange objects Hypobj

Condition error files Hyperr

Sequential files Hypseq

Definition files Hypdef

Exchange schemes Hypgen

You must select the ASCII option if you FTP the files.
Use caution when unzipping or moving the files. Type the file names in the case
in which they appear, and do not truncate or change the file names. For example,
some FTP utilities change the case of the file name. Confirm that the case
remains consistent with the original file after the FTP process.

This document explains the the installation instructions for BaanERP V.0c
version of Baan. For installation instructions of other versions of Baan, please
refer to the following documents present on the CD :

Version of Baan Product Document

Baan 3.1b, IVa, IVb, IVc and IVc4 rel2_v3.pdf, rel2_v4.pdf and
whats_new.pdf

BaanERP V.0b rel2.5.pdf. Also refer to documents
rel2_v4.pdf and whats_new.pdf

NOTE

NOTE
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To install HyperionReady Interface for Baan:

1 Unzip the relevant HYPGEN*.ZIP or HYPGEN*.TAR file based on the
version of Baan that you are using.

2 Unzip the relevant EXC*.ZIP or EXC*.TAR file based on the version of
Baan that you are using.

3 Create the following directories on the server:
− Path:\hypgen
− Path:\hypobj
− Path:\hyperr
− Path:\hypseq
− Path:\hypdef

where Path is the drive and directory that contains the Baan application
software.

4 Copy the following files from the HYPGEN*.* file based on the version of
Baan that you are using, to the \hypgen directory.
− ttuxch001xxx.F
− ttuxch002xxx.F
− ttuxch003xxx.F
− ttuxch004xxx.F
− ttuxch005xxx.F
− ttuxch006xxx.F
− ttuxch008xxx.F
− ttuxch009xxx.F
− ttuxch010xxx.F
− ttuxch011xxx.F
− ttuxch012xxx.F
− ttuxch013xxx.F
− ttuxch014xxx.F
− ttuxch017xxx.F
− ttuxch021xxx.F
− ttuxch022xxx.F
− ttuxch031xxx.F
− ttuxch032xxx.F
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5 Copy the following files from the EXC*.* based on the version of Baan that
you are using, to the \hypseq directory.
− HYP.SEQ
− tuxch001
− tuxch002
− tuxch003
− tuxch004
− tuxch013
− tuxch014
− tuxch021
− tuxch022
− tuxch031
− tuxch032

Specify Your Base Company
After you copy the HyperionReady Interface files to the Baan server, you can log
in to Baan and begin setting up your exchange schemes. You must select one
company to which you install the exchange schemes. The specified company is
used throughout the setup process and you must be logged to this company
before you perform each step.

To specify your base company:

1 Log in to Baan.
2 Select Options > Change Company.
3 In the Company edit box, specify the base company ID.
4 Select OK.

Hypgen Exchange Scheme Setup
You load the hypgen exchange scheme into Baan Exchange so you can set up the
HYPENT, HYPPIL, and HYPIMP exchange schemes. You load the hypgen
exchange scheme by performing the following steps.

1 Create and reorganize tables.
2 Verify that the hypgen exchange scheme has been generated.
3 Specify the Company ID for the Import batch.
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Create and Reorganize Tables

You create and reorganize tables using the supplied hypgen exchange files. The
create tables process loads the files that were copied into the HYPGEN directory
into tables. The tables define the format of the hypgen exchange scheme. If you
previously created the exchange tables in another Baan application, this step
loads the hypgen exchange scheme into Baan Exchange.

You use the Create Tables From Sequential Dump session to create the tables.
You must complete Tabs 1 and 2 on the Baan Tools Create Tables From
Sequential Dump session.

The following figure shows a sample Create Table From Sequential Dump
session – tab 1 Details.

Figure 1  Create Table from Sequential Dump
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You then selecttab 2 Files and specify the name given to the error files created
during this session. The following figure shows a sample Create Table from
Sequential Dump – tab 2 Files.

Figure 2  Create Tables from Sequential Dump

You then reorganize the data that is loaded into the tables. The following figure
shows a sample Reorganize Tables session.

Figure 3  Reorganize Tables
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To create and reorganize tables:

1 From the Baan Menu Browser, select BAANERP Tools > Database
Management > Database Utilities > Create Table From Sequential Dump.

Create Table from Sequential Dump is session ttaad4227m000.

2 In the Form 1 tab perform the following tasks:
− Select Create Tables For Different Company.
− Specify your base company ID in the Create Tables For Different

Company field.
− Select the following options:

Append if Table Exists
Overwrite Duplicate Records from Dump
Create Rows before Index
Disable Domain Constraints
Ignore Referential Integrity Constraints.

If the system diplays messages telling you to run the Reorganize Tables
session, select OK.

3 In the Form 2 tab perform the following tasks:
− Select the following options:

Sequential File has Fixed Record Length
− Type path:\hypgen in the Directory for Searching Table Files field,

where Path is the drive and directory you created on the server.

4 Select the Form 2 tab, then specify a name for the error file in the Name of
the Error File field.5
Do one of the following:
− Select Create
− If your version of Baan does not bring you to the Reorganize Tables

dialog box when you select Continue, go to the Baan Menu browser and
select BAANERP Tools > Database Management > Database Utilities
> Reorganize Tables.

Reorganize Tables is session ttaad4225m000

5 Type the base company ID in the Company To and From fields in the
Reorganize Tables session.

Your base company ID is the company to which you install the Hyperion
Ready Interface exchange schemes.

6 Type tu in the Package fields.

tu is the abbreviation for the Baan Exchange module.

NOTE

NOTE

NOTE

NOTE

NOTE



Export Data from Baan

HyperionReady Interface for Baan

2-8

7 Type xch001 in the From Table field, and type xch999 in the To Table field

8 Select Reference Integrity and repair Reference Counter.

All other fields must remain deselected.

9 Select Reorganize

10 Select Close when the busy message no longer appears at the bottom of the
Reorganize Tables session.

11 Select Close from the Create Tables From Sequential Dump session.

NOTE:
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Verify Generation of hypgen Exchange Scheme

You can confirm that the table has been created and the hypgen exchange
scheme is set up. You open the Baan Utilities Maintain Exchange Schemes
session to view the parameters for the hypgen exchange scheme. Under the
hypgen exchange scheme, the path edit boxes must point to the drive and
directory paths you created on the server.

The following figure shows a Exchange Schemes session.

Figure 4  Exchange Schemes
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Change the Company ID for the Import Batch

You then open the Baan Exchange > Master Data > Batches session to verify that
the Import batch exists and to change the company ID for the Import batch. The
Import batch is predefined in the hypgen exchange scheme and is required to
import the HYPENT, HYPPIL, and HYPIMP exchange schemes into the Baan
Exchange tables.

You must change the displayed company ID to your base company ID for each
batch. The following figure shows a Batches session.

Figure 5  Batches
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To verify that the hypgen exchange scheme has been generated, the
Import batch exists, and to change the base Company ID for the
Import batch:

1 From the Baan Menu Browser, select Baan Exchange > Master Data >
Exchange Schemes.

Exchange Schemes is session tuxch0101s000.

2 Do one of the following:
− If hypgen appears in the exchange Scheme field, change the four Path

fields to the drive and directory paths you created on the server.

− If the hypgen scheme does not appear, select the arrow toolbar icons until
it appears in the exchange scheme field.

If you do not find the hypgen scheme, review the error file. The error file is
located in the directory you specified in the Create Table From Sequential
Dump session.

Figure 6  Exchange Schemes

Leave the Separator edit box blank. If this field contains a character, you will
encounter errors when you try to import the HYPENT, HYPIMP, and
HYPPIL exchange scheme files.

3 Do the following:
− Select Special > Batches from the specific menu.

NOTE

TIP

WARNING
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Batches is session tuxch0104m000.

4 Confirm that IMPORT and EXPORT in the Batch field for the hypgen
exchange scheme.

5 Change the Company edit box ID next to Import and Export to your base
Company ID.

Figure 7  Batches

Your base company is the company to which you install the HyperionReady
Interface exchange schemes.

6 Save the changes in the Batches session.

7 Save the changes in the Exchange Schemes session.

Load the Product-Specific Exchange Schemes

The HYPENT and HYPPIL exchange schemes define the format of the Baan
data that you export into Hyperion Enterprise, and Hyperion Pillar. The HYPIMP
exchange scheme defines the format for the Hyperion Pillar data that you export
into Baan.

Perform the following tasks to import the product-specific exchange schemes
into Baan Exchange:

n Create the hypgen import script.
n Load the product-specific exchange schemes.
n Confirm that the HYPENT, HYPPIL, and HYPIMP exchange schemes have

been imported and specify the correct paths.
n Change the base company ID for the exported batches.

NOTE

NOTE
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Create the hypgen Import Script and Import the Product-
Specific Exchange Schemes

You create the hypgen import script to create a compiled version of the hypgen
exchange scheme. The system uses the compiled version of the exchange scheme
to import the HYPENT, HYPPIL, and HYPIMP exchange schemes into Baan
Exchange. You create the import script in the Baan Exchange > Create Import
Programs session.

The following figure shows a sample Create Import Programs session.

Figure 8  Create Import Programs

After you create the import programs, you can import the product-specific
exchange schemes into Baan Exchange. You import the exchange schemes with
the Baan Exchange > Import Module > Import Data (Non-Regular) session.
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The following figure shows a sample Import Data (Non-Regular) session.

Figure 9  Import Data (Non-Regular)

To create the import scripts and import the exchange schemes:

1 From the Baan Menu Browser, select Baan Exchange > Import Module >
Create Import Programs.

Create Import Programs is session tuxch0227m000.

2 Type hypgen in the Exchange Scheme From and To fields.

3 Type IMPORT in the Batch From and To fields.

Figure 10  Create Import Programs

IMPORT and hypgen are case-sensitive.

NOTE

NOTE
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4 Select Create.

5 Do the following:
− Select Import Data

Import Data (Non-Regular) is session tuxch0223m000.

6 Type Yes in the Overrule Batch Company edit box, then type your base
company ID.

7 In the remaining fields, use the default values as indicated in the Import Data
(Non-Regular) Session figure.

Figure 11  Import Data (Non-Regular)

8 Select Import Data.

9 Select OK.

10 Select Log Table.

Ensure that the values in the fields Error Rej. , Cond Rej. and Records
Skipped are all zero for all the tables. If not, than you must Import Data
once again.

11 Select File > Exit

12 Select Cancel from the Import Data (Non-Regular) session.

13 Select Close from the Create Import Programs session.

NOTE
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Confirm Import of the Product-Specific Exchange
Schemes

After you import the product-specific exchange schemes, you open the Baan
Exchange Maintain Exchange Scheme session to confirm that the HYPENT,
HYPPIL, and HYPIMP exchange schemes appear in the exchange schemes list.
You then specify the names of the directories that you created on the server.

The directories are shown in the following table.

Exchange Scheme Directories
Description Directory

Exchange objects hypobj

Condition error files hyperr

Sequential files hypseq

Definition files hypdef

The following figure shows a sample Maintain Exchange Schemes session.

Figure 12  Exchange Schemes
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To confirm import of the product-specific exchange schemes:

1 From the Baan Menu Browser, select Baan Exchange > Master Data >
Exchange Schemes.

Exchange Schemes is session tuxch0101s000.

2 Select the desired exchange scheme in the Exchange Scheme session, and
select OK.

You can use the arrow icons to search for exchange schemes.

3 Specify the path names you created on the server in the path name fields in
the Exchange Schemes session.

4 Use the default value that appears in the Separator field.

If you are importing data to Hyperion Pillar and have commas within the
descriptions, you must change the delimiter to a pipe character ( | ). Failure to
change the delimiter to a pipe causes the commas in the descriptions to be
used as delimiters, and you will encounter errors when you attempt to import
the file.

5 Select File > Save

NOTE

TIP:

NOTE
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Change the Company ID for the Exported Batches

For each batch in each product-specific exchange scheme, change the displayed
company ID to your base company ID. You use the Baan Exchange Maintain
Batches session to verify that all of the required batches exist and to change the
company ID.

The following figure shows a Batches session.

Figure 13  Batches

To change the company ID:

1 Do the following:
− Select Special > Batches from the Special menu.

Batches is session tuxch0104m000.

2 In the Company ID column next to each batch, change the displayed
company ID to your base company ID.

3 Select File > Save + Exit from the Maintain Batches session.

4 Select Close from the Maintain Exchange Schemes session.

Create Import and Export Programs
To transfer data between Baan and Hyperion Enterprise, and Hyperion Pillar,
you must create import and export programs. Import and export programs are
compiled versions of the product-specific exchange schemes. The system uses
the compiled versions of the exchange schemes to import and export data from
Baan.

NOTE
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Create an Import Program for Hyperion Pillar
You create an import program to import the Hyperion Pillar data into the Baan
FBS module. You create the import program using the Baan Exchange Create
Import Programs session.

The following figure shows a sample Create Import Programs session.

Figure 14  Create Import Programs

To create an import script for Hyperion Pillar:

1 From the Baan General Menu, select Baan Exchange > Import Module >
Create Import Programs.

Create Import Programs is session tuxch0227m000.

2 Type HYPIMP in the Exchange Scheme From and To fields.

3 Type IMPORT in the From and To fields.

4 Select Create.

5 Select Close when the Ready message appears at the bottom of the screen.

NOTE:
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Create Export Programs for the Product-Specific
Exchange Schemes

You create the export programs in the Create Export Programs session. After the
export programs are created, you can export data for Hyperion Enterprise, or
Hyperion Pillar using the HYPENT and HYPPIL exchange schemes.

The following figure shows a Create Export Programs session.

Figure 15  Create Export Programs

To create an export program for the product-specific exchange schemes:

1 From the Baan Menu Browser, select Baan Exchange > Export Module >
Create Export Programs.

Create Export Programs is session tuxch0228m000.

2 Type HYPENT and HYPPIL in the From and To Exchange Scheme fields
to create export programs for Hyperion Enterprise, and Hyperion Pillar.

You can use default values for the Batch From and To fields. The default
values are blank for the From field, and ZZZZZZ for the To field. This
generates the export scripts for all exchange schemes.

3 Select Create.

4 Select Close when the Ready message appears on the bottom of the screen.

NOTE

NOTE
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Data Export
After you set up the product-specific exchange schemes, you can export your
data from Baan using the exchange schemes. After the Baan files are exported,
you must convert the data files into a format that Hyperion Enterprise, or
Hyperion Pillar can recognize.

Here are the steps that you perform to export data from Baan:

n Specify the data parameters for export.
n Run the export.
n Convert and transfer the data files.

BaanERP V.0c

Using the Baan Finance Import From/Export To Hyperion Product session, you
specify your target product, then you specify the data export parameters based on
the type of data you are exporting.

The following figure shows a sample Import from/ Export To Hyperion Products
session.
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Figure 16  Import from or Export to Hyperion Products

To run the exchange schemes:

1 From the Baan Menu Browser, select Baan Finance > General Ledger >
Inquiries and Reports > Import From/Export To Hyperion Products.

Import/Export to Hyperion Products is session tfgld3204m000.

2 Type or select Export in the Type of Exchange field.

3 Type or select Enterprise, or Pillar in the Hyperion Product field.

4 Type of select the data type you are exporting.

5 Type or select the physical company ID from which you are exporting data.

If you select a physical company that shares tables with other companies, and
leave the Company To fields blank, the data for all companies that share the
tables with that company is exported. You can also specify a range of
companies within that physical company to export.

6 Complete the remaining fields, then select Continue.

The remaining fields are conditional depending on the type of data you are
exporting.

NOTE

NOTE:

NOTE:
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Baan IVc

Baan IVc has a different session for exporting data. If you have BaanIVc, you
can install the 4C_SESSION_PATCH from the HyperionReady Interface for
Baan CD-ROM present under the sub-directory PATCHES under the directory
Baan31b_4a_4b_4c.

Baan IVc4

Baan IVc4 has a different session for exporting data. If you have BaanIVc4, you
can install the HYPPATCH.DMP file from the HyperionReady Interface for
Baan CD-ROM present under the sub-directory PATCHES under the directory
BaanIVc4.

BaanERP V.0b

BaanERP V.0b has a different session for exporting data. If you have
BaanERPV.0b, you can install the HYPPATCH.DMP file from the
HyperionReady Interface for Baan CD-ROM present under the sub-directory
PATCHES under the directory BaanV.0b.

Installing and Copying Dumps for BaanIVc,
BaanIVc4 and BaanERP V.0b
You need to install the correct dumps from the correct directory under which
they are present for the version of Baan that you are using.

To copy the dumps for BaanIVc:

n Create the following directory on the server
− Path:\hyppatch\tfB40_c

where Path is the drive and directory that contains the Baan application

n Copy the files under the directory BAAN31B_4A_4B_4C\ PATCHES\
4C_SESSION_PATCH on to this directory.

To copy the dumps for BaanIVc4 and BaanERP V.0b:

n Create the following directory on the server
− Path:\hyppatch

where Path is the drive and directory that contains the Baan application

n Copy the files from the directory BAAN1VC4\ PATCHES for BaanIVc4 or
from the directory BAANV.0B\ PATCHES on to this directory
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To extract the dumps for BaanIVc4 and BaanERP V.0b:

1 Run the sesion Import Patch (ttiex1284m000).

2 In the Pathname Patch File specify : Path\hyppatch, where Path is the drive
and directory that contains the Baan Application.

3 The Path Runtime Directory defaults to $BSE/application. Leave it as it is.

4 Select the Extract Only check box.

5 Set the Path to extract to as : Path\hyppatch, where Path is the drive and
directory that contains the Baan Application.

6 Click on the Import Button.

The session will import the patch to a sub-directory tfB50_b_wrk for
BaanERPV.0b and to a sub-directory tfB40_c5_dev for BaanIVc4. This sub-
directory will be created under the directory Path\hyppatch.
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To install the dumps for BaanIVc, BaanIVc4 and BaanERPV.0c:

1 Run the session Import ttiex1285m000

2 In the Path Sequential Dumps give the following :
− Path\hyppatch\tfB40_c for BaanIVc
− Path\hyppatch\tfB40_c5_dev for BaanIVc4
− Path\hyppatch\tfB50_b_wrk for BaanERPV.0b

3 The Path Runtime Directory defaults to $BSE/application. Leave it as it is.

4 Check the Overwrite, Overwrite Helptext links and Write software
components in other Package VRC buttons.

5 Select the Package VRC under which you want to install the dumps

6 Click the Import Button.

Deleting Exchange Schemes
If previous versions of HyperionReady Interface for Baan are installed, we
recommend that you delete the hypgen, HYPENT, HYPPIL, HYPIMP Exchange
Schemes from Baan and then reinstall them. Similarly, if you encounter any
errors during the setup of any of the exchange schemes, we recommend that you
delete the schemes and then start from the beginning of the exchange scheme
setup.

After you delete your exchange schemes, you can confirm that they have been
deleted using the Baan Exchange Maintain Exchange Scheme session. If you
deleted all your exchange schemes, the Maintain Exchange Scheme session will
be blank. If you deleted a specific exchange scheme, search for that specific
exchange scheme to verify that it no longer exists.
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After all exchange schemes are deleted, you can then reinstall them. Follow the
instructions beginning with hypgen Exchange Scheme Setup in this chapter. If
you only deleted a specific exchange scheme, with the exception of the hypgen
exchange scheme, follow the instructions beginning with the Creating Import and
Export Programs topic in this chapter.

The following figure shows a sample Delete Exchange Scheme session:

Figure 17  Delete Exchange Scheme

To delete exchange schemes:

1 From the Baan Menu Browser, select Options > Change Company.

2 In the Company field, specify your base company ID.

Your base company is the company for which you installed HyperionReady
Interface.

3 Select OK.

4 Select Baan Exchange > Miscellaneous > Tools > Delete Exchange
Scheme.

Delete Exchange Scheme is session tuxch0222m000.

NOTE

NOTE
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5 Use the following figure to complete the Delete Exchange Scheme session
for each exchange scheme you wish to delete.

Figure 18  Delete Exchange Scheme

Leave the Exchange Scheme From edit box blank and type ZZZZZZZ in the
Exchange Scheme To edit box to delete all exchange schemes from the
system.

6 Select Continue.

7 Select Close when the Ready ,message appears at the bottom of the screen

8 From the Baan Menu Browser, select Baan Exchange > Master Data >
Exchange Schemes.

Maintain Exchange Schemes is session tuxch0101m000.

9 Confirm that the specified exchange schemes no longer appear.

10 Select File > Exit.

NOTE:

NOTE
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The HyperionReady Interface transfers actual and budget data from Baan
Finance to Hyperion Enterprise. A Hyperion Software consultant can assist with
the loading of the metadata and the creation of the Hyperion Enterprise
application.

You use Hyperion LedgerLink to import the actual and budget data into
Hyperion Enterprise. In LedgerLink, you create a template that maps the Baan
names and accounts to the Hyperion Enterprise names and accounts. The
template can be reused, but may have to be updated if the data or metadata
changes.

This is the process you follow the first time you import data to Hyperion
Enterprise:

n Export the HYPENT exchange scheme.
n Convert the data files.
n Create Hyperion Enterprise application.
n Use LedgerLink to import the data files.

Subsequent imports only require that you export the HYPENT exchange scheme,
transfer and convert the files, and load the data into Hyperion Enterprise. You
must, however, maintain the application. For example, if a new account is added,
you must add the account in the application.

Export the HYPENT Exchange Scheme
To import data from Baan, you export the HYPENT exchange scheme from
Baan Exchange. For more information on exporting the HYPENT exchange
scheme, see the Exporting Data from Baan chapter.

Transfer and Convert the Data Files

The export program extracts the files BBALL.SEQ, ACTUAL.SEQ, and
BUDGET.SEQ. These files contain the beginning balances, actual data, and
budget data. Before you can import the extracted data files into Hyperion
Enterprise, you must convert some of the data files into a standard Enterprise
format. You run a provided batch file to transfer and convert the data files. The
batch file transfers the files to a specified directory and converts the .SEQ files to
GLO files, which is the format required by LedgerLink.

3 Importing Data to Hyperion Enterprise
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Hyperion Enterprise Data Files

These files are exported from Baan.

Baan Data Files used by Hyperion Enterprise
File Name Data Type Contents

ACTUAL.SEQ Actual Actual amounts and
quantities

BBALL.SEQ Beginning balance Beginning balances
BUDGET.SEQ Budget Budget amounts and

quantities

HYPENT Batch File

There are different batch files for the UNIX and Windows NT servers. The batch
file name for UNIX is HYPENTUNIX.BAT, and the batch file name for
Windows NT is HYPENTNT.BAT. Use the appropriate batch file for your
operating system.

The HYPENT batch file transfers the data files from the HYPSEQ directory to
the local drive from which you run the batch file and converts the exported
sequential (.SEQ) files to .GLO files.

FTPENT.DAT File

You use the FTPENT(UNIX or NT).DAT to define your server login and your
password, and to specify the directory path and file names of your data files.
When you run the HYPENT*.BAT file, the FTPENT*.DAT file launches FTP,
and transfers the files from the server to the specified drive.

Here is a sample file:

baanid

baanpsw

cd /opt/app/baan/hypseq

get actual.seq

get bball.seq

get budget.seq

quit

You must update the first three rows with your login ID, password, and the
directory to which you export your files. The directory path is the path in which
your exported sequential files reside.
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The following table describes the first records of the FTPENT*.DAT file.

FTPENT(UNIX or NT).DAT File
Record Description

baanid Login ID
baanpsw Password
cd /opt/app/baan/hypseq Directory Path of the exported

sequential files
get actual.seq Command to find the actual sequential

file
get bball.seq Command to find the beginning

balance sequential file
get budget.seq Command to find the budget

sequential file
quit Quits the DOS program

CONVERTER.BAT File

The CONVERTER.BAT program runs the following files.

n CONVERTER.DAT
n FILES.LST
n ICT.EXE

CONVERTER.DAT File

You edit the CONVERTER.DAT to define your server login and your password,
and to specify the directory path and file names of your data files. When you
execute the CONVERTER.BAT file, the CONVERTER.DAT file launches FTP
and transfers the files from the serve to the local drive. Here is a sample file :

baanid

baanpsw

cd /opt/app/baan/hypseq

get actual.seq

get bball.seq

get budget.seq

get curr.seq

get dim1.seq

get dim2.seq

get dim3.seq

get dim4.seq

get dim5.seq
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get ownchacc.seq

get ownbud.seq

get owndim1.seq

get owndim2.seq

get owndim3.seq

get owndim4.seq

get owndim5.seq

quit

The following table describes the CONVERTER.DAT file.

CONVERTER(UNIX or NT).DAT File
Record Description

baanid Login ID
baanpsw Password
cd /opt/app/baan/hypseq Directory Path of the exported

sequential files
get actual.seq Command to find the actual sequential

file
get bball.seq Command to find the beginning balance

sequential file
get budget.seq Command to find the budget sequential

file
….. …..
quit Quit the DOS program

You must edit the three rows of the CONVERTER.DAT file with your login ID,
password, and the path to the directory to which you export your files. The
directory path is the path to the directory in which you save your Baan data files.

FILES.LST File

The FILES.LST file defines the element, ownership and translation files. The
ICT.EXE program reads the list file to convert the Baan metadata files and data
files : ACTUAL.DAT, BBALL.DAT and BUDGET.DAT

We strongly recommend that if you must change a filename, that you change it
after the export from Baan and after you run the conversion process.

The files in the provided FILES.LST file correspond to the predefined names of
the exported Baan files. The conversion program will not successfully execute if
you change the names of any of the predefined names.

NOTE
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ICT.EXE File

If there are duplicate acount IDs after the invalid characters are removed, the
program appends a letter A-Z to the end of each duplicate.

For example, if the original record is :

@123|Company 123

*123|Company1231

the program converts the records to :

_123|Company 123

_123|Company1231

If there are duplicates, then the program converts the records to:

_123A|Company123

_123B|Company1231

This proess reviews and appends letters A-Z five times. If there are still
duplications after the fifth verification, the duplications appear in a file labeled
DIM*.C01 or OWN*.C01.

If any *.C01 files are generated, you must open the *.C01 file and edit the
duplications in the Baan file corresponding to the .C01 file on the server
manually. The following table shows the DIM*.C01 files and the corresponding
exported Baan files that they represent.

DIM*.C01 File Mapping

Dim* Files Corresponding Baan Export Files

DIM01.C01 COMPANY.SEQ

DIM04.C01 CHACC.SEQ

DIM05.C01 BUDG.SEQ

DIM06.C01 DIM1.SEQ

DIM07.C01 DIM2.SEQ

DIM08.C01 DIM3.SEQ

DIM09.C01 DIM4.SEQ

DIM10.C01 DIM5.SEQ

DIM11.C01 CURRENCY.SEQ

For example, if the DIM10.C01 file is generated, the DIM5.SEQ file in Baan has
more than five account ID duplications. You must open the DIM5.SEQ file and
edit the account Ids manually. You then can rerun the CONVERTER.BAT file.
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The ICT.EXE program then verifies that the metadata files do not exceed the
maximum Hyperion Enterprise limitation of 32,000 line items. If a file exceeds
32,000 line items, the conversion stops, and a message displays indicating that
the file exceeded the Hyperion MBA 32K limitation.

You can determine which file exceeded the 32,000 limit by reviewing the
directory from which the batch file was run. You will see the names of the
processed files up to and including the file that failed. The file that exceeds
32,000 is displayed with a size equal to zero(0) KB. Make the necessary changes
to the files on the server and rerun the HYPMBA.BAT file.

After the conversion is complete, a message appears that tells you that the
conversion is successful.

Modify and Run the HYPENT Batch File

The FTPENT*.DAT, HYPENT*.BAT, FILES.LST, ICT.EXE
CONVERTER.BAT and CONVERTER.DAT files contained on the CD-ROM
are read-only files. Before you can modify these files, you must change the read-
only status. Here are the steps required to change the read-only status, modify,
and run the HYPENT*.BAT file:

To modify and run the HYPENT*.BAT file:

1 Copy the HYPENT*. BAT, FTPENT*.DAT, FILES.LST, ICT.EXE,
CONVERTER.BAT and CONVERTER.DAT files from the CD-ROM to a
local client directory. The HYPENT.BAT file transfers the data files from the
Baan server to this directory.

2 Open Windows Explorer or File Manager.

3 For all the files, do the following:
− Browse for the file and select the right mouse button.
− Select Properties from the option list.
− In the Attributes section, deselect the Read Only check box.
− Select Apply, then select Close.

4 Open the FTPENT*.DAT file.

Because the FTPENT*.DAT file is a text file, the password appears on the
screen as text and not asterisks. Ensure that you consider security
implications when opening this file.

5 Change the server login and the password, and specify the directory path and
file names of your data files.

NOTE
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Make sure there are no additional spaces following the login ID or password,
or the file will not execute.

6 Select the HYPENT*.BAT file and select the right mouse button.

7 Select Edit.

8 Specify the IP address in the fifth line. For example, in the sample below, you
overwrite the 139.64.54.47 with your IP address.

ftp -v -i -s:ftpentnt.dat 139.64.54.47

9 Select File > Save, then select File > Close.

10 Select the CONVERTER.DAT file, then select the right mouse button.

11 Select Edit

12 Specify the IP address in the eighth line. For example, in the sample below,
you overwrite the 139.64.54.47 with your IP address.

ftp –v –i -s :ftpendtnt.dat 139.64.54.47

13 Select File > Save, then select File > Exit

14 Run the HYPENT*.BAT file.

15 Review the *.TRA files for duplicate records.

16 Do one of the following :
− If the number of duplicate records is small, you can either edit the files

manually or run the CONVERTER.BAT file.

− If there are a large number of duplicates, we recommend that you run the
CONVERTER.BAT file.

NOTE
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Create an Enterprise Application
Your Hyperion Software consultant can assist you in setting up the Enterprise
application. After the application is created, you can use LedgerLink to map the
data elements from the transferred Baan files to the data elements that you define
in the Hyperion Enterprise application. For more information on creating
Hyperion Enterprise applications, see the Setting Up Applications chapter in the
Hyperion Enterprise Administrator’s Guide.

Use LedgerLink to Import the Data Files
After you create the dimensions in your Hyperion Enterprise application, you use
LedgerLink to map the Baan dimensions to these Hyperion Enterprise
dimensions. These steps are required only when you initially set up the
application, however, you can modify them as necessary:

n Define LedgerLink templates.
n Define LedgerLink translations.
n Define translate and load profiles.
n Load data to Hyperion Enterprise.
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Define LedgerLink Templates

For the Baan files, you set up a minimum of two LedgerLink templates. You can
set up one template for budget data, and a single or separate templates for
beginning balance and actual balance data. At least two files are needed because
the ASCII files that contain beginning balance and actual data information have
the same format, while the budget file has an extra data element to identify, the
budget code. You can use the LedgerLink Template wizard to define the field
relations in the ASCII file with the dimensions in Hyperion Enterprise.

To define a LedgerLink template:

1 In LedgerLink, select GL Template Wizard, then select New.

2 Select Select Sample File.

3 Select Table Extract.

4 Browse for each data (.GLO) file, then select OK.

5 Select Next.

6 Select the first record in the View Of edit box, then select Next.

7 Select Delimited - Characters such as commas or semicolons separate
each field.

8 Highlight the delimiter and change it to the character you selected as a
delimiter for your application, then select Next.

9 Select the column that contains the company ID, which is the first column,
and drag it to the Name field.

10 Select the column that contains the account, which is the second column, and
drag it to the Account field.

11 Select the columns that contain data, which starts in the ninth column, and
drag the data amounts to the Data field.

12 Select Finish.

13 Type a name for your template, then select OK.

14 To create another template, go to Step 1.

15 Select Close to close the module.
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Define LedgerLink Translations

You use the Translation Builder module in LedgerLink to map the data (.GLO)
file dimensions from Baan to the dimensions in the Hyperion Enterprise
application.

You define the name translation for entities, then you define the account
translations. You can use wildcards and ranges. Using ranges and wildcards can
help minimize maintenance of translation mapping when you update dimensions
in Baan or your Hyperion Enterprise applications. The following figure shows a
sample account translation.

Sample Account Translation session

Figure 19 Sample Account Translation session

To define LedgerLink translations:

1 In LedgerLink, select Translation Builder.

2 Select File > New.

3 Select Options > Name Translation, then select File > New.

4 Map the companies in the Baan files to the names in the Hyperion Enterprise
application.
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5 Select File > Save As. Type a file name with the extension .LNT, then select
OK.

6 Select Options > Account Translation, then select File > New.

7 Map the accounts in the Baan files to the accounts in the Enterprise
application.

8 Select File > Save As. Specify a file name with the extension .LAT, then
select OK.

9 Select File > Close.

Define Translate and Load Profiles

You must define a profile for each data file you import into a template. The
profile populates the template with the data to be loaded to Hyperion Enterprise.
You specify the following items in the profile:

n The source output file
n The template that you want the system to use
n The Hyperion Enterprise data category, periods, and loading options

To define translate and load profiles:

1 In LedgerLink, select Translate and Load Profiles, and do one of the
following:
− Select New if you are defining a new profile.
− Select Edit if you are using an existing profile.

2 On the Translate panel, browse for, or specify the following items:
− Output file. The file extension is .GLO.
− Load file. The file extension is .DAT.
− Name of the template
− Name translation file. The file extension is .LNT.
− Account translation file. The file extension is .LAT.

3 Select Create Enterprise Load File.

4 Select one of the following loading options:
− Translate G/L file and load to Enterprise, to translate the profile and

create a load file.
− Translate G/L file only, to translate the profile into an Enterprise load

file, but do not create a load file.
− Load Translated G/L file to Enterprise only, to create a load file only.

5 Select OK.
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6 Select the Load tab and specify the following options:
− Category
− Start period
− End period

7 If you selected the first or third Load option from Step 4, select a mode and
data view.

8 Select OK.

9 Enter a profile name, and select OK.

10 Select Close.

Load to Hyperion Enterprise

You selected a loading option for each profile to tell the system what to do when
you select Load to Hyperion Enterprise.

If you chose to Translate G/L file and load to Enterprise, you select File > Load
to translate the file and load the load file into the Hyperion Enterprise
application.

If you chose to Translate G/L file only, you select File > Load to create a load
file only. You must go into Hyperion Enterprise to load the load file into the
application.

If you chose to Load Translated G/L file to Enterprise only, you select File >
load to load the load file into the Hyperion Enterprise application.

To load to Hyperion Enterprise:

1 At the LedgerLink Desktop, select Load to Hyperion Enterprise.
2 Select a load profile, and select File > Load.
3 Repeat step 2 for each profile in the list.
4 Select File > Close.
5 At the LedgerLink Desktop, select File > Exit.

For information on the CONVERTER.BAT Files, please refer to Appendix A –
Conversion Program File Descriptions of the document “whats_new.pdf”. The
logic used for converting files

NOTE
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You can transfer actual, budget, opening balance, and application structure
(metadata) from Baan to Hyperion Pillar. You can import data to Hyperion Pillar
by following these basic steps.

n Export the HYPPIL exchange scheme.
n Load the setup (metadata) information.
n Load the actual and budget data files.

When importing data into a previously defined Hyperion Pillar report, we
recommend that you delete the line items for the previous periods, and then
import all of the actuals up to the current month. For example, you would delete
the line items from January and February, and then import the data for January,
February, and March. This is a standard Hyperion Pillar approach, and is faster
than using the update matching line items import.

Baan exports the immediate parent of an account to Hyperion Pillar. You can use
the METADATA CONVERSION.XLS spreadsheet provided on your
HyperionReady Interface for Baan CD-ROM to create hierarchial relationships
in Pillar. The spreadsheet allows you to convert the single-level relationships into
multi-level hierarchies. For more information, see the Import Multiple
Dimension Levels topic later in this chapter.

During the export, if you specify 0 as the From Period in the Actual Assets or
Liabilities files, an extra Beginning Balance column is included on the report. If
you select period 0 through 1, the HYPPIL exchange scheme exports two amount
values: one for the beginning balance and one for the year-to-date amount for
period 1. The Beg Bal column appears between the Company Number and
Periods columns.

Export Hyperion Pillar Data from Baan
You export the data from Baan Exchange using the HYPPIL exchange scheme.
For more information on exporting the HYPPIL exchange scheme, see the Data
Export topic in the Exporting Data from Baan chapter.

4 Importing Data to Hyperion Pillar



Importing Data to Hyperion Pillar

HyperionReady Interface for Baan

4-2

Transfer the Data Files
The export program extracts the beginning balances, actual data, budget data, and
metadata files from Baan. You transfer the data files by modifying and then
running a provided batch file to transfer the files to a specified location.

Baan Data Files

These files are exported from Baan.

Baan Data Files used by Hyperion Pillar
File Name Data Type Contents

ASSP.SEQ Actual Asset

EXPP.SEQ Actual Expense

LIABP.SEQ Actual Liability and equity

REVP.SEQ Actual Revenue

BBLIABP.SEQ Actual Beginning Balance
Liability and Equity

BBASSETP.SEQ Actual Beginning Balance Asset
BASSP.SEQ Budget Budget asset

BEXPP.SEQ Budget Budget expense

BLIABP.SEQ Budget Budget liabilities and equity

BREVP.SEQ Budget Budget revenue

COMPANYP.SEQ Setup data Companies

CHACCP.SEQ Setup data Chart of accounts

CURRP.SEQ Setup data Currency

DIM1P.SEQ Setup data Dimension 1

DIM2P.SEQ Setup data Dimension 2

DIM3P.SEQ Setup data Dimension 3

DIM4P.SEQ Setup data Dimension 4

DIM5P.SEQ Setup data Dimension 5

HYPPILLAR Batch File

There are different batch files for the UNIX and Windows NT servers. The batch
file name for UNIX is HYPPILLARUNIX.BAT, and the batch file name for NT
is HYPPILLARNT.BAT. Use the appropriate batch file for your operating
system.



Importing Data to Hyperion Pillar

HyperionReady Interface for Baan

4-3

You execute the HYPPILLAR*.BAT file to define the IP address of the server.
The batch file executes the FTPPILLAR*.DAT file in which you define your
server login and your password, and specify the directory path and file names of
your data files. The batch file then places the exported Baan files on your local
drive.

FTPPILLAR.DAT File

You use the FTPPILLAR*.DAT to define your server login and your password,
and to specify the directory path and file names of your data files. When you
execute the batch file, the FTPPILLAR*.DAT file launches FTP and transfers
the files from the server to the local drive. Here is a sample file:

Baanid

baanpsw

cd /opt/app/baan/hypseq

get assp.seq

get expp.seq

get liabp.seq

get revp.seq

get bbliabp.seq

get bbassetp.seq

get bassp.seq

get bliabp.seq

get brevp.seq

get chaccp.seq

get currp.seq

get dim1.seq

get dim2.seq

get dim3.seq

get dim4.seq

get dim5.seq

quit

You must update the first three rows with your login ID, password, and the
directory to which you export your files. The directory path is the path in which
your exported sequential files reside.
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The following table describes the first four rows of the FTPPILLAR*.DAT file.

FTPPILLAR*.DAT file
Record Description

baanid Login ID

baanpsw Password

cd /opt/app/baan/hypseq Directory Path

get assp.seq Command to find sequential file

...

...

....

get dim5p.seq Command to find the dim5.seq sequential
file

quit Quits the DOS program

To modify and run the batch file:

1 Copy the HYPPILLAR*.BAT and FTPPILLAR*. DAT files from the CD-
ROM to a local client directory. The HYPPILLAR.BAT file transfers the
data files from the Baan server to this directory.

2 Open Explorer or File Manager.

3 For both the HYPPILLAR*.BAT and FTPPILLAR*.DAT files, do the
following:
− Select the file once and select the right mouse button.
− Select Properties from the option list.
− In the Attributes section, deselect the Read Only check box.
− Select Apply, then select Close.

4 Open the FTPPILLAR*.DAT file.

Because the FTPPILLAR.DAT file is a text file, the password appears on the
screen as text and not asterisks. Ensure that you consider security
implications when defining this file.

5 Change the server login and the password, and specify the directory path and
file names of your data files.

Make sure there are no additional spaces next to the login ID or password, or
the file will not execute.

6 Select File > Save, then select File > Exit.

7 Select the HYPPILLAR*.BAT file and select the right mouse button.

NOTE

NOTE
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8 Select Edit.

9 Specify the IP address in the sixth line. For example, in the sample below,
you overwrite the 123.45.67.891 with your IP address.

ftp -v -i -s:ftpfile.dat 123.45.67.891

10 Select File > Save, then File > Exit.

11 Run the HYPILLAR*.BAT file.

Load the Setup Data into Hyperion Pillar
You extract the metadata from Baan to set up the Hyperion Pillar reports. The
setup data is your company, currencies, chart of accounts, and dimension
elements.

You can import the following setup data files into Hyperion Pillar:

n COMPANYP.SEQ
n CHACCP.SEQ
n CURRP.SEQ
n DIM1P.SEQ - DIM5P.SEQ

The chart of accounts, cost center, and revenue center are required dimensions.
You must select one of the five exported Baan dimensions for your cost center
and one of the five dimensions for your revenue center. You can use the same
Baan dimension for both Cost Center and Revenue Center. The company
information, COMPANYP.SEQ, is also an additional dimension in Hyperion
Pillar. If Budget Code is a desired additional dimension, it would need to be
defined as one of the additional dimensions as well.

You can customize the dimension labels in Hyperion Pillar to match the name of
the dimension in Baan. However, if you use the same dimension extract for both
Cost Center and Revenue Center, each should have a unique label in Hyperion
Pillar.

Before you import attributes into Hyperion Pillar, you must first define them for
each dimension file. For information, see the Hyperion Pillar Help.
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If you import actual data from more than one company into a single Hyperion
Pillar report, you must set up an additional Hyperion Pillar dimension in which
to define Companies. Similarly, if you include budget data for more than one
budget code, then you must set up an additional Hyperion Pillar dimension in
which to define Budget codes. If you would like the end-user to be required to
enter budget code information, you set up these additional dimensions in the
Customization module as Required Dimensions.

The account type is a required column for all account IDs. The Baan Exchange
translation process automatically assigns an account type to each account ID. The
exchange session assigns a Hyperion Pillar account type based on the following
table.

Equivalent Account Types
Baan Account Type Pillar Account Type

Profit and Loss (Credit) Revenue

Profit and Loss (Debit) Expense

Balance Sheet (Credit) Liability

Balance Sheet (Debit) Asset

There may be exceptions to the account types shown in the previous table. We
recommend that you review the Line Item columns in Hyperion Pillar and adjust
them accordingly.

To load the setup data into Hyperion Pillar:

1 In the Configuration module, open a currency report and select File >
Import.

2 Browse for the CURRP.SEQ file, and select OK. The column order must be:
− Symbol
− Name

3 Select File > Save to save the currency report.

4 Open an Account report and select File > Import.

5 Browse for the CHACCP.SEQ file, and select OK. The column order must
be:
− Account ID
− Account
− Type
− Level
− Parent

NOTE
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6 Open the Cost Center dimension, and select File > Import.

7 Browse for the dimension file, and select OK. The column order must be:
− CC ID
− Cost Center
− CC Level
− CC Parent
− CC Type

8 Open the Revenue Center dimension, and select File > Import.

9 Browse for the dimension file, and select OK. The column order must be:
− Rev ID
− Revenue Center
− Rev Level
− Rev Parent
− Rev Type

10 Repeat step 9 for the remaining Baan dimensions that you want to include in
your budgeting and planning model. Import any additional dimensions used
from Baan into the additional dimensions in Hyperion Pillar.

Import Multiple Dimension Levels
You can import multiple dimension levels into Hyperion Pillar by modifying the
spreadsheet to convert the data and importing the new spreadsheet into a
Hyperion Pillar report.

Convert the data

You can use the METADATA CONVERSION.XLS file to convert your
exported data into multiple hierarchies. You can modify the spreadsheet if your
chart of accounts contains more or less than the number of records included.

To add cells, you must copy the formulas from the existing cells into the
additional cells into the first two worksheets. If you have more than five parent
levels in your chart of accounts structure, you can add more parent columns to
the worksheets. Then you adjust the formulas to reflect the cell references.

To import multiple dimension levels:

1 In Excel, select File > Open, and open the spreadsheet template.

2 Select the sample data in the columns that are colored blue, then select Edit >
Clear > Contents.
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3 In Excel, open the chart of accounts sequential file (CHACCP.SEQ), select
the data, then select File > Copy.

Open the CHACCP.SEQ file as a comma delimited file.

4 In the template, select the first blue cell, then select Edit > Paste Special.

5 Select Values, then select OK.

6 If your chart of accounts file contains less than the total number of records in
the spreadsheet or less than 5 parent levels, do the following:
− Select the contents of the rows in which no data appears and press Delete.
− Select the contents of the columns in which no data appears and press

Delete.

7 If your chart of accounts file contains more than the number of records in the
spreadsheet or more than 5 parent levels, do the following:
− Select the rows containing the desired formulas in the first spreadsheet,

then select Edit > Copy.
− Select the cells for which you have additional records, and select Edit >

Paste.
− Select the columns containing the desired formulas in the second

spreadsheet, then select Edit > Copy.
− Select the cells for which you have additional records, and select Edit >

Paste.
− Edit the formulas, as required.

8 Press F9 to calculate the formulas.

9 Save the file as a text file as a comma delimited file with the extension .CSV.

Import the Spreadsheet

After you add your data to the spreadsheet and recalculate the formulas, you can
import the spreadsheet to a Hyperion Pillar report.

To import the spreadsheet:

1 In Excel, delete the first heading row.

2 Select File > Save, then File > Close.

3 Open an Account report and select File > Import.

NOTE
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4 Browse for the CHACCP.CSV file, and select OK. The column order must
be:
− Account ID
− Account
− Type
− Level
− Parent

Load Actual and Budget Data into Hyperion
Pillar
The actual files are summarized at the Account, Cost Center, and Revenue
Center level for each Hyperion Pillar module. Assets and liabilities are always
exported in year-to-date (YTD) values and include beginning balances for
Actuals, and imported in periodic values for Budgets.

Expenses and revenues are always exported in periodic values for both Actuals
and Budgets. Beginning balances are always included in the Assets and
Liabilities for Actuals, regardless if you select period 1 through 12 or period 4
to 5.

The actuals files are shown in the following table.

Actual Data Files
Baan Source File Name File Description

ASSP.SEQ Assets

LIABP.SEQ Liabilities and equities

EXPP.SEQ Expenses

REVP.SEQ Revenues
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The budget files are shown in the following table.

Budget Data Files
Baan Source File Name File Description

BASSP.SEQ Assets

BLIABP.SEQ Liabilities and equities

BEXPP.SEQ Expenses

BREVP.SEQ Revenues

Import the Actual Data

The following steps show the procedure for importing the actual data to
Hyperion Pillar.

To import the actual data:

1 Create a report for each module in Hyperion Pillar and select File > Import.

2 Import each actual file in the following column order:
− Acct ID
− CC ID (or Rev ID)
− Dim1 ID
− Dim2 ID
− Dim3 ID
− Dim4 ID
− Line Item
− Company Number
− <Periods>

If you exported period 0, you need an extra column on the report for beginning
balance. The column must be between Company Number and the period
columns.

NOTE
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Import the Budget Data

The following steps show the procedure for importing the budget data to
Hyperion Pillar.

To import the budget data:

1 Create a report in Hyperion Pillar and select File > Import.

2 Create a report and select File > Import. Import the budget sequential files in
the following column order:
− Acct ID
− CC ID (or Rev C ID)
− Dim1 ID
− Dim2 ID
− Dim3 ID
− Dim4 ID
− Line Item
− Currency
− Company Number
− <Periods>

3 The company number must first be set up as an additional dimension prior to
importing the values.
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You can use HyperionReady Interface to export your Hyperion Pillar data to
Baan. You export one budget file for each Hyperion Pillar module: Assets,
Expenses, Liabilities, and Revenues.

Before you import the budget data into Baan, you must convert the files into a
format that Baan can recognize. The Baan-Pillar import function allows you to
modify the descriptor files and convert the files for import. We provide a batch
file which carries out the conversion according to parameters that you define in
the descriptor files. The descriptor files define the mapping between the
Hyperion Pillar and the Baan data. The batch file converts the Hyperion Pillar
output files to one sequential file, BUDGIMP.SEQ.

The following table shows the budget files that are converted into the
BUDGIMP.SEQ file by the import function.

You can name the reports anything you want, but the extension must be .ASC.

Exported Hyperion Pillar Files
Export File Name Descriptor File Name File Description

ASSETS.ASC PILLARASSETS.DES Assets

EXPENSES.ASC PILLAREXPENSES.DES Expenses

LANDE.ASC PILLARLANDE.DES Liabilities and equities

REVENUES.ASC PILLARREVENUES.DES Revenues

5 Transferring Data From Hyperion
Pillar to Baan

NOTE
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Export From Hyperion Pillar
Before you export your Hyperion Pillar report, the following columns must be
included and appear in this order:

n Acct ID
n CC ID (or Rev ID)
n Dim1 ID
n Dim2 ID
n Dim3 ID
n Dim4 ID
n Line Item
n Currency
n Budget Code
n <Periods>

Budget Code must first be set up as an additional dimension prior to importing
the values. To export the data from Hyperion Pillar, open each report, and select
File > Export.

Convert the Data Files
Before you import the budget data, you use the Baan-Pillar import function to
reformat the data files. Here are the steps required to convert the data files using
the Baan-Pillar import function:

n Modify the batch file (CONVERTTOFBS.BAT).
n Modify the descriptor files (FBS*.DES).
n Run the batch file (CONVERTTOFBS.BAT).

When you run the CONVERTTOFBS.BAT file, the Baan-Pillar import function
(BAANPILLAR.EXE) is executed and carries out the conversion according to
the parameters you have defined in the descriptor file and the batch file. It also
converts the exported ASCII files to one sequential file, BUDGIMP.SEQ.
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Modify the Batch File

You must modify the import function batch file. For example, you might want to
change the period, year, beginning period, or the number of periods defined in
the batch file. Here is a sample batch file:

CONVERTTOFBS.BAT

Baanpillar.exe -per 01 -year 1999 -num 12 -def "default  cc"

-in assets.asc -out budgimp.seq -des pillarassets.des -dir

p2b -append

type bpconv.log

Baanpillar.exe -per 01 -year 1999 -num 12 -def "default

cc" -in expense.asc -out budgimp.seq -des pillarexpenses.des

-dir p2b -append

type bpconv.log

Baanpillar.exe -per 01 -year 1999 -num 12 -def "default

cc" -in liability.asc -out budgimp.seq -des pillarlande.des

-dir p2b -append

type bpconv.log

Baanpillar.exe -per 01 -year 1999 -num 12 -def "default

rev" -in revenue.asc -out budgimp.seq -des pillarrevenue.des

-dir p2b -append

type bpconv.log

The -append key takes the data from all exported Hyperion Pillar modules and
combines them into a single output file. The -dir p2b key converts the files from
Hyperion Pillar format to Baan format. The following table shows the key
parameters of the batch file.
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Budget Batch File Key Parameters
Key Description Example

-def Default field for defaulted key
fields

def

-per Starting period number in
output file

01

-year Starting year in output file 1999

-num Number of periods to output 12

-in Input file name ASSETS.ASC

-out Output file name BUDGIMP.SEQ

-des Descriptor file name PILLARASSETS.DES

-log Log file name BPCONV.LOG

-dir Direction of transfer p2b

-append Appends the data in the output
file

Not Applicable

You typically will not need to change the output, descriptor, or log file names.

Modify the Descriptor Files
The descriptor files (.DES file) describe how the Baan-Pillar import function
maps and filters the columns in the Hyperion Pillar files to the Baan files. The
descriptor files also remove the default cost and revenue center values that were
defined in the HYP.SEQ file.

You modify the descriptor files to describe the mapping of the ASCII files to the
sequential files. The following examples show a sample exported ASCII file, a
Baan sequential file, and the descriptor file that defines the mapping of the files.

ASSETS.ASC

"012215","default cc","","","","","Assets","USD","003",

0,0,0,1000,1000,0,0,0,0,0,0,0
"011120","default cc","","","","","Assets","USD","003",

0,0,0,1000,1000,0,0,0,0,0,0,0

BUDGIMP.SEQ

1999,"003","012215","","","","","",1,0.0000

1999,"003","012215","","","","","",2,0.0000

1999,"003","012215","","","","","",3,1000.0000

1999,"003","012215","","","","","",4,0.0000

1999,"003","012215","","","","","",5,-1000.0000

1999,"003","012215","","","","","",6,0.0000
1999,"003","012215","","","","","",7,0.0000

1999,"003","012215","","","","","",8,0.0000
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PILLARASSETS.DES

01, year

03, key, inputquotes,outputquotes

04, defaultkey, inputquotes,outputquotes

05, key, inputquotes,outputquotes

06, key, inputquotes,outputquotes

07, key, inputquotes,outputquotes

08, key, inputquotes,outputquotes

00, ignore

09, period

00, ignore

02, key, inputquotes,outputquotes

10, amount

Each line in the descriptor file describes a field of a record as it appears in the
Hyperion Pillar ASCII file. Each line contains a number character followed by
one or more keyword entries. The number is the output position of the key field
in the corresponding Baan record in the BUDGIMP.SEQ file.

The following table shows the keywords and their descriptions in a descriptor
file.

Descriptor File Key Parameters
Keyword Description

key Hyperion Pillar dimension or attribute

defaultkey Key field where -def parameter is
placed

Amount** Amount field in the Baan record

period Period field in the Baan record

year Year field in the Baan record

ignore Does not appear in the Hyperion Pillar
record

Inputquotes* Specifies that the input field is in
quotes

Outputquotes* Specifies that the output field is in
quotes

* Optional

** Represents multiple fields in the Hyperion Pillar record

You can type comments at the end of a descriptor line by typing two slashes ( // )
and then text at the end of the line.

NOTE
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After you modify the batch file and descriptor files, you must then execute the
batch file. The batch file launches BAANPILLAR.EXE and carries out the
conversion according to the parameters in the descriptor file you have defined.
Execution of this file also converts the ASCII files to one sequential file called
BUDGIMP.SEQ.

To convert the data files:

1 Modify the CONVERTTOFBS.BAT file using a text editor.

2 Modify the *.DES files.

3 Run the CONVERTTOFBS.BAT file.

Import Budget Data into Baan
After you have converted the Hyperion Pillar ASCII files to the BUDGIMP.SEQ
file containing your budget data, you transfer the data file to the HYPSEQ
directory on the Baan server. You can then import the file into Baan using the
HYPIMP exchange scheme.

If you transfer the BUDGIMP.SEQ file to your server using an FTP program,
you must select the ASCII transfer option.

Import Data to BaanERP5.0b

You import the budget data to BaanERP5.0b using the Baan Finance Import
From/Export To Hyperion Products session. You specify the exchange scheme
and the Import batch, and you use the default values for all other options.

NOTE
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The following figure shows a sample Import From/Export To Hyperion Products
session.

Figure 20 Import from/ Export to Hyperion Products

To import data to BaanERP5.0b:

1 From the Baan Menu browser, select Baan Finance > General Ledger >
Inquiries and Reports > Import From/Export to Hyperion Products.

Import From/Export To Hyperion Products is session tfgld3204m000.

2 Type or select Import in the Type of Exchange edit box.

3 Type or select Pillar in the Hyperion edit box.

4 Select or select the data type you are exporting.

5 Complete the remaining fields, then select Continue.

The remaining fields are conditional depending on the type of data you are
exporting.

NOTE

NOTE
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With HyperionReady Interface for Baan, we supply preformatted data extracts
from Baan to be used by Hyperion Software products. You can use the
predefined extracts to import data to Hyperion Enterprise, and Hyperion Pillar.
You can also use HyperionReady Interface for Baan to transfer data from
Hyperion Pillar back to Baan.

You may want to build your own data extracts from Baan by a means other than
Baan Exchange. This appendix details the ASCII files that are created by the
HyperionReady Interface for Baan exchange scripts. You can use these scripts,
or build your own ASCII files with other development tools.

This appendix lists the files you export from Baan, example file formats of the
layouts that can work with Hyperion Enterprise, and Hyperion Pillar, and the
table in Baan from which the file originates. This section also shows you a
sample data record from each ASCII file.

After your data is structured in the specified formats, you can import data into
your target application.

Hyperion Enterprise Import
The tables in this section list the exported ASCII files you use to import Baan
data into Hyperion Enterprise.

Appendix A ASCII file formats
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Exported Baan Files

The following table lists the files used to transfer Baan data to Hyperion
Enterprise. The table lists the file name, description, and source Baan tables.

Exported Baan Files
File Description Sample File Name Baan Table

Actual Balances (All Types) ACTUAL tfgld205

Beginning Balances (Asset/liability) BBALL tfgld206

Budget Amounts and Quantities BUDGET tffbs101

Budget Codes BUD tffbs003

Chart of Accounts CHACC tffbs008

Companies COMPANY tfgld001

Currencies CURR tcmcs002

Dimension type 1 DIM1 tfgld010

Dimension type 2 DIM2 tfgld010

Dimension type 3 DIM3 tfgld010

Dimension type 4 DIM4 tfgld010

Dimension type 5 DIM5 tfgld010

Ownership Budget Codes OWNBUD tffbs003

Ownership - Companies OWNCOMP tfgld001

Ownership - Chart of Accounts OWNCHAC tfgld008

Ownership - Dimension type 1 OWNDIM1 tfgld010

Ownership - Dimension type 2 OWNDIM2 tfgld010

Ownership - Dimension type 3 OWNDIM3 tfgld010

Ownership - Dimension type 4 OWNDIM4 tfgld010

Ownership - Dimension type 5 OWNDIM5 tfgld010

File Formats

The tables in this section list the ASCII format for each exported Baan file used
to import Baan data into Hyperion Enterprise. Each table lists the field number
and name, description, field type, start and length.

Actual Balances (All Types)

The source table for this file is: tfgld205
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Actual Balances
Field Number Field Name Description Attributes

 10  cono Company Code Field Type: Numeric
Start Position: 1
Length: 3

 20  leac Ledger Account Field Type: Alphanumeric
Start Position: 4
Length: 12

 30  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 16
Length: 6

 40  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 22
Length: 6

 50  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 28
Length: 6

 60  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 34
Length: 6

 70  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 40
Length: 6

 80  year Year Field Type: Numeric
Start Position: 46
Length: 4

 90  balamt Balance
Amount

Field Type: Alphanumeric
Start Position: 50
Length: 20

 100  unit1 Unit 1 Field Type: Alphanumeric
Start Position: 70
Length: 3

 110  qty1 Quantity 1 Field Type: Alphanumeric
Start Position: 73
Length: 20

 120  unit2 Unit2 Field Type: Alphanumeric
Start Position: 93
Length: 3

 130  qty2 Quantity 2 Field Type: Alphanumeric
Start Position: 96
Length: 20

 140  atyp Account Type Field Type: Alphanumeric
Start Position: 116
Length: 12
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Field Number Field Name Description Attributes

150 datype Dual
Accounting
Type

Field Type: Alphanumeric
Start Position: 128
Length: 12

 160  inco Intercompany Field Type: Alphanumeric
Start Position: 140
Length: 12

750|011110||||||1999|0|0|0|0|21100|21100|21100|21100|211

00|21100|21100|21100||0|0|0|0|0|0|0|0|0|0|0|0||0|0|0|0|0

|0|0|0|0|0|0|0|Asset|

Beginning Balances (Asset/Liability)

The source table for this file is: tfgld206

Beginning Balances (Asset/Liability)
Field Number  Field Name  Description Attributes

 10  cono Company Code Field Type: Numeric
Start Position: 1
Length: 3

 20  leac Ledger Account Field Type: Alphanumeric
Start Position: 4
Length: 12

 30  dim1 Dimension 1 Field Type: Alphanumeric
Start Position: 16
Length: 6

 40  dim2 Dimension 2 Field Type: Alphanumeric
Start Position: 22
Length: 6

 50  dim3 Dimension 3 Field Type: Alphanumeric
Start Position: 28
Length: 6

 60  dim4 Dimension 4 Field Type: Alphanumeric
Start Position: 34
Length: 6

 70  dim5 Dimension 5 Field Type: Alphanumeric
Start Position: 40
Length: 6

 80  year Year Field Type: Numeric
Start Position: 46
Length: 4

SAMPLE RECORD



ASCII file formats

HyperionReady Interface for Baan

ASCII file formats  - Page 5

Field Number  Field Name  Description Attributes

 90  balamt Balance
Amount

Field Type: Alphanumeric
Start Position: 50
Length: 20

 100  unit1 Unit for
Quantity 1

Field Type: Alphanumeric
Start Position: 70
Length: 3

 110  balqty1 Balance
Quantity 1

Field Type: Alphanumeric
Start Position: 73
Length: 20

 120  unit2 Unit for
Quantity 2

Field Type: Alphanumeric
Start Position: 93
Length: 3

 130  balqty2 Balance
Quantity 2

Field Type: Alphanumeric
Start Position: 96
Length: 20

 140  atyp Account Type Field Type: Alphanumeric
Start Position: 116
Length: 12

 150 datype Dual
Accounting
Type

Field Type: Alphanumeric
Start Position: 128
Length: 12

 160  inco Intercompany Field Type: Alphanumeric
Start Position: 140
Length: 12

750|111000||||||1999|2000||0||0|Asset|

Budget Amounts and Quantities

The source table for this file is: tffbs101

SAMPLE RECORD
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Budget Amounts and |Quantities
Field Number  Field Name Description Attributes

 10  cono Company Code Field Type: Numeric
Start Position: 1
Length: 3

 20  budg Budget Code Field Type: Alphanumeric
Start Position: 4
Length: 3

 30  leac Ledger Account Field Type: Alphanumeric
Start Position: 7
Length: 12

 40  curr Currency of
Budget

Field Type: Alphanumeric
Start Position: 19
Length: 3

 50  dim1 Dimension 1 Field Type: Alphanumeric
Start Position: 22
Length: 6

 60  dim2 Dimension 2 Field Type: Alphanumeric
Start Position: 28
Length: 6

 70  dim3 Dimension 3 Field Type: Alphanumeric
Start Position: 34
Length: 6

 80  dim4 Dimension 4 Field Type: Alphanumeric
Start Position: 40
Length: 6

 90  dim5 Dimension 5 Field Type: Alphanumeric
Start Position: 46
Length: 6

 100  year Year Field Type: Numeric
Start Position: 52
Length: 4

 110  amnt Amount Field Type: Alphanumeric
Start Position: 56
Length: 20

 120  unit1 Unit 1 Field Type: Alphanumeric
Start Position: 76
Length: 3

 130  qan1 Quantity 1 Field Type: Alphanumeric
Start Position: 79
Length: 20
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Field Number  Field Name Description Attributes

 140  unit2 Unit 2 Field Type: Alphanumeric
Start Position: 99
Length: 3

 150  qan2 Quantity 2 Field Type: Alphanumeric
Start Position: 102
Length: 20

 160  atyp Account Type Field Type: Alphanumeric
Start Position: 122
Length: 12

 170  datype Dual Accounting
Type

Field Type: Alphanumeric
Start Position: 134
Length: 12

 180  inco Intercompany Field Type: Alphanumeric
Start Position: 146
Length: 12

750|001|011110|USD||||||1999|0|0|0|0|21100|21100|21100|2

1100|21100|21100|21100|21100||0|0|0|0|0|0|0|0|0|0|0|0||0

|0|0|0|0|0|0|0|0|0|0|0|Asset|

Budget Codes

The source table for this file is: tffbs003

Field Number  Field name  Description Attributes

 10  budg  Budget Code Field Type: Alphanumeric
Start Position: 1
Length: 3

 20  desc  Description Field Type: Alphanumeric
Start Position: 4
Length: 30

 30  curr  Currency Field Type: Alphanumeric
Start Position: 34
Length: 3

BP|new|USD

SAMPLE RECORD

SAMPLE RECORD
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Chart of Accounts

The source table for this file is: tffbs008

Chart of Accounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  desc Description Field Type: Alphanumeric
Start Position: 13
Length: 30

 30  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 40  datype Dual Accounting
Type

Field Type: Alphanumeric
Start Position: 58
Length: 12

 50  subl Sub-Level Field Type: Numeric
Start Position: 70
Length: 2

 60  uni1 Unit 1 Field Type: Alphanumeric
Start Position: 72
Length: 3

 70  uni2 Unit 2 Field Type: Alphanumeric
Start Position: 75
Length: 3

 80 inco Intercompany Field Type: Alphanumeric
Start Position: 78
Length: 12

010000|Estate|Asset|9|cms|boxSAMPLE RECORD
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Companies

The source table for this file is: tfgld001

Companies
Field Number  Field Name Description Field Type

 10  cono Company Field Type: Numeric
Start Position: 1
Length: 3

 20  desc Description Field Type: Alphanumeric
Start Position: 4
Length: 35

 30  ccur Company
Currency

Field Type: Alphanumeric
Start Position: 39
Length: 3

750|Philips Corporation|USD

Currencies

The source table for this file is: tcmcs002

Currencies
Field Number  Field Name Description Field Type

 10  ccur Currency Code Field Type: Alphanumeric
Start Position: 1
Length: 3

 20  desc Description Field Type: Alphanumeric
Start Position: 4
Length: 30

AUD|Australian Dollar

SAMPLE RECORD

SAMPLE RECORD
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Dimension type 1

The source table for this file is: tfgld010

Dimension type 1
Field Number  Field Name  Description Attributes

 10  dimx  Dimension Code Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc  Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl  Sub-Level Field Type: Numeric
Start Position: 37
Length: 2

 40  dtyp  Dimension Type Field Type: Numeric
Start Position: 39
Length: 1

1000|New Water Generation Concept|0|1

Dimension type 2

The source table for this file is: tfgld010

Dimension type 2
Field Number  Field Name Description Attributes

 10  dimx Dimension
Code

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position:7
Length:30

 30  subl Sub-Level Field Type: Numeric
Start Position: 37
Length: 2

 40  dtyp Dimension
Type

Field Type: Numeric
Start Position: 39
Length: 1

See Dimension type 1.

SAMPLE RECORD

SAMPLE RECORD



ASCII file formats

HyperionReady Interface for Baan

ASCII file formats  - Page 11

Dimension type 3

The source table for this file is: tfgld010

Dimension type 3
Field Number  Field Name Description Attributes

 10  dimx Dimension
Code

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-Level Field Type: Numeric
Start Position: 37
Length: 2

 40  dtyp Dimension
Type

Field Type: Numeric
Start Position: 39
Length: 1

See Dimension type 1.

Dimension type 4

The source table for this file is: tfgld010

Dimension type 4
Field Number  Field Name Description Attributes

 10  dimx Dimension
Code

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-Level Field Type: Numeric
Start Position: 37
Length: 2

 40  dtyp Dimension
Type

Field Type: Numeric
Start Position: 39
Length: 1

See Dimension type 1.

SAMPLE RECORD

SAMPLE RECORD
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Dimension type 5

The source table for this file is: tfgld010

Dimension type 5
Field Number  Field Name Description Attributes

 10  dimx Dimension
Code

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-Level Field Type: Numeric
Start Position: 37
Length: 2

 40  dtyp Dimension
Type

Field Type: Numeric
Start Position: 39
Length: 1

See Dimension type 1.

Ownership Budget Codes

The source table for this file is: tffbs003

Owner Budget Codes
Field Number  Field Name Description Attributes

 10  pbud Parent Budget Field Type: Alphanumeric
Start Position: 1
Length: 3

 20  budg Budget Field Type: Alphanumeric
Start Position: 4
Length: 3

|001

SAMPLE RECORD

SAMPLE RECORD
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Ownership - Chart of Accounts

The source table for this file is: tfgld008

Ownership – Chart of Account
Field Number  Field Name Description Attributes

 10  Plac Parent Ledger
Account

Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  leac Ledger Account Field Type: Alphanumeric
Start Position: 13
Length: 12

 30  datype Dual Accounting
Type

Field Type: Alphanumeric
Start Position: 25
Length: 15

930000|934000

Ownership - Dimension type 1

The source table for this file is: tfgld010

Ownership – Dimension type 1
Field Number  Field Name Description Attributes

 10  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  dimx Dimension Field Type: Alphanumeric
Start Position: 7
Length: 6

 30  dtyp Dimension
Type 1

Field Type: Numeric
Start Position: 13
Length: 1

|1000

SAMPLE RECORD

SAMPLE RECORD
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Ownership - Dimension type 2

The source table for this file is: tfgld010

Ownership – Dimension type 2
Field Number  Field name Description Attributes

 10  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  dimx Dimension Field Type: Alphanumeric
Start Position: 7
Length: 6

 30  dtyp Dimension
Type 2

Field Type: Numeric
Start Position: 13
Length: 1

C/C|C0001

Ownership - Dimension type 3

The source table for this file is: tfgld010

Ownership – Dimension type 3
Field Number  Field Name Description Attributes

 10  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  dimx Dimension Field Type: Alphanumeric
Start Position: 7
Length: 6

 30  dtyp Dimension
Type 3

Field Type: Numeric
Start Position: 13
Length: 1

See Ownership-Dimension type 1 or Ownership-Dimension type 2.

SAMPLE RECORD

SAMPLE RECORD
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Ownership - Dimension type 4

The source table for this file is: tfgld010

Ownership – Dimension type 4
Field Number  Field Name Description Attributes

 10  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  dimx Dimension Field Type: Alphanumeric
Start Position: 7
Length: 6

 30  dtyp Dimension

Type 4

Field Type: Numeric
Start Position: 13
Length: 1

See Ownership-Dimension type 1 or Ownership-Dimension type 2.

Ownership - Dimension type 5

The source table for this file is: tfgld010

Ownership – Dimension type 5
Field Number  Field Name Description Attributes

 10  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  dimx Dimension Field Type: Alphanumeric
Start Position: 7
Length: 6

 20  dtyp Dimension
Type 5

Field Type: Numeric
Start Position: 13
Length: 1

See Ownership-Dimension type 1 or Ownership-Dimension type 2.

SAMPLE RECORD

SAMPLE RECORD
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Hyperion Pillar Import and Export
The tables in this section list the exported ASCII files you use to import Baan
data into Hyperion Pillar, and to import Hyperion Pillar data into Baan.

Exported Baan Files

The following table lists the files used to transfer Baan data to Hyperion Pillar.
The table lists the file name, description, and Baan tables.

Exported Baan File
File Description Sample File Name Baan Table

Actual Asset Amounts and
Opening Balances

ASSP tfgld205
tfgld206

Actual Expense Amounts EXPP tfgld205

Actual Liability Amounts and
Opening Balances

LIABP tfgld205
tfgld206

Actual Revenue Amounts REVP tfgld205

Budget Asset Amounts BASSP tffbs101

Budget Expense Amounts BEXPP tffbs101

Budget Liability Amounts BLIABP tffbs101

Budget Revenue Amounts BREVP tffbs101

Chart of Accounts for Pillar CHACCP tfgld008
Companies COMPANYP tfgld001
Currency CURRP tcmcs002

Budget Codes BUDGP tffbs003

Dimension 1 DIM1P tfgld010

Dimension 2 DIM2P tfgld010

Dimension 3 DIM3P tfgld010

Dimension 4 DIM4P tfgld010

Dimension 5 DIM5P tfgld010

Opening Balances Assets BBASSETP tfgld206

Opening Balances Liabilities BBLIABP tfgld206
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File Formats

The tables in this section list the ASCII format for each exported Baan file used
to import Baan data into Hyperion Pillar. Each table lists the field number and
name, description, field type, start and length.

Actual Asset Amounts and Opening Balances

The source tables for this file are: tfgld205 and tfgld206

Actual Asset Amounts and Opening Balances
Field Number  Field Name Description Attributes

 10  Leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company Code Field Type: Numeric
Start Position: 70
Length: 3

 90  Balamt Balance Amount Field Type: Alphanumeric
Start Position: 73
Length: 20

011110,default   cc,,,,,Asset,750,0,0,0,0,0,21100,

21100,21100,21100,21100,21100,21100,21100

SAMPLE RECORD
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Actual Expense Amounts

The source table for this file is: tfgld205

Actual Expense Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company
Number

Field Type: Numeric
Start Position: 70
Length: 3

 90  balamt Balance Amount Field Type: Alphanumeric
Start Position: 73
Length: 20

411000,default   cc,,,,,Expense,750,0,0,0,0,1500,0,

0,0,0,0,0,0

SAMPLE RECORD
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Actual Liability Amounts and Opening Balances

The source tables for this file are: tfgld205 and tfgld206

Actual Liability Amounts and Opening Balances
Field Number  Field Name Description Attributes

 10  Leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension 1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension 2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension 3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension 4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension 5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company
Number

Field Type: Numeric
Start Position: 70
Length: 3

 90  balamt Balance Amount Field Type: Alphanumeric
Start Position: 73
Length: 20

146200,default   cc,,,,,Liability,750,1000,1000,

1000,1000,1000,938.9,938.9,938.9,938.9,938.9,938.9,

938.9,938.9

SAMPLE RECORD
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Actual Revenue Amounts

Actual Revenue Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company
Number

Field Type: Numeric
Start Position: 70
Length: 3

 90  balamt Balance
Amount

Field Type: Alphanumeric
Start Position: 73
Length: 20

The source table for this file is: tfgld205

100220,default  rev,,,,,Revenue,750,0,0,0,0,-36475,0,

0,0,0,0,0,0

SAMPLE RECORD
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Budget Asset Amounts

The source table for this file is: tffbs101

Budget Asset Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  curr Currency Field Type: Alphanumeric
Start Position: 58
Length: 3

 90  budg Budget Code Field Type: Alphanumeric
Start Position: 61
Length: 3

 100  amnt Amount Field Type: Alphanumeric
Start Position: 64
Length: 20

011110,default   cc,,,,,Asset,USD,001,0,0,0,0,0,21100,

21100,21100,21100,21100,21100,21100,21100

SAMPLE RECORD
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Budget Expense Amounts

The source table for this file is: tffbs101

Budget Expense Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  curr Currency Field Type: Alphanumeric
Start Position: 58
Length: 3

 90  budg Budget Code Field Type: Alphanumeric
Start Position: 61
Length: 3

 100  amnt Amount Field Type: Alphanumeric
Start Position: 64
Length: 20

172000,default   cc,,,,,Expense,USD,001,229,229,458,

458,687,687,458,458,229,229,229,229

SAMPLE RECORD
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Budget Liability Amounts

The source table for this file is: tfgld206

Budget Liability Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  curr Currency Field Type: Alphanumeric
Start Position: 58
Length: 3

 90  budg Budget Code Field Type: Alphanumeric
Start Position: 61
Length: 3

 100  amnt Amount Field Type: Alphanumeric
Start Position: 64
Length: 20

146200,default   cc,,,,,Liability,USD,001,0,0,0,0,0,0,

0,-61,0,0,0,0,0

SAMPLE RECORD
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Budget Revenue Amounts

The source table for this file is: tffbs101

Budget Revenue Amounts
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  curr Currency Field Type: Alphanumeric
Start Position: 58
Length: 3

 90  budg Budget Code Field Type: Alphanumeric
Start Position: 61
Length: 3

 100  amnt Amount Field Type: Alphanumeric
Start Position: 64
Length: 20

172000,default   rc,,,,,Revenue,USD,001,228.9,228.9,

457.8,457.8,686.7,686.7,457.8,457.8,228.9,228.9,228.9,

228.9

SAMPLE RECORD
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Budget Codes

The source table for this file is: tffbs003

Field Number  Field name Description Attributes

 10  budg Budget Code Field Type: Alphanumeric
Start Position: 1
Length: 3

 20  desc Description Field Type: Alphanumeric
Start Position: 4
Length: 30

 30  curr Currency Field Type: Alphanumeric
Start Position: 34
Length: 3

BP,new,USD

Chart of Accounts

The source table for this file is: tfgld008

Chart of Accounts
Field Number  Field Name Description Attributes

10 leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  desc Description Field Type: Alphanumeric
Start Position: 13
Length: 30

 30  atyp Account type Field Type: Alphanumeric
Start Position: 43
Length: 15

 40  subl Sub-level Field Type: Numeric
Start Position: 58
Length: 2

 50  plac Parent Ledger
Account

Field Type: Alphanumeric
Start Position: 60
Length: 12

010000,Estate,Asset,9,FAS

SAMPLE RECORD

SAMPLE RECORD
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Companies

The source table for this file is: tfgld001

Companies
Field Number  Field Name  Description Attributes

 10  cono  Company Field Type: Numeric
Start Position: 1
Length: 3

 20  desc  Description Field Type: Alphanumeric
Start Position: 4
Length: 35

 30 gcmp  Group
Company

Field Type: Alphanumeric
Start Position: 39
Length: 3

750, XYZ Company, 920

Currency

The source table for this file is: tcmcs002

Currency
Field Number  Field Name  Description Attributes

 10  ccur  Currency Code Field Type: Alphanumeric
Start Position: 1
Length: 3

 20  dsca  Description Field Type: Alphanumeric
Start Position: 4
Length: 30

AUD|Australian Dollar

SAMPLE RECORD

SAMPLE RECORD
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Dimension 1

The source table for this file is: tfgld010

Dimension 1
Field Number  Field Name Description Attributes

 10  dimx Dimension Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-level Field Type: Numeric
Start Position: 37
Length: 2

 40  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 39
Length: 6

 50  dtyp Dimension
Type

Field Type: Numeric
Start Position: 45
Length: 1

1000,New Water Generation Concept,0,,1SAMPLE RECORD
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Dimension 2

The source table for this file is: tfgld010

Dimension 2
Field Number  Field Name Description Attributes

 10  dimx Dimension Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-level Field Type: Numeric
Start Position: 37
Length: 2

 40  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 39
Length: 6

 50  dtyp Dimension
Type

Field Type: Numeric
Start Position: 45
Length: 1

See Dimension 1.SAMPLE RECORD
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Dimension 3

The source table for this file is: tfgld010

Dimension 3
Field Number  Field Name Description Attributes

 10  dimx Dimension Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-level Field Type: Numeric
Start Position: 37
Length: 2

 40  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 39
Length: 6

 50  dtyp Dimension
Type

Field Type: Numeric
Start Position: 45
Length: 1

See Dimension 1.SAMPLE RECORD
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Dimension 4

The source table for this file is: tfgld010

Dimension 4
Field Number  Field Name Description Attributes

 10  dimx Dimension Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-level Field Type: Numeric
Start Position: 37
Length: 2

 40  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 39
Length: 6

 50  dtyp Dimension
Type

Field Type: Numeric
Start Position: 45
Length: 1

See Dimension 1.SAMPLE RECORD
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Dimension 5

The source table for this file is: tfgld010

Dimension 5
Field Number  Field Name Description Attributes

 10  dimx Dimension 5 Field Type: Alphanumeric
Start Position: 1
Length: 6

 20  desc Description Field Type: Alphanumeric
Start Position: 7
Length: 30

 30  subl Sub-level Field Type: Numeric
Start Position: 37
Length: 2

 40  pdix Parent
Dimension

Field Type: Alphanumeric
Start Position: 39
Length: 6

 50  dtyp Dimension
Type

Field Type: Numeric
Start Position: 45
Length: 1

See Dimension 1.SAMPLE RECORD
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Opening Balances Assets

The source table for this file is: tfgld206

Opening Balances Assets
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension 1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension 2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension 3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension 4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension 5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp  Account
Type

Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company
Code

Field Type: Numeric
Start Position: 70
Length: 3

 90  balamt Opening
Balance
Amount

Field Type: Alphanumeric
Start Position: 73
Length: 20

111000,default   cc,,,,,Asset,750,2000SAMPLE RECORD
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Opening Balances Liabilities

The source table for this file is: tfgld206

Opening Balances Liabilities
Field Number  Field Name Description Attributes

 10  leac Ledger Account Field Type: Alphanumeric
Start Position: 1
Length: 12

 20  dim1 Dimension1 Field Type: Alphanumeric
Start Position: 13
Length: 6

 30  dim2 Dimension2 Field Type: Alphanumeric
Start Position: 19
Length: 6

 40  dim3 Dimension3 Field Type: Alphanumeric
Start Position: 25
Length: 6

 50  dim4 Dimension4 Field Type: Alphanumeric
Start Position: 31
Length: 6

 60  dim5 Dimension5 Field Type: Alphanumeric
Start Position: 37
Length: 6

 70  atyp Account Type Field Type: Alphanumeric
Start Position: 43
Length: 15

 80  cono Company
Number

Field Type: Numeric
Start Position: 70
Length: 3

 90  balamt Opening Balance
Amount

Field Type: Alphanumeric
Start Position: 73
Length: 20

146200,default   cc,,,,,Liability,750,1000SAMPLE RECORD
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Exported Hyperion Pillar File and Format

The following tables describe the exported Hyperion Pillar file used to transfer
budget data from Hyperion Pillar to Baan.

Exported Hyperion Pillar File
File Description Sample File Name Baan Table

Budget Amount and Quantities BUDGIMP tffbs100
tffbs101

Table tffbs100 shows yearly values; Table tffbs101 shows periodic values.

Budget Amount and Quantities

The destination tables for this file are: tffbs100 and tffbs101
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Budget Amount and Quantities
Field Number  Field name Description Attributes

 10  year Financial
Year

Field Type: numeric

Start Position: 1

Length: 4

 20  budg Budget
Code

 Field Type: alphanumeric

Start Position: 5

Length: 3

 30  leac Ledger
Account
Code

Field Type: alphanumeric

Start Position: 8

Length: 12

 40  dim1 Dimension 1 Field Type: alphanumeric

Start Position: 20

Length: 6

 50  dim2 Dimension 2 Field Type: alphanumeric

Start Position: 26

Length: 6

 60  dim3 Dimension 3  Field Type: alphanumeric

Start Position: 32

Length: 6

 70  dim4 Dimension 4  Field Type: alphanumeric

Start Position: 38

Length: 6

 80  dim5 Dimension 5  Field Type: alphanumeric

Start Position: 44

Length: 6

 90  prod Period
Number

 Field Type: numeric

Start Position: 50

Length: 2

 100  amnt Amount  Field Type: numeric

Start Position: 52

Length: 20

1997,"001","BIKES1","1000","","","","",2,488.0000SAMPLE RECORD
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