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This document describes two ways to install the BaanERP Windows Client
software. If you install BaanERP Windows Client with the Microsoft Windows
Installer, you must follow the directions in chapters one, three, and four. If you
decide to install the software the old way, you must follow the directions
described in chapters two, three and four.

The chapter content is as follows:

Chapter 1 describes how you can install the BaanERP Windows client software
for Windows installer.

Chapter 2 describes how you can install the BaanERP Windows client software.

Chapter 3 describes how you can perform miscellaneous administration tasks.

Chapter 4 describes how you can use the BaanERP system policy options.

About this document
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This chapter describes:

n The hardware and software requirements for BaanERP Windows (BW)
n The installation procedure for the BaanERP Windows software

BaanERP Windows (BW) is a graphical user interface (GUI) program in
BaanERP. It runs on an Intel-compatible PC in a Windows 95, Windows 98,
Windows NT 4.0, or Windows 2000 environment. BW displays BaanERP as an
application with the same look and feel as a native Windows application.

Hardware and software requirements
You need the following software and hardware before you can install BaanERP
Windows (BW).

n The operating system Windows 95, Windows 98, Windows NT  Workstation,
Windows NT Server, Windows 2000 Professional, Windows 2000 Server, or
Windows 2000 Advanced Server must be installed and running.

n The system on which BaanERP Windows will be installed, must be at least
an Intel-based system with a 50 Mhz 486DX processor. Furthermore,
BaanERP Windows requires at least a SVGA video display, 16 MB of main
memory (RAM), and 20 MB of free disk space.

n A network adapter that supports TCP/IP.

n TCP/IP network software must be installed and running.

1 To install BaanERP Windows for
Windows installer
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To install the BaanERP Windows (BW)
software
To install the BaanERP Windows (BW) software, you must follow one of the
procedures descibed below:

n If you have an UNIX or AS/400 BaanERP server, the BaanERP Windows
(BW) software can be copied from the server to the client. Use ftp to copy
the software from the directory $BSE/mswindows/BW/i386 to a temporary
directory on the client. Double-click the file setup.exe. This action starts the
BW installation program.

n If the client has a local CD-ROM drive (and you have the BaanERP
distribution CD-ROM for Windows NT), you can install BaanERP Windows
(BW) directly, by using the BaanERP distribution CD-ROM. If not, you must
share the CD-ROM of the server.

Advertised install does not work on a Windows95 machine without Active
Desktop, although it is shown in the installation dialog box. Also, advertised
install must be supported on NT4 with SP5 and Active Desktop, but this feature
is not shown in the installation dialog box. If you install the advertised install
from a CD and the CD is not available, the installer shows an incorrect location
for the CD.

The description below assumes that your client has a local CD-ROM drive.

Take the following steps to install BaanERP Windows.

1 Close all running applications and insert the BaanERP Windows distribution
CD-ROM in the CD-ROM drive. If the Baan ERP Client fails to start
automatically, double click the file setup.exe. The setup file is located in the
route directory of the BaanERP Windows distribution CD-ROM in your CD-
ROM drive.

You know that the setup file is working when an InstallShield Wizard
dialog box appears.

NOTE

NOTE
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This dialog box disappears automatically.  If Windows 2000 is installed, or if
the Windows Installer has been previously installed, the Windows Installer
dialog box shown in Step 4 is shown next. Otherwise, the Microsoft
Windows Installer will be installed.

A Restart System dialog box appears after Windows Installer has been
installed.

2 Click Restart System. After your system restarts, log on again if you are
prompted to do so. The Baan ERP Client Setup will automatically start.

The Windows Installer dialog box appears, which is followed by a Welcome
mesage.



To install BaanERP Windows for Windows installer

Installation Guide for BaanERP Windows Client

1-4

3 Click Next. A short delay can occur before the Next button is enabled.A
License Agreement message screen appears. Click I accept the terms in the
license agreement.
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4 Click Next.

A Customer Information screen appears.

 

Typically, BaanERP menu items will appear on the menus of all users of this
computer. If you want these menu items to appear only on the menus of the
current user, click Only for me. This option is not displayed for all operating
systems. If this option is not displayed, BaanERP menu items will be
accessible to all users.
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5 Click Next.

A Setup Type screen appears.

6 Select setup type Normal, click Next, and skip to Step 10. For advanced
options, select the setup type Custom, and click Next to continue.
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The Custom Setup screen appears.

7 If you want to defer the installation of the BaanERP Client software, click the
tiny down arrow located immediately to the right of the hard drive icon
( ).

8 On the drop down menu that appears, select This feature will be installed
when required, click Next, and skip the remainder of this step. Note that this
deferred installation option, called Install-On-Demand, is not supported on
operating systems that do not have the Microsoft Active Desktop feature
installed and functioning. The Install-On-Demand feature is always available
on Windows 2000.

If you select the deferred installation option above, any specifications you
make to the Baan Environment or the installation location will be ignored.
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If desired, change the name of the Baan Environment.

9 Accept the default path or click Change… to enter another path. Click Next
to continue.

10 In the Ready to Install the Program dialog box, click Finish to continue
with the displayed setup (or click Back to change the displayed setup).

11 After the software is installed, you must click Finish to exit the installation
script. If you are prompted to restart your computer, you must do so before
continuing.

Proceed with the Miscelleanous Administration Tasks in Chapter 3.
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This chapter describes:

n The hardware and software requirements for BaanERP Windows (BW)
n The installation procedure for the BaanERP Windows software

BaanERP Windows (BW) is a graphical user interface (GUI) program in
BaanERP. This program runs on an Intel-compatible PC in a Windows 95, 98, or
Windows NT 4.0 (or later) environment. BW displays BaanERP as an
application with the same look and feel as a native Windows application.

Hardware and software requirements
You need the following software and hardware before you can install BaanERP
Windows (BW).

n The operating system Windows 95, 98 Windows NT Workstation or
Windows NT Server must be installed and running.

n The system on which BaanERP Windows must be installed, must be at least
an Intel-based system with a 50 Mhz 486DX processor. Furthermore,
BaanERP Windows requires at least a SVGA video display, 16 MB of main
memory (RAM), and 20 MB of free disk space.

n A network adapter that supports TCP/IP.

n The TCP/IP network software must be installed and running.

2 To install BaanERP Windows
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To install the BaanERP Windows (BW)
software
To install the BaanERP Windows (BW) software, you can follow one of these
procedures:

n If you have a UNIX or AS/400 BaanERP server, the BaanERP Windows
(BW) software can be copied from the server to the client. Use ftp to copy the
software from the directory $BSE/mswindows/BW/i386 to a temporary
directory on the client. Double-click the file setup.exe, which starts the BW
installation program.

n If the client has a local CD-ROM drive (and you have the BaanERP
distribution CD-ROM for Windows NT), you can install BaanERP Windows
(BW) directly by using the BaanERP distribution CD-ROM. If your client
does not have this type of drive, you must share the CD-ROM of the server.

The description below assumes that your client has a local CD-ROM drive
and is running the Windows NT operating system.

Take the following steps to install BaanERP Windows.

1 Close all running applications and insert the BaanERP distribution CD-ROM
in the CD-ROM drive. A Welcome message appears.

2 Click Next. A Software Licence Agreement message screen appears.

NOTE
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3 Click Yes.

The Select Baan sofware environment dialog box appears.

4 If you perform a new installation, click Install New Environment and enter
a name for the new installation. If you want to upgrade an existing BW
installation, you must click Select Existing Environment. In addition, you
must select the existing environment to be upgraded from the list box.
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5 Click Next to continue.

The Choose Destination Location dialog box appears.

Accept the default path or click Browse to enter another path (if you supply a
non-existing directory, you will be asked if the Install Wizard must create the
directory).

Only if you are installing from the BaanERP BackOffice distribution CD-ROM,
the dialog box shown in step 6 appears. In all other installation scenarios you
must skip step 6, and continue the installation with step 7.

6 Click Next to continue.

NOTE
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The Setup Type dialog box appears.

You can select the following server types:
− User Interface

This type is a BaanERP Windows (BW) client.

− User Interface and Logic
This type is a stripped version of a BaanERP Windows NT server (with
local application logic).

− Full (Including Application Files and Database)
This type is the full installation of the complete BaanERP Windows NT
server version.

7 Select User Interface and click Next.

The Select Program Folder dialog box appears.

8 Select the Program Folder to which the BaanERP Windows icons must be
added (default BaanERP) and click Next. The Setup Information dialog box
appears.

9 Click Next to continue with the displayed setup (or click Back to change the
displayed setup).

10 After the software is installed, click OK to exit the installation script.
Proceed with the Miscelleanous Administration Tasks in Chapter 3.
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This chapter describes miscellaneous administration tasks and contains the
following sections:

n The Baan Environment and Configuration Selector.
n The installation directory of BaanERP Windows (BW)
n The BaanERP Windows (BW) environment variables
n The procedure to uninstall BaanERP Windows

The Baan Environment and Configuration
Selector
The Baan Environment and Configuration Selector is a tool that allows you to
run different Baan Windows versions on a single client. To add a new
environment, you must perform following steps:

1  Click Start ➤ Programs ➤Baan ERP ➤ Baan ERP. The BECS – Baan
Environment and Configuration Selector window appears.

2 Select the new environment (preceded with <empty>), and select the New
command in the File menu. The BW Configuration Properties dialog box
appears.

3 Miscellaneous administration tasks
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3 Supply the following information:

On the Application Server tab, you can select the following Baan services:

Published
This option will use the Active Directory Service (ADS) feature. The
connection information will be retrieved from ADS if you select the
appropriate environment name in the browse window.

Private
You must fill in the following fields:

− Host Name
Enter the host name of the BaanERP server.

− BSE
Enter the path to the BSE environment on the BaanERP server (equals the
BSE environment variable on the BaanERP server).
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− Protocol
You can select (depending on the protocol that is installed and configured
on the BaanERP server) one of the following protocols: Rexec,
BaanLogin, and SSPI Login. For more information about the protocol to
be selected, refer to the relevant BaanERP server installation guide.

In Windows 95, 98, and NT, the Published feature will only work if

− You are actually logged on to the Windows network.

− You have installed the Active Directory Services Interface (ADSI)
correctly on your system. ADSI can be obtained from the Microsoft Web
site.

You can only make use of the SSPI feature if your BaanERP server is a
Windows NT server and you are logged on to the Windows network.

− Portnumber
If you want to change the default port number, you must have selected
BaanLogin as the protocol to be used. If you intend to change the default,
you must be sure that the supplied port number is the same as the port
number on which the BaanLogin daemon on the server is listening.

− Username
Enter a valid user name that is known on the BaanERP server. If you
selected SSPI Login as the protocol to be used, you do not have to supply
a username because your current Windows network identity will be used.

− Password
If this option is enabled (not applicable if you use the SSPI Login), your
password will be stored in the Baan configuration .bwc file .

On the Bshell Environment tab you must fill in the following fields:

− Bshell Name
Enter the application logic to use on the remote BaanERP host (changing
the default of bshell will only be useful during debugging).

− Command
Enter the option you want to pass to the bshell. You can, for example,
define environment variables by using the following syntax:

-- -set Environment Variable1=xxx -set Environment Variable2=yyy

On the NLS tab, you must fill in the Locale field. This box allows you to
select the character set to be used (the default character set is International
[ISO]).

NOTE
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On the Font tab, fill in the Font type field. This box allows you to enter the
desired font type. You can change the setting if you click on the button at the
right side of the font boxes.

Font settings only affect the BW character windows (for example, display
browser).

On the Automation tab, you can review the information in the Class Name
field. This field contains the name of the Baan automation object
Baan.Application.server, where server is the hostname of the BaanERP
server you supplied on the Application Server tab.

4 Click OK to save the new configuration in a configuration file. The BECS –
Baan Environment and Configuration Selector window is displayed again,
but now the new configuration is shown.

You can start BW by selecting and double-clicking the entry for the new
configuration.

The BaanERP .bwc files are registered by the Windows NT or Windows 95
operating system. You can find the .bwc files in the directory Lib\User under
the installation directory of the BaanERP client software. This placement
implies that you can start a BaanERP logon procedure by double-clicking the
icon in front of the relevant .bwc file in the File Manager. You can also make
BaanERP program icons by dragging the .bwc configuration files to a
Program Group.

5 From the BaanERP Tools menu, choose Software Installation➤

Installation . Open the Download Help Files (ttadv8245m000) session. This
session has two options:

− Download help files
This command installs the Windows Help files on your client. Select the
Help Groups for which you want to see Help and choose Download Help
Files from the Specific menu.

NOTE

NOTE
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− Edit HTML Help transfer script
If you install HTML help on an HTTP server, you must edit the HTML
Help transfer script. This script is used to transfer the HTML Help files
from the application server to the HTTP server. To run this script, you
need access to the HTTP server.
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Installation directory of BaanERP Windows
(BW)
The installation directory C:\Program Files\BaanERP is created during the setup
process of BaanERP Windows (BW). During setup you can change this
installation directory. This section assumes you have chosen the default name for
the installation directory of BaanERP Windows (BW).

The following subdirectories are created in directory C:\Program Files\BaanERP
during setup:

n bin
This directory contains the bw.exe program to start the BaanERP application,
as well as the bwconfig.dll for the configuration program.

n lib
This directory contains the files bw.tlb (type library information for OLE
Automation) and tss_bw (language support).

n log
This directory contains logging information about BaanERP Windows.

n samples
This directory contains a Microsoft Excel spreadsheet, which outlines the use
of OLE Automation to access BaanERP dynamic link libraries.

n tmp
This directory contains the temporary files.

n help
This directory contains the Help files. The C:\Program Files\Baan\lib.
subdirectory is created in the directory.

n nlsinf
This directory contains the special character set file xwindows.in.

n user
This directory contains the configuration files.

n The following subdirectories are created in the directory C:\Winnt\Baan (for
Windows NT) or C:\Windows\Baan (for Windows 95 or 98).

n bin
This directory contains all binaries that are shared between different versions
of BW, for example, becs.exe.

n lib
This directory is empty.
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To uninstall the BaanERP Windows client
To uninstall BaanERP Windows, start the Windows Control Panel and then
start the Add/Remove Programs control panel applet.  Select Baan ERP Client
and click Remove. Click OK on the Add/Remove Programs dialog box, which
will appear after the remove is completed.
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The current version of BW supports options to centralize the following
configuration actions on the network domain controller instead of on the local
client:

n Password storage
n BW configuration editing

This chapter describes how you can centralize these configuration actions on the
network domain controller.

Password storage
With this BW version, each user can store and retrieve passwords, which are
used to authenticate a user to a Baan Application Server. Some secure
environments do not want a BW password to be stored on the local client. This
structure can allow unauthorized individuals to access the Baan environment
without logging on if such a password file is stolen or accidentally put on a
shared directory.

This potential problem is solved in this version of BW by an option to disable the
local storage of the BW password.

The enabling or disabling of the password storage and retrieval feature is related
to a registry key setting under HKEY_LOCAL_MACHINE. By default, this
section of the registry can only be updated by a person with system
administrators rights.

The system administrator can disable the local storage of BW clients by taking
the following steps:

1 Log on as user with admin rights on the Windows NT server that is the
domain controller of the Windows network.

2 Copy the C:\Program Files\Baan\Lib\bw.adm file (from a BW client) to the
directory C:\WINNT\INF on the domain controller.

3 Start the System Policy Editor.

4 From the Options menu, select the Policy Template.

5 Click Add, and select C:\WINNT\INF\bw.adm.

4 BaanERP system policy options
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6 Click Open. The C:\WINNT\INF\bw.adm is added in the Policy Template
dialog box. Select this entry and click OK.

7 Select the Open Policy command from the File menu in the System Policy
Editor dialog box (or New Policy if you want to add one).

8 Select the systems (or groups of systems) for which you want to disable local
password storage, and select the Properties command in the Edit menu.

9 Disable local storage as shown below and click OK.
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BW configuration editing
In some environments, BW configuration files are stored on a shared drive and
managed centrally by a system administrator. In such a configuration, each
individual user must not be able to create, delete, and modify BW configuration
files. Therefore, an optional feature is added that permits only system
administrators to perform these activities.

The system administrator can disable local configuration editing by taking the
following steps:

1 Log on as user with admin rights on the Windows NT server that is the
domain controller of the Windows network.

2 Copy the C:\Program Files\Baan\Lib\bw.adm file (from a BW client) to the
directory C:\WINNT\INF on the domain controller.

3 Start the System Policy Editor.

4 Select the Policy Template from the Options menu.

5 Click Add, and select C:\WINNT\INF\bw.adm.

6 Click Open. The C:\WINNT\INF\bw.adm is added in the Policy Template
dialog box. Select this entry and click OK.

7 Select the Open Policy command from the File menu in the System Policy
Editor dialog box (or New Policy if you want to add one).

8 Select the user (or groups of users) for which you want to disable local
configuration editing, and select the Properties command in the Edit menu.
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9 Disable local configuration editing as shown below and click OK.
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