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About this Guide

This document describes the Process Modeler Workbench that is used to graphically create and maintain the
different types of diagrams that make up an enterprise model.

About this guide

This document is assembled from online Help topics.

The functionalities you can use to create and maintain the models, are basically the same for all, and explained
in Functions used in all diagram types and Operations used in all diagram types.

It is assumed that you have a general understanding of LN Infor LN Enterprise Modeler and understand these
topics:

• Enterprise Structure Diagram
• Business Control Diagram
• Business Function Diagram
• Business Process Diagram
• Entity Relationship Diagram

Underlined terms indicate a link to a glossary definition. If you view this document online and you click the
underlined text, you jump to the glossary definition at the end of this document.

Related documents:

For details, see the LN Infor LN Enterprise Modeler Online Help.

Contacting Infor
If you have questions about Infor products, go to Infor Concierge at https://concierge.infor.com/ and create
a support incident.

The latest documentation is available from docs.infor.com or from the Infor Support Portal. To access
documentation on the Infor Support Portal, select Search > Browse Documentation. We recommend that
you check this portal periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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Chapter 1: Process Modeler Workbench

The Process Modeler Workbench is used to graphically create and maintain the different types of diagrams
that make up an enterprise model.

The enterprise model consists of these parts:

• The highest level is the enterprise-structure model that is represented by the enterprise-structure diagram
that visualizes the multicompany structure of the Company.

• The next level is the business model that is a subset of following diagrams that are maintained in the
repository.
• Business control diagram; visualizes the primary process that takes place and the business functions

that are used to control that process.
• Business-function diagram; visualizes the multilevel relationships between business functions.
• Business-process diagram; visualizes a business objective.

• Then there is the data model that is represented by the Entity Relationship Diagram. This diagram provides
information about the physical and logical data model of the LN package combination to which the
Enterprise Model applies.

How to use the Process Modeler Workbench

The functionalities you can use to create and maintain the models are basically the same for all.

The diagram specific information is explained in these topics:

• Enterprise Structure Diagram
• Business Control Diagram
• Business Function Diagram
• Business Process Diagram
• Entity Relationship Diagram

For the explanation of all buttons, icons on the toolbars and graphical objects that are available in the Process
Modeler Workbench, see Legend on page 20.

Functions that are used in all diagram types

Drop-down menus

DescriptionMenu Options

To undo the last user action.Edit -> Undo

To reverse the last Undo command.Edit -> Redo
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DescriptionMenu Options

To delete the currently selected diagram objects from the diagram and
copy these objects to the diagram clipboard.

Edit -> Cut

To copy the currently selected diagram objects from the diagram and
copy these objects to the diagram clipboard.

Edit -> Copy

To copy the diagram objects from the diagram clipboard into the dia-
gram.

Edit -> Paste

To delete the currently selected diagram objects from the diagram.Edit -> Delete

To select all diagram objects in the diagram.Edit -> Select All

All To deselect all selected objects in the diagram.Edit -> Deselect

To show or hide the diagram header.View -> Show Header

To show or hide the external codes that are setup in the graphical object
properties.

View -> Show External Codes

To increase zoom level.View -> Zoom in

To decrease zoom level.View -> Zoom out

To set the zoom to the default value 100.View -> Actual size

To resize the diagram so it is completely visible.View -> Zoom to fit

To switch on or off the automatic alignment of objects that are based
on a fixed grid.

View -> Snap to Grid

The Action drop-down menu contains diagram specific options which
can be found here:
• Enterprise Structure Diagram Action drop-down menu
• Business Control Diagram Action drop-down menu
• Business Function Diagram Action drop-down menu
• Business Process Diagram Action drop-down menu

Action drop-down menu

To insert a text block that contains information regarding the diagram
such as diagram code, description, version, creation date and last
modification date.

Insert -> Info Block

To insert a note that is directly readable in the diagram.Insert -> Annotation

The other graphical objects that can be selected in the Insert drop-
down menu differ per diagram type and are explained here:
• Enterprise Structure Diagram graphical objects
• Business Control Diagram graphical objects
• Business Function Diagram graphical objects
• Business Process Diagram graphical objects
• Entity Relationship Diagram graphical objects

Insert -> ....

To align all selected graphical objects vertically, relative to the top of
the object that is most at the top.

Arrange -> Align -> Top
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DescriptionMenu Options

To align all selected graphical objects vertically, relative to the middle
of all selected objects.

Arrange -> Align -> Middle

To align all selected graphical objects vertically, relative to the bottom
of the object that is most at the bottom.

Arrange -> Align -> Bottom

To align all selected graphical objects horizontally, relative to the left
of the object that is most to the left.

Arrange -> Align -> Left

To align all selected graphical objects horizontally, relative to the
middle of all selected object.

Arrange -> Align -> Center

To align all selected graphical objects horizontally, relative to the right
of the object that is most to the right.

Arrange -> Align -> Right

To resize the width of all selected graphical objects to the widest of all
selected objects.

Arrange -> Make Same Size ->
Width

To resize the height of all selected graphical objects to the highest of
all selected objects.

Arrange -> Make Same Size ->
Height

To resize the height and width of all selected graphical objects to the
highest and widest of all selected objects.

Arrange -> Make Same Size ->
Both

To align all selected graphical objects with the same horizontal distance
from each other.

Arrange -> Space Evenly -> Across

To align all selected graphical objects with the same vertical distance
from each other.

Arrange -> Space Evenly -> Down

Operations that are used in all diagram types

These operations are generic for all diagram types:

DescriptionOperation

From the Insert drop-down menu or the Diagram Objects toolbar select rela-
tionship or trigger. Click and hold the left mouse key on the first graphical
object that you want to connect. Then move the cursor to the destination
object and release the left mouse button.

Insert a relationship/trigger

From the Insert drop-down menu or the Diagram Objects toolbar select the
desired graphical object. Move the cursor to the first a location in the diagram
and click once.

Insert all other graphical
objects

Select one or more graphical objects and drag them to the new location.Move a graphical object
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DescriptionOperation

Select the graphical object and drag one of the black squares that are posi-
tioned at the outline of the object. To change the width of the object by
dragging the black squares positioned at the left or the right side. To change
the height of the object by dragging the black square positioned at the top
or the bottom. To change both the width and the height, drag the black square
at the top or the bottom. To change both the width and the height, drag the
black square that is positioned at the corner. Not all diagram objects are re-
sizable!

Modify the size of a graphi-
cal object

Right-click the graphical object. Select Text or Model Text. A text window is
displayed where you can enter your text. In this text window, from the Refer-
ence menu you can select Zoom session. A list of possible options is displayed.
You can add references to other LN Enterprise Modeler content or LN sessions
in the text. To exit the text window click save changes and exit. After a Text
or Model Text is linked to a graphical object, a Text- or Model Text icon is
linked to the diagram object. Double-click this icon to open the text window

Link a text to a graphical
object

Right-click a graphical object, select Properties to view/modify the properties
of the graphical object.

View/Modify the properties
a graphical object

Right-click the diagram canvas outside an graphical object and select Prop-
erties to view/modify the properties of the diagram.

View/Modify the properties
of the diagram
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Chapter 2: Enterprise Structure Diagram

Locate Enterprise Units on a geographical map to create a graphical representation of the organization and
its entities such as warehouses, departments or work centers.

An enterprise unit can also represent an external business partner. Insert an Enterprise Unit Relationship
between enterprise units. Link a category to the relationship to define if it is for example a goods or a money
flow.

To describe in more detail the operations within the enterprise unit, link a business control diagram to that
unit.

Enterprise Structure Diagram graphical objects

DescriptionMenu option

To insert an Enterprise Unit.Insert -> Enterprise Unit

To insert an Enterprise Relationship with a description to identify the
relation between two Enterprise Units.

Insert -> Enterprise Relation-
ship

Enterprise Structure Diagram Action drop-down menu

DescriptionMenu option

To switch on or off the background map that is set up in the diagram proper-
ties.

Action -> Show Back-
ground

Operations used Enterprise Structure Diagram

DescriptionOperation

Right-click the Enterprise Unit and select Properties. In proper-
ties select a business model and a Business Control Model. A
Linked Business Control Diagram icon is linked to the Enterprise
Unit.

Link a business control diagram to an
enterprise unit

Right-click the Enterprise Relationship and select Reverse Direc-
tion.

Modify the direction of the Enterprise
Relationship
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Chapter 3: Business Control Diagram

In a business control diagram, Business Functions are used to describe the operations that take place in a
specific enterprise unit.

When those Business Functions fall within the circle of influence of the enterprise unit, they are grouped
together in an Area. External Agents (such as customers, suppliers, governments) are added to indicate their
influence on the operations both located outside the Area. Arrows are drawn between External Agents and
Business Functions to indicate what triggers the operation. The results from this operation can trigger the
next operation in another business function and arrows are drawn between business functions. The arrows
are called Triggers.

Further detail in the operations can be added by linking Business Processes to Business Functions using
Transformation Rules. The transformation rules are created in the repository through the Rules
(tgbrg7500m000) session. For more information on the creation of transformation rules, see the LN Session
Help .

At the bottom of the diagram a flow represents the primary goods or money flow.

The repository is the modeling environment in which the Business Control Diagrams are defined. These
business control diagrams serve as a basis on which you can create a business model(s).

Business Control Diagram graphical objects

DescriptionMenu option

To insert a Trigger between the other graphical objects in the diagram.Insert -> Trigger

To insert a business function.Insert -> Function

To insert External Agents such as customers, suppliers and governments that
affect the Business Functions.

Insert -> External Agent

To insert an Area to visualize related business functions.Insert -> Area

To insert a Flow to visualize the goods flow, financial flow or information flow.Insert -> Flow

To insert a Customer Order Decoupling Point to be located on the Flow.Insert -> CODP

To insert a Buffer, representing a queue or a stock point to be located on the
Flow.

Insert -> Buffer

To insert a Primary Activity such as receive goods or production to be located
on the Flow.

Insert -> Primary Activi-
ty
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Business Control Diagram Action drop-down menu

DescriptionMenu option

To make parts of the Business Control Diagram visible or not, based on the
categories of the Business Functions.

Action -> Function Cate-
gories

To link child Business Control Diagrams to the current diagram.Action -> Children

Operations used in Business Control Diagram

DescriptionOperation

Right-click the Trigger, point to Type and select one of one of these
options:
• Free (midpoints can be added)
• Direct
• Z-style
• Horizontal-Vertical
• Vertical-Horizontal

Modify the Type of the Trigger

Right-click the Trigger and select Reverse direction or BidirectionalModify the direction of the Trigger

Right-click the Trigger and select Add Midpoint to change the route
of the Trigger. This is only possible if the Type of the Trigger is Free.
You can add as many Midpoints as required.

Add a Midpoint to a Trigger

Right-click the Business Function, select Time Trigger or Normal
to switch the time trigger on or off.

Add or remove a Time Trigger

Right-click the Business Function/external agent, select Category.
The category determines the color of the business function/exter-
nal agent/Buffer/Primary Activity.

Modify the Category of the Business
Function/External Agent/Buffer/ Pri-
mary Activity

If a transformation rule exists for a Business Function, a business
process icon is linked to this function. Double-click this icon, a list
of linked business processes is shown. Click "Go to Details" in front
of the appropriate process.

View/edit the Business Process that is
linked to the Business Function

Right-click the Area/CODP and select Properties. In properties
change the background color.

To modify the color of the Area/CODP

Right-click the Flow, point to Type and select one of these options:
• Goods
• Information
• Financial

To modify the Flow Type

Right-click the Enterprise Relationship and select Reverse DirectionModify the direction of the Enterprise
Relationship
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Chapter 4: Business Function Diagram

For a Parent Business Function a Business Function Diagram can be created to represent the child Business
Functions. Icons indicate if a Wizard is available to implement the Business Function.

The repository is the modeling environment in which the Business Functions are defined. The Business Function
Diagrams from the Repository serve as a basis on which to create a business model (s). The Business Function
Diagrams in the Business Model is used to indicate the Optimization Relations between Business Functions.
This is to represent either a variant (replacement functionality) or an option (additional functionality. Phases
can be linked to Business Functions to indicate in which phase the functions are implemented and used. This
is represented by colored circles linked to the Business Functions.

Business Function Diagram graphical objects

DescriptionMenu option

To insert a Business Function.Insert -> Function

To insert an Optimization Relationship.Insert -> Optimization Relationship (only available in a Business
Model)

Business Function Diagram Action drop-down menu

DescriptionMenu option

To make parts of a selection of optimizations visible. Optimization phases must
be linked to the Business Functions.

Action -> Phases by Mod-
el

Operations used in Business Function Diagram

DescriptionOperation

Right-click the business function, click Phases and modify the
phases that this function is using. The Phases icon is linked to the
Business Function. Also colored circles become visible depending
on the selected phases.

Link Optimization Phases to a busi-
ness function

Right-click the Business Function, click Properties and set up a
wizard. The Wizard icon is linked to the business function.

Link a Wizard to a business function

Double-click the Wizard icon that is linked to the Business Function.
The wizard is started.

Execute a Wizard linked to a business
function
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Chapter 5: Business Process Diagram

A Business Process Diagram is the lowest level of representation of the business operations.

The diagram represents the flow of activities, manual or application, users must run from start to finish.
Control Activities are used to represent the choices users must make in that process.

Sub Business Processes are used to bring sufficient detail but still keep the structure understandable.

Linking Roles to Business Processes or to business process activities authorizes employees that are linked to
those roles to run the activities.

Business Processes are created and maintained in the repository and serve as a basis on which to create a
business model (s). Changes you make in the repository reflect in the Business Models. In a Business Model
you can modify the authorization that is setup in the Repository, thus creating enterprise unit specific
authorization setup.

The Business Process Diagram is based on the Petri nets modeling conventions.

Business Process Diagram graphical objects

DescriptionMenu option

To insert an Activity that represents work to do in the form of:
• Manual activity; a not (in LN) automated task
• Business process; links a sub-process
• Application; starts an application of the selected component

Insert -> Activity

To insert a State that defines a particular point in time:
• Begin; always the start of a business process
• End; always the end of a business process
• Normal; all other states in the business process

Insert -> State

To insert a Control Activity that represents a decision moment and can
be:
• XOR; only one of the paths must be executed
• OR; one or more of the paths can be executed
• AND; all paths must be executed
• JOIN; to join the paths split by XOR, OR or AND

Insert -> Control Activi-
ty

To insert a Relationship. Valid relations:
• Between State and Activity
• Between State and Control Activity

Insert -> Relationship
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Business Process Diagram Action drop-down menu

DescriptionMenu option

Renumbers the external codes used in the diagram.Action -> Renumber External
Codes

Checks the syntax/validity of the business process; see Business Pro-
cess Syntax Checks for more information.

Action -> Syntax Check

Links Roles to the business process.Action -> Roles

Operations used in Business Process Diagram

DescriptionOperation

Right-click the State, point to Type and select one of these options:
• Begin; always the start of a business process
• End; always the end of a business process
• Normal; all other states in the business process

Modify the State Type

Right-click the Activity, select Properties. In the properties setup a Support
Application. A Support Applications icon is linked to the Activity. Double-
clicking this icon shows a list with Support Applications from which you can
start the application.

Link a Support Application
to an Activity

Right-click the Activity, select Properties. In the properties setup an AO Docu-
ment. An AO Document icon is linked to the Activity. Double-clicking this icon
opens the AO Document.

Link an AO Document to
an Activity

Right-click the Activity/Control Activity, select Properties. In the properties
setup an URL. A Linked URL icon is linked to the Activity/Control Activity.
Double-clicking this icon opens the URL.

Link a URL to an Activi-
ty/Control Activity

Right-click the Activity/Control Activity, select Roles by Activity. Add or delete
Roles, or click "Go to Details" in front of the Role to modify the authorization
level to:
• No authorization
• Display authorization
• Display/Print authorization
• Modify/Display/Print authorization
• Insert/Modify/Display/Print authorization
• Full authorization
A Linked Roles on Activity Level icon is linked to the Activity/Control Activity.
Double-clicking this icon opens the session to modify the Roles by Activity.

Link a Role to an Activi-
ty/Control Activity

Right-click the Activity, select Sub Applications. Double-click ‘All possible
subapplications for …’, a list unfolds. Highlight a Sub Application and from
the appropriate menu select Add subapplications as modeled Subapplication.
The Sub Applications icon is linked to the Activity.

Activate Sub Application
Authorization
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DescriptionOperation

Double-click the Sub Applications icon that is linked to the Activity. Highlight
the Sub Application and from the Change authorization menu select one of
these options:
• No authorization
• Display authorization
• Display/Print authorization
• Modify/Display/Print authorization
• Insert/Modify/Display/Print authorization
• Full authorization
Or use one of the appropriate buttons.

Modify Sub Application
Authorization

Double-click the Sub Applications icon that is linked to the activity.
1 To change the authorization level for a Role that is already linked to the

Activity, highlight the Role, holding the Ctrl-key. Highlight the Sub Appli-
cation and from the Specific menu select Link Roles to modeled Subap-
plications. The Role appears underneath the Sub Application.

2 To change the authorization level for a Role that is not yet linked to the
Activity, highlight a sub application. From the Specific menu select Link
unmodeled Roles to modeled Subapplications. The Role appears under-
neath the Sub Application.

For both 1 and 2, highlight the new line and from the Change authorization
menu select one these options:
• No authorization
• Display authorization
• Display/Print authorization
• Modify/Display/Print authorization
• Insert/Modify/Display/Print authorization
• Full authorization
Or use one of the appropriate buttons.

Link Specific Role Autho-
rization to a Sub Applica-
tion

Right-click the Control Activity and point to Type, select one of these options:
• XOR; only one of the paths must be executed
• OR; one or more of the paths can be executed
• AND; all paths must be executed
• JOIN; to join the paths split by XOR, OR or AND

Change Control Activity
Type

Right-click the Relationship, point to Type. Select one of these options:
• Free (midpoints can be added)
• Direct
• Z-style
• Horizontal-Vertical
• Vertical-Horizontal

Modify the Type of the Re-
lationship

Right-click the Relationship and select Reverse direction.Modify the direction of the
Relationship
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DescriptionOperation

Right-click the Relationship and select Add Midpoint to change the route of
the Relationship. This is only possible if the Type of the Relationship is Free.
You can add as many midpoints as required.

Add a Midpoint to a Rela-
tionship

Business Process Syntax Checks

CheckSyntax Error

Static conditions are only allowed on relationships that flow from
an OR, XOR, AND Control Activity to an Activity or a JOIN Control
Activity. Solution: Remove the static conditions from the properties
of the relationship concerned.

Error: [object type] [external code]
[description]: Static condition not al-
lowed on outgoing arrow

Except for the Begin State each other State must at least have one
incoming arrow. Solution: Add a Relationship between an Activity
or a Control Activity that is missing an outgoing arrow.

Error: state [external code] [descrip-
tion]: Missing incoming arrow

Except for the End State each other State must have one outgoing
arrow. Solution: Add a Relationship between an Activity or Control
Activity that is missing an incoming arrow.

Error: state [External code] [descrip-
tion]: Missing outgoing arrow

All Activities and JOIN type Control Activities must have one outgo-
ing arrow. Solution: Add a Relationship between the Activity or the
JOIN Control Activity and a state that is missing an incoming arrow.

Error: [object type] [external code]
[description]: Missing outgoing arrow

A State can only have one outgoing arrow. Solution: Remove all
but one of the outgoing Relationships that are linked to the men-
tioned State. Consider using a Control Activity to split the business
process in multiple paths.

Error: state [external code] [descrip-
tion]: Too many outgoing arrows"

Only one arrow can exist between the same State and Activity or
Control Activity. Solution: Remove the duplicate arrow(s) between
the listed State and Control Activity.

Error: state [external code] [descrip-
tion]: Duplicate incoming arrow

An Activity can only have one outgoing arrow. Solution: Remove
all but one of the outgoing Relationships that are linked to the
mentioned Activity.

Error: activity [external code] [descrip-
tion]: Too many outgoing arrows

All Control Activities with type OR, XOR, AND must at least have
two outgoing arrows. Solution: Add an outgoing Relationship from
the Control Activity to a state that is missing an incoming.

Error: control [external code] [descrip-
tion]: Too few outgoing arrows

A JOIN Control Activities must at least have two incoming arrows.
Solution: Add an incoming Relationship from the JOIN Control Ac-
tivity to a state that is missing an outgoing arrow.

Error: control [external code] [descrip-
tion]: Too few incoming arrows

Each business process must start with only one Begin State. Solu-
tion: Ensure the business process starts with a state and change
the State type to ‘Begin’.

Error: Missing begin state
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CheckSyntax Error

Each Activity and Control Activity should be reachable from the
Begin State. Solution: Ensure all paths in the business process starts
from a Begin State and all necessary relationships are drawn.

Error: [object type] [external code]
[description]: Not reachable from
begin state

Each business process must start with only one Begin State. Solu-
tion: Ensure the business process starts with only one state of the
type ‘Begin’.

Error: Too many begin states

Each business process must start with only one Begin State. That
means that there can be no incoming arrow for a begin state. In
case of a loop an arrow return to the begin state. Solution: Ensure
the business process starts with a begin state and remove any
other begin states.

Error: state [external code] [descrip-
tion]: Incoming arrow not allowed

Each business process must end with one state and this must be
of the ‘End’ type. Solution: Ensure the business process ends with
one state and change the State type to ‘End’.

Error: Missing end state

Each business process path should end in an End State. Solution:
Ensure all paths in the business process end in an End State and
all necessary relationships are drawn.

Error: [object type] [external code]
[description]: Cannot reach end state

Each business process path should end in an End State. Solution:
Ensure all paths in the business process end in an End State and
remove any arrow that flows out of the end state.

Error: state [external code] [descrip-
tion]: Outgoing arrow not allowed

Each business process path should end in an End State. A business
process can have more than one end state, but this is not common.
Thus a warning is displayed. Solution: Ensure all paths in the busi-
ness process end in the correct End State.

Warning: Too many end states
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Chapter 6: Entity Relationship Diagram

The Entity Relationship Diagram represents Entity Types for which data must be stored in the LN Application,
such as Purchase Orders, Customers and Projects.

Entity Types that represent database tables are placed in the diagram. Relationships are drawn between the
Entity Types. Their graphical representation indicates the cardinality of the relationship (one to one, one to
many or many to many) and the relation is optional.

Using Decomposed Diagrams you can link another Entity Relationship Diagram to one of the Entity Types in
a diagram, thus indicating all the other relationships of that Entity Type. For example, in a diagram that is
created for Purchase Orders, there is an Entity Type for Items. If you would draw all the Entity Types that are
linked to the Item Entity, the diagram becomes unreadably large. By linking an Decomposed Diagram of the
Item Entity, the Purchase Order Diagram is readable.

Entity Relationship Diagram graphical objects

DescriptionMenu option

Inserts an Entity that represents an object for which you must record informa-
tion. Select one of these types:
• Normal; Logical entity type; a meaning to the real world and is comprised

of one or more physical entity types
• Physical entity type; database tables in the Infor applications.
• Associative; used to link other entity types.

Insert -> Entity Type

Inserts a relationship between two entity types. The cardinality of the rela-
tionship defines the expected number of related occurrences for each of the
two entity types

Insert -> Relationship(1:n)

Inserts a subtype relationship between two entity types, a subtype and a su-
pertype. It is used to indicate that the supertype’s attribute also apply to, are
inherited by, the subtype.

Insert -> Subtype Relation-
ship

Operations that are used in Entity Relationship Diagram

DescriptionOperation

Right-click the Entity Type, point to Type. Select one of these op-
tions:
• Normal
• Associative; an octagon is added inside the graphical object

Modify the Type of the Entity Type
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DescriptionOperation

Right-click the Entity Type, select Properties. Link the appropriate
Decomposed Diagram to the Entity Type. The Entity Type graphical
object is embossed.

Link a Decomposed Diagram to the
Entity Type

Right-click the Entity Type, select Edit linked ERD.Edit/view the Decomposed Diagram
that is linked to the Entity Type

Right-click the Entity Type, select Tables. Link the appropriate LN
tables to the Entity Type. A Linked Tables icon is attached to the
Entity Type.

Link tables to the Entity Type

Right-click the (Subtype) Relationship, point to Type. Select one
of these:
• Free (midpoints can be added)
• Direct
• Z-style
• Horizontal-Vertical
• Vertical-Horizontal

Modify the Type of the (Subtype) Rela-
tionship

Right-click the Relationship, point to Cardinality. Select one of
these:
• One to One (midpoints can be added)
• One to Many
• Many to Many

Modify the cardinality of the Relation-
ship

Right-click the (Subtype) Relationship and select Reverse direction.Modify the direction of the (Subtype)
Relationship

Right-click the (Subtype) Relationship and select Add Midpoint to
change the route of the Relationship. This is only possible if the
Type of the Relationship is Free. You can add as many midpoints
as required.

Add a Midpoint to a (Subtype) Relation-
ship

Right-click the Relationship and select one of these options:
• Optional From To
• Optional To From
A circle is displayed at the end of the Relationship that is indicated
as optional.

Indicate an optional Relationship be-
tween two Entity Types

Right-click the Entity Type, select Properties. Now add/modify
the description From-To or To-From. The descriptions display in
the diagram and can be moved around.

Add/modify the description on one or
the other side of the Relationship
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Chapter 7: Legend

An explanation is given of all buttons, icons and graphical objects that are available in the Process Modeler
Workbench.

Top Toolbar
DescriptionBut-

ton

To save the diagram and close the workbench

To save the diagram

To return to the last saved version of the diagram

To delete the current selected diagram objects from the diagram

To print the diagram on a local printer

To undo the last user action

To reverse the last Undo command

To increase zoom level

To decrease zoom level

To set the zoom to the default value 100

To resize the diagram to make it completely visible

Diagram Objects Toolbar
Generic buttons
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The Diagram Objects toolbar shows the graphical objects you can insert in the diagram.

This table shows the buttons that are generic for all diagram types:

DescriptionBut-
ton

To turn on or off the automatic creation of a relationship (connector) between an existing (selected)
diagram object and a newly inserted diagram object

To switch to the ‘select mode’ to select one or more graphical objects in the diagram

To insert a graphical object that contains information regarding the diagram such as diagram code,
description, version, creation date and last modification date

To insert a note that is directly readable in the diagram

Align Toolbar
DescriptionBut-

ton

To align all selected graphical objects vertically, relative to the top of the object that is most at
the top

To align all selected graphical objects vertically, relative to the middle of all selected objects

To align all selected graphical objects vertically, relative to the bottom of the object that is most
at the bottom

To align all selected graphical objects horizontally, relative to the left of the object that is most to
the left

To align all selected graphical objects horizontally, relative to the middle of all selected object

To align all selected graphical objects horizontally, relative to the right of the object that is most
to the right

To align all selected graphical objects with the same horizontal distance from each other

To align all selected graphical objects with the same vertical distance from each other

To resize the width of all selected graphical objects to the widest of all selected objects

To resize the height of all selected graphical objects to the highest of all selected objects

To resize the width and height of all selected graphical objects to the widest and highest of all
selected objects
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Graphical objects used in all diagram types
The fields are filled automatically.

Info block

Diagram Name
Diagram Description
Diagram Version
Diagram Category
Created By
Creation Date
Role
Modification Date
Status

The Diagram Name, Description, Version, Role and Category are defined in the LN session where you create
or modify the diagram properties.

Annotation

Annotation

Icons used in all diagrams

Icons are graphical decorators linked to the diagram objects to indicate that certain data has been setup for
that object.

Text created for a graphical object in the repository.Text icon

Text created for a graphical object in a business model.Model Text
icon

Graphical objects used in the Enterprise Structure Model
Enterprise Unit

The graphical representation of the enterprise unit, it can be changed by selecting a different category in the
enterprise unit properties. For each enterprise unit category a different image can be setup. The description
is an object that can be moved individually from the image.
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Indicates that a business control diagram has been linked to
the Enterprise Unit

Linked Business Control Diagram icon

Enterprise Relationship

The graphical representation of a relationship between enterprise units. The description is an object that can
be moved individually from the line.

Enterprise Structure Diagram objects toolbar

DescriptionBut-
ton

To insert an Enterprise Unit.

To insert an Enterprise Relationship with a description to identify the relation between two Enter-
prise Units

Graphical objects used in the Business Control Model
Trigger

The graphical representation of a relationship between business functions or business functions and external
agents. The description is an object that can be moved individually from the line.

Function

Indicates that business processes are linked to the business function
via a Transformation Rule

Linked Business Process icon

Indicates that a Business function created in the Business Functions
(tgbrg2500m000) session have been linked.

Linked Business Function
icon
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Function with Timed Trigger

It indicates that the function either triggers itself completely at a fixed moment in time, for example monthly.
O that after receiving a trigger from anywhere else it waits to also trigger itself before actually starting.

External Agent

Represents External Agents such as customers, suppliers and governments that affect the Business Functions

Area

Visualizes which functions are related and fall within the circle of influence of the enterprise unit. If the area
is moved, all graphical objects within that area are moved with it.
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Flow

Shows the primary process controlled in the diagram. It can be represent a goods flow, financial flow or
information flow.

Customer Order Decoupling Point

A customer order decoupling point indicates up to what point in the material flow the product is tied to a
specific customer order.

Buffer

The graphical representation of a queue or a stock point to be located on the Flow

Primary activity

Represents a primary activity such as receive goods or production to be located on the flow
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Business Control Diagram objects toolbar

DescriptionBut-
ton

To insert a Trigger between the other graphical objects in the diagram. An incoming Trigger repre-
sents the cause/origin of the Business Function. The outgoing Trigger represents the result of an
action

To insert a business function

To insert External Agents such as customers, suppliers and governments that affect the Business
Functions

To insert an Area to visualize related business functions

To insert a Flow to visualize the goods flow, financial flow or information flow

To insert a Customer Order Decoupling Point to be located on the Flow

To insert a Buffer, representing a queue or a stock point to be located on the Flow

To insert a Primary Activity such as receive goods or production to be located on the Flow

Graphical objects used in the Business Function Model

Function

Represents a model item that defines relevant business issues and operations.

Indicates that a wizard is linked to the business functionWizard icon

Indicates that phases are linked to the business function, only available in a
business model.

Phases icon

Indicates which phases are linked to the business function, only available in a
Business Model.

Linked Phases
icon
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Optimization relationship

Represents the relation between two business functions and can only be used in a Business Model.

Business Function Diagram objects toolbar

DescriptionBut-
ton

To insert a Business Function

To insert an Optimization Relationship, only available in a Business Model.

Graphical objects used in the Business Process Model

Activity

An activity represents work to do in the form of:

• Manual activity; a not (in LN) automated task
• Business process; links a sub-process
• Application; starts an application of the selected component

Indicates that an URL is linked to the activity. Click on the icon to
start the URL

Linked URL icon

Indicates that an AO document is linked to the activity.Linked AO Document icon

Indicates that sub application authorization has been setup for the
activity

Sub Applications icon

Indicates that Roles authorization is setup for the activityLinked Roles on Activity Level
icon

Indicates that a support application has been linked to the activitySupport Application icon
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State

Represents a particular point in time.

Control activity

A control activity represents a decision moment and can be one of the following:

• XOR; only one of the paths must be executed
• OR; one or more of the paths can be executed
• AND; all paths must be executed
• JOIN; to join the paths split by XOR, OR or AND

Indicates that an URL is linked to the activity. Click on the icon to
start the URL

Linked URL icon

Indicates that Roles authorization is setup for the activityLinked Roles on Activity Level
icon

Relationship

Indicates the flow of activities in the business process.

Valid relations:

• Between State and Activity
• Between State and Control Activity

Business Process Diagram objects toolbar

DescriptionBut-
ton

To insert an Activity to represent work to do
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DescriptionBut-
ton

To insert a State that defines a particular point in time

To insert a Control Activity that represents a decision moment

To insert a Relationship

Graphical objects used in the Entity Relationship Model

Entity type

Entity that represents an object for which you must record information. It can be one of the following:

• Normal; to represent a Logical entity (has a meaning to the real world and is comprised of one or more
physical entity types) or a Physical entity (database tables in the LN applications)

• Associative; used to link other entity types

An entity in a diagram can have a Decomposed diagram linked to it. The graphical object is represented
embossed.

Indicates that a database table is linked to the Entity TypeLinked Tables
icon
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Relationship (1:n)

Represents the relationship between the entity types. The cardinality of the relationship defines the expected
number of related occurrences for each of the two entity types.

Subtype relationship

An indication that the supertype’s attribute also apply to (are inherited by) the subtype

Entity Relationship Diagram objects toolbar

DescriptionBut-
ton

To insert an Entity that represents an object for which you must record information

To insert a relationship between two entity types

To insert a subtype relationship between two entity types
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