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About this guide

This guide describes the configuration and usage of the Infor PLM Discrete for Microsoft Office.

Use this guide as a reference at your site. This guide does not teach you about Microsoft Office practices. This
guide shows you how to use the PLM integration for Microsoft Office application administrative and user
functions to complete specific setup and maintenance tasks.

Intended audience

This guide is for the administrative users who are responsible for the installation of the PLM Integration for
Microsoft Office and who would use the PLM integration to exchange information between PLM and Microsoft
Office. This could include searching, browsing, viewing and manipulating documents from a secured central
database, enhancing collaborative teamwork.

Prerequisite knowledge

To fully understand the information presented in this guide, you should first install the following:

• Infor PLM Discrete
• Microsoft Office

The server to which you will connect to from the integration must be defined as well.
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Contacting Infor

If you have questions about Infor products, go to Infor Concierge at https://concierge.infor.com/ and create
a support incident.

The latest documentation is available from docs.infor.com or from the Infor Support Portal. To access
documentation on the Infor Support Portal, select Search > Browse Documentation. We recommend that
you check this portal periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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Chapter 1: Microsoft Office Integration Overview

The Infor PLM Discrete integration for Microsoft Office enables you to incorporate your Microsoft Office
documents into PLM product data. From the first specifications typed out on a word processor, the budgets
(worksheets) and project plans prepared by project management, and the marketing presentations prepared
by the sales people, Microsoft Office and PLM exchange information throughout the life cycle of the product
and documents.

The PLM- Microsoft Office integration menu is embedded within the native Microsoft Office application menus.
It provides some of the core functions of PLM from within the familiar Microsoft Office environment.

The integration allows you to run Microsoft Office programs simultaneously, while taking advantage of PLM's
basic features. You can track the life cycle of files within the integration, in conjunction with all related
engineering design objects.

The Infor PLM Discrete integration for Microsoft Office allows effective exchange of information between PLM
and the supported Microsoft Office applications. All authorized users are provided with the tools to search,
browse, view and manipulate documents from a secured central database, enhancing collaborative teamwork.

Once the PLM- Microsoft Office integration has been installed, the PLM toolbar is added to your Microsoft
Office application toolbars, and the PLM menu is added to the Microsoft Office application menu bar. All the
options that can be accessed from the toolbar can also be accessed from the menu.

You can run the PLM- Microsoft Office integration from the following Microsoft Office applications:

• Microsoft Word
• Microsoft Excel
• Microsoft PowerPoint
• Microsoft Outlook

The main features of the Infor PLM Discrete integration for Microsoft Office include:

• Easy access to PLM document management operations from the Microsoft Office application through a
fully embedded menu and toolbar.

• Microsoft Office documents, worksheets, project plans and presentation files are represented from within
PLM, via graphic displays of the file dependency and structure for all projects, using the familiar tree view
component.

• All files supported by Microsoft Office Word, and Excel can be imported into PLM, with automatic updates
of links, reflecting the relationships between all types of documents and files. These can be quickly and
easily accessed using the PLM document management system.

• File names are maintained for all new Microsoft Office files. They are automatically checked against the
PLM database to eliminate redundancy or errors caused by overwriting files.

• Foolproof authorization ensures security and enables monitoring during the entire product life cycle,
based on user access rights and status of the document.
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• All files can be vaulted from within the Microsoft Office environment, based on authorization.
• For Word and Excel files, the PLM- Microsoft Office integration allows you to map PLM data into Microsoft

Office file properties. For example, you can choose to view the PLM ID of a document in your Microsoft
Office file.

• Microsoft Office documents can be linked to items directly from the integration. This way, for example,
a design document can be easily linked to the item it describes.

Infor PLM for Discrete Microsoft Office User Guide | 9

 

Microsoft Office Integration Overview



Chapter 2: Installation

This section shows how to install the integration. To install the integration, follow these steps:

1 Select Preferences in the Preferences drop down menu.
2 The PLM Preferences window opens.

About the PLM embedded menu and toolbar
After the PLM integration for Microsoft Office has been installed, the PLM toolbar is added to your Microsoft
Office toolbar, and a menu is added to the Microsoft Office menu bar.

The following menu and toolbar options are available:

See/DescriptionOptionIcon

Connecting to PLM on page 12Connect

Disconnecting from the PLM inte-
gration on page 12

Disconnect

Saving to PLM on page 14Save to PLM

Saving and Unlocking a file on
page 16

Save and Unlock

Introduction on page 24General Mapping

The Associate Mapping Rules
menu option on page 46

Associate mapping

Display Mapping on page 47Display mapping

Removing Mapping Associations
on page 47

Remove mapping

Checking in a file on page 19Check In

Checking out a file on page 20Check Out

Checking out a file on page 20Check Out Major
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See/DescriptionOptionIcon

Changing Ownership of a file on
page 20

Change in Ownership

Opening a file in a PLM workspace
on page 21

Open in WorkSpace

Preferences on page 49Preferences

Link to object on page 16Link to Item

Link to Document on page 18Link to Document

Link to Folder on page 18Link to Folder

Contains product and system in-
formation as well as additional
sources for professional assis-
tance.

About

Using Infocards on page 22Update Item

Using Infocards on page 22Update Document

Using Infocards on page 22Update File

Opening a file in a PLM workspace
on page 21

Show Document Structure

Opening a file in a PLM workspace
on page 21

Show item Structure
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Chapter 3: Working with PLM

This section contains the following topics that describe the tasks to be executed while working with PLM.

Connecting to PLM
To use PLM Integration for Microsoft Office, you need to establish connection between Microsoft Office and
PLM. The connection gives you access to the PLM database and projects that you need to work with.

To connect to PLM, proceed as follows:

From the Microsoft Office application, do one of the following:

• Click the Connect icon in the PLM integration toolbar.
• Select Connect from the PLM menu.
• If the PLM is already connected, an automatic silent connection occurs.

The functions in the PLM menu and toolbar are enabled. When you open another Microsoft Office application,
it will automatically have an enabled PLM toolbar and menu ready to use.

Disconnecting from the PLM integration
Disconnecting is a global operation for all Microsoft Office integration applications; disconnecting from one
Microsoft Office application disconnects all connected Microsoft Office application from PLM.

To disconnect from the PLM integration, do one of the following:

1 Select Disconnect in the PLM integration drop-down menu.
2 Click on the Disconnect icon in the PLM integration toolbar.
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Chapter 4: Managing Objects

When any Microsoft Office file, such as a Word document or an Excel table, is saved to PLM, it is represented
by two PLM objects that are linked to each other:

• A PLM file which is revision-controlled and specifies the location of the Microsoft Office file, together with
additional data about it. This PLM file (also known as a data set) has the same name as the Microsoft
Office file.

• A PLM document, which is also revision-controlled, and which contains attributes that describe the
characteristics of the file. The file's name is held in the document's Description attribute.

For example, when the Word document Report_2002.doc is created and then saved to PLM, the integration
creates:

• A PLM document with the description attribute Report_2002.doc
• A linked PLM file with the file name Report_2002.doc

File Hierarchy Management
The PLM documents representing Microsoft Office files are linked to one another in a way that reflects the
dependencies between the actual files.

The PLM hierarchical representation of those dependencies reflects the links inserted in the Microsoft Office
files. Changes made in Microsoft Office files are reflected in PLM as follows:

• When a link is inserted into a Microsoft Office, the change is reflected in PLM only after the file is saved
to PLM. After this operation, you can view the file and the related document and PLM file in PLM.

• When a link is deleted from a Microsoft Office file after the file is saved to PLM, the link between the PLM
documents are also removed, but the linked document and related file are not deleted from PLM.

Controlling Document Revisions
The Integration provides revision control by physically transferring the original file into the vault and handling
the revisions via the documents that are the PLM representation of the physical Microsoft Office files.

When you want to edit a file that is checked in, you must first check it out from the PLM vault (this creates a
new revision of the file). For more information, see:
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• Checking in a file on page 19
• Checking out a file on page 20

The system will then place the new revision of the file in a location for your use.

File Revisions
When a revision is first created, it is assigned the status DRAFT. When the revision is ready for general access,
it is checked into the vault, and PLM then assigns the status RELEASED. Releasing a PLM object makes it
available for distribution.

When you want to make changes in a released PLM object, you must check it out of the vault. The original
revision is then assigned the status UNDER CHANGE, which indicates that another revision is being prepared,
and a new revision is created with the status DRAFT.

Saving to PLM
When you save a Microsoft Office file to PLM for the first time, the integration creates two PLM objects, a PLM
document with the status DRAFT and a linked PLM file with the appropriate attributes for the newly saved
Microsoft Office file.

The Save to PLM process saves your Microsoft Office file in the PLM database. The document is saved with
the status DRAFT. Each consecutive save updates the latest changes performed on the DRAFT revision of the
document in PLM.

You can only save a file if its related PLM document has a status of DRAFT. If a document has the status UNDER
CHANGE or RELEASED, the file cannot be saved to PLM.

To save your changes on the server (not only locally), perform Save to PLM. However, to save system
performance, do not save to PLM too often. For more information, refer to Saving files in PLM - Best Practices
on page 14.

Saving an existing file to PLM also saves the file in Microsoft Office. If you save the file only to Microsoft Office,
the file is saved only locally and the associated documents and/or items in PLM are not saved.

The assignment of the file ID is determined by the parameters set up by the administrator as well as by the
selected preference settings. The IDs for documents and items can be assigned manually or automatically
by PLM, this is also set up in the preferences.

Saving files in PLM - Best Practices
Saving to PLM draws heavily on your configuration's resources. To save system performance, you are
recommended only to save to PLM when updating the associated PLM documents, items, and files is actually
required. For routine saves, use local save options.
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In addition, the PLM Check in and Save and Unlock commands also save your data to PLM. Therefore, if the
goal of your current session is to check in or save and unlock your part file, you can save your file locally from
time to time and complete working on your file by checking in or using Save and Unlock.

To save a file in PLM
Before you can save a file to PLM, you must save it in Microsoft Office with a unique name. Do not use & < > '
" symbols in the file names that you save to PLM, this will cause errors to occur.

Do one of the following:

• Click Save to PLM in the toolbar.
• Select Save to PLM from the PLM drop down menu.

Clicking Save to PLM in the menu or the toolbar results in one of the following:

• If all the IDs are generated automatically by PLM, you can specify in the preferences where the file is
saved. To access the preferences, click PLM Options in the PLM menu. For further information about the
preferences, see PLM options on page 49.

Duplicate file names
PLM enables you to save two or more files with the same name. Since in Microsoft Office you cannot save two
files by the same name in the same location, you first need to save the second file in a different location and
then save the file to PLM.

If you save a file with a name that already exists in the same location, you must do the following:

1 When prompted by Microsoft Office on whether you want to replace the existing file, select No.
2 Save the file with the same name to a different location on your hard disk or network.
3 Save the file to PLM.

To save a duplicate file name in PLM
1 Save the file in PLM as described in Duplicate file names on page 15.
2 The PLM - Resolve Filename dialog box is displayed.
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3 Select Create a new Document with the same name.
The file is saved in PLM with the selected name.

Link to item
You can link your Microsoft Office file to a PLM item.

To link a Microsoft Office file to a PLM item, proceed as follows:

1 Click PLM Menu > Link to Item.
2 The Set Object Properties dialog box appears.

3 In the Item ID field, enter or browse for the ID of the item to which you want to link your Microsoft Office
document or work sheet.
In the PLM, select Item, right-click and Select Source. In the Set Object Properties dialog box, select
Browse. The selected Item in the PLM is displayed in the Item ID field.

4 If required, in the Revision field, enter a revision number for the item to which you want to link your
Microsoft Office document or work sheet.

Saving and Unlocking a file
If a file that you are working on is supposed to be used in a business process, the business process cannot be
launched while the file is locked. To avoid this situation, you should save such files using the Save and Unlock
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command. This automatically updates your data, while relinquishing ownership of the file. The business
process can then proceed.

If you have finished working on a file and the file must be passed on to an unknown new user, you should
also use the Save and Unlock command. The new user who needs to work on the file can now acquire
ownership of the file.

If you know who will be the new owner of the file, you can transfer ownership to the new owner. See Changing
Ownership of a file on page 20.

To Save and Unlock a file

• Click Save and Unlock in the PLM toolbar.
• Select Save and Unlock from the PLM menu.

The file is saved in PLM with no owner.

To acquire ownership of a saved and unlocked file
1 Click Save to PLM in the PLM toolbar or select Save to PLM from the PLM menu.

The Take Ownership List dialog box is displayed.

2 Select the required file and click OK.
3 Save the file again in Microsoft Office.
4 Enter the appropriate ID(s), if prompted. This depends on the preference settings. See PLM Options on

page 49.
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5 Click OK.
The integration verifies that the ID(s) can be used and proceeds with saving your file, or notifies you if
the entry is invalid.

Link to Document
You can link your Microsoft Office file to a PLM folder.

To link a Microsoft Office file to a PLM item, proceed as follows:

1 In the Microsoft Application, click Infor PLM Menu > Link to Document.
2 The Set Object Properties dialog box appears.

3 You can perform one of the following:
a In the Document ID field, specify the ID of the document to which you want to link your Microsoft

Office document, work sheet, powerpoint or outlook file.
b In the PLM, select document, right-click and Select Source. In the Set Object Properties dialog box,

select Browse. The selected Document details in the PLM is displayed in the Document ID field.
4 If required, in the Revision field, enter a revision number for the item to which you want to link your

Microsoft Office document or work sheet.
5 Click Ok.

Link to Folder
You can link your Microsoft Office file to a PLM folder.

To link a Microsoft Office file to a PLM item, proceed as follows:

1 In the Microsoft Application, click Infor PLM Menu > Link to Folder.
2 The Set Object Properties dialog box appears.
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3 In the Folder ID field, specify the ID of the folder to which you want to link your Microsoft Office document,
work sheet, powerpoint or outlook file.
In the PLM, select folder, right-click and Select Source. In the Set Object Properties dialog box, select
Browse. The selected Folder details in the PLM is displayed in the Folder ID field.

4 If required, in the Revision field, enter a revision number for the item to which you want to link your
Microsoft Office document or work sheet.

Checking in a file
When you have finished working with a file, it can be released. The PLM integration for Microsoft Office enables
you to check in any Microsoft Office file and its linked documents to the PLM vault.

The check-in operation accomplishes the following:

• Confirms the changes you made in the Microsoft Office file.
• Changes the file's status from DRAFT to RELEASED.
• Transfers the Microsoft Office file to the PLM Released area from the Microsoft Office location.

The integration verifies that you have authorization to perform this operation and that the document linked
to the file has the DRAFT status. If the file is new, the system prompts you with the Save dialog box to save
the file locally and perform the check-in operation. You can only access this file in Microsoft Office via the
PLM Integration Query tool. See Introduction on page 13.

After the file has been checked in, you can only change the file by checking it out.

To check in a file
1 Do one of the following:

• Click the Check-In icon in the PLM toolbar.
• Select Check In from the PLM menu.

2 If prompted, save the file to Microsoft Office first.
The file is checked in.
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Checking out a file
You must check a file out of the vault in order to change it.

To check out the file, you need to open it for editing in the integration. The file is opened in read-only mode
and cannot be modified until it is checked out. If you try to perform any modification in it, you will be prompted
to check it out first. This is done to protect the integrity of your data.

Two types of Check Out are available:

Check Out
This option is usually used for minor design revision changes. A minor check-out results in a higher sequence
number within the current revision for the checked out file, for example from A0001 to A0002.

Check Out Major
This option is usually used for significant changes with major impact on the form, fit or functionality of the
product. A major check-out results in a higher version number for the checked out file, for example from
A0001 to B0001.

To check out a file
1 In Microsoft Office, select Query PLM from the PLM menu and in the Query Manager that opens, run a

search for the file you want to check out.
2 In the Document List pane, select the required file and right-click on the file. Select Download files from

PLM in the menu that appears.
The file is opened in Microsoft Office.

3 Select the file that you want to check out and select Check Out from:
• The PLM toolbar
• The PLM menu

4 The file is checked out.
After the check-out, the file is no longer in read-only mode and can be modified as required

Changing Ownership of a file
The owner of a file is determined by one of the following:

• The user who created it and saved it to PLM.
• The user who checked it out of PLM.
• The user to whom the ownership has been transferred.
• The user who performs the Download files from PLM process on a saved and unlocked file.
• Project administrators are not the owners of all files, but they are given access to modify the files owned

by users in their projects.
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When you are registered as the owner of a file in PLM, you can edit the file as required while other users can
view but not modify the file. You can choose to transfer the ownership to another user when the user needs
to work on that file. Ownership can only be changed if the file has been saved to PLM.

After a file has been checked in (and has the status of RELEASED), it does not have a specific owner.

To change the ownership of a file
1 In Microsoft Office, in the file with which you are working with, select Change Ownership in PLM menu

or toolbar.
2 In the Select User dialog box that appears, select the user you want to transfer the ownership to and

click OK.

The selected user now owns the file.

Opening Document Structure
To open document structure of a file, proceed as follows:

1 In Microsoft Office, create a part file and save it to PLM. See Saving to PLM on page 14.
2 Select Show Document Structure in the PLM menu or toolbar. A dialog will open that shows the document

structure of the file.
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Using Infocards
An infocard is a dialog box that enables you to update metadata of items, documents or files generated from
part files created in Microsoft Office. There are three types of infocards, one for items, one for documents,
and one for files. You must use infocards to make changes to the item, document or file in Microsoft Office
rather than in PLM. You can update only those items, document, or files that you own.

To update items, documents or files generated from the Microsoft Office object that you are working on,
proceed as follows:

1 In Microsoft Office, select an item, document or file.
2 From the PLM menu, select the relevant update option. You can select Update Item, Update Document

or Update File.
The relevant Update dialog box is displayed.

3 Make the required changes.
4 Click Update.

You can update the document using the Details pane as shown in the following screen:
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Chapter 5: General mapping

Introduction

General mapping is available for Microsoft Word. General mapping enables you to define attribute-based
mapping rules for a template. When you create documents or work sheets in Microsoft Word using a template,
the mapping rules are carried over to the documents or work sheets based on how you set up the rules.

The mapping rules determine how values of Microsoft Word attributes are mapped to PLM attributes and
vice versa for files that use the template containing the mapping rules. To use general mapping, you must
have administrator's rights. You must link the Word document to the PLM item prior to performing the
mapping.

Defining mapping rules

In Microsoft Word, create template Template_001.dot. For Template_001.dot, define the following mapping
rule:

Microsoft Word property Project_ID goes to PLM item attribute Project. Create a document based on template
Template_001.dot.

As a result, if you enter a value for the Project_ID property of the Microsoft Word document, this value is
entered in the Project field of the PLM item that you link to the Microsoft Word document.

For Microsoft Word documents, the mapped attributes can be displayed anywhere in the Microsoft Office
files derived from the template:

• The body of the file
• The header and/or footer of the file
• Tables within the file

Summary of mapping setup in Word
You can map Microsoft Word properties to PLM or vice versa. Each direction in each application requires a
different property setup

Word to PLM

When mapping from Microsoft Word to PLM, define the following data:
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• Bookmark
• Document property attribute
• Select Link to Content check box for document property attribute

Result:

The property is linked to the bookmark. If you create a document based on the template and you insert a text
in the bookmark, this text is filled in the property attribute and through the property attribute, the text is
updated in the PLM attribute that you specify in the mapping rules. For further information on mapping rules,
see Defining the mapping rules on page 42.

PLM to Word

When mapping from PLM to Microsoft Word, define the following data:

• Document property attributes
• Document fields in which the properties are to be displayed

Result:

From the PLM attribute specified in the mapping rules, the Microsoft Word template property attribute is
filled. In turn, the template property attribute fills the field in the documents derived from the template. For
further information on mapping rules, see Defining the mapping rules on page 42.

Outline of the procedure to set up general mapping
The procedure to set up general mapping for Microsoft Word includes the following steps:

1 Define a template in Microsoft Word.
2 Decide on the direction of mapping:

• PLM to Microsoft Office
• Microsoft Office to PLM
• Both

3 Define the property attributes and related data as appropriate for the relevant mapping direction and
application.

4 Using the PLM mapping tool, take the following steps:
a Import the template to PLM.
b Define the mapping rules.

5 In Microsoft Word, create a file based on the template.
6 In the PLM - Microsoft Office Integration, take the following steps:

a Save the file to PLM.
b Associate the mapping rules.
c Save the mapping association and the file to PLM.

7 Exit and restart PLM and Microsoft Office for the mapping to take effect.
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Creating the template
To use general mapping, templates must exist for which mapping rules have been defined. You can only
create mapping rules if you have administrator’s rights.

To create a Word template, proceed as follows:

1 In Microsoft Word, select File > New.
2 In the New Document task pane that appears, select one of the options to select a template type.
3 In the Templates dialog box that appears, select a template type, select Template and click OK in the

Create New group box.
4 To define attribute properties for the template, select File > Properties to open the Template <name>

Properties dialog box.

Importing the template into PLM
Before you can define mapping rules for new or changed templates, you must import them in PLM. Re-importing
a template will not remove any previously defined rules for this template.

To import a template into PLM, proceed as follows:

1 Click Infor PLM > Preferences > Mapping Template Tool.
2 From the Application list in the upper left of the Mapping Template Tool dialog box.
3 Click Import.
4 In the Open dialog box that appears, select the template for which you want to define mapping rules and

click Open.
The template properties are displayed in the upper right section of the PLM Mapping Tool dialog box.

Mapping from Word to PLM
To enable a text inserted in a Microsoft Word file to be updated automatically in PLM, you must define a
bookmark and a property in the Word template. The property must be linked to the bookmark.

To define a bookmark and a property, take the following steps:

1 In the template, create some text where the text that must be mapped is to be located and highlight this
text as shown in the following picture.
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In this example, the text to be mapped is located in the header, but this could be anywhere in the
document.

2 Insert a bookmark for the highlighted text as shown in the picture above.
3 Select Insert > Bookmark.

The Bookmark dialog box opens.

4 In the Bookmark dialog box, make sure that you:
a Type the name for the bookmark in the Bookmark name field, for example, Document Description.
b Select Sort By: Location.
c Click Add.

5 Select File > Properties and in the Custom tab of the <Template name> Properties dialog box, proceed
as follows:
a In the Name: field, enter a name for the property.
b Select the Link to content check box.
c In the Source: field that is enabled after you select the Link to content check box, select the bookmark

that you created in the previous steps.
The property is now linked to the bookmark. If you create a document based on the template and
you insert a text in the bookmark, this text is updated in the PLM attribute specified in the mapping
rules.

d Click Add.
e Click OK.
f Import the template into PLM. See Importing the template into PLM on page 26.
g Define the mapping rules. See Defining the mapping rules on page 42.
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Mapping from PLM to Word
To map a PLM attribute to a Microsoft Word file, in the template you must define a property and a field that
is based on the property. Through the property, the value of the PLM attribute will be displayed in the field.

To define a property and a field in the Word template, proceed as follows:

1 Select File > Properties and in the Custom tab of the <Template name> Properties dialog box proceed
as follows:
a In the Name field, enter a name for the property, for example, Document number.
b In the Value field, enter a dummy value. This value will be overwritten by the value of the PLM

attribute.
In the mapping rules you can specify that the value of the Document ID attribute in PLM must be
filled in the Microsoft Word Document number property attribute.

c Click OK.
2 In the template, place the cursor in the location where you want to insert the field.
3 Select Insert > Quick Parts > Field, and in the Field dialog box that appears, proceed as follows:

a In the Categories list, select (All). This is the default value.
b In the Field name list, select DocProperty.This is a type of field that refers to document properties.
c In the Property: list, select the property, for example, Document number, that you defined in the

previous steps.
d Click OK.

4 After you have finished defining property attributes and fields, proceed as follows:
a Import the template into PLM. For further information, see Importing the template into PLM on page

26.
b Define the mapping rules. For further information, see Defining the mapping rules on page 42.

To view the field code of a field, place the cursor on the field and from the right-click menu, select Toggle
Field Codes.
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Example of Word file with mapped attributes

Mapping examples in Word
In these examples, Microsoft Word and Infor PLM Discrete attributes will be mapped as follows:

ItemDocument

DirectionPDM attribute
(item)

Word attributeDirectionPDM attribute
(document)

Word attribute

To integrationItem IDItem IDTo integrationDocument IDID

To PLMItem Descrip-
tion

DescriptionTo PLMDocument De-
scription

Description
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ItemDocument

DirectionPDM attribute
(item)

Word attributeDirectionPDM attribute
(document)

Word attribute

To integrationItem StatusRevision StatusTo integrationDocument Sta-
tus

Revision Status

To integrationItem RevisionRevisionTo integrationProjectProject

To integrationOriginatorReviewed by

To integrationCreation dateReview date

Create Word file based on the template
First, you must create a Microsoft Word file based on the template. The text highlighted in yellow will be
updated in the Document description in PLM.

Save the document and link an item.
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Associate mapping
After you save the document and link the document to an item, you must associate the document to the
template for which the relevant mapping rules have been defined.

Mapping results in Word
In the Microsoft Word document, the mapping results look as follows:

In the PLM document, the document description looks as follows:
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After you create the Microsoft Office attributes, you must define the mapping rules. To define mapping rules,
you must have administrator authorization. Mapping rules are defined in the PLM Mapping Tool dialog box,
which is accessed from the Infor PLM Discrete. To access PLM Mapping Tool:

• Open the Infor PLM Discrete application.
• Select Mapping Template Tool. Click Import for New Template or Select Template for existing Template.

• In the Template list, select the template for which you want to define mapping rules.
Note: If the template is new or if changes were made to the template in the application, you must import
the template into PLM first.
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Any previously defined mapping rules for the selected template are displayed in the dialog box.

Mapping from Excel to PLM
To enable the value of an attribute inserted in a Microsoft Excel file to automatically be updated in Infor PLM,
in the Excel template, you must define an attribute and a property. The property must be linked to the attribute.

To define an attribute and a property:

1 In the template, from the Formula menu, select the Define Name.
2 In the Define Name dialog box that appears, proceed as follows:

a In the Name in workbook: field, enter the name, for example, Document_Description, for the
attribute.

b Click Ok.
3 In the File menu, select Properties, and in the Custom tab of the <Template name> Properties dialog

box that appears, proceed as follows:
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a In the Name: field, enter the name for the property you are going to create, for example, Doc_Descr.
b Select the Link to content check box.
c In the Source: list, select the attribute titled Document_Description that you created in the previous

steps. As a result, the property is linked to the attribute.
d If you create a workbook based on the template and you insert a value in the attribute, this value

will be updated in PLM through the template property. In the SSA PDM mapping tool, you can
determine to which PLM attribute the value will be mapped. For further information, see Defining
the mapping rules.

e Click Add.
f Click Ok.

Mapping from PLM to Excel
To enable the value of an Microsoft Excel cell to be automatically updated with the value of an PLM attribute,
you must define a property attribute, a macro, and a function in the Microsoft Excel template. You must insert
the function in the cell that must be updated with the property attribute value. The property will be updated
with the PLM attribute value. The macro will pass on the PLM attribute value to the cell in the workbook.

To map PLM attribute value to a cell in a workbook:

1 In the File menu, select Properties.
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2 In the Custom tab of the <Template name> Properties dialog box that appears, proceed as follows:

Defining a macro
To define a macro:

1 In the Microsoft Excel template, press ALT - F11 to start the VBA editor.
2 In the VBA editor, select the Insert menu and from the Insert menu, select Module to define a new module.
3 In the VBA editor window, define a function for each property attribute that you defined in the template

as described in the previous procedure. For property attribute DOC_ID, for example, enter the following
code:

Function getDOC_ID (temp As Integer) As String getDOC_ID=ActiveWorkbook.CustomDocumentProper
ties("DOC_ID").Value 
End Function

Note that the function name, getDOC_ID, consists of two parts:

• get
• DOC_ID

DOC_ID is the name of the property. This macro will fill the cell that is selected in the following procedure.
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Inserting a function from a cell
To insert a function for a cell:

1 In the template, select the workbook cell in which you want the value from the property attribute, for
example, DOC_ID, to be inserted.

2 From the Formulas menu, select Insert Function. In the dialog box that appears, proceed as follows:
a From the Or select a category: list, select User Defined.
b From the Select a function: list, select the macro that the function will use, for example, getDOC_ID.
c Click OK.
d In the Function Arguments dialog box that appears, define any integer that you want to use as

function input.

To view the function name in the cell in which the function was inserted, double-click the cell.

Mapping examples in Excel
The following picture shows how the mapping setup described in Mapping from Excel to PLM and Mapping
from PLM to Excel takes effect in Microsoft Excel workbooks.
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The following picture shows how the mapping setup described in Mapping from Excel to PLM and Mapping
from PLM to Excel takes effect in PLM documents.

Defining attribute properties in the Powerpoint
To use general mapping, templates must exist for which mapping rules have been defined. You can only
create mapping rules if you have administrator’s rights.

To map a PLM attribute to a Microsoft Powerpoint file, in the template you must define a property and a field
that is based on the property. Through the property, the value of the PLM attribute will be displayed in the
field.

To create a Powerpoint template and define attribute properties:

1 In Microsoft Powerpoint, select File > New.
2 In the New Presentation task pane that appears, select one of the options to select a template type.
3 In the Templates dialog box that appears, select a template type, select Template and click OK in the

Create New group box.
4 To define attribute properties for the template, select File > Properties > Advanced Properties to open

the Template <name> Properties dialog box.
5 In the Custom tab, specify the following information:

• Name: The name of the PLM attributes that must be mapped in Powerpoint. For example, specify
PLM_ID. This value will be mapped with Document ID field in the PLM.

• Type: Specify whether the value must be Text, Date, Number and so on.
• Value: Specify a dummy value. This value will be overwritten by the value of the PLM attribute.
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6 Click Ok.

Mapping from Powerpoint to PLM
To enable a attributes in a Microsoft Powerpoint file to be updated automatically in PLM, you must define a
property in the Powerpoint template. The property must be mapped to the PLM.

To map Powerpoint attributes to PLM:

1 In the template, go to File > Properties > Advance Properties and in Summary tab specify a Title and
Subject.
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2 Save the template.
3 Open PLM Discrete Mapping Tool and import the template. See Importing the template into PLM on page

26.
4 Define the mapping rules. See Defining the mapping rules on page 42.
5 Save the file to PLM.

Document is created in the PLM and the information that is mapped from Powerpoint is updated in PLM.
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Mapping from PLM to Powerpoint
To map a PLM attribute to a Microsoft Word file, in the template you must define a property. Through the
property, the value of the PLM attribute will be displayed.

To map attributes from PLM to Powerpoint:

1 In Powerpoint file define the property. See Defining attribute properties in the Powerpoint on page 37.
2 Save the template.
3 Open PLM Discrete Mapping Tool and import the template. See Importing the template into PLM on page

26.
4 Define the mapping rules. See Defining the mapping rules on page 42.

5 Save the file to PLM.

Document is created in the PLM and the information that is mapped from PLM is updated in Powerpoint.
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Mapping from Microsoft Outlook to PLM
To map attributes in Microsoft Outlook to be updated automatically in PLM, you must define mapping rules
in PLM. You can only map attributes such as, To, Sender name, Subject, SentOn, Creation Time, CC, BCC, and
Subject.

To map Microsoft Outlook attributes to PLM:

1 In the PLM Discrete Mapping Rule window, select the Application and the Template to map.
2 Select the Document and MS Office attributes.
3 Define the mapping rules. See Defining the mapping rules on page 42.
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4 Associate mapping to the Outlook file. See Associate the mapping rules to documents or work sheets on
page 46.

5 Save the file to PLM.
Document is created in the PLM and the information that is mapped from Microsoft Outlook is updated
in PLM.

Defining the mapping rules
In the Infor PLM > Mapping Template Tool dialog box, you can define the mapping rules that are used to
map attributes between PLM and Microsoft Office. This dialog box is divided into two sections, one for the
PLM attributes and one for the Microsoft Office attributes.

The following example shows how to map attributes from Microsoft Office to PLM and vice versa. To map,
for example, the value of the Title attribute in the Summary group in Microsoft Office to the Description
attribute of an item from PLM, proceed as follows:

1 Click the Item icon on the left side of the Mapping Tool dialog box.
A list of item attributes is displayed on the left side in the middle section of the screen.
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2 From the list of item attributes, click Description.
3 From the Microsoft Office side of the window, click Summary from the Microsoft Office tree.

A list of attributes is displayed in the section below.

4 In Word, you can find these properties in the Summary tab of the Properties dialog box. This dialog box
appears if you select File > Properties in Microsoft Word.

5 Click Title from the list of attributes.
6 Click the To PLM button in the middle section of the dialog box. This maps the value of the Title attribute

to the Description attribute of the item in PLM.
You can add more mapping rules before accepting them. See Mapping options on page 44 for further
information on the available mapping options.

7 Click Apply when you are through specifying mapping rules.
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Mapping options
There are countless variations of the attributes you can map. You can select an attribute associated with an
object in PLM and map it to an attribute in Microsoft Office. Also you can reverse the direction and map an
attribute value in Microsoft Office to an object's attribute in PLM.

For this purpose, make selections from the PLM and Microsoft Office sections and click the button that
describes the direction you want the mapping to take place.

• The Integ. button maps the selected attributes from PLM to Microsoft Office.
• The To PLM button maps the selected attributes from Microsoft Office to PLM.
• The Both button maps the selection to both PLM and Microsoft Office. The mapping rule goes in both

directions, meaning the values remain in sync.

In Microsoft Office, if you are working with a part file and you enter a value for an attribute that is mapped to
both, the following dialog box appears when you save the part file to PLM.

This dialog box prompts you to indicate which value you want to keep: the value just entered in Microsoft
Office or the value entered in PLM.

Mapping restrictions
Depending on the attributes selected in the PLM Mapping Tool dialog box, mapping to PLM, to Microsoft
Office, or both can be unavailable. The mapping restrictions are described in the following sections. Attributes
not included in the following lists are available for mapping to PLM, Microsoft Office, and to both.

For all mapping rules that you want to define, the target attribute must be a modifiable field.

The following PLM attributes are only available for mapping from PLM to Microsoft Office:
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The PLM Effective From and Effective To attributes.

Item

Lifecycle.

All attributes related to an item's life.

Business Process.

The attributes related to an item business process or a business process.

Keywords.

Keyword attributes.

Business Attribute.

Manufacturer, supplier, customer, and subcontractor attributes.

Document

Lifecycle.

All attributes related to an item's life.

Business Process.

The attributes related to an item business process or a business process.

Business Attribute.

Manufacturer, supplier, customer, and subcontractor attributes.

Project

Project.

All project attributes.

Attribute format restrictions
To enable you to define mapping rules, the PLM attributes and the Microsoft Office attributes must have the
same format or must have a conversion in order to facilitate the following matches:

RealDateIntegerTo: StringFrom

+String

+(*)+(*)+Integer

+(*)+Date

+(*)+Real

Infor PLM for Discrete Microsoft Office User Guide | 45

 

General mapping



Note: + (*) According to regional settings.

The target attribute must be of type string if more than one attribute is mapped to this attribute. The target
PLM attribute to which Microsoft Office dimensions are mapped is of type string, because the value and the
unit must be concatenated to a string.

The target PLM attribute in a Microsoft Office file-specific rule can have no other general mapping.

Relationship

You can map one Microsoft Office attribute to one PLM attribute, one Microsoft Office attribute to many PLM
attributes, or many Microsoft Office attributes to one PLM attribute.

Associate the mapping rules to documents or work sheets
Now that you have created mapping rules and saved them to a template, you can create parts, assemblies,
or drawings in Microsoft Office using this new template. The part, assembly, or drawing acquires the values
of the attributes you defined in the mapping rules. Only the owner of a file or the project administrator can
perform associations.

To associate mapping rules to documents or work sheets, proceed as follows:

1 For the mapping rules to take effect, disconnect and then reconnect to PLM.
2 In Microsoft Office, open a template file for which you have created mapping rules as described in Defining

the mapping rules on page 42.
3 Save the template document or work sheet under another name.

The new document or work sheet has obtained the attributes and the mapping rules of the template.

4 Save the document or work sheet with the new name to PLM.
5 If you mapped attributes from Microsoft Office to PLM items, link your Microsoft Office document or work

sheet to a PLM item using the Link to Item option from the PLM menu for the mapping rules to take
effect.
For further information, see Link to Object on page 16.

The Associate Mapping Rules menu option
In addition to saving the template, for which you have defined mapping rules, under a different name, as
described in Associate the mapping rules to documents or work sheets on page 46. You can use the Associate
Mapping Rules option from the PLM menu to associate mapping rules to files.

Note that you can only use this option for files not associated to a mapping template previously by opening
the template and saving the file under another name.

To associate a file to a template using the Associate Mapping Rules option, proceed as follows:

1 In Microsoft Office, open the file for which you want to associate mapping rules.
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2 In Microsoft Office, click on the PLM Menu > Associate Mapping Rules. The PLM Mapping Tool dialog
box is displayed, as shown below.

3 From the Template list, select a template you created in Microsoft Office and imported into PLM. The
mapping rules for this template are displayed.

4 Click OK.
The mapping is completed when you save to PLM.

5 After the mapping rules are associated, you can click Display Mapping from the PLM menu to display
the current mapping rules.

Removing Mapping Associations
You can remove the rules that are associated with the template. For this purpose, select Remove Mapping
Association from the PLM menu. Only project administrators who own the file can remove an association.

Display Mapping
You can use the Display Mapping Rules option in the PLM menu to view the mapping rules defined for the
template associated to the part file with which you are working. If you click this option, the PLM Mapping
Tool dialog box appears in view-only mode showing the associated template and the mapping rules.

Applying the Mapping Rules
For the mapping rules to take effect after you define or update them in the PLM Administrative Console as
described in Defining the mapping rules on page 42, you must first disconnect and reconnect your Microsoft
Office application to PLM.

The mapping then takes place depending on the rules that you set up. In the example in Defining the mapping
rules on page 42, the mapping takes place when you:

• Save to PLM
Note: If the file is new and has not been saved to PLM, you must save the file to PLM to apply the mapping.
After the mapping is applied, you can select Update Item, Update Document or Update File from the
PLM menu to see the mapped values. For further information, see Using Infocards on page 22.
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• Use the infocard options: Update Item, Update Document or Update File.
• Edit the file.
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Chapter 6: Setting Preferences

PLM Options

The PLM integration preferences control the way the PLM integration for Microsoft Office works.

Users locally manage integration properties for which they have been authorized by the administrator. The
local integration properties are specific to each user. Your settings do not affect the properties of other users.

Users manage their local integration properties in the PLM Preferences pane. To access the PLM Preferences
pane:

1 In Microsoft Office Application, select the Infor PLM menu.
2 Select Preferences > PLM Options.

The PLM Preferences pane appears.

Locations
To carry out various commands, such as View File or Edit File from the Results panel of the integration query,
PLM must locally download the files that you want to view or edit in Microsoft Office.

In the Locations section you can specify the folders in which PLM must locally download the files that you
want to view or edit in Microsoft Office.
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Initial save option
The properties comprising the Initial Save Option determine how files behave when saved to PLM for the first
time.

Specify Manual ID for Documents
This option is used to specify whether the IDs and revision number of files created in Microsoft Office and
saved in PLM must be entered manually or generated by PLM. If you select this check box, you must manually
enter an ID when you save a Microsoft Office file to PLM.

Set Object Attribute During Save
If this check box is selected, you can specify or change the attribute of the objects when you save them. If
you set this preference, the Attributes for Files-Documents- Items objects dialog box appears.

Concatenate Item-ID/ File-ID
If this check box is selected, Microsoft Office files are downloaded with filename prefixed with file id and file
version.

General
Use the General preferences category, to specify your preferences such as, Query Search Default and File
Name Uniqueness.

File Name Uniqueness
If this check box is selected, the names of the files stored in PLM are unique. If this check box is cleared, you
can store multiple files with identical file names in PLM but in different projects. It is not recommended to
clear this check box, since it might cause problems if you want to download a file while a file with an identical
name already exists locally. Three options are available for this setting.
• Unique across all projects: Only one file can be saved with a given name into PLM from Office integration.
• Unique per Project: At most one file with a given name can be saved in a project.
• Duplicate file name is allowed: Multiple files with a given name can be saved in PLM.

Query Search Default
This option defines the default search object in Infor PLM > Download files from PLM tool. The following
options are available:
• File
• Document
• Item

Post Save Process
Use the Post Save Process category to define the actions that can be performed on the local Microsoft Office
file when it is copied to the PLM. The preferences are:
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Show message on successful save
If this check box is selected, the PLM integration displays a dialog box when an object is saved successfully
on the server.

Check in cleanup
Select the action that must be performed on the file, when it is checked into the PLM Server.
• Make Files Read-Only: After check-in, all the files (within the structure, including the root file) will be

made read-only in the local system.
• Delete File: After check-in, only the root file will be deleted from local system. Rest of the files (within

the structure) will be read-only.

Save and Unlock Cleanup
Select the action that must be performed on the file, when the Save and Unlock operation is executed.
• Make files read-only: After save and unlock, all the files (within the structure, including the root file) will

be made read-only in the local system.
• Delete File: After save and unlock, only the root file will be deleted from local system. Rest of the files

(within the structure) will be read-only.

Troubleshooting
Generate Log files
If this check box is selected, the Integration log file is created.

Attached to Workflow
Use the Attached to Workflow property to control the Dispatch to Business Process functionality. The options
in Attached to Workflow property:

• Attach to Business Process
• Attach all related objects
• Attach Draft Objects only
• Allow edit workflow

Attach to Business Process
This option controls the PLM objects of a Microsoft Office file that can be attached to the business process.
The available options:
• Documents Only: Only the documents associated with the Microsoft Office file are attached to the

business process.
• Items Only: Only the items associated with the Microsoft Office file are attached to the business process.
• Both: Both the documents and the items associated with the Microsoft Office file are attached to the

business process.
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Attach all related objects
If this check box is selected, the PLM objects (items, documents) of all the components in Microsoft Office
file are attached to the business process. The PLM objects attached to the business process are based on the
values selected for the Attached to Business Process preference.

Attach Draft Objects only
If this check box is selected, the PLM objects (items, documents) with DRAFT status of all the components
in Microsoft Office file are attached to the business process. The PLM objects attached to the business process
are based on the values selected for the Attached to Business Process preference.

Allow edit workflow
If this check box is selected, you can edit the workflow template when you dispatch a Microsoft Offices file
to business process.

Automatic Link to Item and/or Folder
Microsoft Office files when saved to PLM through the MS Office integration, the files will be linked automatically
to the PLM item or folder(s) to which they refer.

Custom properties will be created on the Excel, Word and Outlook documents specifying values for Item or
Folder Ids. A link is established in PLM between the PLM document and Item and/or Folder based on the
values found in these properties.

If Enable Automatic Link to Item and/or Folder check box is selected, automatic linking of item and/or folder
is enabled.

You must specify the Item/Folder Ids available in the names of custom properties that will be created on
Excel/Word.

Outlook
Append Received Time on the Outlook Message to the filename
If this check box is selected and you save outlook file to PLM, the PLM includes the received time of the mail
message as part of the filename.

Editing View/Edit File Locations for the Office Integration
When you log in to PLM for the first time, you need to change the Edit and View Location to where your Office
files would be transferred to.

1 Select Preferences in the Preferences drop down menu.
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2 The PLM Preferences window opens.

3 Click on the value in Edit and View Location.
4 Change the paths for Edit and View Location.

You should be able to perform View File and Download files from PLM now.
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Chapter 7: Setup and Administration

This section describes solutions for troubleshooting and known limitations with the Office Integration.

Troubleshooting
Microsoft Office not available in application list of Mapping Tool dialog box
To define mapping rules for a particular Microsoft Office template, in the PLM Mapping Tool dialog box, you
must first select Microsoft Office in the Application list and then select the template for which you want to
define the mapping rules. However, sometimes Microsoft Office is not available in the Application list.
Recommendation
In file C:\Infor\PLM_Integration\temp\cfeMappingTool.xml, add the following line to the <APPLICATIONS>
list:

MS_ITC.exe convector is the utility used by Microsoft Office for converting mapping template information to
xml.

The entry for APPLICATION ID=' must be in upper case as shown in the previous example. The entry for LABEL='
is the shown label and has no functionality. The entry for the TEMPLATE_CONVERT_APP=" line includes the
local path for the ITC executable and the ITC executable name corresponding to the integration license.

In addition, make sure that the directory and executable "Office2010/MS_ITC.exe" indicated in the applicable
TEMPLATE_CONVERT_APP line exists under the integration installation directory.

The entries in the cfeMappingTool.xml file use forward slashes (/) even though the windows standard is to
use backward slashes (\) as a path separator.
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Error Messages
If the user is unable to open the integration, this may be due to one of a number of reasons. The error message
displayed to the user should include an error number. The following table lists the error numbers with an
explanation of the possible problem:

MeaningNumber

Invalid number of input parameters.1

Failed to create DeProxy.exe instance.2

Invoke Action Failed in Toolkit.3

COM Error occurred during invocation.4

An exception occurred during invocation.5

No integration exists for this file format.70001

Missing originating application parameter.70002

Development Toolkit Callback not set.70003

Server Error cannot be identified.70004

The Open operation failed.70005

Limitations
The following known issues exist for the Microsoft Office integration:

Mapping interaction with Property comment
If a relationship is defined between a PLM attribute and the Comments field of the file properties of a file,
any data manually entered in the Comments field will be replaced by the value of the mapped PLM attribute.

Deleting custom mapped properties
You must delete custom mapping properties before you remove standard mapping file properties, otherwise
you cannot delete the custom properties.

Using Word as your email editor
You cannot use Microsoft Word as your email editor with the PLM- Microsoft Office integration.

Viewing Microsoft Office files through PLM
Due to a Microsoft limitation, you cannot use the Microsoft Office integration while viewing Microsoft Office
files via the PLM viewer.

Word documents with Control Toolbars
The Microsoft Office integration does not support Word documents containing control toolbars, that is, forms
or check boxes. This limitation extends to documents that used to contain check boxes that have since been
deleted.
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