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About this guide

This guide describes how to perform user tasks in M3 CE Core. This document also describes related
concepts and features.

Intended audience

This guide is for users and Infor consultants who are responsible for user tasks in M3 CE Core.

Prerequisite knowledge

To fully understand the information presented in this guide, you should must have knowledge and
experience in navigating and using M3 Core Infrastructure and Technology.

Organization

This table describes the sections of this guide:

DescriptionChapter

Contains concepts related to M3 CE Core user
tasks and chapter descriptions.

Overview

Explains how to use HTML 5-based user interface
for accessing work-related information and appli-
cations from the M3 business system.

Using M3 H5 Enterprise

Discusses how to use M3 Metadata Publisher
(MDP) to explore M3-related metadata.

M3 Metadata Publisher User Tasks

Explains how to use keyboard shortcuts.Hot keys

Related documentation
See docs.infor.com for industry-specific information.
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Contacting Infor
If you have questions about Infor products, go to Infor Concierge at https://concierge.infor.com/ and
create a support incident.

The latest documentation is available from docs.infor.com or from the Infor Support Portal. To access
documentation on the Infor Support Portal, select Search > Browse Documentation. We recommend
that you check this portal periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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Chapter 1: M3 H5 user tasks

M3 H5 provides an HTML 5-based user interface for accessing work-related information and applications
from the M3 business system.

In M3 H5, you can run M3 programs under predefined workflows. You can also perform other tasks
such as:

• Export records to spreadsheets.
• Work with Gantt Charts.
• Access User Documentation for M3 Business Engine.
• Work with different personalization tools for panels and programs.
• Communicate with the context applications of Infor Ming.le™.

Opening M3 H5
M3 H5 can only be accessed through Infor Ming.le.

1 Sign in to Infor Ming.le.

2 Click the App Menu icon.

3 Select Infor M3.

Note: To avoid an error, there must only be one instance of M3 H5 running on a browser.

M3 H5 opens with the application menu and the landing page:

DescriptionRegion

You can make these selections:

• Favorites: contains favorite M3 programs defined by the
user.

• Administration Tools: provides access to tools and is
available to administrators who maintain the H5.

• M3 Transactions menu: categorized menu which provides
access to M3 programs.

You have the option to hide or show the selections by clicking
the application menu.

Application menu

Infor M3 Core Infrastructure & Technology User Guide | 8

 

M3 H5 user tasks



DescriptionRegion

Shows the Favorites and Recent lists which provide quick ac-
cess to the user's frequently used programs.

This page also contains the company information, division in-
formation, user ID, environment URL, and the current version
of H5 installed in the environment.

Landing page

Opening M3 programs using the search and start
function
Search and start is both applicable to the classic and new H5 user interfaces.

1 In M3 H5, press Ctrl + R.

2 Specify the name or ID of the M3 program in the Search and Start dialog.

For example, a specific name could be 'Item. Open' and the ID of this program is MMS001.

3 Press Enter or click OK.

You can also specify a keyword in the Search and Start dialog. After you press Enter, a list of
possible matches is displayed. Select the item from the list that matches your criteria.

Note: In the new H5 UI, the list of matches will be displayed while typing a keyword in the Search
and Start dialog. Available items from the Administration Tools, Mashup Library, Favorites, and
Recent menu are included in the suggested matches.

The M3 program is displayed in a new tab where you can view or update records. The status bar
shows the company or division information by default.

The taskbar shows currently opened M3 programs in tabs. You can click a tab to switch between
opened programs.

Opening M3 programs using the application menu
1 In the application menu, expand an M3 transaction. For example, select SMS - Sales and Marketing

Automation > COP - Customer Order Processing.

2 Click your preferred M3 program, for example 'Customer Order. Open'.

A new tab is created which displays the M3 program. The status bar shows the company or division
information by default.

The task bar shows currently opened M3 programs in tabs. You can click a tab to switch between
opened programs.
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Opening M3 programs using startup
You can open programs quickly by pinning them directly to the taskbar.

1 Right-click a program tab.

2 Select Launch at Startup. When this feature is activated, a check mark is displayed beside this
option.

3 Restart H5 for this setting to take effect.

4 Click the tab of the pinned program to open.

Closing M3 programs
Use any of the steps to close M3 programs individually:

• Click the x icon on the program tab.
• Right-click a program tab and click Close.
• In the menu of the opened M3 program, select Actions > Close.

To close all M3 programs, perform this procedure:

1 Right-click a program tab and select Close All.
2 To exclude the current program you are working on, right-click a program tab and click Close

Others.

Displaying M3 programs simultaneously
Users can display M3 forms simultaneously by pairing tabs. You can only pair two program tabs but
you can form several pairs simultaneously.

Pairing M3 program tabs
1 Open the M3 programs to pair.

2 Click the program tab and drag over to the center section of another tab. Ensure that the tab where
you can form a pair is highlighted with a blue transparent indicator.

The dragged tab is positioned in the right of the tab pair by default.

3 The M3 programs are displayed simultaneously.

Both program tabs are displayed in an active state.

4 By default, a paired tab is always formed in vertical split. To pair the M3 programs horizontally,
access the context menu by right-clicking the tab header of a program and select Split horizontally.
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Note: The context menu can only be accessed in an active paired tab.

5 Optionally, you can exchange the position of the programs whether in vertical or horizontal
arrangement. Right-click the tab header and select Exchange positions.

Decoupling M3 program tabs
1 Click one of the tabs of an active tab pair.

2 Drag and move the tab to the preferred location. When you start the drag movement, the tab will
automatically become a separate tab.

3 Release the tab to your new location.

a To place the tab to an empty space, drag the tab further beside another tab or to the edge
section where a drop indication filled with blue highlight is displayed. The underlying tabs
automatically create space for the dragged tab.

b To create a new pair formation, drag the tab over to the center section of another tab.

4 When released, the tab returns to its standard form or creates a new pair formation.

Changing the language of M3 H5
• To change the language of M3, update the user's language in the E panel of MNS150 then sign

out of M3 H5. Sign in to M3 H5 again and check if the new language is displayed.
Note: You can also use the Change option to directly change the language.

See creating a user to know the details on accessing the system language in the M3 Application
Foundation User Guide.

• To switch the M3 language temporarily, use the LNG command. For example, to change the
language to Swedish, press Ctrl + R and specify LNGSE.

• To display content in H5 based from the language used by Infor Ming.le, you must enable Use
Infor Ming.le Language in the User settings.

See information about changing the site default language of Infor Ming.le in  Infor Ming.le User
Guide.

Note: UDI content is displayed only in English.

Signing out from M3 H5
1 Click your user ID on the top navigation panel and select Sign Out.
2 When a message is displayed, click OK or click Leave this Page.
3 To complete the sign out process, close the browser.
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Panels
Panels guide the user on how to move through an M3 program. Each program has a predefined
workflow, that is, by default, a program displays specific panels in a certain order. Although, the workflow
of a current session may be modified by adding, deleting, or reordering the panels.

A panel is designated either by a letter or a number. A letter represents the type of information that is
displayed in the panel. By contrast, a number indicates that a panel is associated with another program,
but this panel can also be accessed from the program you are currently working with.

This table shows the panel types:

DescriptionTypePanel let-
ter assign-
ment

Used for specifying information, especially when object ID is known

Serves as an opening panel for some programs

EntryA

Shows records in the list view

Serves as an opening panel for some programs

User can expand or collapse the filter options to maximize the available
space for viewing the records list

BrowseB

Panel is displayed when user is asked where to copy the record that is
being duplicated

CopyC

Panel is displayed when user is being asked to confirm the deletion of a
record

DeleteD

Shows detailed information of records

Use E panel as an opening panel for report orders

Use F panel as an opening panel for document printouts

DetailE–N

Used for selecting the method for delivering the output of a record

The available methods are mail, printer, fax,or file.

OutputO

To access, go to Actions > Settings

Available when there are parameters to be set for a program

Parame-
ter

P

Where user can specify data that is related to a recordTextT

Reserved for Infor Partners and customer-specific modificationsUserU

Used for specifying the corresponding item type of an item number

This panel applies only to M3 Business Engine 15.1.x

UserV
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Setting the default panel sequence
Use this procedure to define the panel sequence that is displayed in a program by default. The available
panels may vary depending on the selected program.

1 Open a program. The program must be in the opening panel.

2 Select Actions > Settings.

3 Specify this information. These fields are available for editing depending on the current program.

Opening panel
Select the panel that is displayed first when the program is started.

Panel sequence
a Click the arrow to see the list of applicable panels.
b Select a panel and click Add. Select and add panels in the preferred sequence.

Optionally, you can clear the available sequence and add the panels that will show by default.

You can add one panel at a time. Select in the order in which the panels will display.

c Click Close from the panels list.

4 Click Next.
5 Verify that the panels follow the preferred sequence.

Moving through the panel sequence
Use this procedure for programs that display records in a list view and have a workflow with two or
more panels.

1 Open a program.

2 Select a record from the list. A record must be selected to be able to move through the panel
sequence of a program.

3 You can also view the panel sequence by performing any of these actions:

• Double-click the record.
• Press Enter.
• Click the default option button.
• Click the Display or Change icons from the menu bar.
• Select display or change from the context menu of the selected record.

When a record is opened, all succeeding panels become active. You can click Next to move
forward, or you can click an active panel to go to that panel.

4 To move back in the panel sequence, click Previous or click the previous panels.
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Modifying the panel sequence
Use this procedure to modify the sequence of the panels through the panel navigator. Reordering the
panels only applies to the current session.

1 Open a program. The program must be in the B panel.

Panel navigator is displayed only in the detail panels. Whereas, the dialog box for editing the panel
navigator can only be accessed from the B panel.

2 From the menu bar, click Panel Navigator. The Edit Panel Navigator dialog box is displayed.

• To reorder the panels, click Direct Change. Specify the new panel order and press Enter.

You can access Direct Change immediately by pressing Ctrl+D.

To reorder panels manually, drag and drop the panels in the preferred sequence.

• To add a panel to the current sequence, click Add Panel and select from the list.
• To delete a panel, drag and drop the panel vertically from the sequence.

3 Click Save.

Note: The panels will return to the default standard sequence when you start a new session of the
program.

Changing the panel view icons
Use this procedure to change how the panel navigator is displayed on the detail panels.

The panel navigator contains small, round icons which represent each panel in a program. To show
the large view, with descriptions for each panel, you must clear the Use small view for panel navigator
option.

1 Open a program. The program must be in the B panel.
2 Select Tools > User Settings or click the Panel Navigator to access the option.
3 Clear Use small view for panel navigator. The selected panel view remain in effect until you

change it.

Copying bookmark links
1 Open a program.

2 In the opening panel, move the pointer to a blank area where you can right-click and select
Bookmarks > Copy to clipboard. A bookmark URL that you can use to open the M3 program is
copied.

Note: You can add the bookmark link in the shortcut panel of another M3 program. When adding
the copied bookmark link in the Target or URL field, follow this format: mforms://<bookmark URL>.
To add shortcuts, see Adding shortcuts on page 30.
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Lists and records
Most M3 programs display a list of records. A record pertains to each individual entry in the B panel
or list view. Each record is composed of a group of related fields that contain individual pieces of data.
For example, in ‘Item. Open’ - MMS001/B, each item is considered a record, and each record includes
data such as Item number, Status, Name, or Item group.

Displaying information in list panels
In some programs, you can select which data or fields are displayed in the B panel. To do this, a user
selects the appropriate inquiry type in the Sorting order box. Each inquiry type returns a specific set of
fields.

Some programs support a user-defined panel version. The panel version is a customized view where
you can select the data or fields to be displayed in the B panel. For example, if you run a query in a
program that contains 10 fields, you can customize your view to see only the fields you are interested
in. If panel versions are supported, you will see a View box beside the Sorting order box. You can
expand the View box and select a panel version from the list.

See Customizing list views on page 34.

Using the Advanced context menu options
The Advanced context menu contains two options: Show Field Information and Copy Field
Information. The Show Field Information displays a new window with a text box that contains field
information. The Copy Field Information copies the field information to the Windows clipboard.

Show Field Information
1 Open the form to view a field information.

2 Right-click a field such as a text box, combo box, or check box.

3 Click Advanced > Show Field Information. Information about the field is displayed in a new
window.

Copy Field Information
1 Open the form where to copy the field information.

2 Right-click a field such as a text box, combo box, or check box.

3 Click Advanced > Copy Field Information. Information about the field becomes available in the
Windows clipboard. You can paste the information in a text editor.
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Note: The field information is different depending on the type of field and what is currently available.
A list column and a list column position field will show a different set of data. The table and field
names are usually only available on detail panel fields.

Search features
The user can perform a simple search by specifying a criteria in the Search field box. Records or rows
that meet the criteria are displayed.

Other than the simple search, the users can perform the advanced search or use macros while searching.
The save search query function saves search criteria or queries. This allows the user to search for
similar instances.

These procedures are only applicable to list views where search is enabled.

Advanced search
1 Click Advanced Search. The Advanced Search input box is displayed.

2 In the Specific Keys section, select the keys to include in the Search.

• To search text in one or several columns, select One or more of these keys.
• To be more specific in your search, so that all columns are included, select All of these

keys.

3 Specify your search criteria in the column fields.

4 Click Search.

Search using a macro
1 Open the list panel of the program where to perform the search.

2 Identify which column to base your search on and take note of the column ID.

3 Identify the macro that is applicable for your search criteria.

The types of macros that are supported in the search are date macros and user-related macros.
You can also include variables in your search, such as <USID> for user ID or <ITNO> for field ID.

4 Specify the criteria in the search box. The criteria consists of the column ID and the macro.

To find records that were created during a specific period of time, you can use date macros.

Date macros include YEAR(x), MONTH(x), WEEK(x), and DATE(x), where (x) is any positive or
negative number that is relative to the current date.

If you want the list to be filtered against the Order Date column (column ID: ORDT), and to show
only the records within the range covering from 30 days before the current date until the current
date, use ORDT:[DATE(-30) TO DATE(0)].
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Save search query
After performing a simple or advanced search, you have the option to save the search criteria or query.

1 Click the arrow beside the notification that shows the number of filtered hits for the search.
2 Click Save Search Query.
3 When the Save Search window is displayed, select one or both of these options to save the search

query:
• Add to Favorites: adds the search query to the Favorites menu
• Save as Shortcut in the Toolbox Area: adds the search query to the collapsible

Toolbox area

Positioning to a specific record
Positioning fields are input fields located under column labels.

1 In a positioning field, specify a keyword.
2 Press Enter. Records that closely match the keywords are listed first.

Creating a record
Use this procedure for programs that are used to create new records, for example, 'Item Type. Open'
(CRS040) is used to create item types.

1 Open a program.

2 If the program opens in the B panel, specify values in the positioning fields. For example, in
(CRS040), the positioning field is in the Itp column. Specify a value in this field.

If the program opens in the A panel, specify the values for the required fields.

3 Select Options > Create.

4 Complete the record with basic details.

5 Click Next.
When creating a new record, a program follows a predefined workflow. Specify the values in the
required fields until the last Detail panel. If you go to the next panel but you missed a required field
in the current panel, you are prompted to specify the information.

6 Optionally, to cancel the changes, select Actions > Cancel.

Caution:  If you click Refresh, the information is not saved.

7 Verify that the new record is in the list.
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Changing a record
Use this procedure to open a record in editable mode.

1 Open a program.

2 If the program opens in the B panel, select a record to edit. If the program opens in the A panel,
specify the values for the required fields.

3 Select Options > Change.

4 Edit information in the fields.

If the record does not open in a detail panel, you can reorder the panel sequence so that the detail
panels follow after the opening panel.

See Setting the default panel sequence on page 13.

5 To save the changes, click Next.
6 Optionally, to cancel the changes, select Actions > Cancel.

Caution:  If you click Refresh, the information is not saved.

Copying a record
1 Open a program. The program must be in the A or B panel.

2 Select a record.

3 Select Options > Copy.

4 In the browse field, specify which record to apply the copied information.

5 Click Next.
6 Verify that the new record contains the copied information.

Deleting a record
1 Open a program. The program must be in the A or B panel.

2 Select a record.

3 Select Options > Delete.

4 When you are prompted to confirm, click OK.

Click Previous or select Actions > Cancel to cancel the deletion.

5 Click Next.
In some cases, deletion is not permitted because of data dependencies. For example, in 'Item.
Open' (MMS001), deleting an item with a status of "00" is not permitted.

6 Verify that the deleted record is removed from the list. The deleted record is displayed as an
unavailable row in the list panel.
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Displaying a record from the records list
Use this procedure to open a record in a non-editable mode.

1 Open a program. The program must be in the B panel.

2 Select a record.

3 Select Options > Display.

The record opens in the Detail panel where fields are non-editable.

4 From the Detail panel, you can scroll to the previous or next record.

For example, when you display a record in 'Item. Open' (MMS001), the program opens in panel
MMS001/E.

a In the Item Number field, select Actions > Scroll Forward or Scroll Backward.
b When the program reaches the first or last record and you continuously scroll, a notification is

displayed. The notification indicates that you scrolled past the first or last record in file.

Displaying a linked document or web page
Use this procedure to access the Infor Document Management documents or web pages that are linked
to a specific record.

1 Open a program. The program must be in the B panel.

2 Right-click a record and select Links. Select either the Web link or the associated information to
access.

Note: In iPad, the list of Links is available from the Options menu.

Populating browse fields
Use this procedure to populate browse fields by using the select command.

M3 programs are not always the same and may change based on the view definition. Browse fields
are characterized by a light gray arrow located on the edge of the field.

An example of a browse input field is located in 'Item. Connect Warehouse' (MMS002) with the label,
Warehouse type.

1 Right-click the browse field and select Browse.

2 In the M3 Browse dialog box, select a record in the list and click Select.
3 Click the available buttons depending on your required action.

DescriptionButton

Click this button to open the M3 program that maintains the list of
records in the Browse dialog box.

Work With

Click this button to update the information in the Browse dialog box.Refresh
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DescriptionButton

Click this button to filter the list in the Browse dialog box.Selection

Click this button to display the next available browse view.Next View

Click this button to select the record as the input for the browse field.Select

The available options may vary depending on the current program.

4 If you do not see the record that you are browsing for in the Browse box and you need to access
the M3 program that maintains the data, follow these steps:

a In the M3 Browse dialog box, click Work With. The M3 program maintaining the data is
displayed.

b Add the new data.

See Creating a record on page 17.

c When the new record is added in the list, select the record and click Select from the menu
bar.

5 Verify that the browse field is populated with the selected record.

Quick Notes
Quick Note is a way to save notes without having to write them on paper.

Quick Note is only available in M3 panels.

1 Click Quick Note from the menu bar.
2 To create a note, drag the text from the M3 panel and drop it on the Quick Note button.
3 You can also specify the text in the input field and click Add QuickNote.
4 To use the text that you saved from the note box, drag the text and drop in an input field of an M3

panel.
5 To remove a note, select an item from the note box and click Delete. You can also delete all notes,

right-click and select Remove All.
6 Optionally, if you prefer the Quick Note box to be always visible, select Keep open.

Exporting to Excel
We recommend that you use a program that can read the .xls file, such as Microsoft Excel or OpenOffice
Calc, so that the user can validate the data.

The administrator can disable this feature for all or selected users.

See administration tasks for H5 in M3 CE Core Administration Guide.

1 Open a program. The program must be in the B panel.

2 Select the records to export.
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3 Select Tools > Export to Excel.
4 Select the rows to export:

• Export currently selected rows.
• Export all rows.

You can export a maximum number of 9999 rows.

5 Select the format of the data to export:

• Source Format: file uses the current data type. The column format in the resulting file is
dependent on the data type defined in the list in the M3 program.

• Target Format: file uses General as the default data format in Excel
• Text Only: file uses Text as the text data format in Excel
• Source Format with Restrictions: file uses the current data type with exception to column type

CHAR and is uppercase.

6 Click EXPORT.

7 Open or save the resulting file.

Exporting to Google Sheets
Use this procedure to export program data to Google Sheets.

The administrator can disable this feature for all users or for selected users.

See administration tasks for H5 in M3 CE Core Administration Guide.

1 Open a program. The program must be in the B panel.

2 Select the records to export.

3 Click Tools > Export to Google Sheets.

4 Select row option:

• Export currently selected rows
• Export all rows

You can export a maximum number of 9999 rows.

5 Select the format of the data to export:

• Source Format: file uses the current data type. The column format in the resulting file is
dependent on the data type defined list in the M3 program.

• Target Format: file uses Auto as the default data format in Google sheets
• Text Only: file uses the text data format

6 Click AUTHORIZE GOOGLE. You are required to do this only once if you are signed in to Google.

7 Optionally, click SIGN OUT to sign in to a different Google account.

8 Click EXPORT.

The records that were exported to Google Sheets are displayed in a new browser. If Google Sheets
does not open in a new browser tab, check your browser's pop-up blocker settings.
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Working with Gantt Charts
A Gantt chart is a type of bar chart that illustrates start and finish dates or times allotted for a certain
element within a project.

These examples show how a Gantt chart is used in M3:

• In Project Order, a Gantt chart represents the project element and activities as intended in the
original implementation of the Gantt chart.

• In the Rental module, a Gantt chart illustrates a renting activity for a specific equipment/car/machine
with the start date/time and end date/time.

• In the Maintenance module, a Gantt chart represents an activity/operation in a workshop with the
start date/time and end date/time.

Some M3 programs support the ability to create a Gantt chart. Setup is often required in order to support
the chart. This topic assumes that any required setup has already been performed.

When the chart exists, you can perform these actions:

• Resize items.
• Move items on the schedule by dragging and dropping.
• Snap to the hour, half hour, or other increment. This action ensures that if you drop a schedule

item in the chart, it will always start on either the hour or half hour.

You can change the time increment for snapping. Right-click the chart and select Snap. Select a
time increment from the list of available increments.

• Run Related options for any item on the chart. Click an item then select an option in the Related
menu from the menu bar.

• Change the bar fill to either color or pattern. Right-click the chart and either select or disable the
Enable Fill Patterns option.

• Collapse the Filter Options feature to show more Gantt chart rows.

Configuring a timescale
1 Open the program with a Gantt chart.

2 Right-click the chart and select Main Timescale.

3 Set the timescale:

• Hour

Select from these options: Extra large, Large, Normal, Small.

• Day

Select from these options: Normal, Small.

• Month
• Quarter

4 To change the settings for days or hours, right-click to open the context menu and then select
Non-Work Settings.
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In the dialog box that is displayed, create changes for the days or hours. These changes are
reflected in the timescale. The days or hours that are set as "non-work" are grayed-out in the
timescale. You cannot drag and drop items in the grayed-out portion of the timescale.

You can also select Compressed Non-Work Setting. Selecting this setting will modify the display
of the non-work hours. The hours are shown as ranges, for example 13:00-17:00, on a single scale.

5 You can manually refresh the data in the chart. Right-click the chart and select Disable Auto
Refresh.

Accessing user documentation for M3 Business Engine
The M3 Business Engine User Documentation contains information for configuring and implementing
M3 Business Engine processes.

1 To access the Business Engine User Documentation, click Help in the menu bar of the BE program.
2 Select Form Help... to open the document that is relevant to the BE program.
3 You can also select Documentation Homepage to display the start page of the Business Engine

user documentation.

The User Documentation is displayed in the language that has been set in (MNS150).

Personalization tools
Personalization tools are used to enhance the standard M3 programs and obtain personalized versions
that will accommodate the preference of the users. For example, you can add shortcuts by specifying
function keys to specific actions or edit the field labels.

Changing M3 program user settings
You can enable or disable M3 program settings depending on the necessity or preference of the users.
The user settings are categorized into two areas: general and program options.

General user settings are applied to all programs. Whereas, default actions that are set in Program
Options are applicable only to specific programs.

Changing general settings
1 Open a program.

2 Select Tools > User Settings.

3 In the General section, select the preferred settings.
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DescriptionOption

Select this setting if you want notification from
the M3 server to display in a dialog window in-
stead of the status bar. Messages are displayed
on the status bar by default.

Display system messages in dialog window

Select this setting to show the company and
division information on the status bar.

Display company and division information on
the status bar

Select this setting to show the full description
of column header labels.

Display label tooltips

Select this setting to show field help.Display help tooltips

Select this setting to align field labels to the
right.

Right align labels

Select this setting to navigate across the M3
panel using the plus (+) key as an alternative
to the tab key.

Use plus key as tab

Select this setting to place a cursor at the end
of the value in an input field. When this option
is not selected, the entire value in the input field
is highlighted.

Position cursor in end of input fields

This setting is applicable only to certain pro-
grams.

If a program supports expandable rows of lists
but this setting is disabled, the expandable
content will display in list columns.

Select this setting to display expandable rows
of lists for programs that support this feature.

Expand list

Select this setting to show the panel navigator
in mini-mode.

Use small view for panel navigator

Select this setting to show the program ID be-
side program name.

Show Program ID

Select this setting to enable H5 to display its
contents using the language used by Infor
Ming.le.

See information about changing the site default
language in Infor Ming.le User Guide.

Use Infor Ming.le Language

Select this setting to enable H5 to automatically
switch to Homepages when all programs in H5
are closed.

Auto-switch to Homepages

Use this setting to publish field context details
when you select and move your pointer to a
particular field or press F1.

Activate context help
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DescriptionOption

Use this setting to set the default action that is
executed after you double-click the record from
the list panel.

The selected option is the default action for all
programs. In the B panel, the blue button shows
this default option.

Standard option

Use this setting to change the theme color of
H5. The theme is only applied on the top part
of H5.

Theme

Use this setting to select the calendar format
displayed when using the date picker tool.

Note: The default format for most supported
languages is Gregorian. Whereas, for some
languages the default format might be different.

Calendar view

4 Click Save.

5 For the changes to take effect, click Refresh.

Setting a program option
Use this procedure to set a default action that will result after opening a record. The setting is applicable
only to the specified program.

1 Open a program.

2 Select Tools > User Settings. The User Settings window is displayed.

3 In the Program-specific Options section, specify this information:

Program ID
Specify the program name, for example, MMS001.

Option
Select the default action that results after opening a record.

For example, you add a program option with these values:

Program ID: MMS001

Option: 3 - Copy

Every time you open a record from MMS001, the copy option is run by default. The succeeding
panels that will follow this default option are determined by what you set.

See instructions in Setting the default panel sequence on page 13.

The selected program option overrides the Standard Options.

See standard options in Changing general settings on page 23.

4 Click Add. You can view the new setting in t Available Program Options.

5 Click Save.
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6 If you set the program option for the current program you are working with, click Refresh for the
setting to take effect.

Updating the program option for a specific program
1 Select Tools > User Settings.

2 From the Available Program Options list, determine the program option to modify. Specify the
program name in Program ID, and select the new default action from the Option list.

3 Click Add. Verify if the Description has been updated to the new program option.

4 Optionally, you can remove a program option by selecting it from the list and clicking Delete.

5 Click Save.

6 If you updated the program option for the current program you are working with, click Refresh for
the setting to take effect.

Personalizing M3 panels
The administrator can disable this feature for all or selected users.

1 Open an M3 program to personalize.
2 Select Tools > Personalize.
3 From the personalize menu, select from these personalizations:

• Hyperlinks
• Conditional Styles
• Shortcuts
• Labels
• Tab Order
• Show/Hide fields
• Scripts
• Custom Fields

4 When you right-click a field and select Personalize, you can access these other tools:
• Enable Favorites
• Enable Mandatory

The tool is disabled if the field does not support that type of personalization.

5 Click Save.
6 After you save the personalization, open the M3 panel in H5 Enterprise and verify the changes. If

you cannot access a personalization tool, it means that the tool was disabled by the administrator.

See the application settings in M3 CE Core Administration Guide.
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Hyperlinks
You can use hyperlink in cases where you use a related program from the Related menu. Instead of
selecting an item from the menu or pressing Ctrl + [option], you can use a hyperlink.

Hyperlinks function like shortcuts or macros in the sense that they save you keystrokes when moving
through a program.

Creating hyperlinks
1 Open the program for which to create a hyperlink. The program must be in the B panel.

2 Select Tools > Personalize > Hyperlinks.

3 Specify this information:

Field
Select the field from which the related option must be linked.

Related options
Select the action to occur when the hyperlink is clicked.

The list of hyperlinks is displayed when you select the Related menu option from within a program.
You can access the same list when you right-click the column header and select Hyperlink.

4 Click Add to create the new hyperlink.

5 Click Save.

Creating text or numeric comparisons using conditional style
Use this procedure to make comparisons between fields that use numeric data or text.

Note: Smart links through conditional style is not supported in H5.

1 Open a program.

2 Select Tools > Personalize > Conditional Styles.

3 Click New.

4 Select the field from the Target Field list.

Note: When working with Gantt chart data, set the value of the Target Field to Gantt Chart.

5 From the Select condition type list, select either Numeric or Text.
6 Specify this information:

Operator for comparison
Select the operator from the list.

For text and numeric data, you can select the standard comparison operators, such as equal to
(=), greater than (>), greater than or equal to (>=).

For text comparisons, you can select Contains, Starts with, and Ends with.
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Field or Specific Value
Select Field if you are comparing the target field to another field. In the next box, select the field
to compare to the target.

Select Specific Value if you are comparing the target field to a value. In the next box, specify
the value to compare to the target.

If the data contains leading blank spaces, you can remove them by selecting Trim blank spaces.

Click the Add button (+) to add another condition, or click the Remove button (-) to delete an
existing condition.

7 Click Next.
8 Format the display characteristics for the field:

a On the Color tab, change the color for the Field or Text. You can apply the color changes to
an entire row by selecting Enable style for entire row.

b On the Text tab, change the alignment and style. You can include your own tooltip text. To
display the default tool tip instead, select Show original value as tooltip.

c On the Icon tab, select an icon to go with the field.

Note: When working with Gantt Chart conditional styles, you can only apply Icon as the format.

d On the Hyperlinks tab, select the Make field a hyperlink check box to create a hyperlink for
the field. Choose between a related option or a new link.

To open the link in a browser, select the Open link in external browser check box.

9 Click Next.
10 Specify this information:

Name
Optionally, specify a name for the conditional style.

Description
Optionally, provide a description for the conditional style.

11 Select the Activate check box for the conditional style to take effect.

12 Click Finish.

Creating date comparisons using conditional style
Use this procedure to make comparisons based on dates.

Note: Smart links through conditional style is not supported in H5.

1 Open a program.

2 Select Tools > Personalize > Conditional Styles.

3 Click New.

4 Select a field from the Target Field list.

5 From the Select condition type list, select Date.
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6 Select an operator. For date comparisons, the operators are similar to traditional operators, for
example less than, greater than, and equal to, but are specific to dates. You can select operators,
such as Earlier than, Later than, Earlier than or equals.

7 Select the type of date comparison.

DescriptionOption

If you are comparing the target field to another date field, se-
lect Field. And then in the next box, select the date field to
compare to the target.

Field

If you are comparing the target field to a specific date or dates,
select Specific Fixed Dates and click Select Dates.

In the Select Dates dialog box, use the date picker calendar
to select the dates to use for the comparison. You can also
remove dates in this dialog box.

Specific Fixed Dates

Use this option to select a range of dates to use for the com-
parison.

Dynamic Date

Use this option to start the interval on a specific date. In this
case, specify both a specific date or dates and a date range.

For example, suppose you need to run a report three days
prior to the last Friday of the month. Because the last Friday
of the month is not a fixed date, you use the Specific Date
section of the dialog box to select the last Fridays of each
month. Then you use the Dynamic Date section to specify the
third day before each last Friday.

Specific Dynamic Dates

Use this option to set up a condition using date tokens. These
tokens are variables that represent date values. When you
right-click the box next to the Expression option, a context
menu is displayed and you can choose among the available
tokens:

• [currentdate]
• [currentmonth]
• [currentyear]

Suppose you need to filter forms that will expire today. To
make these forms stand out, you can compare the target field
against a token expression. For example, the maturity date
(target field) is equal (=) to the [currentdate] (token expres-
sion).

Expression

8 If you select Dynamic Date and you need to specify when to apply the style, click Set Date Interval.
If you select Specific Dynamic Dates, click Select Dates to specify a date range. In both cases,
the Set Date Interval dialog box is displayed.

9 Specify this information:

Set Date Interval
Select the check box.
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Conditional style starting and ending
Specify a number, and then select Days, Weeks, Months, or Years and Before or After.

If you do not specify an end date, the style will continue indefinitely.

The intervals that are available for selection depend on the selected operator. For example, if the
condition should compare dates later than another date, and ending option is not available.

10 Click OK.

11 Click the Add button to add another condition, or click the Remove button to delete an existing
condition. Click Next.

12 Format the display characteristics for the field:

a On the Color tab, change the color for the Field or Text. You can apply the color changes to
an entire row by selecting Enable style for entire row.

b On the Text tab, change the alignment and style. You can include your own tooltip text. To
display the default tool tip instead, select Show original value as tooltip.

c On the Icon tab, select an icon to go with the field.
d On the Hyperlinks tab, select the Make field a hyperlink check box to create a hyperlink for

the field. Choose between a related option or a new link.

To open the link in a browser, select the Open link in external browser check box.

13 Click Next.
14 Specify this information:

Name
Optionally, specify a name for the conditional style.

Description
Optionally, provide a description for the conditional style.

15 Select the Activate check box for the conditional style to take effect.

16 Click Finish.

Adding shortcuts
You can add shortcuts to the Toolbox area. The Toolbox slides out from the right side of the M3 panel.

1 Open a program panel from which to create a shortcut.

2 Click the Collapse Toolbox to expand the toolbox area, and click Shortcuts... (+).

You can also right-click anywhere in the Toolbox area, and then select Add from the context menu.

3 In the Shortcuts Organizer window, select the type of shortcut to add from the Available options:

Related options
Select from the list.

Function keys
Select from the actions/keys.
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Link
Specify a name for the link and the Target or URL. Select New Window for the shortcut to open
a new window.

Links
This option is available only when links to Document Management or to a web page have been
previously created through the Link Manager. Select from the list of available links.

Sorting order
Select a query.

4 Click Add to send the selected option to My Shortcuts box. Other available options are:

Move Up/Move Down
Use to change position of items in the list.

Heading
Use to organize your shortcuts into groups. You can assign a heading for each group to distinguish
one from the other.

Space
Use to add space in between items in the Toolbox.

Remove/Remove All
Use to remove an item from the Toolbox.

To remove all shortcuts, use Remove All.

You can also right-click an item from the Toolbox, and then select Remove from the context menu.
After you click Remove, you are prompted to remove the shortcut. Click Yes.

Rename
Use this option to change the name of a shortcut or a heading.

From the My Shortcuts list, you can rename a shortcut or heading by doing any of these actions:

• Double-click the shortcut or heading.
• Select the shortcut or heading and press Enter.

5 Expand the Advanced section to create shortcuts for your scripts.

6 Specify this information:

Name
Specify a name for the script shortcut.

Value
Specify the shortcut key for the script.

Script name
Select script name.

Script arguments
Specify arguments to include in the script.

Click Add to create the script shortcut.
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7 Click Save.

8 Verify that your shortcuts are added to the Toolbox.

Editing labels
When you edit labels, you change the displayed text on a specific form that shows field names or
column headers. You can edit labels to use a term that you find more meaningful than the term provided
by Infor.

1 Open a program.

2 Select Tools > Personalize > Labels. The form opens in editable mode.

You can also perform any of these actions to start editing labels:

• Right-click the column header > Labels.
• Right-click the open space of filter options > Personalize > Labels.

3 Replace the current text with a new label.

4 Click Save.

To restore the default labels, click Use Default. You can restore defaults after a form containing
edited labels has been saved.

Hiding or showing fields
If there are fields on the M3 panel that you do not use, you can hide them. The fields are not removed
from the database, just from your version of the form.

1 Open a program.

2 Select Tools > Personalize > Show/Hide Fields.

3 Select a check box to remove either the field or label. To reinstate a field or label, select the check
box.

4 To hide all fields on a form, click Clear All.
5 To reinstate all hidden fields, click Show All.
6 Click Save.

Creating scripts
Use this procedure to link an existing script to a target within a program. The script must already exist
at the time you link the target.

1 Open a program.

2 Select Tools > Personalize > Scripts or right-click the open space of Filter Options and select
Personalize > Scripts.

3 From the Target list, select the item for which to attach a script.

4 Specify the name of the script.
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5 Specify arguments to include in the script.

6 Click Add.

7 Click Save.

Adding custom fields to panel
See the overview of customer-defined fields in the M3 Application Foundation User Guide.
Note: This personalization is not applicable in list panels.

1 Open a program.

2 Double-click any record.

The detail panel of the program is displayed.

Note: In User Settings, set the standard option to Change or Display first.

3 Select Tools > Personalize > Custom Fields.

4 Drag and drop a custom field to the panel.

5 To change the width of the field, rest your pointer on the added field and click Decrease width or
Increase width.

6 Click Save.

Removing custom fields from a panel
1 Access the detail panel of the program and launch the custom fields personalization tools.

2 Rest your pointer on the added field and click Remove.

3 Optionally, click Clear All to delete all custom fields.

4 Click Save.

Enabling text box history
Use this procedure to enable or disable history in input fields of detail panels. This feature stores
previously specified information as text box favorites.

1 Access the detail panel of a program.

2 Select the input field where to enable the text history.

3 Right-click the field and select Personalize > Enable Favorites.

Setting a field to mandatory
Use this procedure to make a field mandatory. A mandatory field must be completed by specifying a
value. If this field is blank, the user cannot proceed to the next panel or form.
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1 Access the detail panel of a program.

2 Select the input field to be mandatory.

3 Right-click the field and select Personalize > Enable Mandatory.

An asterisk indicates that the field is mandatory. To disable the feature, right-click the field and
select Personalize > Disable Mandatory.

Customizing list views
You can customize list views for M3 programs where the Edit View feature is available. If the M3
program shows a View menu, then the Edit View feature is enabled for that program.

Customizing a view
1 Access the list panel of the M3 program to customize.

2 From the View menu, select a view to customize.

3 Click Edit view. The program opens in Edit mode where the column and the position usage bars
are displayed.

4 Right-click the column to customize and click Edit. If the column should not displayed, click Hide
Column.

5 Specify this information:

Name
The menu for this field is disabled.

Field information code
Specify additional field information. This information is used to show the field correctly.

Field length
Specify the number of characters that the field will show. The field length also determines the
column width.

If the field is blank, then the field length will follow the M3 standard.

If the value is longer than the M3 standard, a portion of the value will not be displayed.

Number of decimals
Specify the number of decimal places that the field will display. The value can range from 0 to 6.
If the field is blank, value defined in the database will determine the number of decimals to be
displayed.

Decimal format
Select from the available options in the menu.

Edit code
Select from the available options in the menu. Click Help for more information about the valid
alternatives.
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Debit/Credit code
Select the check box if a transaction entry must be supplemented with a debit or credit code in
addition to the amount's sign (+/-).

If you select the check box, then the amount is recorded as a debit or credit record, regardless of
the character. The code is mandatory for each amount entry.

If you do not select the check box, then an amount with a positive sign is always recorded as a
debit, whereas an amount with a negative sign is always recorded as a credit.

Note: Changing how debit or credit codes are handled must not be performed during an active
accounting year because extensive changes are required.

Edit field
Select the check box to make the columns editable in the list view.

Date format
Select from the available options in the menu.

Aggregation display rule
Specify how the information in the field is displayed if the line is aggregated. Select from the
available options in the menu.

Subtotal rule
Specify how the information in the field is displayed if the line is a subtotal. Select from the available
options in the menu.

Drop down
Specify how to display a text description for a specified field value. Select from the available options
in the menu.

Note: These properties may not be enabled in all columns. Enabled properties depends on what
column you are editing.

6 Click OK.

7 To add columns, click the Select columns arrow. Drag and drop the columns to rearrange them.

Note: In the new H5 UI, when you add columns you have to select Manage Columns.

8 Select the columns to add. As you select or deselect columns, the usage bars for columns and
positions move accordingly.

9 Click Save.

To save the changes as a new view, click Save As. Specify a name and description, and determine
whether the view should be shared. Click Save.

Creating a view
1 Access the list panel of the M3 program to customize.

2 Click Edit view.

3 Click New.

4 Specify a name and description, and determine whether the view is shared. Click Save.
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5 Make the customizations.

6 Click Save.

Deleting a view
1 Access the list panel of the M3 program to customize.

2 From the View menu, select the view.

3 Click Edit view.

4 Click Delete.

5 Click Yes to confirm the action.

Customizing list column order
You can customize list columns for M3 programs manually. If an M3 program does not have an Edit
View feature, you can customize the order of list columns through drag and drop action.

Removing personalizations
You can undo the personalizations that you made to panels and programs in M3 H5.

If you are a member of a group, you can see all the changes made by the other group members. If you
make additional changes, your changes will override any group changes and will only be visible to you.

You can also delete all personalizations that you have made to a panel or program. This is not the
same as removing individual personalizations which you can do from within the type of personalization.
For example, if you have made personalizations to the tab order and to the field labels, you can remove
all of them by using Delete Panel Personalizations. To reinstate the tab order instead, select Tools
> Personalize > Tab Order.

Removing panel and program personalizations
1 Open a panel or program.

• You can only remove personalizations that you made.
• Program personalizations are personalizations that are applied to the entire program, for

example, MMS001, as opposed to a browse panel such as MMS001/B. If you delete program
personalizations, then personalization on all panels within a program are deleted.

• Global and role personalizations are removed permanently by using the Delete option from
Administration Tools > Personalizations.

2 Select Tools > Personalize. Select from these options:

• Delete User Panel Personalizations: deletes your own personalizations on the current panel
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• Delete User Program Personalizations: deletes your own personalizations on the current
program

• Delete Panel Personalizations: hides global and role personalizations, in addition to removing
your personalizations on the current panel

• Delete Program Personalizations: hides global and role personalizations, in addition to
removing your personalizations on the current program

3 Click YES to confirm.

4 Refresh the program for the changes to take effect.

M3 H5 and Infor Ming.le
Infor Ming.le provides the first level navigation for one or more Infor applications and serves as an
infrastructure to mash-up these applications. This infrastructure includes the capability to send context
data between Infor Core products and Context Applications.

As an Infor Core product, M3 H5 Client runs inside Infor Ming.le and uses its infrastructure to
communicate with the Context Applications of Infor Ming.le.

Using Infor Ming.le
Infor Ming.le allows social interaction between users within a business environment. To be able to
connect and share information with other users and groups, you must first set up your profile.

For information about user profiles, see  Infor Ming.le Online Help.

Posting on feed page

After you set up your own profile, you can access your Feed page.

1 Click the My Feed link or the Activity Feed icon to access your Feed page. When you use M3 H5,
you can share M3 program-related data on your feed page.

2 Click the Share icon on the top navigation panel. You can use this icon to post on your feed page
without leaving the current M3 panel.

3 Provide a description for your post.
4 Optionally, add an attachment and set the privacy level as Connections, Public, or Groups.
5 Click Share to share the content to your feed page. The post is recorded in the My Feed Page

and contains the link to the M3 panel for sharing.

For information about using the Infor Ming.le header, see  Infor Ming.le Online Help.
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Using Homepages for M3
Homepages provide role-based home pages with widgets containing information from multiple ERP
systems in one place.

See more details about Homepages in Infor Ming.le Cloud Edition Online Help.

Navigating to M3 Homepages
1 Sign in to Infor Ming.le.

2 Click the App Menu icon.

3 Select Homepages.

Creating a page
1 Click the page menu icon (…) on the page title bar.

2 Select New Page.

3 In the New Page dialog, specify the page title and description. You can also select a page color.

4 Click Create.

Adding a widget
1 In your new page, click Add Widget.
2 Click the search icon in the widget catalog title bar and specify M3.

3 To show the M3 standard widgets only, expand Type under the Refine by section in the side bar
and select Standard only.

4 Locate a widget in the catalog, and click the add icon (+) to add the widget.

5 Click Save.

Adding a banner widget
1 In your homepage, click Edit.
2 On the header area, click + Add Banner widget.
3 From the Banner Widget Catalog, select an existing widget or search for a particular widget to add.

4 On your selected widget, click + Add Widget. A message indicating that the widget has been
added is displayed.

5 Click Close to return to your homepage. The selected widget is now added to the header area.

6 Click Save.
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Configuring a banner widget
1 Add your preferred widget.

2 Click Configure Widget.
3 The next steps may vary depending on the selected widget. Refer to respective configuration

procedures for every available widget that can be added as a banner.

If you add a viewer widget for example, see Configuring the M3 Information Viewer widget on page
40.

M3 widgets
M3 Homepages contain a set of widgets that are highly configurable and can be tailored to the needs
of the user.

Configuring the M3 Application Messages widget
Note: Items that are displayed in this widget are taken from (CRS640).

1 Add the M3 Application Messages from the widget catalog.

2 Click Configure Widget.
3 Specify this information:

Title
Click the unlock button and specify a widget title.

Sort by
Click the drop down field and select a sorting option.

Sort order
Click the drop down field and select an order for sorting the messages.

4 Click Save.

Using the M3 Application Messages widget

The context menu provides options that you can use for each item displayed in the application messages
widget. To access the context menu, right-click an item and select your preferred option:

• Select Open to go to Infor M3.
• Select Copy link to clipboard to open an M3 record.
• Select Mark as complete to change the status of the task to complete. When you select this option,

a prompt is displayed to confirm the completion. After confirming, the completed task is removed
from the widget. In M3, the status field of the record in (CRS420) is automatically set to
50-'Completed'.

• Every task in the widget is assigned a color depending on the status:
• Blue: signifies that the task is not started yet.

Infor M3 Core Infrastructure & Technology User Guide | 39

 

M3 H5 user tasks



• Yellow: signifies that the task is needed for the current date.
• Red: signifies that the task is overdue.

Configuring the M3 Environment widget
1 Add the M3 Environment from the widget catalog.

2 Click Configure Widget.
3 Specify a title for the widget. To modify the title, click the unlock button and specify a new title.

4 Click Save.

Configuring the M3 Menu widget
1 Add the M3 Menu from the widget catalog.

2 Click Configure Widget.
3 Specify a title for the widget. To modify the title, click the unlock button and specify a new title.

4 Click Save.

Configuring the M3 Information Viewer widget
1 Add the M3 Information Viewer from the widget catalog.

2 Click Configure Widget.
3 Specify this information:

Title
Click the unlock button and specify a widget title.

Automatic Refresh Rate
Click the drop down field and select a refresh rate minute interval.

Bookmark Options

Optionally, you can select from existing bookmark options. Click Get Ming.le Bookmark and
select an existing bookmark.

To create your own bookmark, see Configuring a bookmark on page 47.

4 Configure the M3 API:

Program
Click the look-up button. You can search for M3 programs, for example CRS610, and provide a
description to filter the results. Click a record from the programs list and click Select.

Transaction
Click the look-up button. You can search for a transaction, for example SearchCustomer, and
provide a description to filter the results. Click a record from the transactions list and click Select.
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Input
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Input column to select the Input Fields to be submitted for the
MI Transaction.

• Change the input field's value in the Value column, for example specify BLCD:[0 TO 8];
for SQRY.

• Select the check boxes in the User input column to enable the user to override the input value
from the widget actions on the widget menu.

• Optionally, specify an entity type if you require the widget to retrieve business context
messages, for example, InforCustomerPartyMaster. And then specify an input in the
Value field that uses the entity type enclosed in a bracket. This example shows the format:
{InforCustomerPartyMaster}. The same input is reflected in the Id1 context message
which you can use as an input field to run the MI request.
Note: Other supported macros are used in the Value field. See Supported macros for the
input field on page 43.

Output
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Output column to select the output fields to be submitted for
the MI transaction.

• Specify a value under the View Order column to specify the order of the output fields for
display, for example CUNO;CUNM;STAT;CUCL.

• Select a maximum record count.
• Optionally, enable a bookmark. If selected, you can configure additional fields. See Enabling

a bookmark on page 48.

Display content as
Click the drop down and select a display type. If you select graph, additional fields should be
configured. See Configuring a graph on page 48.

5 Click Save.

Configuring the M3 Information Monitor widget for basic MI transactions
1 Add the M3 Information Monitor from the widget catalog.

2 Click Configure Widget.
3 Specify this information:

Title
Click the unlock button and specify a widget title.

Automatic Refresh Rate
Click the dropdown field and select a refresh rate minute interval.

4 Click Add Monitor and configure the monitor to be added.
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Monitor Name
Specify a monitor name.

Severity Indication
If selected, you can press the Configure button and add input ranges for indicators.

Drilldown
If selected, you can specify a primary action to either Drilldown or Open and specify a maximum
record count.

Bookmark Options
Click Get Ming.le Bookmark. Click the dropdown field and select from the existing bookmark
options.

Optionally, you can modify your own bookmark. See Configuring a bookmark on page 47.

5 Configure the M3 API. Specify this information:

Program
Click the look-up button. You can search for M3 programs, for example CRS610, and provide a
description to filter the results. Click a record from the programs list and click Select.

Transaction
Click the look-up button. You can search for a transaction, for example SearchCustomer, and
provide a description to filter the results. Click a record from the transactions list and click Select.

Input
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Input column to select the Input Fields to be submitted for the
MI Transaction.

• Change the input fields’ value in the Value column, for example specify BLCD:[0 TO 8];
for SQRY.

• Select the check boxes in the User input column to enable the user to override the input value
from the widget actions on the widget menu.

• Optionally, specify an entity type if you require the widget to retrieve business context
messages, for example, InforCustomerPartyMaster. And then specify an input in the
Value field that uses the entity type enclosed in a bracket. This example shows the format:
{InforCustomerPartyMaster}. The same input is reflected in the Id1 context message
which you can use as an input field to run the MI request.
Note: Other supported macros are used in the Value field. See Supported macros for the
input field on page 43.

Output
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Output column to select the output fields to be submitted for
the MI transaction.

• Specify a value under the View Order column to specify the order of the output fields for
display, for example CUNO;CUNM;STAT;CUCL.
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• Select the check boxes in the User input column to enable the user to override the input value
from the widget actions on the widget menu.

• Select a maximum record count.
• Optionally, you can enable a bookmark. See Enabling a bookmark on page 48.

Display content as
Click the dropdown and select a display type. If you select graph, additional fields should be
configured. See Configuring a graph on page 48.

6 Click OK.

Supported macros for the input field
• Infor entities macros

The macros for entities uses this format: {<infor_provided_entity_name>}. For example,
{InforCustomerPartyMaster}. Take note that the user should also add the same entity name on the
entity type column when configuring the input parameter.

• Location macros

The macros for location uses this format: {<coordinate>, [<no_of_decimals>]} where the value
inside the square brackets [] are optional.

The types of location macros include:

• {longitude}
• {latitude}
• {latitude, 3} where 3 is optional in this example

• Date macros

The macros for location uses this format: DATE(<integer>).

The date macros may vary depending on the supplied integer:

• DATE(-30): calculates date of 30 days behind from the current date
• DATE(0): current date
• DATE(+30): calculates date of 30 days ahead from the current date

• User context macros

The macros for user context uses this format: {<user context fields>}.

Note: The user context fields are retrieved from the current user records from (MNS150).

This list contains the supported user context macros:

• {CONO} - user's company
• {DIVI} - user's division
• {LANC} - user's language
• {DTFM} - user's date format
• {DCFM} - user's decimal format
• {TIZO} - user's time zone
• {FACI} - user's facility
• {WHLO} - user's warehouse
• {TX40} - user's company name
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• {CONM} - user's division name
• {DFMN} - user's start menu
• {USID} - user's ID
• {NAME} - user's full name
• {USTA} - user's status
• {USTP} - user's type
• {EQAL} - user's equipment alias search sequence
• {EMAL} - user's email address
• {MNVR} - user's menu version

Using the Copy Monitor functionality
Use this functionality to copy an existing monitor without doing a configuration of the widget manually.

1 Add M3 Information Monitor from the widget catalog.

2 Click Configure Widget and specify a widget title.

3 Click + Add Monitor and complete your configuration, see Configuring the M3 Information Monitor
widget for basic MI transactions on page 41.

4 Click Save.

5 Right-click your existing widget, and select Copy.

6 Optionally, specify a new title for your widget copy and click OK. All configurations from the source
widget are copied to the new widget. You may update the configurations of your widget copy after
using this functionality.

Using Translations in M3 Information Monitor widgets
Add translations that converts the monitor names to your preferred language.
Note: The change will reflect depending on the language set from the User settings of homepages.

1 On the Edit Monitor dialog, click Translations.

2 On the Add Translation dialog, specify this information:

Language
Use the list to select your preferred language.

Name
Specify the name to translate.

3 Click Add.

4 On the Translations dialog, click Add Translation to add more languages.

5 Click OK.

6 On the Edit Monitor dialog, click OK to exit.
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Configuring the M3 Product Updates widget
1 Add the M3 Product Updates from the widget catalog.

2 Click Configure Widget.
3 Specify this information:

Title
Click the unlock button and specify a widget title.

Product
Select a value from the list, for example M3 Business Engine.

Latest Update
Select this check box to view the latest update for the selected product.

Feature review status
Select this check box to view the number of installed features that require review. By clicking
Details, you are navigated directly to H5 Enterprise with the list of features by NCR record.

Current product version
Select this check box to view the latest product version.
Note: This is only available when you select M3 Business Engine in the Product field.

4 Click Save.

Configuring the M3 Information Creator widget for basic MI transactions to
create data
1 Add the M3 Information Creator from the widget catalog.

2 Click Configure Widget.
3 Specify a title for the widget. To modify the title, click the unlock button and specify a new title.

4 Configure the M3 API. Specify this information:

Program
Click the look-up button. You can search for M3 programs, for example CRS610, and provide a
description to filter the results. Click a record from the programs list and click Select.

Add Transaction
Click the look-up button. You can search for a transaction, for example AddTool, and provide a
description to filter the results. Click a record from the transactions list and click Select.

Input Fields
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Input column to select the Input Fields to be submitted for the
MI Transaction.

• Change the input fields’ value in the Value column.
• Optionally, configure a browse field. See Configuring a browse field on page 49.

Infor M3 Core Infrastructure & Technology User Guide | 45

 

M3 H5 user tasks



5 Click Save.

Configuring the M3 Information Editor widget for basic MI transactions to
update data
1 Add the M3 Information Editor from the widget catalog..

2 Click Configure Widget.
3 Specify this information:

Title
Click unlock button and specify a widget title.

Automatic Refresh Rate
Click the dropdown field and select a refresh rate minute interval.

4 Configure the M3 API. Specify this information:

Program
Click the look-up button. You can search for M3 programs, for example CRS610, and provide a
description to filter the results. Click a record from the programs list and click Select.

Get Transaction
Click the look-up button. You can search for a transaction, for example SearchCustomer, and
provide a description to filter the results. Click a record from the transactions list and click Select.

Input
Click the look-up button.

On the data grid, you can perform these tasks:

• Select the check boxes in the Input column to select the Input Fields to be submitted for the
MI transaction.

• Change the input fields’ value in the Value column.
• Optionally, specify an entity type if you require the widget to retrieve business context

messages, for example, InforCustomerPartyMaster. And then specify an input in the
Value field that uses the entity type enclosed in a bracket. This example shows the format:
{InforCustomerPartyMaster}. The same input is reflected in the Id1 context message
which you can use as an input field to run the MI request.
Note: Other supported macros are used in the Value field. See Supported macros for the
input field on page 43.

Output
Click the look-up button.

On the datagrid, you can perform these tasks:

• Select the check boxes in the Output column to select the output fields to be submitted for
the MI transaction.

• Specify a value under the View Order column to specify the order of the output fields for
display, for example CUNO;CUNM;STAT;CUCL.

• Select a maximum record count.
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Update Transaction
Click the look-up button. You can search for update transactions, for example ChgBasicData
and provide a description to filter the results. Click a record from the transactions list and click
Select.

Editable Fields
Click the look-up button to switch to the Input/Output Parameters page.

On the datagrid, you can perform these tasks:

• Select the check boxes in the Input column to select the Input Fields to be submitted for the
MI transaction.

• Change the input fields' value in the Value column.
• Optionally, configure a browse field. See Configuring a browse field on page 49.

5 Click Save.

Editing an information in the M3 Information Editor widget
1 Open the M3 Information Editor widget.

2 Optionally, specify a value or a description in the Search field.

3 Click the available record from the list.

4 The displayed fields are based from the values gathered from the M3 Information Creator. You
can modify values in the existing fields, for example Name field.

5 Click Submit. An Update Transaction Success is displayed.

Configuring a bookmark
Use this procedure to create a bookmark that opens an M3 program. To access the bookmark, click
the main options of the widget where you configured the bookmark and click Open.

1 When configuring a widget, click Edit beside Get Ming.le Bookmark.

2 Specify this information:

Program
Specify any M3 program, for example CRS610. Click Get beside the field to get accurate bookmark
parameters for the program.

Table
Specify any M3 Table, for example OCUSMA. Click Get to get accurate bookmark parameters.

Sort Order
Specify any M3 sort order value, for example 1.

View
Specify any M3 view value, for example STD01-01.

Query
Specify any bookmark query value, for example CONO:880.
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3 Click OK.

Enabling a bookmark
Use this procedure to bookmark a user's record in M3. To access the bookmark, right-click a specific
record where you configured the bookmark, then select Open.

Note: This option is only enabled if the selected output fields meet these requirements:
• Key string (KSTR) fields
• Combination of table fields and program fields:

• Program field should either be YPGM or PGNM.
• Table name should either be YFIL or FILE.

1 When selecting parameters for the Output field, enable your bookmark settings.

2 Specify this information:

Option
Specify an M3 bookmark option, for example 2.

Start panel
Specify an M3 bookmark start panel, for example J.

Focus Field
Specify an M3 bookmark focus field, for example WRBLCD.

3 Click OK.

Configuring a graph
1 In Display content as, select graph as your display type. .

2 Press the Configure Button.

3 In the graph view settings, specify this information:

Chart type
Click the dropdown and select a chart type.

Label Column
Click the dropdown and select a label column. The values are taken from the fields selected in
the MI Output Configuration above, step 4.

Value Column(s)
Click the dropdown and select the value column. The values are taken from the fields selected in
the MI Output Configuration above, step 4.

Group by label column
If enabled, data is aggregated by value type.

Group by type
Select between count or by sum.
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Enable debit/credit conversion
If enabled, you can specify values for the Debit sign or Credit sign fields.

Configure Drilldown
Perform the same steps in configuring an M3 API which is done for selected widgets. Additionally,
provide field mappings for Map drill parameters that uses retrieved data from output fields after
clicking a specific information in the configured graph.

4 Click OK.

Configuring a browse field
1 In the Input fields, click the look-up button.

2 Specify this information:

Table
Specify a table, for example OCUSMA.

Field Override
Specify any M3 API Field, for example CONO.

Set as Browse
Select the check box to set the parameter as browse field.

Browse Field
Click the Edit button to modify the browse field overrides.

DescriptionField

Contains M3 API fields, for example CONO.Field Override

Contains an index of the available data.Parameter List Index

Contains M3 table values, for example {} or OCUSMA. This field
is auto filled by the Parameter List Index.

From Table

Contains browse variant values, for example 00 or 01. This field
is auto filled by the Parameter List Index.

Browse Variant

Selecting this check box enables you to specify filter fields.Add a filter

View Order
Specify an input a value to specify the order of the input fields for display.

3 Click Save.
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Infor Business Context
The Infor Business Context feature broadcasts contextual data from H5 application, which then triggers
a related output from a subscribed Infor Ming.le context application. For the feature to work, the context
application must be subscribed to the Infor Business Context message of type inforBusinessContext.

Note: The Infor Business Context option is not displayed in the Context Publisher menu when the Auto
Publish Infor Context property is enabled. All data matching the specified business context fields will
be automatically published when this property is enabled.

See application settings in M3 CE Core Administration Guide.

Using Infor Business Context

1 Open a program. If program opens in B panel, select a record.
2 Select Tools > Context Publisher > Infor Business Context.
3 In the Infor Context Business window, the business entities are mapped to specific fields. These

entities will differ depending on which M3 panel is opened.

To use the Paparazzi context application, a reference between the business context and the
corresponding BODs must be configured. The required configuration can only be performed by
looking at the specific noun and how M3 data is mapped into the BOD elements.

DescriptionField

This noun corresponds to the Infor Business Context.Noun

See M3 Business Engine BODs Mapping Documentation - Inbound
and M3 Business Engine BODs Mapping Documentation - Out-
bound for information about how the M3 data is mapped into the
Document ID of the BOD.

Document ID

The M3 standard specifies that it must be defined as
<CONO>_<DIVI> (Company_Division). This can change during
installation, so verify that the installation follows the standard.

Accounting Entity

The value for the location corresponds to M3 Warehouse. See M3
Business Engine BODs Mapping Documentation - Inbound and
M3 Business Engine BODs Mapping Documentation - Outbound.

Location

This is usually blank.Revision ID

If you select Auto Publish, these entities are automatically published regardless of which record
you open.

To reset the values, click Use Default.

4 Click Save after supplying the values.
5 Verify that all subscribed context applications are triggered to show information related to the

current record.

Context Publisher data is stored as personalization.
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Using Mashup Context
Use the Mashup Context to send contextual information from an M3 program directly to the Mashup
context application.

1 Open a program.

2 Select Tools > Context Publisher >  > Context Publisher.
3 In the Mashup Context window, specify this information:

Mashup
Specify the name of the mashup.

Application
Specify the application within the mashup to show the context application.

Default Values
This field can hold startup parameters for the mashup. Valid fields are located in this list.
Double-click the field name to add to the Default Values field. The value is divided in key-value
pairs separated by a semi-colon, where the key is the name of the parameter in the mashup and
the value is the field name in the M3 program.

To reset the values, click Use Default.

If you select Auto Publish, these entities are automatically published, regardless of which record
you open.

4 Click Save.

5 Verify the mashup in the Mashup context application.

Note: Context Publisher data is stored as personalization.

Adding M3 program in the Favorites menu
If you use an M3 program regularly, you can add it in Favorites for easy access.

Adding an M3 program
1 Select an M3 Transactions category from the application menu and select a program.

2 Right-click the program tab and select Add to Favorites.

3 Verify if the program is added to your Favorites.

a Select Favorites from the application menu.
b Click the program name from the Favorites list.
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Removing an M3 program
When you remove favorites from the application menu, the favorites list are also removed from the
Favorites section in the landing page.

1 Select Favorites from the application menu.

2 To remove a specific item in the list, right-click the program name and select Remove.

3 To remove all items, right-click anywhere on the panel and select Clear All.

New H5 UI
The new H5 user interface is updated with the latest visual style and controls from Infor Design System.

Application menu
The default or normal view of the application menu contains these selections:

• Start: Provides an option to users where they can search for a specific program name or ID.
• Favorites: Contains favorite M3 programs and other applications defined by the user.
• Recent: Gathers the selection that you last accessed, for example M3 program, administration tool

etc.
• Administration Tools: Provides access to tools and is available to administrators who maintain the

H5.
• Mashup Library: Contains available mashup applications
• M3 transactions menu: Provides access to M3 programs

User settings
The M3 program settings are customized depending on the necessity or preference of the users. The
user settings are categorized into these areas: General, Options, Appearance.

• General: Settings that are applicable to all programs
• Options: Settings that are only applicable to specific programs
• Appearance: Settings that enhance the look of the interface

The user settings for the new H5 UI contains distinct settings that are not accessible in the classic H5.

Changing the user settings
1 Open a program.
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2 Select Tools > User Settings.

3 In the General tab, select the preferred settings:

DescriptionOption

Select this setting if you want notification from the M3
server to display in a dialog window instead of the
status bar. Messages are displayed on the status bar
by default.

Display system messages in dialog win-
dow

Select this setting to show the company and division
information on the status bar.

Display company and division informa-
tion on the status bar

Select this setting to show the company and division
information on the toolbar.

Display company and division informa-
tion on the toolbar

Select this setting to show the program ID beside the
program name.

Show Program ID on program tab

Select this setting to show the full description of field
labels.

Display label tooltips

Select this setting to show field help.Display help tooltips

Use this setting to publish field context details when
you select and move your pointer to a particular field
or press F1.

Activate context help

Select this setting to align field labels to the right.Right align labels

Select this setting to navigate across the M3 panel
using the plus (+) key as an alternative to the tab key.

Use plus key as tab

Select this setting to place a cursor at the end of the
value in an input field. When this option is not select-
ed, the entire value in the input field is highlighted.

Position cursor in end of input fields

This setting is applicable only to certain programs.

If a program supports expandable rows of lists but
this setting is disabled, the expandable content will
display in list columns.

Select this setting to display expandable rows of lists
for programs that support this feature.

Expand list

Select this setting to show the panel navigator in mini-
mode.

Use small view for panel navigator

Select this setting to enable H5 to display its contents
using the language used by Infor Ming.le.

See information about changing the site default lan-
guage in Infor Ming.le User Guide.

Use Infor Ming.le language

Select this setting to enable H5 to automatically switch
to Homepages when all programs in H5 are closed.

Auto-switch to Homepages
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DescriptionOption

Use this setting to switch between the classic UI and
the new UI.

Enable classic UI

Use this setting to automatically fill text fields using
the value that you used as input. This setting over-
rides the Enable Favorites personalization feature.

Note: Ensure that the 'Save and fill addresses' setting
in Chrome is also enabled to make the autofill work.

Enable browser autofill

Use this setting to select the calendar format dis-
played when using the date picker tool.

Note: The default format for most supported lan-
guages is Gregorian. Whereas, for some languages
the default format might be different.

Calendar view

4 In the Options tab, configure the settings of a specific program:

DescriptionOption

Use this setting to set the default action that is execut-
ed after you double-click the record from the list panel.

The selected option is the default action for all pro-
grams. In the B panel, the blue button shows this de-
fault option.

Standard option

To configure this setting, see procedures:

• Setting a program option on page 25
• Updating the program option for a specific pro-

gram on page 26

Program Options

5 In the Appearance tab, enhance the look of the interface:

DescriptionOption

Use this setting to change the size of the fields and
buttons.

Form Size

Use this setting to change the row height of the data
grid.

Row Size

Select from the available colors to apply for the inter-
face.

In the new H5 UI, color is also applied in the applica-
tion menu.

Theme Colors

6 Click Save.
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Split screen functionality
Split screen supports merging with non-standard M3 programs and other external sites. This functionality
is useful if you have SDK applications that are connected to Infor Business Context messages.

Using the split screen functionality
1 Open a program.

2 Open another non-standard M3 program or any external website.

3 Click the program tab and drag over to the center section of another tab. Ensure that the tab where
you form a pair is highlighted with a translucent shade. The dragged tab is positioned in the right
of the tab pair by default.
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Chapter 2: M3 Metadata Publisher user tasks

Use the M3 Metadata Publisher (MDP) to explore M3-related metadata. It contains files, fields, and
relationships between file-programs and program-files. You can use MDP to generate and show
metadata for each unique M3 Business Engine customer installation. These metadata are based on
the Standard and Market installed components.

You perform these two tasks in this order:

1 Perform MDP Client functions.
2 View MDP Client task results.

The typical users of the M3 Metadata Publisher are business consultants, partners, and customers.
These users can browse M3 Business Engine (BE) tables, columns, and program relationships using
M3 Metadata Publisher.

Signing in using a web browser
Use this procedure to sign in to MDP through LifeCycle Manager or a web browser. Before you start
ensure that the Application Server for MDP is started.

1 Open a web browser.

2 Sign in to M3 Cloud Suite.

3 Expand Administrator Tools.

4 Click M3 Metadata Publisher Tool link. The MDP opening page is displayed.

M3 Metadata Publisher Client UI
When MDP Client is started, a standard view is displayed with several features.

Tabs
Use these tabs to access MDP Client tasks.
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DescriptionTab

Click to select MDP search types:

• Search by System Configuration

See Client tasks on page 60.

Search

Click to access M3 API RepositoryM3 API Repository

• Settings

• Language Code: Set the Language code to
use.

For example, GB for English, SE for Swedish,
or NO for Norway.

Note: The available languages are generated
from the applied languages on the MNE
folder of the M3 Business Engine installation.

• Page size: Set the page size to display.

The minimum setting is 100 rows per page.

• Content proposal: Toggle the use of Content
Proposal in applicable fields. When enabled,
open fields will display suggested match as
you type. This is not applicable to search
strings using wild character asterisk (*).

• Search history: Option to clear MDP Client
search history.

• About: Opens the copyright and product infor-
mation window.

Settings

Control Functions
Use these icons to access the MDP Client UI functions.

DescriptionIcon

Arrow pointing down. Use this to retrace your
search result actions.

Session navigation

Search task field definitions
Use the Search feature in MDP Client to select the search type to use and to define the corresponding
fields.

Note: Your selected M3 BE System, BE Installation, and Language code is saved on the last signin.
Fields are described in this table:
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There are MDP functions that are configured so that you can search and view M3-related metadata.

DescriptionField/Option

Use this field to type your search query. You can
use alphanumeric characters (A-Z,a-z), blank
space, hyphen, colon, or underscore.

You can use the wildcard character * (asterisk)
in place of an unknown string. For example, if
you search for "b*d", the results will show hits for
"ABCD", "bed" and "abd-001".

Keywords or Program Name

Use this open drop-down field to select the MDP
BE System where to perform Search.

A default M3 BE selection is displayed.

Select MDP BE System

Represented by an information (i) icon beside
the Select MDP BE System field, use this to dis-
play more details about your selected MDP BE
System.

MDP BE System information

Similar to Keywords field, use this for a more
specific method contained when you select
Search by Component.

Containing method/keyword

Select one or more entities to use on your
search.The list of available entities vary depend-
ing on your selected Search option to use.

Select Entity

Click this link to show advanced search options.
The selections here change depending on your
selected Search option to use.

More Options

After you define the required task information,
click on this icon to invoke search.

Search

Search Results
When you perform an MDP Client task, the Search Results tab opens.

Here is a table list of the Result tab components with description.
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DescriptionComponent

Indicates this information:

• Search query - enclosed in single quotes ('),
in this example, the text 'CONO'.

• Search method - in this example, Search by
System Configuration.

• Selected BE Installation/System - enclosed
in single quotes (') shows where the indexed
search was executed.

Tab Header

Indicates your selected entity and the total num-
ber of results matching your query.

Type of System Element: Total match

Click Type of System Element to display the re-
sults by type or by available relation information.

Note: You can drill down the table rows to view
more matching results by Program.

Use the session navigation icon in the left pane
for your history views.

Results Count

By default a tab is unlocked. When you perform
a new search, the current tab is replaced with the
result of your new search.

Lock the current tab to display subsequent search
results in new tabs.

Lock tab icon

Click More to display a list of active tabs and se-
lect which tab to display.

List All tabs

Click to export applicable tables or program
search results to Excel.

Export to Excel icon

Use the Sort icon to arrange the results, alphabet-
ically or numerically for each column, depending
on the column property.

Sort icon

Lists the available filter options for your search
result table.

Type a free text filter in each column and select
a filter condition from this list.

To execute your filter definitions, select Run Filter
in the Filter menu located in the right most side
of the pane.

Filter options

• Run Filter- select to execute your filter defini-
tions.

• Clear Filter - select to clear your filter defini-
tions.

Filter Menu
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DescriptionComponent

From the Settings menu, set the Page size in
terms of number of rows to display in a page.

The status at the bottom of the screen shows the
number of rows and the number of pages dis-
played in a given total.

Click the Forward and Back arrows to navigate
through the pages. The minimum setting is 100
rows per page.

Table Paging

Client tasks
There are MDP functions that are configured so that you can search and view M3-related metadata.

• Viewing MDP BE system information on page 60
• Searching by System Configuration on page 62
• Viewing Relation Information on page 76
• M3 API Repository on page 101

Viewing MDP BE system information
You must verify the MDP BE System information when searching by system configuration or by
component.

Viewing by system configuration
1 On the Search tab, click Search By System Configuration.

2 Select an MDP BE System to use.

3 Click the information icon beside the Select MDP BE System field.

The MDP BE System information window is displayed.

4 Verify the information applicable to your selected MDP BE system:

MDP BE System

Lists all available M3 BE Installation and MDP System in MDP Client.

Standard base M3 BE is a system that comes with the installation of the M3 Metadata Publisher
and all other BE system metadata generated using LifeCycle Manager.

Note: You can select another MDP BE system to view.
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Type

Method used to generate the BE system metadata, by system configuration or by component.

MDP ID
ID assigned to the MDP client version.

BE version
System metadata BE version.

Environment
LCM environment where MDP is installed.

Server
Server where the component is installed.

Configuration
Configuration used in the MDP BE system.

For example: MVX

Components
List of system configuration components.

For example: MVX, MAR, MDK

Last update
The date and time when the BE system was last updated in LifeCycle Manager.

Status
Status of the BE system metadata files, if synchronized or not synchronized.

You should always check if the metadata files are updated and synchronized to ensure that new
files or fixes are applied in the BE environment.

5 Click OK to close the window.

Viewing by Component
1 On the Search tab, click Search By System Configuration.

2 Select an M3 BE Installation to use.

The M3 BE Installation information window is displayed.

M3 BE Installation
Lists all available M3 BE Installation and MDP System in the MDP client.

Type
Method used to generate the BE system metadata, by system configuration or by component.

MDP ID
ID assigned to the MDP client version.
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BE version

System metadata BE version.

Server
Server where the component is installed.

Components

List of system configuration components.

For example: MVX, MAR, MDK

Last update
The date and time when the BE system was last updated in LifeCycle Manager.

Status

Status of the BE system metadata files if synchronized or not synchronized.

You should always check if the metadata files are updated and synchronized to ensure that new
files or fixes are applied in the BE environment.

Searching by System Configuration
Use these procedures to search by System Configuration.

Search by System Configuration Details
Search by System Configuration is accessed from the Search tab and contains these features and
fields.

System Configuration fields

Use these options to perform search on M3 BE by System Configuration.

DescriptionFields

This open text Keyword field is auto complete.
Here you type the name or description associated
with the program you are searching for using al-
phanumeric characters, space, hyphen, colon,
or underscore.

You can also use a wildcard (*) at the beginning,
middle, or end of the keyword. Search will look
for a match based on your keyword and the posi-
tion of the wildcard.

Keywords
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DescriptionFields

This open text M3 BE field is auto complete. Use
this to select the M3 BE System where to execute
the search. A default M3 BE selection is dis-
played.

Note: MDP saves your selected MDP BE System
on the last sign in.

To view MDP BE information - click the MDP BE
information (i) icon to display more details about
your selected M3 BE System.

Select MDP BE System

Use this to select an entity or a combination of
entities for your M3 BE by System Configuration.
By default, the Program and Table entities are
selected.

In the right pane, the Search Result tab displays
the result. By default the table lists 500 data
match. On the bar at the top, the information on
Entity:Number of matches is shown.

M3 BE entities

After you define the required task information,
click this to perform the search.

Search

M3 BE entities

Drill down on any available data in the list to view more data relational information. The column and
data listings vary according to your selected entity.

DescriptionEntity

This selection displays matching data for program
entities.

Program entities are selected in combination with
Table entity.

Program

Shows data match for parameter list entities.Parameter List

Shows data match for data structure entities.Data Structure

Shows data match for output file entities.Output File

Shows data match for reference field entities.Reference Field

Shows extension point details.Extension Point

Shows data match for table entities.

Table entities are selected in combination with
Program entity.

Table

Shows data match for table column entities.Table Columns
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DescriptionEntity

Shows data match for table index entities.Table Index

Shows data match for util entities.Util

Checks all Entity check boxes.All

System Configuration Advanced Search

Click the link to More Options and refer to the field definitions here for M3 Business Engine (BE) system
and version advanced filtering.

DescriptionFields

Select a component corresponding to your select-
ed MDP BE system.

Select Component

List of categories corresponding only to Program,
Table, or Program and Table M3 BE entities. This
is not available to other entities in the list.

• For Programs, use Program category list
• For Tables, use Table category list

Select Category

Select the option appropriate to your required
program filter.

• With Bookmark - filters bookmark-enabled
programs only.

• With Bookmark Parameter - filters
bookmark parameter enabled programs only.

• With Bookmark and Bookmark Param-
eter - filters both bookmark enabled and
bookmark parameter-enabled programs.

• Function Programs - filters function pro-
grams only.

Program Filter

Set the result limit from a range of 100 to 10000
with an interval value of 100 for the first 1000. By
default the search result displays the first 500
data match.

For volume data, processing can take time, we
recommend that you consider setting the search
limit.

Search Limit

Program category list

DefinitionName

APIApi

Autostart jobAsj
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DefinitionName

Conversion programsCnv

Electronic Chart of Account ReportCrt

Inquiry programsDsp

Fix programsFix

FunctionsFnc

ListsLst

Maintenance programsMnt

Parameter listPl

PTF programsPtf

Copy subroutinesSr

TableTb

Test programsTst

Work with programsWrk

Table category list

DefinitionName

Data structuresDS

History fileHF

Join DynamicsJD

Master data fileMF

System fileSF

Transaction fileTF

Work fileWF

Searching for M3 BE entities
Use this procedure to search for M3 BE entities by system configuration.

1 Access the Search tab and select Search By System Configuration.

2 Specify the keyword to search.

3 Select an MDP BE system to use.

4 Select an M3 BE entity to use.

5 Click the link to More Options and set the advanced search filter options.
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6 Select a Component.

7 Select a Category.

This option is available only to Program or Table entity.

8 Set a Search Limit.
9 Select a Program Filter.

• With Bookmark: filters bookmark-enabled programs only.
• With Bookmark Parameter: filters bookmark parameter-enabled programs only.
• With Bookmark and Bookmark Parameter: filters both bookmark enabled and bookmark

parameter-enabled programs.

• Function Programs: filters function programs only.

10 Click Search.

The Search Results tab displays a list of matching entries based on your search criterion and other
relational information corresponding to your selection. On the bar at the top, it shows Selected
entity: Number of matches.

11 Use these options to manage your results:

• To sort the results alphabetically or numerically, click the Sort icon on the column headings.
• To filter the results, click the Filter icon in the last column and type a dynamic free text filter

for each column.

12 To view relation information, click a system element name.

Searching for program
Use this procedure to search for programs of M3 Business Engine (BE) system by system configuration.

1 On the Search tab, select Search By System Configuration.

2 In the Keywords field, type a keyword to search.

3 Select an MDP BE System to use.

See System Configuration fields on page 62.

4 Select an entity: Program.

See M3 BE entities on page 63.

5 Click the link to More Options for additional search filter.

a Select a Component.
b Select a Category.

See System Configuration Advanced Search on page 64.

c Select a Program Filter to use.

With Bookmark: to select only bookmark-enabled programs.

With Bookmark Parameter: to select only bookmark parameter-enabled programs.

With Bookmark and Bookmark Parameter: to select both bookmark-enabled and bookmark
parameter-enabled programs.

Function Programs: to select only function programs.
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d Set the search limit. The default search limit is 500.

6 Click Search.

On the Search Results tab, the Entity (Total match), and a data list with this information is displayed:

Program name
Name of the program.

Description
Description of the program.

Component
Component of the program.

Category
Category of the program.

Area
Area of the program.

Bookmark
To toggle bookmark enabled.

Bookmark Parameter
To toggle bookmark parameter enabled.

Source Code

Shows the source code of a selected program.

7 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter
for each column.

8 To view program relations, click a Program name.

See Viewing Program Relation Information on page 76.

Searching for parameter list
Use this procedure to search for parameter list of M3 Business Engine (BE) system by system
configuration.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.

3 Select the MDP BE System.

4 Select an entity: Parameter.

5 Click the link to More Options for additional search filter.
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• Select a Component.
• Set the Search limit. The default value is 500.

See System Configuration Advanced Search on page 64

.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list with this information is displayed.

Parameter List Name
The name of the parameter list.

Component
The components of the parameter list.

Source Code

Shows the source code of a selected program.

7 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter
for each column.

8 To view Parameter list, click an entity name.

See Viewing Parameter List Relation Information on page 90.

Searching for data structure
Use this procedure to search for data structure of an M3 Business Engine (BE) system by system
configuration.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, type a keyword to search.

3 Select an MDP BE System.

4 Select an entity: Data Structure.

5 Click the link to More Options for additional search filter.

• Select a Component from the list.
• Set the search limit. The default value is 500.

See System Configuration Advanced Search on page 64.

6 Click Search.

On the Search Results tab the Entity: Total match, and a data list with this information is displayed.

Data Structure Name
The name of the data structure.
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Component
The components of the data structure.

7 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

8 To view data structure name, click an entity name.

See Viewing Data Structure Relations Information on page 92.

Searching for output file
Use this procedure to search for output files of M3 Business Engine (BE) system by system configuration.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.

3 Select the MDP BE System to use.

4 Select an entity: Output Files.

5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the search limit. The default value is 500.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list is displayed:

Output file name
The name of the output file.

Description
The description of the output file.

Component
The components of the data structure.

7 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter
for each column.

8 To view Output File file name, click an entity name.
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Searching for tables
Use this procedure to search for tables and table indexes of M3 Business Engine (BE) system.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.

3 Select the MDP BE System.

See System Configuration fields on page 62.

4 Select an entity: Table.

See M3 BE entities on page 63.

5 Click the link to More Options for additional search filter.

a Select a Component.
b Select a Category.
c Set the search limit. The default value is 500.

See System Configuration Advanced Search on page 64.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list is displayed:

Table Name
The name of the table.

Description
The description of the table.

Component
The component of the table.

Category
The category of the table.

7 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter
for each column.

8 To view table relations, click a Table Name.

See Viewing Table and Column Relation Information on page 83.

Searching for table column
Use this procedure to search for table columns of M3 Business Engine (BE) system and version.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.
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3 Select the MDP BE System.

4 Select an entity: Table Column.

5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the Search Limit. The default value is 500.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list is displayed:

Column Name
The name of the column.

Description
The description of the column.

Data type
The data type of the column.

Length
The length of the column.

Decimals
The decimals of the column.

Edit code
The edit code of the column.

Indexes
The list of index names.

Parent table
The name of the Parent table of the column.

Component
The component of the column.

7 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and specify a dynamic free text filter
for each column.

8 To view table relations, click Parent Table name.

Searching for table index
Use this procedure to search for table indexes of M3 Business Engine (BE) system and version.

1 On the Search tab, click Search By System Configuration.
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2 In the Keywords field, specify a keyword to search.

3 Select an MDP BE System to use.

4 Select an entity: Table Index.

5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the Search Limit. The default value is 500.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list is displayed:

Index Name
The name of the index.

Unique
Yes indicates that the index is unique and there can only be one unique key for every table.

Parent Table
The parent table of the index.

Parent Table Description
The description of the parent table.

Component
The component of the index.

Key Info
The option to view the keys of an index.

Condition Info
The condition information of an index.

Join Table
The join table of an index.

Join Condition
The join condition of an index.

7 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and specify a dynamic free text filter
for each column.

8 To view index relations, click View Index Keys.

Searching for Util
Use this procedure to search for Utils of M3 Business Engine (BE) system and version.
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1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.

3 Select an MDP BE System to use.

4 Select an entity: Util.

5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the Search Limit. The default value is 500.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list is displayed:

Util Name
The name of the Util.

Component
The component of the Util.

7 Component of the Util.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter
for each column.

• To view util relations, click Util name.

Searching for Extension Points
Use this procedure to search for Extension Points in M3 Business Engine (BE) system and version.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search. Use Interface Name or Extension Point Name.

3 Select an MDP BE System to use.

4 Select Extension Point.
5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the Search Limit. The default value is 500.

6 Click Search.

On the Search Results tab, the matching results and data lists are displayed.

Interface Name
Shows the name of the Interface with Extension Points.

Interface Description
Shows the description of the Interface with Extension Points.

Infor M3 Core Infrastructure & Technology User Guide | 73

 

M3 Metadata Publisher user tasks



Component
Shows the component of the Interface with Extension Points.

7 Optionally, use these options to sort and filter your results.

• Click the Sort icon located in one or more column headings to sort the results alphabetically
or numerically.

• Filter results by clicking the Filter icon in the last column and type a dynamic free text filter for
each column.

• Click Interface name to view extension points relations.

Searching for reference fields
Use this procedure to search for Reference Fields of M3 Business Engine (BE) system and version.

1 On the Search tab, click Search By System Configuration.

2 In the Keywords field, specify a keyword to search.

3 Select an MDP BE System to use.

4 Select an entity: Reference Field.

5 Click the link to More Options for additional search filter.

• Select a Component.
• Set the Search Limit. The default value is 500.

6 Click Search.

On the Search Results tab, the Entity: Total match, and a data list with this information is displayed:

Reference Field
Name of the Reference Field.

Description
Description of the Reference Field.

Component
Component of the Reference Field.

Ext
Ext - Extension file of the Reference field

Type
Type - Type of the Reference field

Category
Category of the Reference field

Length
Length of the Reference field
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Decimals
Decimal value of the Reference field

Add info length
Add info length value of the Reference field

Add info short length
Add info short length value of the Reference field

Heading
Heading value of the Reference field

Help ID
Help ID value of the Reference field

Constraints
Constraints value of the Reference field

7 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and specify a dynamic free text filter
for each column.

Setting the advanced search filter by system configuration
Use this procedure to set the advanced filtering of M3 Business Engine (BE) system and version.

1 On the Search tab, select Search By System Configuration.

2 Select the System Configuration fields.

3 Click the link to More Options for additional search filter.

a Select a Component.
b Select a Category for Program or Table entities only.
c Select a Program Filter to use.

With Bookmark: to select only bookmark-enabled programs.

d Set the Search Limit. The default is 500.

4 Click Search.

On the Search Results tab, the Entity or Total match and other relational information corresponding
to your search is displayed. Use this function to have multiple tabs by using the lock function. Filter
and sort search results using this feature.
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Viewing Relation Information
These functions show the relation between entities. Use Viewing Relation Information functions to
check the relationship of entities to various programs.

Viewing Program Relation Information
These are the functions used to view relations of Programs to other entities. Users can check which
entities are being referenced by which Programs.

Viewing tables used by a selected program

Before you start, you must complete a program search task. See Searching for program on page 66.

1 On the Search Results tab, click Program name.

A new search result opens with the header Program Relation Type: Total match.

2 Click Tables used to show the tables used by your selected program.

A new search result opens with this information:

Table Name
The name of the table that is used by your selected program.

Description
The description of the table that is used by your selected program.

Component
The component of the table that is used by your selected program.

Usage
The function of the table that is used by your selected program: Read, Update, and/or Delete.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column to specify a dynamic free text filter
for each column.

4 To view table relations, click a table name.

Viewing programs used by a selected program

Before you start, you must complete a program search task. See Searching for program on page 66.

1 On the Search Results tab, click a Program name.

A new search result opens with the header Program Relation Type: Total match.
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2 On the bar at the top, click Programs used to show the programs used by your selected program.

A new search result opens with this information.

Program name
The name of the program used by your selected program.

Component
The component of the program used by your selected program.

Description
The description of the program used by your selected program.

Source Code

Shows the source code of a selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

4 To view program relations, click a program name.

Viewing programs using a selected program

Before you start, you must complete a program search task. See Searching for program on page 66.

1 On the Search Results tab, click a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Used by to show the programs that are using your selected program.

A new search result opens with this information:

Program name
The name of the program using your selected program.

Description
The description of the program using your selected program.

Component
The component of program using your selected program.

Source Code

Shows the source code of a selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column to type a dynamic free text filter for
each column.
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4 To view program relations, click a program name.

Viewing parameter list used by a program

Before you start, you must complete a program search task.

1 On the Search Results tab, click a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Plist Used to show the programs using your selected program.

A new search result opens with this information:

Parameter list name
The name of the parameter using your selected program.

Component
The component of program using your selected program.

3 Use these options to sort and filter the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter for
each column.

4 To view program relations, click a Program name.

Viewing data structure used by a program

Before you start, you must complete a program search task.

1 On the Search Results tab, click a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Data structure used to show the data structures used by your selected
program.

A new search result opens with this information:

Data Structure Name
The name of the Data structure used by your selected program.

Component
The description of the Data structure used by your selected program.

3 Use these options to manage the results:

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

4 To view program relations, click a program name.
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5 To view data structure relations, click a data structure name.

Viewing output files used by a program

Before you start, you must complete a program search task.

1 On the Search Results tab pane, click a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Output files used to show the output files used by your selected program.

A new search result opens with this information:

Output file Name
The name of the output file used by your selected program.

Description
The description of the output file used by your selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column to type a dynamic free text filter for
each column.

4 To view output file relations, click an output file name.

Viewing Util used by a program

Before you start, you must complete a program search task.

1 On the Search Results tab, select a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Util used to show all Utils used.

A new search result opens with this information:

Util Name
The name of the util used by your selected program.

Component
The component of util using your selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view table relations, click a Table Name.
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Viewing extension points used by a selected program

Before you start, you must complete extension points search task.

1 On the Search Results tab, select a Program name.
A new search result opens with the header Program Relation Type: Total match.

2 Click Extension Points Used, to show the extension points used by your selected program.

Extension Point Name
The name of the extension point used by your selected program.

Component
The component of the extension point using your selected program.

Advice
The advice of the extension point used by your selected program.

Interface Name
The name of the interface.

3 Use these options to sort and filter your results.

• Sort the results alphabetically or numerically by clicking the Sort icon located in one or more
column headings.

• Filter results by clicking the Filter icon in the last column and type a dynamic free text filter for
each column.

4 To view extension points relations, click an Interface Name.

Viewing panels of a program

Before you start, you must complete a search task.

1 On the Search Results tab, click a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Program panels, to show all the panels used by your selected program.

A new search result opens with this information:

Panel Name
The name of the panel used by your selected program.

Description
The description of the panel used by your selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column to type a dynamic free text filter for
each column.

Infor M3 Core Infrastructure & Technology User Guide | 80

 

M3 Metadata Publisher user tasks



4 To view table field relations, click View Table Fields Used.

Viewing bookmark tables of a program

Before you start, you must complete a program search task.

1 On the Search Results tab, select a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Bookmark tables to show all the bookmark tables used.

A new search result opens with this information:

Table Name
The name of the table used by your selected program.

Description
The description of the panel used by your selected program.

Component
The component of the panel used by your selected program.

3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

4 To view table relations, click a Table Name.

Viewing bookmark parameter of a program

Before you start, you must complete a program search task.

1 On the Search Results tab, select a Program name.

A new search result opens with the header Program Relation Type: Total match.

2 On the bar at the top, click Bookmark parameters to show all the bookmark tables used.

A new search result opens with this information:

Param
The parameter identifier corresponding to a field in the program or view def.

Type
Parameter type: ALPHA, NUMERIC, or DATE

Name
The name of the parameter

Description
The purpose of the parameter.
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3 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

• To view table relations, click a Table Name.

Viewing function parameter

Before you start, you must complete a program search task.

1 On the Search Results tab, select a Program name to use.

A new search result opens with the header Program Relation Type: Total match.

2 Click the link to Function parameters header.

A new search result opens with this information:

Param List Name
The name of the function parameter used your selected program.

When you click a Param List name link, a new search result window opens. It displays the available
parameter names for this Param List name.

Param List Type
The type of this parameter.

Param List Details
The details for this parameter.

3 Optionally, you can click the Export to Excel icon to save the table list to an .xsl file.

Viewing source code

You can view the source code of a selected program in search results, using the view source code
feature. You will find the view source code in one of the columns in the search results. View source
code columns show in search results from Programs used, Used by and Programs using tabs.

Note: You will need a text and source code editor, such as Notepad, to view and open the specified
source code file.

To view or download the source code of the specified program:

1 In Search by System Configuration, search for the target program.

2 On the Search Results tab, click the target program's source code icon in the source code column.

3 Click Download or View.
You can download the file by selecting download. MDP will download the source code java file to
your default browser downloads folder. You can view the source code by selecting view. Your
browser will display the source code.
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Viewing Table and Column Relation Information
Use these procedures to view table and column relation information. Results from these procedures
show entities tied to the selected table. These entities are table column, table index, join table, join
index, programs and utils. Use these functions to view unique keys and foreign keys of the selected
table.

Viewing columns used by a table

Before you start, you must complete a table search task. See Searching for tables on page 70.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Table Column to show all the columns used by your selected table.

A new search result opens with this information:

Column Name
Name of the column used by your selected table.

Description
Description of the column used by your selected table.

Data type
Data type of the column used by your selected table.

Length
Length of the column used by your selected table.

Decimals
Decimals of the column used by your selected table.

Edit Code
Edit Code of the column used by your selected table.

Index
List of index names for your selected table column.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

Viewing indexes of a table

Before you start, you must complete a table search task.

1 On the Search Results tab, click a Table name.
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A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Table Index to show all the indexes of your selected table.

A new search result opens with this information:

Index Name
Name of the index used by your selected table.

Unique
A "Yes" in this column indicates a unique index. There can only be one unique key for each table.

Key Info
Option to view index keys.

Condition Info
The condition information of an index.

Join Table
The join table of an index.

Join Condition
The join condition of an index.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view index key relations, click View Index Keys.

Viewing index keys

Before you start, you must complete a search task and display the search result for index relation
information.

1 On the Search Results tab, select an Index name.

2 On Key Info column, click View Index Keys to display all the keys of your selected index.

A new search result tab opens with this information:

Keys (Column name)
The name of the keys used by your selected index.

Description
The description of the keys used by your selected index.

Sort order
The ascending or descending sort order of the keys used by your selected index.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.
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• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing Index Conditions

Before you start, you must complete a table search task and display the search result for index relation
information.

1 On the Search Results tab, select an Index name.

2 On the Key Info column, click View Index Conditions to display all the keys of your selected index.

A new search result opens with this information.

Condition: Condition of your selected index.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing tables with the same unique keys

Use this procedure to view all the tables containing unique keys similar to your selected table.

Note: 

The CONO and DIVI column keys are used by most of the BE tables. These keys are not included in
the unique key comparison.

Before you start, you must complete a table search task.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Same unique keys to display all tables containing unique keys similar
to your selected table.

A new search result opens with this information:

Table Name
The table name with unique keys similar to your selected table.

Description
The description of the table with unique keys similar to your selected table.

Key Info
The option to view the same unique keys with this table name.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.
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4 To view more table relations, see Viewing Table and Column Relation Information on page 83.

5 To view same unique keys, see Viewing same unique keys on page 86.

Viewing same unique keys

Before you start, you must complete a table search task and display the index relation information on
the Search Result tab.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Same Unique Keys to display all the tables containing your selected
index.

3 On Key Info column, click View Same Unique Keys to view the same unique key.

A new search result named after your selected table to Same Unique Keys , opens with this
information:

Same Unique Keys (Column name)
The name of the unique keys used by your selected table.

Description
The description of the keys used by your selected table.

Sort order
The sort order of the keys used by the table you selected. Ascending or Descending.

4 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

5 You can also view table relations.

See Viewing Table and Column Relation Information on page 83.

Viewing tables with Foreign Key relation

Note: The CONO and DIVI column keys are used by most of the BE tables. These keys are not included
in the unique key comparison.

Before you start, you must complete a table search task.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, select Foreign Keys to display a list of selection with foreign keys used.

A new search result opens with this information:

Table Name
The name of the table used by your selected program.
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Description
The description of the panel used by your selected program.

Importance Rank
The total number of programs with semantic importance relation between two tables.

To view programs of importance rank relation, click the importance rank number.

Key Info
An option to view foreign keys.

To view foreign keys relation, click View Foreign Keys.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing programs of importance rank

Use this procedure to view the importance rank of programs used by two tables in a specific pattern.
Before you start, you must complete a table search task.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, select Foreign keys to display a list of selection with Foreign keys used.

3 On Importance rank column, click the number corresponding to your selected table to view the
programs with importance rank relation.

A new search result opens with this information:

Program Name
Displays the program name that is used by both tables.

Description
The description of the program.

4 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing Foreign Key

Before you start, you must complete a table search task.

1 On the Search Results tab, select a Table name.

A new search result opens with the header Table Relation Type: Total match.
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2 On the bar at the top, select Foreign keys to display a list of selection with Foreign keys used.

3 On the Key Info column, click View Foreign Keys corresponding to your selected table to view.

A new search result opens with this information:

Foreign Key
Displays the foreign key column name.

Description

The description of the panel used by your selected program.

Sort order
Shows the view order of foreign keys.

4 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing programs using a table

Before you start, you must complete a table search task.

1 On the Search Results tab, click a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Program using to display all programs using your selected table.

A new search result opens with this information:

Program Name
The name of the program using your selected table.

Description
The description of the program using your selected table.

Component
The component of program using your selected table.

Usage
The usage type of the program using your selected table: Read, Update, and/or Delete.

Source Code

Shows the source code of a selected program.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view program relations, click a Program name.
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Viewing function programs

Use this procedure to view programs that has maintain, archive, and delete functions on a selected
table. Before you start, you must complete a table search task.

1 On the Search Results tab, click a Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the bar at the top, click Function programs to display the function programs for your selected
table.

A new search result opens with this information:

Maintained by pgm
The name on the function programs that is used to maintain data in a specific table.

Archiving function
The name on the function programs that is used to archive data in a specific table.

Mass Delete function
The name on the function programs that is used to delete all data in a specific table.

Viewing columns of a parent table

Use this procedure to view all the columns that belong to the same parent table of a selected table
column. Before you start, you must complete a table search task.

1 On the Search Results tab, click a Parent Table name.

A new search result opens with the header Table Relation Type: Total match.

2 On the Parent table column, click an item across the column name of your selection.

A new search result opens with this information:

Column Name
The name of the column used by your selected table.

Description
The description of the column used by your selected table.

Data type
The data type of the column used by your selected table.

Length
The length column used by your selected table.

Decimals
The decimals of the column used by your selected table.

Edit Code
The edit code of the column used by your selected table.

Indexes
The edit code of the column used by your selected table.

Infor M3 Core Infrastructure & Technology User Guide | 89

 

M3 Metadata Publisher user tasks



3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing Parameter List Relation Information
Use these procedures to view parameter list relation information. The relation information shows the
fields used by the selected parameter and programs being used by the selected parameter.

Viewing fields used in a Parameter list

You must complete a search task before viewing fields in a parameter list.

1 On the Search Results tab, select a Parameter list name.

The search result header displays the Table Relation Type: Total match.

Field Name
The name of the field table used by your selected program.

Type
The data type.

Length
The string length.

Decimals
The decimals to display.

2 Use these options to manage the results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, click the Filter icon in the last column and type a dynamic free text filter for
each column.

Viewing programs used by Parameter list

Before you start, you must complete a search task.

1 On the Search Results tab, select a Parameter list name.

The search result header displays the Parameter list Relation Type: Total match. Additionally, the
parameter fields used are also displayed.

2 On the bar at the top, select Programs used.

A new search result opens with this information:
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Program Name
The name of the program.

Description
The brief description of the program.

Source Code

Shows the source code of a selected program.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view program relations, click a Program name.

Viewing programs using Parameter list

Before you start, you must complete a search task.

1 On the Search Results tab, select a Program name.

A new search result opens with the header Parameter list Relation Type: Total match. Additionally,
the parameter fields used are also displayed.

2 On the bar at the top, select Used by.

A new search result opens with this information:

Program Name
Name of the program

Description
Brief description of the program

Component
Components of the program

Source Code

Shows the source code of a selected program.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view program relations, click a Program name.
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Viewing Data Structure Relations Information
Use these procedures to view data structure relations information. The relation information shows the
fields used by the selected data structure and the programs using the selected data structure.

Viewing Data Structure fields used

Before you start, you must complete a search task.

1 On the Search Results tab, select a data structure name.

The search result header displays the Data Structure Relation Type: Total match.

Field Name
The name of the field table used by your selected program

Type
The data type.

Length
The string length.

From
The source.

To
The destination.

Decimals

The decimals to display.

2 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing programs using Data Structure

You must complete a search task before viewing programs using data structure.

.

1 On the Search Results tab, select a data structure name.

The search result header displays the Data Structure Relation Type: Total match. In addition, the
field name, type, length, from, to, and decimal information are displayed.

2 On the bar at the top, select Used by. This information is displayed.

Program Name
The name of program used by the selected item.
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Description
The brief description of the program.

Component
The program component.

Source Code

Shows the source code of a selected program.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view programs relations, click a Program name.

Viewing Output Files Record Format
Use these procedures to view output files record format. Relation information shows the record format
of the selected output file and what programs are using the selected data structure, pages and programs
using the selected output file.

Viewing output files record format

You must complete a search task before viewing output files in record format.

1 On the Search Results tab, select an output file name.

The search result header displays the Output file Relation Type: Total match.

Record Format Name
The name of the record format.

Stream
The record format stream.

Type
The record format type.

Record Format field info
Drill down to show the record format field information.

You can also view the record format fields.

2 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.
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Viewing Record Format Fields

You must complete a search task before viewing record format fields.

1 On the Search Results tab, under Record Format field info column, click View Record Format
Fields to view the corresponding record.

A new search result opens with this field information:

Field name
The field name of your selected record format.

Data Type
The data type of your selected record format.

Length
The field length.

Decimals
The number of decimals in the field.

2 Before you start, you must complete a search task.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing output file pages

You must complete a search task before viewing output file pages.

1 On the Search Results tab, click Pages to view the output file page details of your selected record.

The search result header displays the Output file pages Relation Type: Total match.

Page Name
The page name of your selected program.

Page field info
The page field information corresponding to a page name. Click this option to view page fields.

2 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing Page Fields

You must complete a search task before viewing page fields.

1 On the Search Results tab, click Pages to view the output file page details of your selected record.
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A new search result opens with the header Program Relation Type: Total match.

2 On the Page field info column, click View Page Fields corresponding to your selected page name
to view.

A new search result opens with this field information:

Field Name
The name of the field for the selected page.

Stream
The page field stream.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

Viewing programs using output file

Use this procedure to view Programs Using Output File of a selected program. Before you start, you
must complete a program search task.

1 On the Search Results tab, click Used by to view the programs using your selected output File.

A new search result opens with this information:

Program Name
The name of the programs in this selection.

Description
The brief description of the program.

Component
The program components.

Source Code

Shows the source code of a selected program.

2 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

3 To view programs relations, click a Program name.
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Viewing Util Relations Information
Use these procedures to view Util relations information. Relation information shows the tables used,
programs used, programs using relations and Utils used by the selected Util.

Viewing tables used by a Util

You must complete a search task before viewing tables used by a Util.

1 On the Search Results tab, click a Util name.

2 On the new search result, click Tbl used to display all tables used by your selected Util with this
information:

Table name
The name of the table used by the Util you selected.

Description
The description of the table used by the Util you selected.

Usage
The function of the table used by the Util you selected: Read, Update, and/or Delete.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view table relations, click a table name.

Viewing programs used by a Util

Before you start, you must complete a program search task.

1 On the Search Results tab, click a Util name.

2 On the new search result, click Pgm used to display all programs used by your selected Util with
this information:

Program name

The name of the program used by the Util you selected.

Description
The description of the program used by the Util you selected.

Component
The component of the program using the Util you selected.

Source Code

Shows the source code of a selected program.
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3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view Util program relations, click a program name.

Viewing programs using Util

Before you start, you must complete a program search task.

1 On the Search Results tab, click a Util name.

2 On the new search result, click Used by to display all programs using your selected Util with this
information.

Program name
The name of the program used by the Util you selected.

Description
The description of the program used by the Util you selected.

Component
The component of the program using the Util you selected.

Source Code

Shows the source code of a selected program.

3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, type a dynamic free text filter for each column and select a Filter action.

4 To view Util program relations, click a program name.

Viewing utils used by Util

Before you start, you must complete a search task.

1 On the Search Results tab, click a Util name.

2 On the new search result, click Util used to display all Utils using your selected Util.

A new search result opens with this information:

Util name
Name of the Util used by the Util you selected.

Component
Component of the Util using the Util you selected.
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3 Use these options to sort and filter your results.

• To sort the results alphabetically or numerically, click the Sort icon located in one or more
column headings.

• To filter the results, specify a dynamic free text filter for each column and select a Filter action.

4 To view Util relations, click a Util name.

Viewing Extension Points Relation Information
Use these procedures to view extension point relation information. The relation information shows the
extension points by the selected interface and programs being used by the selected parameter.

Viewing extension points in an interface

Before you start, you must complete extension points search task. See Searching for Extension Points
on page 73.

1 On the Search Results tab, select an Interface name.

2 A new search result opens with the header Extension Points: Total match.

Extension Point Name
The name of the extension point in the selected interface.

Description
The description of the extension point in the selected interface.

Advice
The advice of the extension point in the selected interface.

3 Use these options to sort and filter your results:

• Click the Sort icon located in one or more column headings to sort the results alphabetically
or numerically.

• Filter results by clicking the Filter icon in the last column and type a dynamic free text filter for
each column.

Viewing programs using Extension Points

You must complete a search task before starting.

1 On the Search Results tab, select an Interface name.
A new search result opens with the header Extension Point Relation Type: Total match. Additionally,
the extension points are also displayed.

2 On the bar at the top, select Used by. A new search result opens with this information:

Program Name
Name of the program.
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Description
Brief description of the program.

Component
Shows the components of the program.

Source Code
Shows the source code of a selected program.

3 Use these options to sort and filter your results:

• Click the Sort icon located in one or more column headings to sort the results alphabetically
or numerically.

• Filter results by clicking the Filter icon in the last column and type a dynamic free text filter for
each column.

M3 function tool
MDP features a UI-based test tool for M3 function programs. This tool serves as an educational tool
for developers learning how to call the REST services function (Fnc). This tool is used to:

• Provide developers a tool to test M3 Fnc-programs
• Reproduce and test defects reported by customers
• Learn how Fnc-REST services work
• Provide client developers a tool for exploring Fnc-REST services, such as metadata and behavior,

while developing client applications.

Execute mode
You can do Fnc-REST calls using execute and interact modes. Execute is appropriate for machine
integrations and corresponds to <resource path="service/execute"> in the application.WADL.

Execute mode is basically a one shot call with one request and one response. You can separately ask
for metadata (metadataMode="MetadataExcluded") using this function.

To display any MDP program information, errors and notifications using execute mode, follow these
steps:

1 From the MDP opening page, click M3 Function > Fnc Development Client.
2 From the Fnc Development Client sidebar, specify these fields:

Program
Shows the available function programs.

Param List
Shows the available parameters.
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Maintain Mode
Shows the available maintain mode options.

3 Click Execute to show the service/execute tab with the results showing any notifications and
errors.

Interact mode
The second type of Fnc-REST call is the interact mode. Interact is a stepwise call involving steps,
preparing, initiation, and update. You can update multiple times until you no longer receive any errors.

To display any MDP program information, errors and notifications using interact mode in the results
screen, follow these steps:

1 From the MDP opening page, click M3 Function > Fnc Development Client.
2 From the Fnc Development Client sidebar, specify these fields:

Program
Shows the available function programs.

Param List
Shows the available parameters.

Maintain Mode
Shows the available maintain mode options.

3 Click Interact to show the service/execute tab.

4 Specify the required information.

5 Click Send to show the results.

The information retrieved based on the user inputs is now displayed.

Tracing communications
Tracer displays all the rest calls used by MDP to connect to M3 Foundation. You can use tracing
communications to copy requests and responses to the windows clip board.

You can view the history of the textual requests and responses using Tracer. This gives you a detailed
understanding of how the Fnc-REST model works.

To trace a REST call, follow these steps:

1 From the MDP opening page, click M3 Function > Fnc Development Client.
2 Click the Tracer tab.

3 Specify the REST call you like to trace from the drop-down menu.

Tracer will now display the content in the Request and Response windows.
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M3 API Repository
M3 API repository has two functions, Search API and Test API. The repository function connects to
the M3 Foundation client to display the information.

M3 API Repository Functionalities
The M3 API repository function displays the list of transactions and the inbound or outbound fields
related to the MI Program.

Search API

Search API displays the list of generated MI Programs.

DescriptionTable heading

The program used by this MI Transaction.Program

The brief description of the program.Program description

Viewing MI Transaction

You can view the MI Transaction with these steps.

1 Click M3 API Repository tab.

2 Click Search API.

3 Select on MI Program Name link:

A new tab is displayed with this information.

Transaction Name
The name of the transaction.

Description
A brief description of the transaction.

Viewing MI Transaction Inbound or Outbound Fields
1 Complete the task Viewing MI Transaction on page 101.

2 On the Selected MI Program tab, select a Transaction name and click the link to view the fields.

View Inbound Fields or View Outbound Fields

A new search result opens with the selected transaction name and <In/Out>bound fields (Total
match).
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Field
The name of this field.

Description
A brief description of this field.

From
The program used by this MI Transaction.

To
The program used by this MI Transaction.

Length
The inbound field length in number of characters.

Mandatory
Indicates whether the MI Transaction on this row is mandatory or not.

Type
Indicates the field type.

3 Optionally, click the Export icon to save this table search result on an .xls file.

4 Use these options to manage your results.

• To sort the results alphabetically or numerically, click the Sort icon on the column headings.
• To filter the results, click the Filter icon in the last column and type a dynamic free text filter for

each column.

Test API
Test API runs the transaction of the selected MI Program. Use this function to test the MI Program's
functionality. MDP cannot verify the MI Content since MDP only calls the MI Foundation Services.

Running of MI Transaction
1 Click M3 API Repository tab.

2 Click Test API.
3 Select MI Program from the Program list.

4 Click Select button.

5 Click MI Transaction from Transaction List.

6 Input the required MI fields (those in bold text).

7 Click Run.
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Show as REST

Show as REST is a URL that shows the response coming from the M3BE FND depending on the input
made from Running of MI Transaction.

1 Complete the task Running of MI Transaction.

2 Click Show as REST link.

3 Click Copy to Clipboard.

4 Open a new tab and paste the copied link.

MDP REST APIs
MDP REST APIs are REST services that are used to get metadata information. These are called
through ION API. All APIs' response type are XML and in JSON.

Here is a sample response code.

200Status Code

Successful OperationMessage

These are the REST services.

Metadata
Use these REST APIs to get metadata information.

1 les/getColumnsUsedByTable/{tableName}/{component}
a Request Type: Get
b Description: Get columns used by a specific table which will return the same data in the MDP

Client.
c Parameters:

1 name : tableName

ValueDetails

pathin:

Table Namedescription:

truerequired:

stringtype:

2 name : component

ValueDetails

pathin:
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ValueDetails

Componentdescription:

truerequired:

stringtype:

MVXdefault:

3 name : langId

ValueDetails

queryin:

Language IDdescription:

falserequired:

stringtype:

GBdefault:

GBx-example:

2 les/getIndexKeys/{indexName}/{component}
a Request Type: Get
b Description: Get Index Keys
c Parameters:

• name : indexName

ValueDetails

pathin:

Index Namedescription:

truerequired:

stringtype:

• name : component

ValueDetails

pathin:

Componentdescription:

truerequired:

stringtype:

MVXdefault:

• name : langId

Infor M3 Core Infrastructure & Technology User Guide | 104

 

M3 Metadata Publisher user tasks



ValueDetails

queryin:

Language IDdescription:

falserequired:

stringtype:

GBdefault:

GBx-example:

3 les/getPrograms
a Request Type: Get
b Description: Get programs
c No Parameters
d Disclaimer - This will return a large response and is not suitable to run in a browser

4 les/getReferenceFields
a Request Type: Get
b Description: Get Reference Fields
c No Parameters
d Disclaimer - This will return a large response and is not suitable to run in a browser

5 les/getTables
a Request Type: Get
b Description: Get all tables
c No Parameters

Table metadata
Use these REST APIs to get standard table metadata information.

1 analytics/getMetadataVersion
a Request Type: Get
b Description: Get the metadata version
c No Parameters

2 analytics/getTableColumns
a Request Type: Get
b Description: Get base table columns (MVX) with key count, mandatory flag, and the usual data

in this entity.
c No Parameters
d Disclaimer - This will return a large response and is not suitable to run in a browser

3 analytics/getTables
a Request Type: Get
b Description: Get Standard (MVX) Tables
c No Parameters
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Relations
Use these REST APIs to get entity relation information.

1 relations/tables/getTableWithForeignKeys/{beSystem}/{tableName}/{component}/{langId}
a Request Type: Get
b Description:
c Parameters

• name : beSystem

ValueDetails

pathin:

BE Systemdescription:

truerequired:

stringtype:

• name : tableName

ValueDetails

pathin:

Table Namedescription:

truerequired:

stringtype:

• name : component

ValueDetails

pathin:

Componentdescription:

truerequired:

stringtype:

MVXdefault:

• name : langId

ValueDetails

pathin:

Language Iddescription:

truerequired:

stringtype:
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ValueDetails

GBdefault:

GBexample:

2 relations/tables/viewForeignKeys/{beSystem}/{tableName}/{component}/{parentTableName}/{langId}
a Request Type: Get
b Description:
c Parameters

• name : beSystem

ValueDetails

pathin:

BE Systemdescription:

truerequired:

stringtype:

• name : tableName

ValueDetails

pathin:

Table Namedescription:

truerequired:

stringtype:

• name : component

ValueDetails

pathin:

Componentdescription:

truerequired:

stringtype:

MVXdefault:

• name : parentTableName

ValueDetails

pathin:

Parent Table Namedescription:

truerequired:
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ValueDetails

stringtype:

• name : langId

ValueDetails

pathin:

Language Iddescription:

truerequired:

stringtype:

GBdefault:

GBexample:

Limitations
MDP functions have bandwidth limitations that affect system performance. To maximize performance,
understand these topics to reduce the issues caused by these limitations.

M3 Metadata Publisher Limitations
The current version of M3 Metadata Publisher has certain limitations. For a better response time when
using your supported browser to access MDP client, we recommend that you limit your open search
results to ten.

MDP cannot verify the MI Content since MDP only calls the MI Foundation Services.
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Appendix A: Hot keys

Hot keys are shortcuts that you can perform using keystrokes.

General hot keys in M3 programs
The hot keys listed in this section are applicable regardless of the current panel you are working with.

ActionKeystroke

Closes these objects:

• context menus

• opened windows

• notifications/messages

Esc

Simulates the action of the Next buttonEnter

Moves the cursor between input fields and but-
tons

Tab

Runs the Start and Search field

Note: In the new H5 UI, this hot key runs the
Start field.

Ctrl + R, Ctrl + S

Opens the application menu and positions the
Start textbox

Alt + S

Switches to the next application in the taskbarCtrl + Shift + Page Down

Ctrl + Shift + Fn + Down (in Mac OS)

Switches to the previous application in the
taskbar

Ctrl + Shift + Page Up

Ctrl + Shift + Fn + Up (in Mac OS)

Copies textCtrl + C

command + C (in Mac OS)

Pastes textCtrl + V

command + V (in Mac OS)

Infor M3 Core Infrastructure & Technology User Guide | 109

 

Hot keys



Cuts (deletes) textCtrl + X

command + X (in Mac OS)

Selects an option from the Options menu or from
the Related menu

Ctrl + [number]

Opens the Actions menuAlt + A

Ctrl + Option + A (in Mac OS)

Opens the Related menuAlt + R

Ctrl + Option + R (in Mac OS)

Opens the Options menuAlt + O

Ctrl + Option + O (in Mac OS)

Opens the Tools menuAlt + T

Ctrl + Option + T (in Mac OS)

Opens the context menuCtrl + Q

command + Q (in Mac OS)

Switches to the last active M3 program(Ctrl+ ~)

Switches to HomepagesCtrl + Shift + E

Displays the Help toolF1*

Closes the applicationF3*

Displays the browse dialog boxF4*

Refreshes the formF5*

Enables text entryF6*

Displays previous recordF7*

Displays next recordF8*

Opens Field Audit TrailF9*

Displays next view for sorting orderF10*

Returns to the previous panel fieldF12*

Displays the settings panelF13*

Add today’s date to the keyboard focused date
picker

t

Opens combo boxes which allows selection from
the list.

Up/Down Arrow

Simulates Next buttonSwipe Left

Simulates Previous buttonSwipe Right
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(*) The keys on the top row of a Mac keyboard are configured to behave as standard function keys.
Select System Preferences > Keyboard. On the Keyboard tab, select "Use all F1, F2, etc. keys as
standard function keys."

Additional configuration must be done for F10 and F12. Select Keyboard Shortcuts tab and clear
Application windows and Show Dashboard check boxes.

Hot keys for list panels
The hot keys listed in this section are applicable only when you are in a list panel.

To apply a specific option to the selected rows, you must keep the Ctrl key pressed until the option is
selected.

ActionKeystroke

Selects the first recordHome

fn + Left Arrow (in Mac OS)

Moves toward the end of a list in larger incre-
ments

End

fn + Right Arrow (in Mac OS)

Removes a selected record from a listDelete

fn + Delete (in Mac OS)

Includes the next row in the selectionShift + Down Arrow

Includes the previous row in the selectionShift + Up Arrow

Selects the cells on the page below the cell in
focus

Shift + Page Down

fn + Shift + Down Arrow (in Mac OS)

Selects the cells on the page above the cell in
focus

Shift + Page Up

fn + Shift + Up Arrow (in Mac OS)

Opens the Edit Panel Sequence dialog box in
Direct Change mode

Ctrl + D

Moves the focus to the listCtrl + L

Keeps the selection and moves the cursor one
row down

Ctrl + Down Arrow

control + command + Down Arrow (in Mac OS)

Keeps the selection and moves the cursor one
row up

Ctrl + Up Arrow

control + command + Up Arrow (in Mac OS)

Includes the row in focus in the selection (to get
a split selection)

Ctrl + Space
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ActionKeystroke

Selects an option from the Options menu or from
the Related menu

Ctrl + [number]

Moves to the next/previous valid optionCtrl + [number] + Up/Down Arrow

Cancels the last number specifiedCtrl + [number] + Backspace

-or-

Ctrl + [number] + Delete

Cancels the last number specifiedCtrl + Backspace

Shows or hides the extra row in an expandable
list

Ctrl + F11

Scrolls one page down in a listPage Down

fn + Down Arrow (in Mac OS)

Scrolls one page up in a listPage Up

fn + Up Arrow (in Mac OS)

Moves the cursor upwardsUp Arrow

Moves the cursor downwardsDown Arrow

Scrolls to the leftLeft Arrow

Scrolls to the rightRight Arrow

Moves focus to the next editable cell in an ed-
itable list

Tab

Moves focus to the previous cell in an editable
list

Shift + Tab
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