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About this guide

Objectives
This guide contains procedures for configuring Infor EAM system modules.

Intended audience
This guide is intended for system administrators, implementation consultants, product architects, and
support specialists.

Organization of this guide
This table describes the chapters of this guide:

DescriptionChapter

Instructions on how to set up Infor EAM to manage
physical assets and maintenance functions more
efficiently

System configuration

Instructions on how to define users and user
groups to ensure limited, password-controlled ac-

System security

cess to the system, and to increase screen-level
security

Instructions on how to configure the Infor EAM in-
terface by personalizing the Start Center and
modifying page layouts

Interface configuration

Instructions on how to track the movement of
goods for asset and maintenance management

Data collection

Instructions on how to integrate Infor EAM with
GIS

GIS administration

Instructions on how to configure the fleet manage-
ment module

Fleet management configuration

Instructions on how to archive Infor EAM recordsArchiving management

Instructions on how to set up basic module dataBasic module data creation
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DescriptionChapter

Instructions on how to understand installation pa-
rameters and methods for modifying

Installation parameters

Related documents
This guide references other documents. See these documents for more information about how to work
within Infor EAM.

• Infor EAM User Guide
• Infor EAM Installation Guide
• Infor EAM Reports User Guide
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Contacting Infor

If you have questions about Infor products, go to the Infor Xtreme Support portal.

If we update this document after the product release, we will post the new version on this website. We
recommend that you check this website periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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1System configuration

This chapter outlines procedures for setting up Infor EAM to manage physical assets and maintenance
functions more efficiently.

Note: This chapter describes Infor EAM functions that only a system administrator has rights to perform.

Defining installation parameters
Define new installation parameters to tailor the system to your working environment. Set up system-wide
defaults to determine settings such as whether department security is on or off or the number of days
before a password expires for users. Infor EAM installation sets up default values, also known as
"installation codes" or "installation parameters." You can also edit existing installation parameters.

Note: Only qualified Infor EAM system administrators should create installation parameters, with specific
guidance and approval from your Infor consultant. Contact your Infor consultant to create installation
parameters.

To define installation parameters:

1 Select Administration > Security > Install Parameters.
2 Click New Record.
3 Specify this information:

Install Parameter
Enter a unique code identifying the installation parameter, and then enter a description of the
installation parameter in the adjacent field.

Note: You cannot define fixed install parameters or assign new install parameters to a module.

Value
Enter the default value for the parameter.

4 Click Save Record.
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Setting up installation parameters
Update installation parameters as required to perform normal operations.

To set up installation parameters:

1 Select Administration > Security > Install Parameter Setup.
2 Installation parameter values are displayed in update mode. Update the installation parameter value,

and then click Save Record.

Understanding entities
Entities are the fundamental core of the system. Configuration of entities and their respective codes
determines what functions of the system are available and to which users. An entity is a table of related
data pertaining to specific system functions.

There are three kinds of entities in the system: Status Entities, Type Entities, and Code Entities.
The system identifies entities as Extended Codes, but they are identified to users as User Codes.
When you install Infor EAM, all Extended Codes and User Codes are identical. Tailor the system to
an organization by adding new user codes on the System Codes form.

Classes divide entities into groups that share certain characteristics. For example, you can subdivide
an entity into classes to define a separate list of custom attributes for each class.

Defining system codes
Define system codes to tailor the system to the entity. You can also edit existing user codes.

Note:  Infor strongly recommends creating new classes, rather than system codes, to subdivide Type
entities when possible.

To define system codes:

1 Select Administration > Setup > System Codes.
2 Select the type of setup for which to define system codes.
3 Specify the For Entity for which to define system codes.
4 Click Add User Code.
5 Specify this information:

User Code
Specify a new user code to represent one of the system codes.

System Code
Specify the system code representing the user code.
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Description
Specify a description of the user code.

Icon
Select the color of the icon to indicate the importance of the user code.

Note: This functionality is currently only available for the PWRS (Risk) and JBPR (WO Priority)
entities on the screen.

Icon Path
Specify the URL path to the image you would like to use for the icon. Accepted icon paths begin
with http://, //, or \\, or https://.

Note: The recommended size of the image is 16 x 16 pixels and file type extension should be .gif,
.jpg, or .png.

System Default
Select one of the user codes as the system code if there are multiple user codes for one system
code. This code is used as the default value for the Type or Status entity.

Out of Service
Select to designate system codes as out of service.

6 Click Submit.

Note: To update the translations by language, click Translations.
See the Infor EAM User Guide.

Creating and modifying screens
Create new screens or modify existing screens by associating icons with screens and setting
background-printing parameters for reports.

Note: To view a list of current screens in the system, run the Function List Report.

To create or modify screens:

1 Select Administration > Screen Configuration > Screens.
2 Click New Record.
3 Specify this information:

Screen
Specify a unique six-character mnemonic code for the new screen, and then enter a brief description
of the screen in the adjacent field.

Class
Specify the class of the screen.
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Form Type
Select the form type for this screen.

Parent
Specify the screen on which this new screen is based.

Last Value
Specify the entity used by the system to "remember" the primary key field in this screen.

Icon
Specify the name of an existing icon file to associate an icon with the screen.

Report
Specify a report that prints (in the background) using the selected data on a screen. Also, specify
background report parameters to use with this functionality.

Employee Filter
Specify the employee type to apply to the screen.

URL Path
Specify the URL location of the screen.

Note: Specify up to three parameters (:user, :password, or :org) in the URL Path to pass values to
the new screen. These values must be entered in lowercase.
Example: http://yourapp.yourserver.com?USERID=:user&PWD=:password

Open URL in New Window
Select to display the URL in a new browser window.

Invoke Dataspy
Select to allow users to utilize dataspy filters on this screen.

Startup Action
Select the stage of the query process in which the screen opens:

• No Action
Select to open the form without running a Dataspy or displaying records.

• Enter Insert Mode
Select to open the form on the Record View tab and in Insert Mode.

• Run Dataspy
Select to open the form with the default Dataspy and to highlight the first record in the list.

• Remember Dataspy
Select to open the form with the last remembered Dataspy (within the current session) with
quick filter and quick sort for the form and to highlight the first record in the list.
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• Remember Last Value
Select to open the form with the last remembered value for the screen.

Startup View
Select the view in which the screen will display when initially accessed, e.g., select Split View to
indicate the screen will open in split view format, select List View to indicate the screen will open
in list view format, or select Record View to indicate the screen will open in record view format.

Split View Display
Select how the fields are displayed on the screen in the summary grid:

• Standard
Fields are displayed in the standard format, including the code and description fields, and icons.

• Grid Fields
Fields are displayed based on the dataspy settings. The code and description fields are not
displayed

• Mixed
Fields are displayed in a combination of standard and grid field settings, including the code and
description fields, and three fields from the dataspy settings.

Auto Refresh Timer (seconds)
Specify the time frequency in seconds in which the screen will automatically refresh, e.g., enter 15
to indicate the screen will refresh every 15 seconds.

Note: This feature only works in full list view mode for List View and Record View screens and
user-defined grids.

4 Click Save Record.

Note: After defining a new screen, you must authorize users to use the new screen.
See "Granting screen-level permissions to user groups" on page 87.

Changing text on a specific screen
Change text on a specific screen if the text usage is in the wrong context for your local language.

Note: The changes you make might be overwritten during system upgrades or by global substitutions.

To change text on a specific screen:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to change text, and then click the Text tab.
3 Select the record for which to change text.
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4 Specify this information:

Text
Change the text as necessary.

5 Click Submit.

Defining URL parameters for custom screens
Define how parameter values are passed to custom screens and tabs.

URL parameters designate locations and directories for schemas, servlets, documents, etc. that must
be set for many Infor EAM (Oracle Forms) and Infor EAM add-ons and features to work properly.

To define URL parameters for custom screens:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to define URL parameters, and then click the Record View tab.
3 Click Add URL Parameter.
4 Specify this information:

Parameter Name
Specify a unique code identifying the parameter. The system automatically populates Sequence
and selects System.

Parameter Value
Specify a URL for the parameter.

Active
Select if the URL parameter is active for the screen or tab.

5 Click Submit.
6 Click Close.

Defining custom tabs for screens
Define custom tabs for existing screens. Specify an external URL to transfer values from the current
screen. The URL information displays inside the tab in the Infor EAM system.

To define custom tabs for a screen:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to define custom tabs, and then click the Custom Tabs tab.
3 Click Insert Custom Tab.
4 Specify a description for the new custom tab. A Tab Code is automatically generated.
5 Specify this information:
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Type
Specify the custom tab type. URL is the recommended setting because it is the only supported
value.

Trusted Site
Select to allow access to the parent frame.

URL
Specify the URL for the custom tab.

6 Click Submit.

Note: The key values are automatically passed from the header of the current form to the URL. This
feature displays only information related to the selected record.
To define URL parameters for custom screens or tabs, click Define URL Parameters.
See "Defining URL parameters for custom screens" on page 20.

Remembering fields for forms
Determine which fields will have their values remembered when a user navigates away from the form.
Selected fields to remember may consist of Work Order, Equipment, etc. When the user selects a
Work Order and navigates away from the Work Orders form to another form such as Assets form,
the system remembers the Equipment value and displays it on the Assets form.

Note: The Fields to Remember feature is only supported for forms that have a Last Value Entity
populated on the Record View page of the Screens form.

To remember fields for forms:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to remember fields, and then click the Fields to Remember tab.
3 Click Add Field.
4 Specify this information:

Field
Specify the field of the value for the system to remember.

Entity
Specify the entity of the value for the system to remember.

5 Click Submit.
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Associating Dataspies to users by screens
Add users to associate Dataspies to additional users on selected screens. Once a Dataspy is associated
with a user on a specific screen, the Dataspy is available to the user whenever they open and view the
screen.

To associate a Dataspy to users on a screen:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to associate users to a Dataspy, and then click the Dataspies tab.
3 Select the non-global Dataspy record to which to add user associations on this screen, and then

click Add Users. The Add Users popup is opened.
4 Select one or more users to receive a copy of this Dataspy for the selected screen.
5 Optionally, select the Set as Default check box to set the Dataspy as the default for the selected

user(s) on this screen.

Note: If the selected Dataspy is marked as a global Dataspy, select one or more users to receive
the Dataspy as their default Dataspy on this screen.

6 Click Submit. The Add Users popup is closed.

Viewing Dataspies associated to screens
View all Dataspies and their associated users on selected screens.

Note: You cannot create a new Dataspy record, nor delete an existing Dataspy record on this screen.
You can only associate users to the Dataspies on the screens.

To view a Dataspy associated to a screen:

1 Select Administration > Screen Configuration > Screens.
2 Select the screen for which to view Dataspy records, and then click the Dataspies tab.
3 View the Dataspy details including owners of the Dataspy on the selected screen.
4 Optionally, select the Default check box to make this the default Dataspy for all users on this

particular screen.
5 Click Submit.

To display the selected Dataspy details on the selected screen for other users, click the Add Users
button. The Add Users popup is opened. See "Associating Dataspies to users by screens" on page
22.

Creating user defined screens
Create, modify, delete, and view user defined screens.
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To create user defined screens:

1 Select Administration > Setup > User Defined Screens.
2 Click New Record.
3 Specify a unique six-character mnemonic code for the new user defined screen in the Screen Name

field, and then enter a brief description of the screen in the adjacent field.

Note: For user defined screens, the second letter of the screen name must be a U, the length of
the screen name cannot exceed six characters, and the screen name cannot contain special
characters.

4 Specify this Screen Details information:

Table Name
Specify a unique code identifying the table to which the user defined screen belongs. The table
name cannot contain special characters.

Note: For tables that are generated a *U5* prefix is automatically added to the table name. For
example, if you create a table called "MyTable", the generated table name will be "U5MYTABLE".

Entity
Specify a unique code identifying the entity to which the user defined screen belongs. The entity
name cannot contain special characters.

5 Optionaly, select the Tab check box to indicate this user defined screen is a tab on another screen.
If selected, you must specify the Parent Screen to which the tab belongs.

6 Optionally, select the Out of Service check box to prevent the new user defined screen from being
displayed in user defined screen lookups or in the grids for the Menus and Scanner Menus tabs
on the User Groups form.

7 Click Save Record.

Note: Add fields to the new user defined screen on the Fields tab. Once you add fields, click the
Generate link button to generate the new user defined screen. The screen is compiled, and it is
added to the list of screens you can make available on the menu.

Defining fields for user defined screens
Create, modify, or delete fields for user defined screens.

To define fields for user defined screens:

1 Select Administration > Screen Configuration > User Defined Screens.
2 Select the user defined screen for which to define fields, and then click the Fields tab.
3 Click Add Field.
4 Specify this information:
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Field Name
Specify the name for the field. The field name must be unique and cannot be a database reserved
word or contain special characters.

Description
Specify a description of the field.

Field Label
Specify the boiler text for the field. The default Field Label is equivalent to the Field.

Sequence
Specify a numeric value for the sequence. Fields are displayed in ascending order by their sequence.

Field Type
Specify the field type. The default Field Type is Alphabetic. Specify the default Field Type as one
of the following options:

• Alphabetic
• Numeric
• Date
• Date Time
• Time
• Free Format Text
• Checkbox

Field Length
Specify the maximum character length if the field type is Alphabetic.

Total Digits
Specify the total number of digits allowed including decimal places for the field if the Field Type is
Numeric.

Decimal Places
Specify the number of digits allowed after the decimal for the field if the Field Type is Numeric.

Computed Data
Specify the computed data statement for the field when Field Type is Computed Value.

Source Field
Specify the source field if the value will be retrieved from another database table.

Query Code
Specify the query code to define the list of values available for selection from the LOV. When a
query code is specified for a field, the field behaves as an LOV.

Parent Screen Key Field
Specify the key field of the parent screen of this field if the user defined screen for which you are
defining this field is the tab on a parent screen.
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5 Optionally, select the Is Primary Key check box to indicate that there cannot be another record with
the same value in that field. Field types of Free Format Text, Checkbox, Date, Date Time, and
Time cannot be selected as primary key fields.

Note: If Auto Generate Key is selected on the header record for this user defined screen, Is Primary
Key is protected because the primary key is auto-generated.

6 Optionally, select the Is Nullable check box to allow users to leave the field blank.

Note: Is Nullable is a protected check box that cannot be edited when a field is selected as a primary
key.

7 Optionally, select the Uppercase check box to enforce uppercase characters for the field value
when the field type is Alphabetic.

8 Optionally, select the Computed Value check box to indicate the defined field will use the valued
entered in the Computed Data field to calculate the field value.

9 Optionally, select the Retrieved Value check box to indicate the value for this field will be populated
from a database table or other screen using the Retrieved Value Query. If selected, the Source
Field and Retrieved Value Query are required as well.

Note: Retrieved Value Query must return one record and one column only.

10 Optionally, select the Out of Service check box to prevent the field from being displayed in user
defined screen lookups.

11 Click Submit.

Defining custom fields information
Tailor the system for the working environment by adding custom fields to forms.

Defining custom fields
Define an unlimited number of new fields, and attach a selection of these fields to any class of an entity,
such as an equipment class or a purchase order class, or to an entity, such as all equipment or all
purchase orders.

Specify valid lookup values for a custom field using the Associate Custom Fields form.

See "Associating custom fields with an entity or class" on page 27.

To define custom fields:

1 Select Administration > Custom Fields > Custom Fields.
2 Click Add Custom Field.
3 Specify this information:
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Custom Field
Enter a unique code identifying the field, and then enter a description of the field in the adjacent
field. The description is the text that the user will see for the custom field.

Type
Select one of the following field types:

• Character
Any alphanumeric characters.

• Numeric
Numeric values.

• Date Field
Date values in DD-MON-YYYY format.

• Date/Time
Date and time values in DD-MON-YYYY HH24:MI format.

• Code+Description
Unique code and a description of the code.
See "Defining lookup values for custom fields" on page 26.

• System Entity
Code description of an Infor EAM entity. The system enables the System Entity field.

System Entity
Enter the code description of the entity for which to define custom fields.

Minimum Value
Maximum Value
Specify the range of values users can enter.

4 Click Submit.

Note: To view translations information, select the custom field for which to view translations, and
then click Translations.
See the Infor EAM User Guide.

Defining lookup values for custom fields
Define lookup values for custom fields of the "Code+Description" type.

To define lookup values for custom fields:

1 Select Administration > Associate Custom Fields > Associate Custom Fields.
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2 Specify this information:

Entity
Enter the entity for which to define a lookup value.

Select the custom field Line for which to define lookup values.
Click Define Lookup Values.
Click Add Value.

Value
Enter the value for the lookup.

Description
Enter a description of the value.

Note:  Description field is only enabled if the Lookup Type is Code+Description.

Out of Service
Select if the lookup value is out of service.

3 Click Submit.

Associating custom fields with an entity or class
Fields associated with a class appear only when the class has been specified in the regular class field.
Fields associated with an entity (class is *) always appear on screens based on that entity, whether or
not a class has been specified.

To associate custom fields with an entity or class:

1 Select Administration > Custom Fields > Associate Custom Fields.
2 Enter the entity to which to associate the custom field. The system automatically populates the entity

description. The system automatically populates Class and Class Org.
3 Click Add Custom Field.
4 Specify this information:

Line
Enter the desired order for displaying the custom fields. The system displays fields associated with
the entity (i.e., to class *) first and then displays the fields associated with the particular class of
the data.

Custom Field
Enter the code of the custom field. The system automatically populates the description.

UOM
Enter the unit of measure.

Lookup Type
Select one of the following lookup types for the custom field:
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• None
Enter any value for this field.

• Property
The lookup is valid for the field without restriction to which entity or class it is attached. This
lookup applies system-wide. You must define the list on the same level. If the custom field is
of Type Code+Description, the default Lookup Type is Property. Refer to Defining Custom
Fields.

• Entity
The lookup displays values specific to the field and entity. Therefore, the lookup may have
different values for items such as equipment or parts.

• Class
The lookup displays values specific to the field, entity, and class. Therefore, the lookup may
have different values within items such as entity parts.

Not Updateable
Select when the system retrieves values from the category of data instead of from the data itself.

Print Custom Fields
Select to enable the system to print the custom field on work order cards.

Note:  Print Custom Fields is only enabled for custom fields associated with the OBJ and EVNT
entities.

Use for Validation
Select to allow users to enter only values that are in the lookups for the field. If unselected, users
can also enter values that are not in the lookups.

5 Click Submit.

Defining global text changes
Access the Global Text Changes form to change boiler text (field labels) throughout the system rather
than using screen designer on each separate screen where the boiler text appears. Making global text
changes creates system-wide terminology changes. Any changes made on the Global Text Changes
form are applied to all Infor EAM forms where the specified text appears.

Note: Error messages, function titles, and code descriptions cannot be changed using the Global Text
Changes form.
It is possible to have duplicate texts within the system. Changing one will not affect the other.

To define global text changes:

1 Select Administration > Setup > Global Text Changes.
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2 Specify the search criteria in the Dataspy, and then select the record to update.
3 Specify this information:

Alternate Text
Specify the text for the new boiler text.

4 Click Submit.

Note: To reverse the text change for the selected record, click Undo. The Original Text becomes
the Current Text for the selected record.
To reverse all of the system boiler text changes, click Undo All.
To update all of the system boiler text changes, click Redo All.

Displaying boiler text where used
To display boiler text where used:

1 Select Administration > Setup > Global Text Changes.
2 Enter the search criteria in the Dataspy, and then select the record to update. The system

automatically populates Current Text, Original Text, Language, Code, andLast Updated.
3 Click Where Used.
4 The system displays all screens where the selected record appears.

Defining cost codes
Define cost codes for the organization, and then reference them along with any data involving costs,
such as work orders, purchases, material issues, etc. Charge maintenance costs to the correct area
by specifying cost codes. The cost for repairing a unit air conditioner, for example, might come out of
a particular department’s budget.

Note: Cost codes simplify tracking costs; however, they might hinder data entry because you must
specify cost codes along with the data.

To define cost codes:

1 Select Administration > Setup > Cost Codes.
2 Click New Record.
3 Specify this information:

Organization
Specify the organization to which the cost code belongs if you use multi-organization security.
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Cost Code
Specify a unique code identifying the cost, and then specify a description of the cost code in the
adjacent field.

Class
Specify the class of the cost code.

Non-billable
Select to prevent the cost code from being included when bills are generated.

Out of Service
Select to prevent the cost code from being displayed in lookups.
Transactions associated with non-billable cost codes will not be included in fleet bills.

Account Segment Value
Specify the general ledger account code segment that represents the organization in your accounting
structure. See your chart of accounts for more information.

4 Click Save Record.

Selecting languages
Configure the system to operate in more than one language. This feature is especially useful for
multinational organizations and for companies in bilingual countries, such as Belgium (French and
Flemish) and Canada (English and French).

When the system is configured with two or more languages, these languages will be predefined in the
system. It is possible to define extra languages. Defining other languages is useful when creating
purchase orders, quotation requests, etc., for suppliers in other languages.

To accommodate multilingual transactions, add free-format text in both your own language and in the
supplier’s language. While you can inspect the text in your own language using the corresponding
features, the text in the supplier’s language will be printed on the form that will be sent to the supplier.

Adding a new language
Infor EAM is delivered with support for nine language translations. Any of these languages that are not
initially installed are classified as Available. Use Install Available Language to install any of these
languages at a later date.

To add a non-supported language, languages not delivered in Infor EAM: first add the language, next
make the language available, install the language, and then designate the language as Active to use
the language.

To add a new language:
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1 Select Administration > Setup > Languages.
2 Click New Record.
3 Specify this information:

Language
Enter a unique code identifying the language, and then enter a description of the language in the
adjacent field. The system automatically populates Available and Installed.

Note:  Language must be less than or equal to two letters.

Out of Service
Select to indicate the language is out of service.

4 Click Save Record.

Note: To make a language Available, click Make Language Available.
To install an available language, click Install Available Language.
To refresh an installed language, click Refresh Installed Language.

Making a language available
Designate an installed language as Available to use in Infor EAM.

To make a language available:

1 Select Administration > Setup > Languages.
2 Select a language to make available, and then click the Record View tab.
3 Click Make Language Available.
4 Specify this information:

Language
Select the language from which to copy the available language.

5 Click Submit.

Installing an available language
Install a language after it has been made Available.

Note: The system will not install the language until it has first been made Available.

To install an available language:

1 Select Administration > Setup > Languages.
2 Select a language to install, and then click the Record View tab.
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3 Click Install Available Language. The system automatically populates Install/Upload Started,
Processing Status, and Install Upload Completed on the Record View page.

Refreshing an installed language
Prior to refreshing a language, the language must be added, made available, and installed.

See "Adding a new language" on page 30.

To refresh an installed language:

1 Select Administration > Setup > Languages.
2 Select a language to refresh, and then click the Record View tab.
3 Click Refresh Installed Language.
4 Choose one of the following options:

Refresh All Dates
Select to refresh all translated text.

Refresh Since
Select to refresh translated text beginning with the selected Date.

5 Specify this information:

Boiler Text
Select to refresh boiler text.

Code Description Text
Select to refresh code description text.

Error Text
Select to refresh error text.

Menu Text
Select to refresh menu text.

6 Click Submit.

Viewing the current status of boiler text records for new languages
View the current status of boiler text records in the system. Use the export to MS Excel functionality to
initiate the first or next round of language translation.

To view the current status of boiler text records for new languages:

1 Select Administration > Setup > Languages.
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2 Select the language for which to view current status of boiler text records, and then click the Boiler
Text tab.

3 Specify this information:

Comparison Language
Enter the language for which to compare the boiler text.

4 View the translated and untranslated boiler text.

Note: To download all selected records to MS Excel, click Save Grid to Excel.

Viewing the current status of code description text records for new
languages
View the current status of code description text records in the system. Use the export to MS Excel
functionality to initiate the first or next round of language translation.

To view the current status of code description text records for new languages:

1 Select Administration > Setup > Languages.
2 Select the language for which to view current status of code description text records, and then click

the Code Description Text tab.
3 Specify this information:

Comparison Language
Enter the language for which to compare the code description text.

4 View the translated and untranslated code description text.

Note: To download all selected records to MS Excel, click Save Grid to Excel.

Viewing the current status of error text records for new languages
View the current status of error text records in the system. Use the export to MS Excel functionality to
initiate the first or next round of language translation.

To view the current status of error text records for new languages:

1 Select Administration > Setup > Languages.
2 Select the language for which to view current status of error text records, and then click the Error

Text tab.
3 Specify this information:

Comparison Language
Enter the language for which to compare the error text.
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4 View the translated and untranslated error text.

Note: To download all selected records to MS Excel, click Save Grid to Excel.

Viewing the current status of menu text tab for new languages
View the current status of menu text records in the system. Use the export to MS Excel functionality
to initiate the first or next round of language translation.

To view the current status of menu text tab records for new languages:

1 Select Administration > Setup > Languages.
2 Select the language for which to view current status of menu text tab records, and then click the

Menu Text tab.
3 Specify this information:

Comparison Language
Enter the language for which to compare the menu text tab.

4 View the translated and untranslated menu text tab.

Note: To download all selected records to MS Excel, click Save Grid to Excel.

Defining closing periods
The system gathers maintenance costs on an ongoing basis. When you are ready to process those
costs, define closing periods. Typically, closing periods occur at the end of every month, although some
companies process transactions on a quarterly basis. When the specified date arrives, the system
freezes all of the relevant data, and a new costing period begins.

Note: Define closing periods just before transferring transaction data to another system for account
processing (general ledger, accounts payable, accounts receivable, etc.).

To define closing periods:

1 Select Administration > Security > Closing Periods.
2 Click Add Closing Period. The system automatically populates Date Entered with the current

server system date.
3 Specify this information:

Closing Date
Enter the closing date for the period.

Note:  Closing Date must be in the past because changes to time sheets, issues and receipts,
purchases, and other transactions cannot occur before the date established by the Closing Period.
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4 Click Submit.

Note: You cannot delete closing periods.

Creating and modifying locales
Create or modify locale settings for users. The system supports the locale at the user level, organization
level, and global level (installation parameter). The system automatically employs the locale of the
user. If this locale is not valid, then the system uses the locale of the default organization of the user.
Finally, if that locale is not valid, then the system employs the locale of the global setting.

To create or modify locales:

1 Select Administration > Setup > Locales.
2 Click New Record.
3 Specify this information:

Locale
Enter a unique code identifying the locale, and then enter a description of the locale in the adjacent
field.

Monetary Decimal Separator
Enter the symbol used as the monetary decimal separator of the locale.

Monetary Group Separator
Enter the symbol used to separate monetary groupings in the locale.

Monetary Group Digits
Enter the number of digits needed to separate monetary groups in the locale.

Monetary Decimal Places
Enter the number of digits to appear after a monetary decimal in the locale.

Negative Symbol
Enter the symbol used to indicate a negative number in the locale.

Date Format
Select the date format of the locale.

Numeric Decimal Separator
Enter the symbol used as the numeric decimal separator of the locale.

Numeric Group Separator
Enter the symbol used to separate numeric groupings in the locale.

Numeric Group Digits
Enter the number of digits needed to separate numeric groups in the locale.
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Numeric Decimal Places
Enter the number of digits to appear after a numeric decimal in the locale.

Positive Symbol
Enter the symbol used to indicate a positive number in the locale.

First Day of Week
Select the first day of the week in the locale.

4 Click Save Record.

Defining documents
Organizations involved with maintenance have much supporting documentation, including schematics
and drawings, reference guides and user manuals, warranties, manufacturer claims, and delivery notes.

In addition, organizations can store information electronically on computer diskettes, CAD drawings,
CDs, videos, or audiotapes. Infor EAM makes it easier to manage this information by allowing
organizations to store entire libraries of documents.

Assign a code to documents, specify track revision information, and identify the location of the document.

When setting up electronic document files, consult your system administrator before defining documents
to determine if directories have already been set up.

To define documents:

1 Select Administration > Setup > Documents.
2 Click New Record.
3 Specify this information:

Organization
Specify the organization to which the document belongs if you use multi-organization security.

Document
Specify a unique code identifying the document, and then enter a description of the document in
the adjacent field.

Revision Number
Specify the revision number of the document, e.g., if you have updated the document since the
document was entered in the system, enter 1.

Original Code
Specify the original code of the document.

File Location
Specify the location of the file.
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File Type
Specify the type of file, such as word document (DOC), spreadsheet (XLS), etc.

IDM Document Type
Specify the document type if you are uploading it from the Infor Document Manager system.

Effective Date
Specify the date to make the document available in the system to users of this organization.

Expiration Date
Specify the date the document at which the document is no longer available to those users in the
system.

Title
Specify the title of the document.

Class
Specify the class of the document.

Revision Date
Specify the date of the latest document revision.

Pages
Specify the number of pages in the document.

File Path
Specify the file path of the document, such as URL (www.infor.net), filename (infor.doc), etc.

4 Optionally, select the Out of Service check box to prevent the document from displaying in lookups
across the system.

5 Click Save Record.

Note: Click Upload Document to upload an existing document record to the server. A document
record must already exist and cannot have unsaved changes to upload it from the Documents form.
After uploading a document, File Type is automatically populated with Uploaded Document and
File Path with the file name.
See the Infor EAM User Guide.
Click View Document to view the document.
To view or remove a document association, click the Where Used tab.
See "Removing document associations" on page 37.

Removing document associations
View entity associations for documents, and then remove entity associations as necessary.

To remove a document association:

1 Select Administration > Setup > Documents.
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2 Select the document for which to remove an entity association, and then click the Where Used tab.
3 Select the entity to disassociate from the document, and then click Remove Document Association.

Setting up access to external documents
Set up access to external documents by defining a URL or file path installation parameter for files.
When accessing an external document, the system looks for the URL or file path you have defined as
an installation parameter for a particular file type or category to display the document.

Define the URL or file path as URLxxx where xxx is the value of File Type on the Documents form.
For example, you might enter the code URLPDF to access a .PDF file. Then you would enter the URL
or file path indicating the location where all .PDF files are stored on the web or network, e.g.,
\\mycompany\myserver.com\documents\PDFs. When you access an external document after setting
up access to external documents, the system identifies the document type or category and then opens
the file using the URL indicating where documents of the specified type or category are stored and the
specific File Path you entered on the Documents form. Thus, the full path to the specific document
you wish to access might be \\mycompany\myserver.com\documents\PDFs\PDFattachment.pdf.

Note: The URL can be a path to the web or a directory. You can separate URLs by type, e.g., .DOC
or .PDF or by a chosen category, e.g., Safety (URLSAF) or Vendors (URLVEN).

To set up access to external documents:

1 Select Administration > Security > Install Parameters.
2 Click New Record.
3 Specify this information:

Install Parameter
Enter a unique code identifying the URL installation parameter, e.g., URLPDF, and then enter a
description of the URL installation parameter in the adjacent field.

Note: You cannot define fixed install parameters or assign new install parameters to a module.

Value
Enter the full path to the URL that contains files of the specified type or category, e.g.,
\\mycompany\myserver.com\documents\PDFs.

4 Click Save Record.

Setting up printers
To set up printers:

1 Select Administration > Setup > Printers.
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2 Click New Record.
3 Specify this information:

Organization
Enter the organization to which the printer belongs if you use multi-organization security.

Printer
Enter a printer code to link the printer to a specific device, and then enter a description of the printer
in the adjacent field.

Note:  Printer is case sensitive; it accepts mixed-case records.

Destination
Enter a unique destination identifying the path to the printer.

Special
Select to prevent the printer from being displayed in the Printer lookup when printing reports.

4 Click Save Record.

Defining classes
Define classes for most entities. You can separate a single entity into groups, most often for cost
analysis. For example, you can assign classes to equipment, and then give all air conditioning units a
class of "HVAC." With this information, an analysis that compares the cost of maintaining all HVAC
units is provided.

To define classes:

1 Select Administration > Setup > Classes.
2 Specify the entity for which to create classes.
3 Click Add Class.
4 Specify this information:

Class
Specify a unique code identifying the class.

Description
Specify a description of the class.

Note: When editing a class, you can only edit the Description.

Organization
Specify the organization of the class if you use multi-organization security.

Coding Entity
Select the coding entity with which to associate the class.
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Level
Specify the level of the class.

Out of Service
Select to prevent the class from being displayed in lookups.

Note:  Coding Entity, Level, and Out of Service apply only to the CLVL entity.

Property Definition
Select the property definition with which to associate the class.

Note: Property Definition applies only to the OBJ entity.

5 Click Submit.

Note: To update the translations by language, click Translations.
See the Infor EAM User Guide.

Defining classes and custom fields
Define class records for entities. Classes allow you to segment a single screen into groups for cost
analysis or other comparisons.

To define classes and custom fields:

1 Open the Classes and Custom Fields form.
2 Click New Record.
3 Specify this information:

Class
Enter a code for the class, and then enter a description in the adjacent field.

Organization
Enter the organization if you use multi-organization security.

Screen
Select the form for which to create the class.

Out of Service
Select to indicate the class is out of service.

4 Click Save Record.

Associating custom fields with classes
Define custom field records or select existing custom fields and associate them with a selected class.
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To define associate custom fields with classes:

1 Select Administration > Setup > Classes.
2 Select the class for which to associate custom fields, and then click the Custom Fields tab.
3 Choose one of the following options:

• To add a new custom field
Click Add Custom Field to add a new custom field to associate with a selected class. Specify
the information below.

• To add an existing custom field
Specify the custom field to associate with the selected class. The system automatically displays
a list of values for the custom field. Select a value, and the system displays the Custom Fields
page and automatically populates Custom Field, custom field description, and Type.

4 Specify this information:

Custom Field
Enter a code for the new custom field, and then enter a description in the adjacent field.

Line
Enter a value for the line.

Type
Select a type for the custom field.

Print on Work Order Report
Select to print the custom field on the work order report.

Enforce Lookup Validation
Select to require lookup validation for the custom field.

Minimum Value
Enter the minimum value required for the custom field.

Maximum Value
Enter the maximum value allowed for the custom field.

Enable Lookup
Select to enable lookup for the custom field.

5 Click Submit.

Setting up field filters for screens
The Screen Setup form allows administrators to configure the options available in lookup fields for
users on specific screens.
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Set up field filters for equipment and work order types on specific screens by specifying which equipment
and work order types are available for selection by a user on the screens.

Using the following check boxes the administrator can set the following filters for fields on selected
screens:

• Type
If selected, on the record view of the selected screen, the system displays the types listed on the
Types tab in the Types lookup.
Only equipment/work orders that belong to Types listed in Field Filter setup will be displayed in
the List View of the selected screen.

Note:  An equipment type can be linked to more than one screen; however, only one type can be
flagged as the default screen type for the selected screen.
The list of screens for which the administrator can filter the types and classes is predefined. Users
cannot insert or delete records.

• Class
Enable the class filter for selected screens. If selected, on the record view of the selected screen,
the Class lookup will only display the classes listed on the Class tab. Only equipment or work orders
that belong to Classes listed in Field Filter setup will be displayed in the List View of the selected
screen.

• WO Equipment Type
On the selected Work Order screen, the Equipment lookup field displays the equipment types that
are also listed on the WO Equipment Type tab.

• Select the Filter WO Equipment Type checkbox to enable the WO Equipment Type filter for the
selected screen.

Note: This check box must be selected only for work order screens.

• Operator Checklist
Specify task plans and equipment classes that will display in the Task Plan and Equipment Class
lookups for users on the Operator Checklists screens.

• Reservation Calendar
If the selected record is a Reservation Calendar screen, the Filter WO Equipment Type checkbox
is protected as are the specific Organization and Class.

Setting up classes for screens
Select classes for equipment or work orders. Administrators can specify which class must be displayed
for a user on the related screens.

To set up classes:

1 Select Administration > Screen Configuration > Screen Setup.
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2 Select the screen for which to set up classes for equipment or work orders, and then click the Record
View tab.

3 Select the Filter Class check box to filter the class records in the class lookup for the selected
screen.

4 Select the Classes tab.
5 Click Add Class to add classes to the class lookup on the selected screen.
6 Specify this information:

Class
Select the class to display in the class lookup on the selected screen, and then click OK.

Note: To select multiple classes to display in the class lookup on the selected screen, click Select
Class. Select the classes, and then click Submit.

7 Click Submit.

Setting up types for screens
Select types for equipment or work orders. Specify which equipment or work order types must be
displayed for a user on the related screens.

Note: The user can select a type, only if the Filter Type checkbox is selected in the Record Viewscreen.

To set up types:

1 Select Administration > Setup > Screen Setup.
2 Select the screen for which to set up the types for equipment or work orders, and then click the

Record View tab.
3 Select the Filter Type check box to filter types for equipment or work orders on the selected screen.
4 Select the Types tab.
5 Click Add Type to add the equipment or work order type to the selected screen.
6 Specify this information:

Type
Select the type of equipment or work order.

Note: To select multiple types for the selected screen, click Select Types. Select the types, and
then click OK.

Default Screen Type
If this checkbox is selected, the system defaults the equipment type or work order type to the type
defined as the Default Screen Type.

7 Click Submit.
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Setting up work order equipment types for screens
Set up work order equipment types. Specify which work order equipment types will display for a user
on the related screens.

To set up work order equipment types for screens:

1 Select Administration > Setup > Screen Setup.
2 Select the screen for which to set up the types for work order equipment, and then click the Record

View tab.
3 Select the Filter WO Equipment Type check box to filter work order equipment types for the selected

screen.

Note: The user can select a work order equipment type, only if the Filter WO Equipment Type
checkbox is selected on the Record View screen.

4 Click the WO Equipment Types tab.

Note:  Filter WO Equipment Type can only be selected for work order screens.

5 Select the Add WO Equipment Type check box to add the equipment type to the selected screen.

Note: To add multiple work order equipment types, click Select WO Equipment Type. Select the
work order equipment types, and then click Submit.

6 Specify this information:

WO Equipment Type
Select the work order equipment type.

7 Click Submit.

Specifying operator checklists for screen setup
Specify which task plans and equipment classes will display in the task plan and equipment class
lookups on the Operator Checklist screens.

To specify operator checklists for screen setup:

1 Select Administration > Screen Configuration > Screen Setup.
2 Select the screen for which to specify operator checklists, and then click the Operator Checklist

tab.
3 Click Add Record.
4 Specify this information:

Equipment Class
Specify the equipment classes to be filtered in the equipment lookups on the Operator Checklist
screens. Equipment Class Org. is automatically populated.
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Task Plan
Specify the task plan to display in task plan lookups on the Operator Checklist screens. The task
plan description and Task Plan Org. are automatically populated.

Complete Status
Specify the operator checklist complete status.

Cancel Status
Specify the operator checklist cancel status.

Default
Select this check box to indicate no more than two Operator Checklist screens will be flagged as
the default screen type for the same equipment class-task combination specified here.

5 Click Submit.

Creating part hierarchy codes
Create part hierarchy codes to create a coding structure that enables you to further define parts by
classifying them into specific levels.

Before creating part hierarchy codes, you must first define the code levels for the part code hierarchy
entity (CLVL) on the Classes form.

See "Defining classes" on page 39.

After defining the code levels for the Part code hierarchy entity, you can then create part hierarchy
codes to define a structured hierarchy between part code combinations. You can define a maximum
of eight coding levels for parts.

To create part hierarchy codes:

1 Select Materials > Setup > Part Hierarchy Codes.
2 Click Add Hierarchy Code.
3 Specify this information:

Description
Enter a description of the part code hierarchy.

Enter the different levels of the part code hierarchy beginning with [Level 1] through [Level 8].

Note: You cannot enter a code for a level until you have entered a code for the previous level, e.g.,
you cannot enter a code for [Level 2] if you have not defined [Level 1].

The system displays the number of code structure levels based on the number of classes you have
defined for the Part code hierarchy entity. For example, if you have defined four code levels for the
Part code hierarchy entity on the Classes form, the system displays four levels for the code hierarchy
[Level 1] – [Level 4].
To update the translations by language, click Translations.
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See the Infor EAM User Guide.

4 Click Save Record.

Defining account details
Access account detail code information on different forms within the system for which the Account
Details page is available.

Note: Account detail codes are defined for use with Databridge and external accounting systems.

The system displays the account detail codes associated with the entity of the form from which you
access the Account Details page. The fields displayed on the Account Details are based on the entity
of the form. For example, the fields for the REQL entity (Requisition Lines) are the Requisition Number,
Organization, and the Requisition Line. You can view detailed account code segment information, copy
an existing account detail record, modify an existing account detail record, or insert a new account
detail record. You can also create account detail records for any entity records for which there are no
existing account details.

To define account details:

1 From any form for which account details is activated, click the Account Details tab.
2 Select the entity for which to access account details. The fields for the selected entity are displayed

for information only and are protected. Only the account detail fields are editable.
3 Specify this information:

Accounted
Select whether the account details should be accounted for as a debit or a credit.

Note: If the ACCOUNT installation parameter is set to YES, Accounted is required. If ACCCOUNT
is set to NO, the system automatically populates Accounted with an asterisk (*).

Segment 01
Segment 30
Enter the account code segment(s) for the account detail record as you have defined the account
code segment codes on the Account Detail Setup form.

Note: The system displays only the account code segments that you defined, up to 30 total
segments. For example, if you defined segments 01 through 10, the system displays fields for
Segment 01 through Segment 10.
If a segment code is defined with a query code on the Account Detail Setup form, then the system
displays a list of values for the segment code enabling you to view the results of the SQL statement
for the code.
If a specific segment code is designated as Required on the Account Detail Setup form, then the
segment field is required for the account detail record on the Account Details tab.

4 Click Submit.
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Note: You can change the name of a segment to something specific to your accounting needs as
necessary using screen designer.
To create additional account detail records based on an existing record, click Copy Record.
If the ACCOUNT installation parameter is set to YES, the system sets Accounted to the opposite
value of the record from which you are copying the account details. For example, if the value of
Accounted is Credit for the existing record, the system sets Accounted to Debit for the copied
record.

Defining capital request categorization codes
Define capital request categorization codes for use on the Capital Planning Request form.

See the Infor EAM User Guide.

Note: The system will be pre-populated with data from the ASTM UNIFORMAT II Classification for
Building Elements (E1557-97).

To define capital request categorization codes:

1 Select Administration > Setup > Capital Request Categorization Codes.
2 Click Add Categorization Code.
3 Specify this information:

Description
Enter the description of the capital request categorization code.

Major Group Element
Enter the major group element.

Note:  Major Group Element, Group Element, and Individual Element cannot contain periods
(.).

Group Element
Enter the group element.

Note: In order to create a new Group Element, you must first create a new Major Group Element.

Individual Element
Enter the individual element.

Note: In order to create a new Individual Element, you must first create a new Major Group
Element and a new Group Element combination.

4 Click Submit.
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Auditing attributes
The system provides a flexible way to track changes of every attribute for almost every table. When a
user enters, updates, or deletes an attribute, the system records the old value, new value, user code,
function used, and date/time stamp. To activate this auditing, you must know the field and the technical
name of the table to track. The system cannot track tables that do not appear in lookups or have no
primary key.

Note: The number of audits might grow very fast; purge data frequently to aid system performance.
See "Purging audit records" on page 49.

Setting up audit triggers
Set up audit triggers to monitor attribute changes to records. Create audit trail triggers to define what
changes to which attributes you should audit. Once you know the field and the technical name of the
table to track, set up audit triggers.

To set up audit triggers:

1 Select Administration > Security > Audit Setup.
2 Enter the table for which to set up audit triggers.
3 Click Add Trigger.
4 Specify this information:

Field
Specify the field to audit, and then enter a description in the adjacent field.

Update
Select to track updates.

Insert
Select to track insertions.

Delete
Select to track deletions.

5 Enter additional comments concerning the trigger.
6 Click Submit.

Viewing trigger status values
To view trigger status values:

1 Select Administration > Security > Audit Setup.
2 Enter the table for which to view the audit.
3 Select the field for which to view the trigger status, and then click the View Trigger Status.
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4 Specify one of the following options:

• Refresh Audit Triggers
All audit triggers are dropped from the table, audit triggers are recreated for each of the fields
selected, and then the Audit Setup list is updated.

• Drop Audit Triggers
All audit triggers are dropped.

5 View the audit information.
6 Click Close.

Purging audit records
Purge audit records. Purge data frequently to aid system performance.

To purge audit records:

1 Select Administration > Security > Audit Setup.
2 Enter the table for which to purge audit records, and then click Purge Audit Records.
3 Specify this information:

From Date
Enter the date from which the audit records will be purged.

To Date
Enter the date up to which the audit records will be purged.

Note: To purge the current date’s audit records, enter tomorrow’s date in To Date.

4 Click Submit.
5 Click Close.

Administering comments and custom fields audit flags
Administer comments and custom fields audit flags. Select the entities for which the system tracks
audit flags, ensuring that the system records all changes to comment and custom field records for the
particular entity.

To administer comments and custom fields audit flags:

1 Select Administration > Security > Audit Setup.
2 Click the Comments and Custom Fields tab.
3 Select the checkbox next to the entity for which to maintain an audit trail of comments and/or custom

fields.
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Viewing audits
After setting up the auditing features in the system, you can view audits for fields or view audit records
for status changes.

Viewing audits for fields
After setting up the auditing features in the system, you can view audits for fields or view audit records
for status changes. View audits in order to monitor changes in attributes.

To view audits for fields:

1 Open any entity record.
2 Select the record for which to view the audit.

Note: You can only view audits on Record View or list detail pages.

3 Right-click within any field on the record, and then choose Audit Trail.
4 View the audit information.

Note:  You can only view audit information if you have established audit control and changes have
been made to the fields under audit.
Recorded in Mobile indicates when comments are updated or deleted in Mobile. The date and
time reflect updates in Mobile.

5 Click Close.

Defining Flex business rules
Define Flex business rules or SQL statements to define validation rules that are specific to your
organization. You can set up one or more statements to be processed for post-insert or post-update
events.

Flex SQL processing supports data query (select) and data manipulation (insert, update, delete)
statements. Use select statements to perform a check condition.

Uppercase and lowercase characters are allowed in the SQL statement. The row identifier token,
however, must be either all uppercase or all lowercase (i.e., :ROWID or :rowid).

Every Flex SQL statement requires the use of a predefined :ROWID token. This token refers to the
database row identifier for the record being processed in the specified table. The statement is executed
for each record in the table affected by the insert or update operation.

The maximum statement length is 4000 characters. No statement termination character (;) is required.

Data manipulation statements are allowed, but make sure you do not begin an infinite cascading of
trigger steps. For example, generally it is not recommended to create a Flex SQL statement that updates
the base table identified in Table.

50 | Infor EAM System Administrator Guide

 

System configuration



Note:  Infor EAM recommends that you define Flex SQL procedures in close cooperation with your
Infor EAM consultant.

To define Flex business rules:

1 Select Administration > Setup > Flex Business Rules form.
2 Click New Record.
3 Specify this information:

Table
Specify the database table.

Sequence Number
Specify the sequence number for the Flex SQL statement.

Trigger
Select one of the following options:

• Post Insert
• Post Update

SQL Statement
Specify the SQL statement for the selected database table.

Failure Message
Specify the failure message.

Comments
Specify comments regarding the Flex SQL statement.

4 Optionally, select the Must Exist checkbox if the Flex SQL statement must exist in the database
table. If Must Exist is selected, SQL statements are run in order of Sequence Number. If one
statement fails, the remainder do not run. If Must Exist is not selected, each statement runs
separately.

5 Optionally, select the Abort on Failure to abort the statement upon failure. If Abort on Failure is
checked, the Failure Message field value is returned, any remaining SQL statements are not
processed, and the save that triggered the flex SQL is cancelled.

6 Optionally, select the Reverse Return Code checkbox to automatically reverse the returned value
upon statement completion, i.e., Null becomes Not Null.
Reverse Return Code is used only with Abort on Failure.

7 Optionally, select the Active checkbox to set this Flex SQL statement record to active.
8 Click Save Record.

Note: Records flagged as Mobile Only cannot be deleted on this screen. You must delete them on
the mobile device.
Click Test Flex SQL to check the validity of the SQL statement.
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Setting up Messenger
Set up Messenger for Infor EAM. Utilize Messenger to notify users via e-mail of specific changes in
database tables. First, define the installation parameters, and then create e-mail templates. Next, create
e-mail notifications to alert users when certain events occur in the system database. Set up the system
to send e-mails when certain conditions are met and to include specific parameters. Finally, view e-mails
to ensure proper delivery.

Defining installation parameters for Messenger
To define installation parameters for Messenger:

1 Select Administration > Security > Install Parameters.
2 Specify this information:

Install Parameter
Query for the following installation parameters, and then define them according to the following
examples and descriptions:

DescriptionExampleInstallation Code

Enter the e-mail sender.mailid@yourcompany.comSMTPSEND

Enter the e-mail server.mail.yourcompany.comSMTPSERV

3 Click Save Record.

Creating e-mail templates for Messenger
Create and modify e-mail messages using e-mail templates.

To create e-mail templates for Messenger:

1 Select Administration > E-mail Messenger > E-mail Templates.
2 Click New Record.
3 Specify this information:

E-mail Template
Enter a unique code identifying the e-mail template, and then enter a description of the template
in the adjacent field.

E-mail Recipients
Select the recipients of the e-mail message. Separate e-mail addresses with a space or a ;.
See "Selecting multiple recipients for e-mail notification" on page 53.
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Note: Parameters can be used in E-mail Recipients as well. If a parameter is associated with a
user or employee record, the system replaces it with the corresponding e-mail address when the
e-mail is sent.

E-mail Subject
Enter the subject of the e-mail message.

E-mail Body
Compose the e-mail message. Identify the parameter number(s) that corresponds to the column
of the system table to be displayed with this e-mail. Enter %1 - %15 for each parameter.

4 Click Save Record.

Selecting multiple recipients for e-mail notification
To select multiple recipients for e-mail notification:

1 Select Administration > E-mail Messenger > E-mail Templates.
2 Click New Record.
3 Specify this information:

E-mail Recipients
Select recipients from the list.

4 Click OK.

Creating e-mail notifications for Messenger
Set up e-mail notifications when certain events occur in the Infor EAM database. Create e-mail
notifications for a defined table based on the e-mail template. Define the parameters and constraints
of each e-mail notification.

To create e-mail notifications for Messenger:

1 Select Administration > E-mail Messenger > E-mail Notification Setup.
2 Enter the table for which to create the e-mail notification.
3 Click Add E-mail Notification.
4 Specify this information:

E-mail Template
Enter the e-mail template to send when this e-mail notification is activated. The system automatically
populates the E-mail Template description and Created By.

Select one or more of the following events:
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• Update
Select to send e-mail when the record is updated.

• Insert
Select to send e-mail when a record is inserted.

• Delete
Select to send e-mail when a record is deleted.

From Status
Enter any status for which to send an e-mail.

To Status
Enter the updated status for which to send an e-mail.

Active
Select to make the selected record active. The system may clear this checkbox if you add, modify,
or delete parameters or conditions.

Include URL
Select to include the URL in the notification.
This checkbox is available only for the following tables:

DescriptionTable Name

Work Order ActivitiesR5ACTIVITIES

Blanket OrdersR5BLANKETORDERS

Blanket Order LinesR5BLANKETORDLINES

Booked HoursR5BOOKEDHOURS

Customer Requests (Call Center)R5CONTACTRECORDS

Work OrdersR5EVENTS

Invoice AllocationsR5INVOICEALLOCATIONS

Invoice Voucher LinesR5INVOICELINES

Invoice VouchersR5INVOICES

Purchase Order LinesR5ORDERLINES

Purchase OrdersR5ORDERS

RequisitionsR5REQUISITIONS

Requisition LinesR5REQUISLINES

Service RequestsR5SERVICEREQUESTS

Warranty ClaimsR5WARCLAIMS
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Comments
Enter any comments to include in the body of the e-mail notification.

5 Click Submit. The system automatically selects Update if either From Status or To Status is
entered.

Purging e-mail records
To purge e-mail records:

1 Select Administration > E-mail Messenger > E-mail Notification Setup.
2 Enter the table for which to purge e-mail records, and then click Purge E-mail Records.
3 Specify this information:

From Date
Enter the date from which the e-mail records will be purged.

To Date
Enter the date up to which the e-mail records will be purged.

4 Click Submit.

Note: You can also purge e-mail records on the E-mail Viewer form.

5 Click Close.

Setting up e-mail notification parameters
Set up parameters to include in the body of the Messenger e-mail, e.g., a work order # %1[Work Order
Number] was created on %2[Date Created] by %3[Entered by] for %4[Equipment Code/Name]. Create
parameters for each of the data-specific items (items in brackets). The system retrieves the data based
on the parameters and inserts it into the e-mail.

Parameters must also be set up in the template e-mail body.

See "Creating e-mail templates for Messenger" on page 52.

To set up e-mail notification parameters:

1 Select Administration > E-mail Messenger > E-mail Notification Setup.
2 Enter the table for which to set up e-mail notification parameters.
3 Select the record for which to set up parameters, and then click Create Parameters.
4 Click Add Parameter.
5 Specify this information:

Parameter
Enter the parameter number for the e-mail notification.
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Note: The parameter must be in a range of 1 to 15.

Column
Enter the name of the column of the system table to be used when creating the e-mail content for
the e-mail body.

6 Click Submit.

Note: The system clears Active on the associated E-mail Notification record.

7 Click Close.

Setting up e-mail notification conditions
Set up e-mail notifications to send e-mail whenever a specific condition is met.

To set up e-mail notification conditions:

1 Select Administration > E-mail Messenger > E-mail Notification Setup.
2 Enter the table for which to setup e-mail notification conditions.
3 Select the record for which to set up conditions, and then click Create Conditions.
4 Click Add Condition.
5 Specify this information:

Column
Enter the name of the column on the system table that applies to the e-mail notification.

Condition
Select the criteria for the e-mail notification.
See the following table when entering conditions for e-mail notifications:

DefinitionCondition

Set this Condition if Column is equal to the value
of Value 1.

Is equal to

Set this Condition if Column is not equal to the
value of Value 1.

Is not equal to

Set this Condition if Column is greater than the
value of Value 1.

Is greater than

Set this Condition if Column is less than the value
of Value 1.

Is less than

Set this Condition if Column is greater than or
equal to the value of Value 1.

Is greater than or equal to

Set this Condition if Column is less than or equal
to the value of Value 1.

Is less than or equal to
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DefinitionCondition

Set this Condition if Column is blank.Is blank

Set this Condition if Column is not blank.Is not blank

Set this Condition if Column is between the val-
ues of Value 1 and Value 2.

Is between

Set this Condition if Column is not between the
values of Value 1 and Value 2.

Is not between

Set this Condition if Column contains the value
of Value 1.

Contains

Set this Condition if Column does not contain
the value of Value 1.

Does not contain

Value 1
Value 2
Enter the value of the e-mail notification condition.

Enter values according to the following formats:

Date
To_date (‘23-OCT-2003’,’DD-MON-YYYY’). For example, if you are entering a date value for a
condition that is equal to a specific date, enter the value according to this exact format:

Value 1ConditionColumn

To_date (‘23-OCT-2003’,’DD-
MON-YYYY’)

Is equal toName of column

Numbers
To_Number (10). For example, if you are entering a number value for a condition that is greater
than a specific number, enter the value according to this exact format:

Value 1ConditionColumn

To_number (10)Is greater thanName of column

• Characters
‘engine’

• Contains
‘%pump%’

Note: You must enter a Value 1. The system protects both Value 1 and Value 2 if you enter "is
blank" or "is not blank" in Condition. Value 2 is required if you enter "is between" or "is not between"
in Condition.
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If you update Column or Condition after you enter Value 1 or Value 2, the system clears both of the
value fields.

6 Click Submit.

Note: The system clears Active on the associated E-mail Notification record.

7 Click Close.

Viewing initiated e-mails for Messenger
View records of all e-mails that have been initiated from database events to ensure proper delivery
and to troubleshoot problems with Messenger. The system displays all sent messages including those
that encountered error messages.

To view initiated e-mails for Messenger:

1 Select Administration > E-mail Messenger > E-mail Viewer.
2 Select the record for which to view the initiated e-mail.
3 View the following information regarding the e-mail record:

• Date
The system displays the date the e-mail was initiated.

• E-mail Record
The system displays a code identifying the e-mail record.

• E-mail Template
The system displays the e-mail template.

• E-mail Recipients
The system displays the list of e-mail recipients.

• Error
Indicates that an error occurred while sending the e-mail.

• Sent
Indicates that the system successfully sent the e-mail.

• E-mail Body
The system displays the composed message.

• Error Message
The system displays the error that the e-mail message encountered.
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Managing alerts
Create e-mail and work order alerts to notify users when data in Infor EAM (e.g. equipment) does not
meet a specified criteria. First, create a grid to query data in the system and then use alert management
to determine if the results need to be measured against a min/max setting or if the results alone will
trigger an email and/or work order.

An alert management record can be created to monitor readings that are being imported into Infor EAM
for chillers. The alert record may monitor to see if the difference between supply air temperature and
the return air temperature is >22 degrees when chilled water temperature is <46 degrees and chilled
water valve is open >50%. If all this criteria is met for a chiller then a work order would be created
indicating that a belt could be slipping or the filters may be plugged.

Note:  Use the new R5ALERTDATAOBJ table to import records into Infor EAM. Then use alert
management to analyze the records and create alerts when deviations occur. R5ALERTDATAOBJ
was specifically designed for analyzing data imported from another system related to Infor EAM
equipment records. This table can be accessed through web services or using the Infor EAM Import
Utility. Once records are created in R5ALERTDATAOBJ, use this table in Grid Designer when creating
the alert management grid query.
Create an active alert management grid on the Grid Designer page before setting up an alert on the
Alerts page.
See "Defining grids" on page 137.

Creating alerts
To create e-mail and work order alerts for specific equipment:

1 Select Administration > Setup > Alert Management.
2 Click New Record.
3 Enter a description for the alert.

Active
Select to set this alert to active.

4 Specify this Alert Definition Details information:

Grid Name
Enter the grid name defined for the Alerts form on the Grid Designer form.
The system automatically populates the grid description and Grid Active.

Dataspy
Select the Dataspy for the grid.

Exception Entity
Enter the exception entity.
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Grid Key Field 1
Enter the mapping to the corresponding grid column that should be used as a key field in the grid,
e.g., if analyzing equipment this would map to the equipment column in the grid. The system
automatically populates the grid key field 1 description.

Grid Key Field 2
Enter the mapping to the corresponding grid column that should be used as a key field in the grid,
e.g., if analyzing equipment this would map to the equipment column in the grid. The system
automatically populates the grid key field 2 description.

Note: Grid key fields are populated on the History page, and used for reviewing data when a delay
period is entered for an alert on the Work Order Alerts, Exceptions, or E-mail Alerts pages.

5 Specify this Min/Max Definition information:

Use Min/Max
Select to use a minimum and maximum range for this alert.

Min/Max Value Field
Enter the mapping to the corresponding grid column. During the alert process the system analyzes
the result of the field for each row in the grid and compares it to the min/max selections on the form.

Min Value
Enter the minimum value for the alert. The system produces alerts when the result of Min/Max
Value Field is less than or equal to the minimum value.

Max Value
Enter the maximum value for the alert. The system produces alerts when the result of Min/Max
Value Field is greater than or equal to the maximum value.

Trigger within Min/Max Values
Select to trigger alerts when the result value is within the Min Value and Max Value.

Note: Triggering within min/max will generate alerts when the result has values equal to or greater
than the Min Value and less than or equal to the Max Value.
Enter the user-defined fields.

6 Specify this Scheduling information:

Frequency
Enter the frequency of the analysis in a numerical amount, and then select the frequency UOM,
e.g., enter 10 and then select Days to enable the system to perform an analysis every 10 days.

Note: Although the analysis may process every 10 days, the system does not generate alerts
unless the analysis meets the specified criteria.

Next Evaluation Date
Enter the next date to evaluate the alert. The system automatically populates Last Evaluation
Date and Last Alert Date.

7 Specify this Active Alert Types information:
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Work Order
Select to create a work order alert based on specific parameters.
See "Creating e-mail alerts" on page 64.

E-mail
Select to create an e-mail alert based on specific parameters.
See "Creating e-mail alerts" on page 64.

8 Click Save Record. The system automatically populates Alert, Created By, and Date Created.

Note: To preview the grid query results, click Preview Grid.
To activate alert management, enable the ALRT driver on the Job Setup form.

Defining before SQL statements for alerts
Define SQL statements that the system will execute prior to executing the defined grid for an alert.
Before SQL statements can be used to prepare data or structures being used by the grid, e.g., purge
records.

To define before SQL statements for alerts:

1 Select Administration > Setup > Alert Management.
2 Select the alert for which to define the before SQL statement, and then click the Before SQL tab.
3 Specify this information:

SQL Statement
Enter the SQL statement that will be executed before the grid query will produce a result set. The
system automatically populates Abort on Failure.

Note: Unselect Abort on Failure to enable the system to continue executing the grid query if the
SQL statement fails.

Comments
Enter comments regarding the SQL statement.

Execute when Previewing Grid
Select to execute the SQL statement when Grid Preview is selected.

Active
Select to set this SQL statement record to active.

Note: To process the before SQL statement when the alert job is run or Grid Preview is selected
on the Record View page of the Alerts form, you must select Active.

4 Click Save Record.

Note: Click Test SQL to check the validity of the SQL statement.
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Previewing grids for alerts
Preview the grid for alerts. The system does not always display the number of alerts the system creates
once the alert management process is run. The system must consider if the alert is using min/max
evaluation and delays in order to get the correct number of alerts to generate. For example, previewing
the grid may show temperature records for many pieces of equipment, but some may not meet the
criteria set up in Min Value or Max Value. Also, some equipment may have a delay period in which
you do not want to create additional work orders or e-mails for equipment continuing to meet a threshold.

To preview grids for alerts:

1 Select Administration > Setup > Alert Management.
2 Select the alert for which to preview the grid, and then click the Record View tab.
3 Click Preview Grid.
4 View the results.
5 Click Close.

Note: To set the Next Evaluation Date for the alert, click Schedule Now.

Defining after SQL statements for alerts
Define SQL statements for system to execute after executing the defined grid query and after creating
e-mail and work order alerts.

To define after SQL statement for alerts:

1 Select Administration > Setup > Alert Management.
2 Select the alert for which to define the after SQL statement, and then click the After SQL tab.
3 Specify this information:

SQL Statement
Enter the SQL statement that will be executed after the grid query and alerts.

Comments
Enter comments regarding the SQL statement.

Execute when Previewing Grid
Select to execute the SQL statement when Grid Preview is selected.

Active
Select to set this SQL statement record to active. The system processes the after SQL statement
after the grid query is processed.

Note: To process the after SQL statement when the alert job is run or Grid Preview is selected on
the Record View page of the Alerts form, you must select Active.

4 Click Save.
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Note: Click Test SQL to check the validity of the SQL statement.

Creating work order alerts
Define a work order alert to create work orders systematically based on a grid query.

Note:  Work Order must be selected on the Record View tab of the Alerts page for an alert before
the system will examine the Work Order Alerts page during the alert management process.
Note: The alert management process uses R5 User ID to create work orders. R5 must have rights to
all organizations required to create work orders from alert management.

To create work order alerts:

1 Select Administration > System Configuration > Alert Management.
2 Select the alert for which to create a work order alert, and then click the Work Order Alerts tab.
3 Specify this information:

Delay Between Alerts
Specify the numerical amount of time between work order alerts for a specific grid key, and then
select the delay UOM, or unit of time to delay between alerts, e.g., enter 2 and then select Hours
to allow 2 hour delays between the work order alerts.

Note: When the system analyzes delay periods, it uses Grid Key Field 1 and Grid Key Field 2
on the Record View and History tabs of the Alerts page to determine if a grid result will get the
delay specified. If it is determined that a grid result will get the delay, then the system does not
produce the alert if the time between the last alert and the current time is within the delay criteria.

Standard WO
Specify the standard work order to associate to the work order alert. The system uses the standard
work order as a template when creating the work order.

Work Order Org.
Specify the organization to which the work order created will belong.

Equipment Field
Specify the grid column that represents the equipment field.

Equipment Org. Field
Specify the grid column that represents the equipment organization.

Description
Specify the description that will be on the work order when the work order is generated. If no value
is entered the system uses the standard work order value.

Due Nonconformities Only
Select to include only new observations created for nonconformities that are due for inspection.
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Note: The inspector will not see nonconformities on the work order that are present but not due for
inspection. The inspector may be confused if he finds such nonconformities during the inspection
that were not on the list, which may lead to duplicate nonconformities

Include Nonconformities
Select to include new observations for re-inspection for existing nonconformities.

4 Specify comments to display on the work order when the work order is generated.
5 Click Save Record.

Note: To create parameters for work order alerts, click Create Parameters. These parameters can
be used to help build a user-friendly description and/or comment when the work order is generated
by setting parameters that represent actual values in the grid results.
See "Creating parameters for alerts" on page 65.
To sssociate additional work order fields to grid fields, click Additional Field Mapping.
See "Mapping additional fields for work order alerts" on page 64.

Mapping additional fields for work order alerts
Associate work order fields to grid fields to create mappings used by the alert for creating work orders.

To map additional fields for work order alerts:

1 Select Administration > System Configuration > Alert Management.
2 Select the alert for which to map additional fields for a work order alert, and then click the Work

Order Alerts tab.
3 Click Additional Field Mapping.
4 Click Add Mapping.
5 Specify this information:

Work Order Field
Specify the work order field to populate, e.g., Standard WO, Department, or Warranty.

Grid Field
Specify the grid field to map to the work order field.

6 Click Submit.
7 Click Close.

Creating e-mail alerts
Define alerts to trigger e-mails when records are identified that cause an alert.

To create e-mail alerts:

1 Select Administration > Setup > Alert Management.
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2 Select the alert for which to create an e-mail alert, and then click the E-mail Alerts tab.
3 Click Add Record.
4 Specify this information:

E-mail Template
Enter the e-mail template to send.

Delay Between Alerts
Enter the numerical amount of time between e-mail alerts for a specific grid key, and then select
the delay UOM, or unit of time to delay between alerts, e.g., enter 2 and then select Hours to allow
2 hour delays between the e-mail alerts.

Note: When the system analyzes delay periods, it uses Grid Key Field 1 and Grid Key Field 2
on the Record View and History pages of the Alerts form to determine if a grid result will get the
delay specified. If it is determined that a grid result will get the delay, then the system does not
produce the alert if the time between the last alert and the current time is within the delay criteria.

5 Click Submit.

Note: See "Creating parameters for alerts" on page 65.
Users may create multiple e-mail alerts for a single alert management record. The system sends
multiple e-mails for each grid result meeting the specified alert criteria.
To activate e-mail alerts, enable the MAIL driver on the Job Setup form, and then enter the correct
values for the e-mail install parameters.
See "Setting up Messenger" on page 52.

Creating parameters for alerts
Create parameters or standard messages for use in substituting values in large text areas such as in
the e-mail message, work order descriptions, and work order comments. By creating standard messages,
the system defaults these messages in the body of the e-mail message, description, or comments.
Example: For an e-mail alert notification the text may read: "HVAC-ROOFTOP-01 has a temperature
of 250 degrees. Please check this equipment by 01/15/2008." To prevent the necessity of entering the
same information repeatedly, create parameters that allow the system to default the same message
for the data-specific items to be pulled from the grid. For the example above, you would enter for the
body of the e-mail: "%1 has a temperature of %2 degrees. Please check this equipment by %3."

To create parameters for alerts:

1 Select Administration > Setup > Alert Management.
2 Create an alert.

See "Creating alerts" on page 59 on the Work Order Alerts or E-mail Alerts page, and then click
Create Parameters.

Note: You may also access this popup by clicking Create Parameter.

3 Click Add Parameter.
4 Specify this information:
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Parameter
Specify the text to be displayed in the text areas of the e-mail message or comments. Enter % for
parameters and the number of the parameter that is to be used.

Recipient
Select to include the recipient.

Note:  Recipient is not displayed when the Create Parameters popup is invoked from the Work
Order Alerts page.

Grid Field
Specify the grid column that represents the value you wish to substitute into the field.

Value
Specify the hard-coded value to substitute into the field.

5 Click Submit.

Note: When you select Recipient, the system takes the resulting grid field value or hard-coded
value and lookup to the Infor EAM user table and then the personnel table and searches for a
corresponding record. The system then takes the e-mail addresses associated with that record and
uses it where the parameter is located in the e-mail template. The system assumes you will enter
the actual % parameter in the recipient line of the e-mail template.

Defining exceptions for alerts
Define exceptions to the alert criteria. Enter the specific records that will have different alert criteria
than all of the other records to be analyzed by the grid query.

To define exceptions for alerts:

1 Select Administration > Setup > Alert Management.
2 Select the alert for which to create an exception, and then click the Exceptions tab.
3 Click Add Record.
4 Specify this information:

Grid Key 1
Enter the actual value expected in the grid result for which to define exceptions.

Note: This LOV is defined by Exception Entity on the Record View page.
You may make your own key fields without using system entity values.

Grid Key 2
Enter the actual values expected in the grid result for which to define exceptions.

Note: The actual values from the grid result for Grid Key 1 and Grid Key 2 should be used in the
columns that are mapped to Grid Key Field 1 and Grid Key Field 2 on the Record View page, e.g.,
equipment and equipment organization would be mapped on the Record View page, and then on
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the Exceptions page the values of HVAC-ROOFTOP-01 and ATLANTA would display for the actual
values for which to set up exceptions.

Delay Between Alerts
Enter the numerical amount of time between alerts for a specific grid key value, and then select
the delay UOM, or unit of time to delay between alerts, e.g., enter 2 and then select Hours to allow
2 hour delays between the alerts.

Note: This delay overrides both delays for work order alerts and e-mail alerts for the Grid Key 1
value specified.

Trigger within Min/Max Values
Select to trigger alerts when the result value is within the Min Value and Max Value.

Min Value
Enter the minimum value for Grid Key Field 1. The system produces alerts when the result of
Min/Max Value is less than or equal to the minimum value.

Max Value
Enter the maximum value for Max Value. The system produces alerts when the result of Min/Max
Value is greater than or equal to the maximum value.

5 Click Submit.

Note: The system overrides any data in Min Value or Max Value specified on the Record View
page of the Alerts form for the Grid Key 1 value specified.
If Use Min/Max is not selected on the Record View page, the system ignores the min/max data
specified on the Exceptions page.

Viewing alert history
View the failure and success records for an alert.

To view alert history:

1 Open the Administration > Setup > Alert Management.
2 Select the alert for which to view history, and then click the History tab.
3 View the history.

Note: For work order type history records, double-click the history record to hyperlink to the Work
Orders form. View the information, and then click Close or Return to close the Work Orders form
and return to the History page.
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Creating region codes
Create and update region codes for tracking degree days.

To create and edit region codes:

1 Select Administration > Setup > Regions.
2 Click New Record.
3 Specify this information:

Region Description
Enter a unique description for the region.

Postal Code
Enter the postal code for the specific region.

Region
Enter a name for the new region.

Organization
Select an organization for the region.

Class
Select a class for the region.

Out of Service
Select to designate this region as out of service.

Degree Day Reference Point
Enter a value for the degree day reference point.

Actual Temperatures Source
Select the source which supplies the actual temperature data, e.g., National Climatic Data Center
or World Weather Online.

Actual Temperatures URL
Enter the URL for the Actual Temperature Source.

Fahrenheit
Select to designate Fahrenheit as the default unit of measure for degree day data.

Celsius
Select to designate Celsius as the default unit of measure for degree day data.

4 Click Save Record.
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Recording actual temperatures for regions
Record actual temperature data for heating degree days and cooling degree days for each day of the
year.

To record actual temperatures:

1 Select Administration > Setup > Regions.
2 Select the region for which to record actual temperatures, and then click the Actual Temperatures

tab.
3 Click Add Actual Temperature.
4 Specify this information:

Date
Enter the date for which to record actual temperatures. The system automatically populates Day
of Year, Month, Day, and Year.

Temperature Minimum
Enter the minimum temperature for which to record actual temperature data.

Temperature Maximum
Enter the maximum temperature for which to record actual temperature data.

Note: The system re-calculates and automatically populates Temperature Average, Heating
Degree Days, and Cooling Degree Days.

5 Click Submit.

Note: To delete actual temperature data for a specific date, select the actual temperature record
for which to delete, and then click Delete Actual Temperature.
To purge actual temperature records to a specific date, click Purge Actual Temperature Records.
To get actual temperature for specific dates, click Get Actual Temperatures.

Updating historical temperatures for regions
Update historical data for heating degree days and cooling degree days for each day of the year.

To update historical temperatures for regions:

1 Select Administration > Setup > Regions.
2 Select a region code for which to update historical temperatures, and then click the Historical

Temperatures tab. The system automatically populates Temperature Average, Day of Year,
Month, and Day.

3 Specify this information:

Temperature Minimum
Enter the new minimum temperature.
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Temperature Maximum
Enter the new maximum temperature. The system re-calculates and automatically populates
Temperature Average, Heating Degree Days, and Cooling Degree Days.

4 Click Submit.

Getting actual temperatures for regions
Get actual temperatures for regions from a weather source such as the National Climatic Data Center
or World Weather Online.

Note: To get actual temperatures, Actual Temperatures Source and Actual Temperatures URL
both must be entered on the Record View of the region.

To get actual temperatures for regions:

1 Select Administration > Setup > Regions.
2 Select the region for which to get actual temperatures, and then click the Actual Temperatures

tab.
3 Click Get Actual Temperatures.
4 Specify this information:

Get Temperatures From
Enter the first date for which to get actual temperatures.

Get Temperatures To
Enter the last date for which to get actual temperatures.

5 Click Submit.
6 Click Close.

Purging actual temperature records for regions
Purge actual temperature records to a specific date.

To purge actual temperature records for regions:

1 Select Administration > Setup > Regions.
2 Select the region for which to purge actual temperatures, and then click the Actual Temperatures

tab.
3 Click Purge Actual Temperature Records.
4 Specify this information:

Up To Date
Enter the date for which to purge the system of all records up to and including this date.
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5 Click Submit.

Printing temperature analysis chart
Before you can set the parameters to generate the temperature analysis chart, you must enter
Temperature Minimum and Temperature Maximum on the Actual Temperatures and Historical
Temperatures tabs.

To print temperature analysis chart:

1 Select Administration > Setup > Regions.
2 Select the region for which to generate the temperature analysis chart, and then click the

Temperature Analysis Chart tab.
3 Specify this information:

Start Date
Specify the starting date for which to retrieve data.

End Date
Specify the ending date for which to retrieve data.

4 Click Submit.
5 Click Print.

Configuring Infor EAM to generate Oracle Forms
reports
Configure Infor EAM to run reports that are in the Oracle Forms version of the product, e.g., the Print
work order cards report (WRJOBF). See Chapter 15 Module Reports of the Infor EAM Oracle Forms
Installation & Upgrade Guide for more information about the reports that are available in the Oracle
Forms version of the product.

Note: You can only configure Infor EAM to generate Oracle Forms reports if you have installed,
configured, and are running both Infor EAM and the Oracle Forms version of the product.

Creating report organization structures
Create an organizational tree-structure to roll up reporting on performance statistics, energy consumption,
and resource utilization. Define an organizational structure by which you control the roll-up of energy
consumption. For example, the reporting structure might roll up like this:
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Operational Area > Facility > Campus > State > Country > Continent > Worldwide

To create a report organization structure:

1 Select Administration > Setup > Report Organization Structure.
2 Click Add Top Level Organization.
3 Specify this information:

Organization
Enter the organization to designate as the top level organization of the structure. Available
Organizations are shown in the right-hand pane.

4 Drag and drop desired organizations to the Report Organization Structure on the left-hand pane
under the Top Level Organization previously selected.

Creating the Oracle Forms report configuration for Infor
EAM
To create the Oracle Forms report configuration for Infor EAM:

1 Locate the [ORACLEHOME]\forms\server directory.

Note: The directory path follows Windows style notation; however, if you are using UNIX, the file
path follows the same directory structure with UNIX style notation.

2 Open the formsweb.cfg file in a text editor.
3 Create a baseHTMLjinitiator parameter that includes the value of the base Java Initiator page

according to the following example:

[d7irep]
envfile=D7i.env
baseHTMLjinitiator=7irep.htm

4 Save and exit the file.

Setting up enterprise searches
An enterprise search allows the capability to search across an entire system of database table records
or repositories. Define the search criteria for the enterprise search lookup capability across the system
by first creating interest centers.

Interest Centers are categories by which to group the search results of the repositories in the Enterprise
Search popup or on the Repositories tab.
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To set up an enterprise search:

1 Select Administration > Enterprise Search Setup.
2 Specify a description of the interest center.
3 Specify this information:

Interest Center Category
Specify a category for the interest center, e.g., if you specify Work Module as a category, the
search results on the Repositories tab will include work order activities, work order parts, service
requests, work orders, employees, employee availability, and other records associated with the
work module.

4 Click Save Record.
An Interest Center Code is assigned.

Setting up repositories for enterprise searches
A repository is a structured location for system data storage. It is used to map a table, user function,
or tab records from which to search during an enterprise system search. Repositories are grouped by
interest centers on the Record View tab.

To set up a repository for an enterprise search:

1 Select Administration > Enterprise Search Setup.
2 Select the interest center for which to set up a repository, and then click the Repositories tab.
3 Click Add Repository.
4 Specify this information:

Repository
Specify a name for the repository, and then enter a description of the repository.

Table Name
Specify the table name for the repository.

User Function
Specify the user function for the repository.

Tab
Specify the tab for the repository.

Thumbnail
Specify a URL location for the thumbnail.

5 Select the Out of Service check box to exclude the repository records from the enterprise search.
6 Click Submit.
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Defining repository columns for enterprise searches
A repository column contains the fields, layout, and sort order of the repository to be used in an enterprise
search.

To define a repository column for an enterprise search:

1 Select Administration > Enterprise Search Setup.
2 Select the interest center for which to define repository columns, and then click the Repository

Columns tab.
3 Select the repository for which to define columns, and then click Add Column.
4 Specify this information:

Column Name
Specify the column name.

Display Order
Specify the order in which the column will display in the repository table.

Alias
Specify an alias for the column.

Facet
Specify a facet to categorize the column name. Multiple column names can have the same facet.

5 Click Submit.

Generating enterprise search definitions
Use this screen to generate repositories and their associated interest centers. Export the repositories
and interest centers that you set up on the Enterprise Search Setup screen. Once you export the items,
upload the zip file to the Infor Enterprise Search.

1 Select Administration > Enterprise Search Setup > Generate Enterprise Search Definitions.
2 Select the repository records to export, and then click Download.
3 Use the Infor IES tool to upload the definitions.zip file to EAM. Browse to

https://<ies_install_server>.infor.com:21000/ies/admin.

Customizing extensible framework
Add business-specific functionality to existing screens/tabs in the product by creating custom JavaScript
files.

To customize extensible framework:

1 Select Administration > Screen Configuration > Extensible Framework.
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2 Specify this information:

Name
Specify a unique name to identify the screen customization.

Screen
Specify the user function mnemonic code of the screen to customize.

3 Specify the Source code to customize the screen.
4 Select the Active check box to execute the JavaScript changes to the screen in EAM.
5 Click Save Record. Navigate to the screen to view the changes.

Infor EAM System Administrator Guide | 75

 

System configuration



76 | Infor EAM System Administrator Guide

 

System configuration



2System security

Define users and users groups to ensure limited, password-controlled access to the system. Increase
screen-level security using interface permissions and Work Order authorization permissions.

Note: This chapter describes Infor EAM functions that only a system administrator has rights to perform.

Implementing multi-organization security (MOS)
Multi-organization security (MOS) is a feature that allows the system administrator to set up separate,
secured, logical databases within the organization. There is one logical database for each organization;
however, there is still one physical system database. To activate MOS, you must set the MULTIORG
installation parameter to YES.

See "Defining Installation Parameters" on page 15.

After activating MOS, you cannot deactivate it. Depending on the type of security set up, the system
does not allow users to view or influence data from organizations to which they do not belong.

With MOS, the system becomes more user-driven, rather than user-group driven, making it possible
for users to have different roles. Associate users with more than one organization and establish a
default organization for that user. The system automatically displays the user’s default organization at
login, which can be changed to any organization to which the user has access. To switch organizations
after login, simply log out and log back in as the new organization. After logging in to a specific
organization, users can view and influence data specific to all the organizations to which they have
access and all information defined as "common," which is information accessible across all organizations
and users.

When inserting new records, the system automatically associates the record to the organization of the
current login session; however, users can change the organization to any organization to which they
have access.

MOS replaces facility security. Therefore, if you do not use MOS, the system does not
displayOrganization on any forms.

Note: MOS affects many system functions, and some sections in the user documentation apply only
to MOS.
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Defining organizations
Define organizations within your enterprise. You can also edit organizations as necessary.

To define organizations:

1 Select Administration > Security > Organizations.
2 Click New Record.

Note: You cannot insert a new organization record if you have multi-organization security set to
NO.

3 Specify this information:

Organization
Specify a code identifying the organization, and then enter a description of the organization in the
adjacent field.

Currency
Specify the currency to attach to the organization.

DUNS Number
Specify your organization’s DUNS number. A DUNS number is a unique nine-digit sequence used
as the universal standard for identifying and tracking businesses worldwide.

Set of Books Name
Specify the name for your general ledger books.

Choose one of the following options for invoice matching:

• Match Tolerance Absolute
Specify the absolute amount allowed as the difference between the purchase order line cost and
the invoice line cost when matching line costs. If no value is specified, the system automatically
sets the value to 0.

• Match Tolerance %
Specify the percentage allowed as the difference between the purchase order line cost and the
invoice line cost when matching cost lines. If no value is specified, the system automatically sets
the value to 0.

• Match Quantity Tolerance %
Specify the percentage allowed as the difference between the purchase order line quantity and
the invoice line quantity when matching line quantities. If no value is specified, the system
automatically sets the value to 0.

Locale
Select the number format to use based on the geographic location of your organization/enterprise.
Selecting a locale determines the manner in which commas and decimals are used in numeric
data. The setting of the LOCALE installation parameter determines the default locale for all users.
However, selecting a locale at the organization level overrides the setting of the LOCALE installation
parameter of the logged in user.
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Code Reference
Specify the code identifying the code reference for the organization.

Server Time Offset
Specify the number of hours difference between the system server and your local time if the system
server is in a different time zone.

Account Segment Value
Specify the general ledger account code segment that represents the organization in your accounting
structure. See your chart of accounts for more information.

Accounting Entity
Specify an accounting entity for the organization.

Depreciation Type
Select the depreciation type for assets within the organization. Depreciation Type is automatically
based on the setting of the ASDEPTYP installation parameter. However, selecting a depreciation
method at the organization level overrides the setting of the ASDEPTYP installation parameter.

Common
Select to indicate that the organization is common, that is the system shares information defined
for this organization among all organizations.

Note: After defining an organization as common, you cannot change it to be a specific organization.
You cannot delete common organizations.

Calendar Group
Specify the calendar group of the organization to determine periods of availability for associated
equipment.

4 Click Save Record.

Adding enterprise locations to organizations
Add, change, or delete enterprise locations on the organizations screen.

To add enterprise locations:

1 Select Administration > Security > Organizations.
2 Select an organization to which to add an enterprise location, and then click the Enterprise Locations

tab.
3 Click Add Enterprise Location.
4 Specify this information:

BOD Group
Select a BOD Group from the list.

Enterprise Location
Enter a unique name identifying the enterprise location.
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5 Click Submit.

Adding options for organizations
Enter, update, and delete parameter option values at the organization level.

For a comprehensive list of organization options, see "Organization options" on page 257.

To add options to organizations:

1 Select Administration > Security > Organizations.
2 Select the organization for which to add options, and then click the Options tab.
3 Click Add Option.
4 Specify this information:

Option
Specify the option to specify for the organization.

Description
Specify a description of the option.

Value
Specify the value of the option, e.g., S.

5 Click Submit.

Defining fiscal years for asset depreciation
Create fiscal years to indicate the fiscal periods on which to base asset depreciation. When defining
fiscal years for an organization, you cannot create any gaps or overlaps between fiscal year periods.

After defining fiscal years, you can update them as necessary. However, updating an existing fiscal
year can invalidate records associated with equipment for which unit of output is the depreciation
method.

See the Infor EAM User Guide.

To define fiscal years for asset depreciation:

1 Select Administration > Security > Organizations.
2 Select the record for which to define fiscal years, and then click the Fiscal Years tab.
3 Click Add Fiscal Year.
4 Specify this information:

Start Date
Enter the date on which the fiscal year begins.
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End Date
Enter the date on which the fiscal year ends.

5 Click Submit.

Note: To delete a fiscal year, select the fiscal year to delete, and then click Delete Fiscal Year.
Deleting an existing fiscal year deletes records associated with equipment for which unit of output
is the depreciation method.
To recalculate depreciation details for the equipment, click Recalculate Depreciation Details.

Activating multi-organization security
Using multi-organization security (MOS), establish record-level security for system forms depending
on the organization of the record. To utilize record-level security for a form, first activate MOS capability
for the entity associated with each function.

Example:

The system user "John" is associated with Infor EAM user group 1 and Infor EAM user group 2. User
group 1 is associated with Organization 1 and User group 2 is associated with Organization 2. User
group 1 has full access rights to the Equipment form; User group 2 has query-only rights to the Equipment
form. When the system user "John" opens the Equipment form and queries for an equipment record,
the system displays only records having organizations to which John has access, and each record
retains the permissions of the organization associated with the equipment. Therefore, if the organization
of the equipment is Organization 1, John will have full access rights to the record. However, if the
organization is Organization 2, John can only view the record.

Note: You cannot establish record-level security for the equipment unless the MULTIORG installation
parameter is set to YES.
See "Defining installation parameters" on page 15.

To activate multi-organization security:

1 Select Administration > Security > Multi-org Security.
2 Select the entity for which to activate multi-organization security, and then click the Multi-org check

box.

Note: After activating an entity for MOS, it cannot be deactivated.
You can select additional Multi-org check boxes to activate multi-organization security for multiple
entities.

3 Click Save Record.
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Setting up user groups
Set up user groups so that people who perform similar tasks within the organization have the same
privileges. In the system, you can copy the header and child information from one user group to another.
You can also edit user groups as necessary.

The system is automatically configured with the R5 user group, which contains one user. The R5 user
group has full access to all functions, including data setups, system setups, and system administration
setups. After installing Infor EAM, change the user password immediately. Only the system administrator
should have access to this user.

Note: After setting up users within a user group, the system administrator cannot delete the group. To
delete a group, all associated records must be deleted first. Infor strongly discourages using the
predefined R5 user group as a default user group because menus and authorizations of this group
might be replaced during system upgrades.

Creating user groups
To create user groups:

1 Select Administration > Security > User Groups.
2 Click New Record.
3 Specify this information:

User Group
Enter a unique code identifying the user group, and then enter a brief description of the user group
in the adjacent field.

Class
Enter a class code for the user group. The system automatically populates Class Org.

Infor EAM Requestor
Select to indicate that this user group performs Infor EAM Requestor functions.

Note: The Requestor user group may only submit work requests and/or purchase requests.
When you change the value of the Requestor checkbox, the system clears Copy From.

Copy From
Enter, from the list of previously defined groups, the ID of the group from which to copy menus,
permissions, and status authorizations to the user group.

Note: For user groups that need extensive system privileges, enter the R5 user group, and then
turn off the unnecessary permissions.
If you do not enter a user group, the system automatically copies menus, permissions, and status
authorizations from the R5 user group.
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Default WO Type
Enter the default work order type for the user group. The system automatically assigns the selected
type as the default work order type for the user group on various forms within the system.

Department
Enter a default department for the user group.

Session Timeout (minutes)
Enter the amount of time in minutes in which the system will timeout.

Corrections Allowed
Select to allow users to make corrective hour bookings in the work management module.

4 Click Save Record.

Viewing users
After setting up new system user groups, view the users that are associated with user groups on the
User Groups form.

To view users:

1 Select Administration > Security > User Groups.
2 Select the user group for which to view users, and then click the Users tab.
3 View the user information.

Granting interface permissions to user groups
Specify the functions to which user groups have access and specify the permission levels for each
function.

To grant interface permissions to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant interface permissions, and then click the Interface

Permissions tab.
3 Click Add Permission.
4 Specify this information:

Function
Enter the function to set up for this user group. The system automatically populates the function
description.

Select one or more of the following options to determine the level of interface permissions for the
user group:

• Query
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Select to allow users to retrieve records.

• Update
Select to allow users to update records. Users must have query permission to update records.

• Insert
Select to allow users to insert new records.

• Delete
Select to allow users to delete records. Users must have query permission to delete records.

Note: When you unselect Query, the system automatically unselects Update and Delete.
When you select either Update or Delete, the system automatically selects Query.

5 Click Submit.

Adding inboxes to user groups
To add inboxes to a user group:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add an inbox, and then click the Inbox tab.
3 Click Add Inbox.
4 Specify this information:

Inbox
Enter the inbox name. The system automatically populates the inbox description.

5 Click Submit.

Adding KPIs to user groups
To add KPIs to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add a KPI, and then click the KPI tab.
3 Click Add KPI.
4 Specify this information:

KPI
Enter the KPI name. The system automatically populates the KPI description.

5 Click Submit.
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Adding charts to user groups
To add charts to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add a chart, and then click the Charts tab.
3 Click Add Chart.
4 Specify this information:

Chart
Enter the chart to add to the user group. The system automatically populates the chart description.

5 Click Submit.

Granting work order authorization permissions to user groups
Specify the web services to which user groups have access and specify the permission levels for each
web service.

Note: You only need to grant work order authorization permission to user groups if the JTAUTH
installation parameter is set to YES.

To grant work order authorization permissions to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant work order permissions, and then click the WO

Authorizations tab.
3 Click Add Authorization.
4 Specify this information:

WO Type
Select the work order type for which to grant permissions.

Select one or more of the following options to determine the level of work order permissions for the
user group:

• Insert
Select to allow users to insert new work order records of this type.

• Update
Select to allow users to update work order records of this type. Users must have query permission
to update records.

• Delete
Select to allow users to delete work order records of this type. Users must have query permission
to delete records.

5 Click Submit.
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Granting store transaction permissions to user groups
Grant permissions for user groups to perform store transactions such as issuing and returning parts,
transferring parts to stores, inserting physical inventory transactions, and updating stock records for
parts.

To grant store transaction permissions to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant store transaction permissions, and then click the Store

Security tab.
3 Click Add Store.
4 Specify this information:

Store
Enter the store for which to grant security rights. The system automatically populates the store
description and Store Org.

Issues/Returns
Select to allow users to issue parts from this store and to return parts to this store.

Store-to-Store Issues (From Store)
Select to allow users to transfer parts from this store on the Quick Store-to-Store Transfer form
and the Store-to-Store Issues form.

Store-to-Store Receipts (To Store)
Select to allow users to transfer parts to this store on the Quick Store-to-Store Transfer form and
on the Store-to-Store Receipts form.

PO Receipts/Supplier Returns
Select to allow users to insert, update, or delete PO receipts for this store on the PO Receipts form
and on the Supplier Returns form.

Physical Inventory
Select to allow users to insert or update physical inventory transactions for this store on the Physical
Inventory form.

Non-PO Receipts
Select to allow users to insert, update, or delete non-PO receipts for this store on the Non-PO
Receipts form.

Create Stock Records with Qty > 0
Select to allow users to add a new record to the Stock page of the Parts form with Qty. > 0 or Qty.
for Repair > 0.

Update Stock Records
Select to allow users to update Qty. on Hand on the Stock page of the Parts form.

Scrap Parts from Stock
Select to allow users to scrap parts directly on the Scrap popup.
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5 Click Submit.

Creating security filters
The system includes the ability for system administrators to create a security filter using the Dataspy.
A security filter enables you to filter which records users can see.

For example, you can create a security filter on the Work Orders form and then assign the security
filter to a user group. The result is that members of the user group cannot see records that are not
included in the security filter. So if the Security Filter is set to display all work orders with a Status of
Released, then when the user opens the Work Orders form, no matter what personal Dataspy or quick
filter they run, they will never be able to see records that have a Statusother than Released. Users
cannot disable a security filter.

To create a security filter, select Security Filter on the Dataspy Filter view. Security Filter is only
displayed for users who are in the R5 user group, and it is disabled for system-delivered Dataspies.

For information about basic Dataspy functions, see the Infor EAM User Guide.

After creating a security filter, assign the security filter to a user group.

See "Granting Screen-Level Permissions to User Groups" on page 87.

Granting screen-level permissions to user groups
Grant screen-level permissions for data manipulation. Screen authorization for user groups is critical
to database security and data integrity.

Note: Because even the system administrator can be locked out of Infor EAM, it is important to allow
at least one other person, in addition to the system administrator, permission to the Users form.

To grant screen-level permissions to user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant screen-level permissions, and then click the Screen

Permissions tab.
3 Click the plus sign (+) beside the menu and/or submenu you wish to view. The system expands the

menu and/or submenu and displays the folders and screens that reside at various levels below the
main menu and/or submenu structure.
See "Setting up menus for user groups" on page 88 for more information about the user group
security hierarchy.

Note: Click the minus sign (-) to collapse the menu.

4 Select the screen to which to apply screen-level permissions. Screen Permissions becomes
unprotected.

Note: If a screen has tabs in addition to a List View page and Record View page, select the tab
to which you want to apply screen-level permissions.
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Tab Available and Tab Always Displayed become unprotected if the tab is available at the screen
level.
If you select a screen or tab that has system-defined security, certain fields will remain protected.
For example, the Issue/Return Parts deletes are not allowed.

5 Select one or more of the following attribute options to determine the level of permissions authorized
for the user group:

DescriptionCheck box

Select to allow users to retrieve data from the
database.

Query

Select to allow users to insert new data into the
database.

Insert

Select to allow users to update data previously
retrieved from existing records in the database.

Update

Users must have query permission to update
database information.

Select to allow users to delete data from the
database. Users must have query permission to
delete data from the database.

Delete

Select to make a tab available to the user group.Tab Available

Select to display the tab to the user group at all
times.

Tab Always Displayed

Note: If the user group has Insert or Update permissions to a screen, the user group must also have
Query permissions to that screen.

Note:  When you unselect Query, the Update and Delete check boxes are unselected.
When you select Tab Always Displayed, Tab Available is selected.

6 In Security Filter, specify the necessary Dataspy to prevent the user group from accessing specific
records.
See "Creating security filters" on page 87.

7 Click Submit.

Setting up menus for user groups
Set up menus on the Menus tab of the User Groups page. Creating a menu structure for user groups
is critical to database security and data integrity. The menu structure is displayed in a tree structure
that extends to four levels: one Main Menu level, two Sub-Menu levels, and one Screen level. The
Main Menu level may contain up to seven items. The Sub-Menu level may contain up to 30 items, and
the items may be a mix of folders and screens. Finally, the Screen level may contain up to 30 items,
but the items must be screens.
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To set up menus for user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to set up menus, and then click the Menus tab.
3 View the tree structure, and then click the plus sign (+) beside the menu and/or sub-menu you wish

to view. The menu and/or sub-menu are expanded, and then the folders and screens that reside at
various levels below the main menu and/or sub-menu are displayed.

Note: Click the minus sign (-) to collapse the menu.

4 In Available Screens, select the screen to add to the menu structure.
5 Drag and drop the screen name into the desired menu structure location on the tree structure. The

number of screens applied to the menu structure are verified. If less than 30 screens exist, the
screen is added to the tree structure and expanded to illustrate the level of the screen as necessary.
Also the screen is inserted into the Screen Permissions table and the Tab Permissions table as
necessary.

Note: If you drop a screen into a sub-menu folder, the screen is added as the last child of the
sub-menu folder. If you drop a screen to another screen, the screen is added directly below the
existing screen.
You may also drag and drop main menu folders, sub-menu folders, and screens within the tree
structure. You cannot make a higher-level item subordinate to a lower-level item, i.e., you cannot
move a main menu folder to the Screen level.
When you delete a menu item, the screen is also deleted from the Screen Permissions table and
the Tab Permissions table as necessary.

Showing menu items
Show a folder, screen, or tab that is hidden in the tree structure.

To show menu items:

1 Select Administration > Security > User Groups.
2 Select the user group for which to show menu items, and then click the Menus tab.
3 Select the folder, screen, or tab to show, and then click Show Menu Item.
4 Click Save Record.

Hiding menu items
Hide a folder, screen, or tab that is displayed in the tree structure.

To hide menu items:

1 Open the User Groups form.
2 Select the user group for which to hide menu items, and then click the Menus tab.
3 Select the folder, screen, or tab to hide, and then click Hide Menu Item.
4 Click Save Record.
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Adding main menu folders
To add main menu folders:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add main menu folders, and then click the Menus tab.
3 Select the main menu-level menu structure to which to add a folder, and then click Add Main Menu

Folder. The system checks to determine if a main menu-level menu structure is selected on the
tree structure and displays the Add Main Menu Folder popup.

Note: You cannot add a main-menu folder to the Sub-Menu or Screen level.

4 Specify this information:

Label
Enter the name of the new folder.

5 Click Submit.

Note: The system adds the main-menu folder directly below the existing main-menu item.

Adding sub-menu folders
To add sub-menu folders:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add sub-menu folders, and then click the Menus tab.
3 Select the main menu folder or sub-menu folder menu structure to which to add a folder, and then

click Add Sub-Menu Folder. The system checks to determine if a main menu folder or sub-menu
folder menu structure is selected on the tree structure and displays the Add Sub-Menu Folder popup.

Note: You cannot add a sub-menu folder to the Screen level.

4 Specify this information:

Label
Enter the name of the new folder.

5 Click Submit.

Note: If you add a sub-menu folder to a main-menu folder, the system adds the sub-menu folder
as the last child of the main-menu folder. If you add a sub-menu folder to another sub-menu folder,
the system adds the screen directly below the existing sub-menu folder.

Changing label names
Change the label name of any menu item in the tree structure.

To change label names;
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1 Select Administration > Security > User Groups.
2 Select the user group for which to change label names, and then click the Menus tab.
3 Select the menu item for which to change the label name, and then click Change Label.
4 Specify this information:

New Label
Enter the new label of the menu item.

5 Click Submit.

Changing screen tab orders
Change screen tab orders to change the order that the tabs appear on the screen.

To change screen tab orders:

1 Select Administration > Security > User Groups.
2 Select the user group for which to change screen tab orders, and then click the Menus tab.
3 Select the screen for which to change the tab order, and then click Change Tab Order.
4 Specify this information:

Error Message
The system displays any error messages associated with the tab.

5 Click Submit.

Copying menus
Copy menus from one user group to another user group.

To copy menus:

1 Select Administration > Security > User Groups.
2 Select the user group to which to copy menus, and then click the Menus tab.
3 Click Copy Menu. The system automatically populates To Group with the current user group.
4 Specify this information:

From Group
Enter the the user group from which to copy the menu.

5 Click Submit.

Viewing form-level help
View form-level help. Learn more information about the form, i.e., what the form is, how it is used, etc.

To view form-level help:
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1 Select Administration > Security > User Groups.
2 Click the Menus tab.
3 Select the screen for which to view help, and then click Help.
4 View the help information.

Setting up scanner menus for user groups
Set up scanner menus on the Scanner Menus page of the User Groups form to associate prompts
to a menu structure. In the system, the menu structure is displayed in a tree structure that extends to
three levels: the Main Menu level, Sub-Menu level and DC Prompt, and Web Service Prompt level.

In order to create folders of the menu structure, you must first create a screen for each folder.

See "Creating and Modifying Screens" on page 17.

To set up scanner menus for user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to set up scanner menus, and then click the Scanner Menus tab.
3 View the tree structure, and then click the plus sign (+) beside the menu and/or sub-menu you wish

to view. The system expands the menu and/or sub-menu and then displays DC Prompts and Web
Service Prompts that reside at various levels below the main menu and sub-menu.

Note: Click the minus sign (-) to collapse the menu.

4 Specify a Dataspy or Filter as necessary.
5 Under All Available Prompts select the prompt to add to the menu structure.
6 Drag and drop the prompt into the desired menu structure location on the tree structure. The system

also inserts the prompt into the Screen Permissions table.

Note: If you drop a prompt into a sub-menu folder, the system adds the prompt as the last child of
the sub-menu folder. If you drop a prompt to another prompt, the system adds the prompt directly
below the existing prompt.
You may also drag and drop main menu folders, sub-menu folders, DC prompts, and Web Service
prompts within the tree structure. You cannot make a higher-level item subordinate to a lower-level
item, i.e., you cannot move a main menu folder to the DC Prompt or Web Service Prompt level.
To delete a menu item, select the menu item to delete, and then click Delete Menu Item. The system
deletes the record and updates the tree structure. The system also deletes the prompt from the
Screen Permissions table as necessary.

Adding scanner main menu folders
To add scanner main menu folders:

1 Select Administration > Security > User Groups.
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2 Select the user group for which to add scanner main menu folders, and then click the Scanner
Menus tab.

3 Select the main menu-level menu structure to which to add a folder, and then click Add Main Menu
Folder. The system checks to determine if a main menu-level menu structure is selected on the
tree structure and displays the Add Main Menu Folder popup.

Note: You cannot add a main-menu folder to the Sub-Menu, DC Prompt, or Web Service Prompt
level.

4 Specify this information:

Menu Code
Enter the name of the new folder. The system automatically populates Description.

5 Click Submit.

Note: The system adds the scanner main-menu folder directly below the existing scanner main-menu
item.

Adding scanner sub-menu folders
To add scanner sub-menu folders:

1 Select Administration > Security > User Groups.
2 Select the user group for which to add scanner sub-menu folders, and then click the Scanner Menus

tab.
3 Select the main menu folder or sub-menu folder menu structure to which to add a folder, and then

click Add Sub-Menu Folder. The system checks to determine if a main menu folder or sub-menu
folder menu structure is selected on the tree structure and displays the Add Sub-Menu Folder popup.

Note: You cannot add a scanner sub-menu folder to the DC Prompt or Web Service Prompt level.

4 Specify this information:

Menu Code
Enter the name of the new folder. The system automatically populates Description.

5 Click Submit.

Note:  If you add a scanner sub-menu folder to a scanner main-menu folder, the system adds the
scanner sub-menu folder as the last child of the scanner main-menu folder. If you add a scanner
sub-menu folder to another scanner sub-menu folder, the system adds the scanner sub-menu folder
directly below the existing scanner sub-menu folder.
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Defining status authorizations for user groups
System administrators define status change authorizations for user groups for activities such as
approving work requests, completing work orders, approving purchase requisitions, and approving
production requests.

To define status authorizations for user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant status change authorizations, and then click the Status

Authorizations tab.
3 Click Add Authorization.
4 Specify this information:

Screen
Select the screen for which to define status authorizations.

From Status
Enter the status from which to change authorizations. The system automatically populates the
description.

To Status
Enter the status to which to change authorizations. The system automatically populates the
description.

5 Click Save Record.

Administering iProcure security for user groups
Administer iProcure security for user groups by specifying which iProcure buttons the system enables
security.

To administer iProcure security for user groups:

1 Select Administration > Security > User Groups.
2 Select the user group for which to administer iProcure security, and then click the iProcure Security

tab.
3 Specify this information:

Active
Select to administer iProcure security per button. By selecting Active for a user group, the system
denies the user group access to the specified button functionality.

Note: Unselect Active to turn off security per button. By unselecting Active for a user group, the
system grants the user group access to the specified button functionality.

4 Click Save Record.
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Viewing menu structure and permissions for user groups
View user group permissions such as which user groups have access to specific screens, reports, or
tabs. Verify security filters assigned to applicable user groups, or find screens and/or report locations
in menu structures.

To view menu structure and permissions for user groups:

1 Select Administration > Overview > Menu Structure and Permissions.
2 View the menu structure and permissions information for user groups.

Setting up Mobile menus in Infor EAM
Infor EAM Mobile menus can be configured in Infor EAM based on user group. The following Infor EAM
Mobile screens can be configured: Regular Mobile screen, Data Collection Prompt screen, Web Service
Prompt screen, user Defined Mobile Grid screen.

To set up Mobile menus in Infor EAM:

1 Start Infor EAM.
2 Open the User Groups form.
3 Select the user group for which to set up Mobile menus, and then click the Mobile Menus tab.
4 Click Add Main Menu Folder. A system check determines if a main menu-level menu structure is

selected on the tree structure, and the Add Main Menu Folder popup is displayed.
5 Specify this information:

Label
Type in the label for the Main Menu Folder.

6 Click Submit. The record is saved and Menu Details is updated.
7 Highlight a Main Menu Folder and click Add Sub-Menu Folder. The Add Sub-Menu Folder popup

is displayed.
8 Specify this information:

Label
Type in the label for the Sub-Menu Folder.

9 Click Submit. The record is saved and Menu Details is updated.
10 Drag Mobile screen from the Available Screens list, and then drop it in the Main Menu Folder or

Sub-Menu Folder. The record is saved and Menu Details is updated.
11 Repeat above steps to configure all menu items.
12 To show or hide a menu item, select a menu item and click Show Menu Item or Hide Menu Item.
13 To delete a menu item, select a menu item and click Delete Menu Item.
14 To change the label of an existing menu item, select a menu item and click Change Label.
15 To change the icon of the Main Menu item, select a menu item and click Change Icon. The Change

Icon popup is displayed. Type in the name of New Icon without file name extension.
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Note: Main Menu icon configuration is only available on Quarter VGA version. Only .gif and .jpg
image file types are acceptable. The image file must be available in the same folder as Mobile
executables on the Mobile device.

16 To copy a menu item, select the menu item, and then click Copy Menu.

Setting default values for user groups in Mobile
Configure the default value settings for user groups on the Infor EAM Mobile application or mobile
devices.

To set default values for user groups in Mobile:

1 Select Administration > Security > User Groups.
2 Select the user group for which to set default values in Mobile, and then click the Mobile Settings

tab.
3 Specify this Work information:

Download Work Orders
Select the checkbox to download work orders by default for the user group.
Specify the dataspy for which to download work orders in For Dataspy.

Download Employees
Select the checkbox to download employees by default for the user group.
Specify the trade, department, or employee for which to download employees for the user group
in For Trade, For Department, or For Employee.

Download Standard WOs
Select the checkbox to download standard work orders by default for the user group.

Download Inspection Results
Select the checkbox to download inspection results by default for the user group.

Download Task
Select the checkbox to download tasks by default for the user group.

4 Specify this Equipment information:

Download Equipment
Select the checkbox to download equipment by default for the user group.
Specify the department, location, class, category, equipment, or type for which to download
equipment for the user group in For Department, For Location, For Class, For Category, For
Equipment, or For Type.

Download Equipment Comments
Select the checkbox to download equipment comments by default for the user group.
Specify whether to download the equipment comments for work orders only in For Downloaded
WO only.
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Download Equipment History
Select the checkbox to download equipment history by default for the user group.
Specify whether to download equipment history for work orders only, or for the latest days in For
Downloaded WO only, or For Latest (Days).

Download Equipment Custom Fields
Select the checkbox to download equipment custom fields by default for the user group.
Specify whether to download equipment custom fields for only work orders in For Downloaded
WO only.

Download Cost Codes
Select the checkbox to download equipment cost codes by default for the user group.
Specify the class or cost code for which to download equipment cost codes in For Class or For
Cost Code.

Download Equipment History Comments
Select the checkbox to download equipment history comments by default for the user group.

5 Specify this Materials information:

Download Stores
Select the checkbox to download stores by default for the user group.

Download Parts
Select the checkbox to download parts by default for the user group.
Specify the store or part for which to downloard for parts for the user group in For Store or For
Part

In Stock and Quantity
Specify the required number of parts in stock at the default store. The number you specify here
becomes the default stock number the part must meet before the part will be download for the user
group. For example, specify 4, and only those parts with a quantity of 4 or more in stock (in the
store) will be downloaded.

Download Bins
Select the checkbox to download bins by default for the user group.
Specify the store or bin to download for bins for the user group in For Store or For Bin.

Download Physical Inventory
Select the checkbox to download physical inventory by default for the user group.
Specify the store or line to download physical inventory for the user group in For Store or For Line.

Download Supplier
Select this checkbox to download the list of suppliers by default for the user group.

Download Asset Inventory
Select the checkbox to download asset inventory by default for the user group.

Download Stock
Select the checkbox to download stock by default for the user group.
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6 Specify this Other information:

Download eSignature Settings
Select the checkbox to download the eSignature settings by default for the user group. This checkbox
determines the records displayed on the eRecords Setup screen.

Setting up users
Set up users with access to the system as members of user groups. You can also edit users as
necessary. After setting up new system users, associate them with specific organizations. When the
user logs in to the system, the default organization determines to what user group the user belongs
for that system session.

Creating users
Note: Only a certain number of users can be active for each product. This number is determined by
the CDKEY installation parameter (Infor EAM), CDKEYREQ installation parameter (Infor EAM
Requestor), 7IMCDKEY installation parameter (Infor EAM Mobile), 7IWCDKEY installation parameter
(Infor EAM Connector), and/or the 7IBCDKEY installation parameter (Infor EAM Barcoding).

To create users:

1 Select Administration > Security > User Setup.
2 Click New Record.
3 Specify this User Details information:

User ID
Specify a unique code identifying the user, and then enter a description of the user in the adjacent
field. The description is usually the user’s full name.

Language
Select the default language for the user.

User Group
Specify the user group to which the user is assigned.

User ID Expiration Date
Specify the date on which the User ID expires.

Password
Specify a six to twelve character password for the user. The password is masked with asterisks as
you type.

Note: After a set amount of unsuccessful attempts to log in, User ID and Password are locked.
At this point, the system administrator or another authorized user must unlock the user record.
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To unlock the user record, open the User Setup page, which will display the Unlock User button
(under normal circumstances, the Unlock User button is hidden). Click the Unlock User button.
The user is unlocked and the Unlock User button is hidden.

Password Expiration Date
Specify the date on which the password expires.

E-mail Address
Specify the user’s e-mail address.

External User ID
Specify an external User ID to provide an alternate method of identifying the user. The external
user ID provides the method to identify the user based on an identifier from an external system
such as Active Directory or some alternate identify provider.

Note:  External User ID must be unique for each user ID and external user ID in the system except
it can be the same as the user's User ID.

Associated Supplier
Specify the supplier to associate with the user when ordering parts.

Default Store
Specify the default store for the user from which parts will be issued or returned for work orders,
equipment, or requisitions.

Buyer
Select if the user can generate requisitions and purchase orders to buy materials/services.

Note:  Buyer must be selected for a user for the system to display the user as a potential purchaser
of materials and services in the lookups for Buyer.

Allow Dataspy Edits
Select if the user can edit Dataspies. If unselected the Edit Dataspy button is hidden throughout
the system on every form for this specified user.

Mobile Administrator
Select if the user is an administrator for Infor EAM Mobile.

Allow Dataspy Advanced Filters
Select if the user can specify advanced filters for Dataspies.

Allow Global Dataspy Configuration
Select if the user can configure global Dataspy settings for all users.

Allow Editing of Other's Comments
Select if the user can edit comments made by others.

Allow Editing of Own Comments
Select if the user can edit their own comments.
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Allow Cancelling of WO Daily Scheduling Sessions
Select if the user can cancel work order daily scheduling sessions on the WO Daily Scheduling
page.

Class
Specify the class code for the user.

Locale
Select the locale of the user.

Department
Specify the default department for the user.

Session Timeout (minutes)
Specify the amount of time in minutes in which the system will timeout.

Success Msg. Timeout
Select the amount of time in which success messages will timeout.

First Screen
Specify the code identifying the function to which the system defaults when the user logs in to the
system.

Screener
Select if the user can screen work requests.

Screen Designer
Select if the user can set up the appearance of screens.

Accessibility Mode
Select to indicate that for the user the system will operate in accessibility mode when they next log
in to Infor EAM. In Accessibility Mode the Infor EAM application is entirely keyboard-navigable
wherein the user will be required to navigate and access features via keyboard shortcuts only.
Additionally those fields with special formatting or validation will display a popup tool tip.

Note:  Accessibility Mode is designed for use with a screen reader program such as JAWS.

Allow Screen Cache Setup
Select to enable the Add to Screen Cache and Remove from Screen Cache options for the user
on available screens.

Allow Creating Import Utility Template
Select to enable the Create Import Utility Template option for the user.

Allow Viewing Audit Trail
Select to enable the Audit Trail option for the user.

Enable Screen Cache Deck
Select to enable the user to view and access the screen cache tabs at the bottom of all screens.
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Enable Transition Animations
Select to enable screen transitions for the user if the user changes screens via the Screen Cache
tabs at the bottom of a screen.

Allow Changes to Mobile Settings
Select to enable the user to make changes to settings in mobile devices.

4 Specify this Infor EAM Products information:

Infor EAM
Select to indicate that the user is an Infor EAM user.

Connector
Select to indicate that this user is an Infor EAM Connector user.

Analytics
Select to indicate that the user is an Infor EAM Analytics user.

Note:  If the Analytics user will create variables within Infor EAM, you must also select Infor EAM.

Requestor
Select to indicate that this user is an Infor EAM Requestor user.

Note: Specify the Requestor user group in User Group to associate the Requestor user with the
Requestor user group.
The Requestor user may only submit work requests and/or purchase requests.

Barcoding
Select to indicate that this user is an Infor EAM Barcoding user.

Mobile
Select to indicate that this user is an Infor EAM Mobile user.

5 Specify this Advanced Reporting Options information:

Consumer
Select to indicate that the user is a reporting consumer. The consumer license allows users to
access the consumer and basic report features.

Author
Select to indicate that the user is a reporting author. The author license allows users to access the
Report Author functionality in Infor EAM to create reports as well as access to the consumer and
basic report features.

6 Specify this User Limits information:

Requisition
Specify the maximum amount the user can enter on a requisition or requisition line.

Requisition Approval
Specify the maximum amount the user can approve for a requisition.
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Invoice Approval
Specify the maximum amount the user can approve on invoices and invoice lines.

Non-PO Inv. Approval
Specify the maximum amount the user can approve on non-purchase order invoices.

Purchase Order
Specify the maximum amount the user can enter on a purchase order or purchase order line.

PO Approval
Specify the maximum amount the user can approve for a purchase order or purchase order line.

Note: Set Requisition, Purchase Order , Requisition Approval, and PO Approval at either the
header level or the line-item level in Installation Parameters. You do not need to define them for
every user.
If you are setting up a new user in a multi-organization environment the fields are set on the
Organizations tab of the User Groups page and the Roles page.

Pick Ticket Approval
Specify the maximum amount of parts that the user can approve for pick tickets.

Note:  If multi-organization security is activated, you must define purchase order and requisition
limits on the Organization tab of the User page.

7 Click Save Record.

Note: Click Unlock User to unlock locked users and make them active in the system.
The following fields are editable on the List View tab of the User ID page: User ID, and Infor EAM.

Changing passwords
Change passwords for individual users. Passwords are encrypted in the .xml configuration files and
are preceded by '{ENCR}' in the .xml file. The following types of passwords will be encrypted: database
schema passwords, Websphere/Weblogic administrator passwords, and LDAP access-user passwords.

To change passwords:

1 Open the appropriate .xml file, and then delete the encrypted password and the ‘{ENCR}’ prefix.
2 Enter the new (unencrypted) password.
3 Redeploy the application.
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Associating users with organizations
After setting up new system users, associate them with specific organizations. When the user logs in
to the system, the default organization determines to what user group the user belongs for that system
session.

To associate users with organizations:

1 Select Administration > Security > User Setup.
2 Open the form.
3 Select the user with whom to associate the organization, and then click the Organizations tab.
4 Click Add Organization.
5 Specify this information:

Organization
Enter the organization to associate with the user. The system automatically populates the
organization’s description in the adjacent field and selects Common if the organization is a common
organization.

User Group
Enter the user group to which the user belongs.

Default
Select to indicate that this organization is the default organization for this user, i.e., the system
automatically displays this organization when the user logs in to Infor EAM and on most forms that
have an Organization lookup.

Note: The system allows only one default organization.

Requisition
Enter the user’s requisition limit.

Requisition Approval
Enter the user’s requisition approval limit.

Invoice Approval
Enter the user’s invoice approval limit.

Non-PO Inv. Approval
Enter the user’s non-purchase order invoice approval limit.

Purchase Order
Enter the user’s purchase order limit.

PO Approval
Enter the user’s purchase order approval limit.

Pick Ticket Approval
Enter the user’s pick ticket approval limit.

6 Click Submit.
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Associating users with KPIs
KPIs associated with a specific user are displayed in the KPI section of the user's Start Center. Review,
add, and remove KPIs associated with a specific user on this screen.

To associate users with KPIs:

1 Select Administration > Security > User Setup.
2 Select the user for which to associate a KPI, and then click the KPIs tab.
3 Click Insert KPI Entry.
4 Specify this information:

Sequence Number
Specify the sequence in which the KPI will be displayed in the Start Center for the user.

KPI Code
Specify the KPI to add to the Start Center for the user. Select one or more KPI codes if desired
for the specific user.

Note: If you select more than one KPI code for the user, a new sequence number is assigned to
each KPI code and these sequence numbers are generated based on the INCRLINO installation
parameter.

5 Select the Auto Refresh check box to automatically refresh the KPI every time the Start Center is
invoked for the user.

6 Click Submit.

Associating users with inboxes
Associate users with inbox entries to display entries in the inbox of the Start Center for that specific
user. Inbox entries associated with a user on this tab with display on that user's Start Center inbox.

To associate users with inboxes:

1 Select Administration > Security > User Setup.
2 Select the user for which to associate an inbox entry, and then click the Inboxes tab.
3 Click Insert Inbox Entry.
4 Specify this information:

Sequence Number
Specify a numeric value for the sequential order for the inbox entry to display.

Note: Sequential order is determined by the incremental value set by the INCRLINO installation
parameter.

Inbox Code
Specify the unique code that identifies the inbox entry. Select one or more inbox codes if desired
for the specific user.
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Note: If you select more than one inbox code for the user, a new sequence number is assigned to
each inbox code and these sequence numbers are generated based on the INCRLINO installation
parameter.

Folder
Specify the folder in which to keep the inbox based on the category.

5 Select the Auto Refresh check box to automatically refresh the inbox every time the Start Center
is invoked.

6 Click Submit.

Creating LDAP roles
Lightweight Directory Access Protocols (LDAP) can store hierarchical data definitions across platforms.
LDAP is most often used to store user credentials across many applications. Create LDAP roles for
automatic user creation.

Note: If LDAP authentication is enabled, Call Center module log ins are authenticated by Infor EAM
and LDAP settings are ignored.

To create LDAP roles:

1 Select Administration > Security > Role Setup.
2 Click New Record.
3 Specify this information:

Role
Enter a unique code identifying the role, and then enter a description of the role in the adjacent
field.

User Group
Enter the user group to which users of the role are assigned.

Note: If you enter a Requestor user group in User Group, the system automatically selects Infor
EAM Requestor and automatically unselects Infor EAM.

Default Org.
Enter the default organization of the role.

Language
Select a default language for the role.

Success Msg. Timeout
Select the amount of time in which success messages will timeout.

Infor EAM Mobile Administrator
Select if users of the role are administrators of Infor EAM Mobile.
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Locale
Select the default locale for the role.

Department
Enter a default department for the role.

First Screen
Enter the code identifying the screen to which the system defaults when users of the role log in.

Buyer
Select if the user of the role can buy materials or services.

Screener
Select if the users of the role can screen work requests.

Infor EAM
Select if the user of the role is an Infor EAM user.

Infor EAM Requestor
Select if the user of the role is a Requestor user.

Note: Enter the Requestor user group for User Group to associate the Requestor user with the
Requestor user group.
The Requestor user may only submit work requests and/or purchase requests.
You cannot select Infor EAM and Infor EAM Requestor for the same user; however, you must select
either Infor EAM or Infor EAM Requestor.

Infor EAM Connector
Select if the user of the role is a Connector user.

Infor EAM Barcoding
Select if the user of the role is an Infor EAM Barcoding user.

Infor EAM Mobile
Select if the user of the role is an Infor EAM Mobile user.

Infor EAM Analytics
Select if the user of the role is an Infor EAM Analytics user.

Consumer
Select if the users of the role are Advanced Reporting consumers.

Author
Select if the users of the role are Advanced Reporting authors.

Requisition
Enter the maximum amount users of the role can enter on a requisition or requisition line.

Requisition Approval
Enter the maximum amount users of the role can approve for a requisition or requisition line.
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Invoice Approval
Enter the maximum amount users of the role can approve on invoices and invoice lines.

Non-PO Inv. Approval
Enter the maximum amount users of the role can approve on non-purchase order invoices.

Purchase Order
Enter the maximum amount users of the role can enter on a purchase order or purchase order line.

PO Approval
Enter the maximum amount users of the role can approve for a purchase order or purchase order
line.

Pick Ticket Approval
Enter the maximum amount users of the role can approve for pick tickets.

4 Click Save Record.

Creating electronic records and signatures
The system allows you to create electronic records, or "snapshots," of events that occur in the database.
A snapshot preserves the entire record, including information related to other database tables, to
provide historical information related to the progress of your operation. For example, a snapshot of a
work order header will include all information on the header as well as the associated activities. The
system also provides the ability to print and export snapshots to external formats such as Adobe Acrobat
Portable Document Format (.PDF).

In addition to creating electronic records of information in the database, you can set up the system to
require an electronic signature to authorize status changes to specific records. The electronic signature
is attached to an entity, and when a system user changes the status of a record based on specific
criteria, the system prompts the user for an ID, password, and a reason for the signature (e.g., review,
approval, responsibility, etc.).

You can also select to associate certifications with electronic signatures to facilitate the proper
authorization of status changes by requiring authorized users to enter a certification number and
certification type when entering their signature, which is required by the Federal Aviation Administration
(FAA) for electronic signatures. The FAAMOD installation parameter determines whether you are
required to enter a certification number and certification type for electronic signatures. If FAAMOD is
set to ON, the system displays Certification Number and Certification Type on the Electronic Signature
dialog box and you must enter a valid certification number and type to sign the record.

See "Signing Records" on page 109.
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Defining entities for electronic records and signatures
Define entities to take a snapshot of the record or require an electronic signature when you change
the status of the record attached to the entity. For example, if your organization requires electronic
records of the specific stages of a purchase order, you can define the snapshot for the PORD entity.
Or, if your organization requires electronic signatures of status changes to work orders, you can define
the electronic signature for the EVNT entity. The system takes the snapshot of the record and/or prompts
you (or any user) for an ID, password, and reason when you save the change to the database.

The following table lists the entities for which you can create electronic records and signatures:

Information RecordedDescriptionEntity

Work order, activities, repairable
parts, permits

EventEVNT

Equipment and warrantiesEquipmentOBJ

Receipt and receipt linesReceiptsRECV

Return and return linesReturnsRETN

Store-to-store transaction and
lines

Store-to-StoreSTOS

Project and budgetProjectPROJ

Pick tickets and linesPick TicketPICK

Purchase order and linesPurchase OrderPORD

Requisition and linesRequisitionREQ

Invoice and linesInvoiceINV

To define entities for electronic records and signatures:

1 Select Administration > Security > eRecords Setup.
2 Click New Record.
3 Specify this information:

Entity
Select the entity for which to define electronic records and/or signatures. The system automatically
populates the entity description.

Signature Required
Select to indicate that the status change requires a signature.

From Status
Enter the old status of the entity.

To Status
Enter the new status of the entity.

4 Click Save Record.
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Signing records
Upon changing the status of a record that has been defined as requiring an electronic signature, the
system prompts you to enter a user ID, password, and reason for the signature. The user ID and
password are the same ID and password used to enter the system; however, any person with a valid
user ID and password can sign electronic records, even if they are not physically logged in to the
system. After verification of the user information, the system takes a snapshot of the record and stores
it in the database. If you update multiple records at one time, the system prompts you for a signature
for every record.

To sign records:

1 Open any form requiring electronic signatures for status changes.
2 Query for the record for which to change the status. Status changes can include record insertion,

deletions, or any specific change as defined on the eRecords Setup form.
See "Defining Entities for Electronic Records and Signatures" on page 108.

3 Change the status of the selected record, and then click Save Record.
4 Specify this information:

User ID
Enter the user ID.

Password
Enter the password associated with the user ID.

Signature Type
Enter the reason for the electronic signature, e.g., review, approval, etc. Define signature types for
the ESTP entity on the System Codes form.
See "Defining System Codes" on page 16.

Certification Number
Enter the unique certification number for the eSignature. The system automatically populates
Certification Type.

Certification Type
Modify the certification type as necessary.

Note: The FAAMOD installation parameter determines whether you are required to enter a
certification number and certification type for electronic signatures. If FAAMOD is set to ON, the
system displays Certification Number and Certification Type on the eSignature popup, and you
must enter a valid certification number and type to sign the record. The system automatically
populates Certification Type based on the selected Certification Number. Certification numbers
and types are associated with employee records on the Qualifications tab of the Employees form.
The Qualifications tab is not available in Infor EAM for SQL Server.
The system only displays certification numbers and types that are associated with training records
for which the employee is currently qualified in the lookups for Certification Number and
Certification Type.
Additionally, the system associates certification numbers and types with employees based on the
user group of the employee on the Employees form. Therefore, if FAAMOD is set to ON, you must
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select a User for each employee who is required to enter a certification number and type when
signing electronic records.

5 Click OK.

Note: If you click Cancel, the system closes the form and does not record changes.
The system does not allow changes to the record without entering an electronic signature. Further,
if you enter an invalid or expired ID and password, or if you do not enter a valid certification number
and type if applicable, or if you do not have status change authorization, the system records an
access violation and the electronic signature will not be recorded. If the number of unsuccessful
signature attempts exceeds the number specified in the SECUVIOL installation parameter, the
system locks the user. Contact your System Administrator to unlock users.

Configuring electronic records and signatures for cGMP equipment
Create electronic records and/or require electronic signatures for work performed on cGMP equipment.
Current Good Manufacturing Practices (cGMP) are a set of standards established by the United States
Food and Drug Administration (FDA) to regulate the manufacturing processes of the food,
pharmaceutical, and medical equipment industries.

Many companies have a combination of equipment regulated by cGMP standards as well as equipment
not regulated by cGMP standards. Configure the system to take a snapshot of a record or require an
electronic signature only when the work is performed on cGMP equipment.

Note: To indicate that a piece of equipment is subject to cGMP standards, select cGMP on the Record
View page of the Assets, Positions, or Systems form.

To configure the system to create electronic records and/or require signatures for only cGMP equipment,
set the CGMPONLY installation parameter to YES.

See the Infor EAM User Guide.

You must also define the electronic records/signatures for the EVNT entity on the eRecords Setup
form.

See "Defining Entities for Electronic Records and Signatures" on page 108.

If CGMPONLY is set to YES and you have configured electronic records/signatures for the EVNT entity,
the system creates an electronic record and/or requires a signature for work orders created/generated
only for cGMP equipment.

Note: If you create a PM route that is associated with a work order containing cGMP equipment, the
system creates an electronic record and/or requires a signature for the work order associated with the
cGMP equipment in the PM route. The system does not create a separate electronic record or require
a signature for each child work order on the PM route.

The electronic signatures for cGMP equipment configuration apply to work orders created/generated
for cGMP equipment using the following forms:

• Work Orders form
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• Work Orders Quick Close form
• Service Requests form
• Generate/Release Work Orders form

Granting status change authorization permissions
Users have different levels of authority within the system. For example, a manager might have authority
to approve purchase requisitions. A planner might have authority to cancel a work order. A project
manager might have authority to freeze a project.

Set up authorization levels for entity status values when records for the entity are created or when their
status is modified. Set authorization levels for user groups or individual users.

To grant status change authorization permissions:

1 Open the Status Change Authorizations form.
2 Click Add Authorization.
3 Specify this information:

User Group
Enter the user group for which to define the status change authorization. Enter * if the authorization
applies to all groups. The system automatically populates the user group description.

Note:  User Group and User cannot both have a value of *.

User
Enter the user for whom to define the status change authorization. Enter * if the authorization applies
to all users in the user group. The system automatically populates the user description.

Entity
Enter the entity over which the user has authority. The system automatically populates the entity
description.

From Status
Enter the status code the user can change. The system automatically populates the from status
description.

To Status
Enter the status code to which the user can change the old status code. The system automatically
populates the to status description.

Note:  If you want the group to have authorization over all aspects of a particular process, enter all
of the available status changes for that process. Enter * for any status and - for "No status yet" (i.e.,
to indicate a new record).

User Specific Auth.
Select to indicate that the authorization is for this user only.
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4 Click Submit.
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3Interface configuration

This chapter provides information about configuring the Infor EAM interface. Personalize the Start
Center by setting up inbox entries, KPIs, and chart controls. Modify the page layout of record view,
detail view, and list-detail view pages.

Note: This chapter describes Infor EAM functions that only a system administrator has rights to perform.

Personalizing the Start Center
Personalize the Start Center to display inbox entries and KPIs. Inbox entries notify you of changes in
the database, and KPIs measure productivity or efficiency with processes or work-related activities.

Personalizing the inbox
The inbox displays notifications (inbox entries) of changes in the system database on the Start Center.
An example of inbox entries is the number of work orders with associated warranties for which there
have been no claims submitted.

Users can open screens necessary to complete actions or activities associated with inbox entries by
double-clicking the inbox entry. For example, launch the Work Orders form directly from the inbox
entry to approve the work orders requiring approval. A Dataspy entered for inbox entries automatically
searches for and retrieves the records associated with an inbox entry to the called screen.

Inbox entries can be assigned to specific user groups, specific users, or defined as public entries that
are displayed for all users. After personalizing the inbox, set system privileges for users to modify their
inbox by adding and/or deleting entries and modifying the order and sequence in which entries are
displayed.

Setting up inbox entries
Set up inbox entries by identifying the notifications that you wish to be displayed in the inbox. Select a
SQL statement for the entry to query the database for the appropriate information to retrieve to the
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inbox. Select an appropriate screen to associate with the entry, e.g., the Work Orders form for an
inbox entry for work orders that currently require approval. Specify a Dataspy to enable the system to
automatically query for the records associated with the inbox entry to the called screen. You can also
designate whether the entry is accessible to all users (public), or specify the user groups for which to
enable the entry.

To set up inbox entries:

1 Select Administration > Start Center Setup > Inbox Setup.
2 Click New Record.
3 Specify this information:

Inbox Code
Specify a unique code identifying the the inbox entry, and then enter a description of the activity to
complete for the inbox entry in the adjacent field. The description will be displayed in the Inbox on
the Start Center.

SQL Statement
Specify the SQL statement to calculate the number of applicable records for the inbox entry. SQL
Statement Text is automatically populated.

Note:  SQL Statement cannot exceed the performance score limit defined in the INBXSCOR
installation parameter.

Public
Select to give all user groups access to the inbox entry.

Note: Inbox entries for which user groups have been associated cannot be public.

Screen
Specify the system screen for which to enable a hyperlink to call the screen for the inbox entry.

Note: If you update Screen, Dataspy is cleared.

Forms Screen
Specify the Infor EAM Oracle Forms screen for which to enable a hyperlink to call the screen for
the inbox entry.

Dataspy
Select the Dataspy used to retrieve records for the called system screen.

Filter
Specify the where clause with which to associate the inbox entry.

4 Click Save Record.

Defining inbox ranges
Define inbox ranges to specify a High Value and a Low Value for each of the scoring ranges defined
for an inbox.
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To define inbox ranges:

1 Select Administration > Start Center Setup > Inbox Setup.
2 Select the inbox for which to define ranges, and then click the Ranges tab.
3 Click Add Range.
4 Specify this information:

Low Value
Specify the value for the low threshold of the inbox range.

High Value
Specify the value for the high threshold of the inbox range.

Color
Select the color to use to display the inbox field box.

Description
Specify a description of the icon to be displayed for the inbox range on the Start Center.

5 Click Submit.

Associating inbox entries with user groups
Associate inbox entries with user groups to display entries in the inbox for only specific user groups.

Note: Inbox entries for which Public has been selected cannot be assigned to specific user groups.

To associate inbox entries with user groups:

1 Select Administration > Start Center Setup > Inbox Setup.
2 Select the inbox entry with which to associate user groups, and then click the User Groups tab.
3 Click Add User Group.
4 Specify this information:

User Group
Specify the user group to which to associate the inbox entry.

5 Click Submit.

Associating inbox entries with users
Associate inbox entries with specific users to display the entries in the inbox of the user's Start Center.
Alternately, you can review or remove a user's associated inbox entries.

To associate inbox entries with users:

1 Select Administration > Start Center Setup > Inbox Setup.
2 Select the inbox entry with which to associate an user, and then click the Users tab.
3 Click Add User.
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4 Specify this information:

User ID
Specify the user's unique ID to which to associate the inbox entry.

Note: User ID is a multi-select lookup which allows you to select more than one user to associate
to an inbox entry. If you select more than one user to associate to the inbox entry, a new sequence
number is assigned to each user, and these sequence numbers are generated based on the
INCRLINO installation parameter.

Folder
Specify the folder in which to keep the inbox based on the category.

5 Select the Auto Refresh check box to automatically refresh the inbox every time the Start Center
is invoked for this specific user.

6 Click Submit.

Personalizing KPIs
The Start Center displays key performance indicators (KPIs) and their scores for users. KPIs are
user-defined parameters that measure productivity or efficiency associated with processes and/or work
order-related activities. An icon is displayed on the Start Center for each KPI that enables users to
view the status of their work environment with respect to the KPIs specific to their job, as well as the
current score for each KPI.

After defining KPIs, grant users access to the KPIs. KPIs can either be user-group specific, user-specific,
or public. Public KPIs can be displayed for all users. Define system privileges for users to personalize
their Start Center to display KPIs based on their preferences.

Note: After personalizing the KPIs, the system administrator must start the KPI driver to enable the
system to recalculate KPI scores based on the specified interval for each KPI.
See "Setting up jobs" on page 161.

To personalize your company’s KPI images, replace the default images provided by the system. KPI
images are stored in the following location on the application server:

• For Jboss installations: APP_HOME/jboss/shared/deploy/web.war/images/default
• For Websphere installations: IBMHttpServer_HOME/web.war/images/default
• For Weblogic installations: APP_HOME/apache/web.war/images/default

Setting up KPIs
Set up key performance indicators (KPIs) for the Start Center. For example, define a KPI to measure
the number of maintenance dollars spent for a production line during a month.

Select a SQL select statement for the KPI to calculate the current value for the KPI. Select a screen
for which to enable a hyperlink for the KPI, and then enter a Dataspy to enable the system to

116 | Infor EAM System Administrator Guide

 

Interface configuration



automatically query for the records associated with the KPI to the called screen. You can also designate
whether the KPI is accessible to all users.

To set up KPIs:

1 Select Administration > Start Center Setup > KPI Setup.
2 Click New Record.
3 Specify this information:

KPI Code
Specify a unique code identifying the KPI, and then enter a description of the KPI in the adjacent
field. The description will be displayed for the KPI on the Start Center.

Out of Service
Select to indicate the KPI should not display in KPI lookups.

Frequency
Specify the frequency in days with which the KPI will be recalculated.

SQL Statement
Specify the SQL statement to calculate the current value for the KPI. The system automatically
populates SQL Statement Text.

Note:  SQL Statement cannot exceed the performance score limit defined in the KPISCOR
installation parameter.

Type
Select the KPI display type to represent the data in the Start Center, e.g., select Donut to represent
the key performance indicators in a gauge graph.

UOM
Specify the unit of measure for the KPI.

Maintain History
Select to record the history of the KPI.
See "Viewing KPI history" on page 121.

Public
Select to give all user groups access to the KPI.

Note: KPIs for which user groups have been associated cannot be Public.

Parent
Select to indicate that the KPI is a parent KPI.

Donut Radius %
If you selected Donut as the KPI type, enter the radius percentage to represent the donut.

Gauge Min.
If you selected Donut as the KPI type, enter the minimum gauge value.
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Gauge Max.
If you selected Donut as the KPI type, enter the maximum gauge value.

Screen
Specify the system screen for which to enable a hyperlink to call the screen for the KPI.

Note: If you update Screen, the system clears Dataspy.

Forms Screen
Specify the Infor EAM Forms screen for which to enable a hyperlink to call the screen for the KPI.

Dataspy
Select the Dataspy used to retrieve records for the called system screen.

Filter
Specify the where clause with which to associate the KPI.

KPI Display Options
Select either Normalized Values (Weighted Average), Actual Values (Weighted Average), or Actual
Values (Summed).

Note:  Parent must be selected to enable KPI Display Options.

4 Click Save Record.

Defining KPI ranges
Define KPI ranges to specify a High Value and a Low Value for each of the scoring ranges defined
for a KPI.

Specify a Normal Score that corresponds with each high and low value for a KPI range. The normal
score for a child KPI is rolled up to any parent KPIs when calculating the Current Value and Normal
Score for the parent KPIs.

For example, a child KPI measures the productivity of a production line during a month. The target goal
for the KPI is 200,000 units per month. If the production line produces between 200,000 to 133,333
units per month, the normal score for the KPI is 3, which indicates an excellent score. 133,332 to 66,666
units is 2, which indicates an average score. 66,665 units or less is 1, which indicates a poor score.

Note: You should maintain consistency when defining normalized scores for KPI ranges. For example,
if you define a normalized score based on a scale of 1 to 3 for one KPI, use that same scale for other
KPIs.
Note: You cannot enter a Normal Score if the KPI is a parent KPI.

To define KPI ranges:

1 Select Administration > Start Center Setup > KPI Setup.
2 Select the KPI for which to define KPI ranges, and then click the Ranges tab.
3 Click Add Range.
4 Specify this information:
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Low Value
Specify the value for the low threshold of the KPI range.

High Value
Specify the value for the high threshold of the KPI range.

Normal Score
Specify the numeric value that represents the score based on the values entered for Low Value
and High Value.

Image Path
Specify the URL file path to the image the system will use to display the KPI range on the Start
Center. To enter the path to the image, Type must be Image on the KPI Setup screen.

Color
Select the color to use to display the KPI range on the Start Center. To specify the color, Type
cannot be Image on the KPI Setup screen.

Description
Specify a description of the displayed KPI range on the Start Center.

5 Click Submit.

Associating KPIs with user groups
Associate KPIs with user groups to enable them to display only the KPIs that are associated with their
user group in the KPI list.

Note: You can only assign KPIs to user groups for which Public has not been selected.

To associate KPIs with user groups:

1 Select Administration > Start Center Setup > KPI Setup.
2 Select the KPI with which to associate user groups, and then click the User Groups tab.
3 Click Add User Group.
4 Specify this information:

User Group
Enter the user group to which to associate the KPI. The system automatically populates the user
group description.

5 Click Submit.

Associating KPIs with users
Associate KPIs with specific users to display the KPIs in the KPI list of the user's Start Center.
Alternately, you can review or remove a user's associated KPI.

To associate KPIs with users:
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1 Select Administration > Start Center Setup > KPI Setup.
2 Select the KPI with which to associate users, and then click the Users tab.
3 Click Add User.
4 Specify this information:

User ID
Specify the user's unique ID to which to associate the KPI.

Note: User ID is a multi-select lookup which allows you to select more than one user to associate
to a KPI. If you select more than one user to associate to the KPI, a new sequence number is
assigned to each user, and these sequence numbers are generated based on the INCRLINO
installation parameter.

5 Select the Auto Refresh check box to automatically refresh the KPI every time the Start Center is
invoked for the specific user(s).

6 Click Submit.

Defining KPI structures
Define KPI structures to create parent/child relationships between KPIs. The scores for child KPIs roll
up to all of the children’s parents. For example, you create a parent KPI to measure the overall efficiency
of a production department during a month. You associate the parent KPI with child KPIs whose scores
will roll up to the score for the parent KPI. One child KPI measures the number of units that the production
line produces during a month. A second child KPI measures the maintenance costs for a production
line during a month.

Each of the child KPIs must be assigned a weight based on their importance, and the sum of all child
KPIs assigned for a parent KPI must be equal to 100. The system uses the value assigned for the
weight of a child KPI to translate the normal score for a child KPI when rolling the score up to a parent
KPI. For example, when calculating the score for the parent KPI, you consider the number of units
produced to be more important than the number of maintenance dollars spent. Therefore, you assign
a weight of 70 for the number of units produced and a weight of 30 to the maintenance dollars spent.

To define KPI structures:

1 Select Administration > Start Center Setup > KPI Setup.
2 Select the KPI for which to define structures, and then click the Children tab. Total Weight (Must

equal 100%) is automatically populated with the total weight of all child KPIs. If no child KPIs are
currently associated with the parent KPI, then Total Weight (Must equal 100%) is populated with
0.

Note: You can only associate child KPIs to parent KPIs. You must select Parent on the KPI Codes
form to indicate that a KPI is a parent KPI.
See "Setting up KPIs" on page 116.

3 Click Add Child KPI.
4 Specify this information:
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Child KPI
Specify the child KPI component for the parent KPI.

Weight (%)
Specify the weight for the child KPI component to use when calculating the Current Value and
Normal Score for the parent KPI.

Note: The sum of the weight of all child KPI components defined for a parent KPI must be 100%.

5 Click Submit.

Viewing KPI history
View KPI history to review the results of KPI calculations. A record in KPI history is generated when
the score for a KPI is calculated. Updating the KPI is optional.

Note: KPI drivers must be running to populate the History page.

You can only view the history of a KPI if you selected Maintain History on the KPI Codes form.

See "Setting up KPIs" on page 116.

To view KPI History:

1 Select Administration > Start Center Setup > KPI Setup.
2 Select the KPI for which to view history, and then click the History tab.
3 View the KPI history.

Personalizing charts
In addition to KPIs and inbox entries, the Start Center displays charts based on user-defined SQL
statements. A chart is a graphical representation of data such as work orders assigned to specific
departments.

After defining charts, grant users access to the charts. Charts can either be user-group specific or
public. Public charts are displayed for all users. Define system privileges for users to personalize their
Start Center to display charts based on their preferences.

Setting up charts
Set up and update charts to display in the Start Center using SQL statements to define chart data.

To set up charts:

1 Select Administration > Start Center Setup > Chart Setup.
2 Click New Record.
3 Specify this information:
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Chart Code
Enter a unique code identifying the chart, and then enter a description in the adjacent field.

Out of Service
Select to indicate the chart should not display in the Start Center.

SQL Statement
Enter the SQL statement which will define the chart data displayed.

Group By Text
Enter the type by which to group the chart data, e.g., for a chart displaying open work orders, enter
Department to display the open work orders by specific department.

Value Type
Select the value type for which the chart will display data, e.g., select Number to display numerical
representations of data in the chart.

Public
Select to indicate the chart should be available to all users in the Start Center.

4 Right-click on the form, and then select Group By Translations to view and edit the translations
for Group By Text.

5 Click Save Record.

Associating charts with user groups

Associate charts with user groups to enable them to display only the charts that are associated with
their user group in the chart list in the Start Center.

Note: You can only assign charts to user groups for which Public has not been selected on the Chart
Setup form.

To associate charts with user groups:

1 Select Administration > Start Center Setup > Chart Setup.
2 Select the chart with which to associate user groups, and then click the User Groups tab.
3 Click Add User Group.
4 Specify this information:

User Group
Enter the user group to which to associate to the chart. The system automatically populates the
user group description.

5 Click Submit.
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Modifying the Overview screen
Modify the layout of the Overview screen. Create, view, and modify widgets for use on the Overview
screen. Layout options include selecting the number of columns displayed on the screen. Drop and
drag widgets to move them around on the Overview screen.

To modify the Overview screen:

1 Select Operations > Overview.
2 Click Edit Mode.
3 Click Add Widget.
4 Specify the type of widget to add in Type, and then click Submit.
5 Click Options to configure the widget to show data after adding the widget.

DescriptionOption

Select options based on the type of widget specified in Type.Edit

Select the color of your preference to personalize the widget.Personalize

Click to refresh the widget with the new options.Refresh

Click to delete the widget.Delete

6 Drag and drop widgets to move them around on the screen.
7 Optionally, click Edit Layout to modify the layout of the screen. In the Edit Layout popup, specify

the Layout Type.
8 Click Submit.
9 Click Exit Edit Mode.

Configuring exports and imports
Create an export file for KPIs, inbox items, custom fields, copied screens, task plans, job plans, and
custom reports using the export configuration feature. Import the files created into another Infor EAM
implementation.

Exporting KPIs
Export a set of KPIs to an export file.

To export a set of KPIS to an export file:

1 Select Administration > System Configuration > Export Configuration.
2 Choose one of the following options:
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Dataspy
Select an existing Dataspy or edit an existing Dataspy.

•

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the equipment, and then click Run. KPI records that are not Out of Service or
Withdrawn are displayed.

3 Select the KPI to export, and then click Export.
4 Select the folder in which to save the file, and then click Save.

Exporting inbox items
Export a set of inbox items to an export file.

To export a set of inbox items:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Inbox Items tab.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the equipment, and then click Run. Inbox records that are not Out of Service or
Withdrawn are displayed.

4 Select the inbox item to export, and then click Export.
5 Select a folder to save the file, and then click Save.

Exporting custom fields
Export a set of custom fields to an export file.

To export a set of custom fields:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Custom Fields tab. No records are displayed until you conduct a search.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.
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• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the equipment, and then click Run. Only custom field records that are not Out of
Service or Withdrawn are displayed.

4 Select the custom field to export, and then click Export.
5 Select a folder in which to save the file, and then press Save.

Exporting Flex SQL statements
Export a set of Flex SQL statements to an export file.

To export Flex SQL statements:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Flex SQL tab.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the equipment, and then click Run.

4 Select the Flex SQL statement to export, and then click Export.
5 Select a folder in which to save the file, and then press Save.

Exporting web service prompts
Export a set of web service prompts to an export file.

To export a set of web service prompts:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Web Service Prompts tab. Records are not displayed until you conduct a search.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes, and then click Run.
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4 Select the web service prompt to export, and then click Export.
5 Select a folder to save the file, and then click Save.

Exporting custom reports
Export a set of custom reports to an export file.

To export a set of custom reports:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Custom Reports tab.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the report, and then click Run.

4 Select the custom report to export, and then click Export.
5 Select a folder in which to save the file, and then press Save.

Exporting user defined grids
Export a set of user defined grids to an export file.

To export a set of user defined grids:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export User Defined Grids tab. Records are not displayed until you conduct a search.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes, and then click Run.

4 Select the user defined grid to export, and then click Export.
5 Select a folder to save the file, and then click Save.
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Exporting alerts
Export a set of alerts to an export file.

To export a set of alerts:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Alerts tab. Records are not displayed until you conduct a search.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes, and then click Run.

4 Select the alert to export, and then click Export.
5 Select a folder to save the file, and then click Save.

Exporting screens
Export a set of copied screens and the associated configuration details such as screen designer changes
to an export file.

To export screens:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Export Copied Screens tab.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the report, and then click Run.

4 Select the copied screens to export.
5 Specify the Screen Designer User Group. This will determine the screen designer options available

to export.
6 Click Export.
7 Select a folder in which to save the file, and then press Save.
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Exporting task plans and job plans
Export a set of task plans and job plans including the associated jobs and other details to an export
file.

To export task plans and job plans:

1 Select Administration > System Configuration > Export Configuration.
2 Click the Task Plans tab.
3 Choose one of the following options:

• Dataspy
Select an existing Dataspy or edit an existing Dataspy.

• Quick Filter
Define a quick filter to filter the list of records in the lookup based on the key fields and many
attributes of the report, and then click Run.

4 Select the task plans to export.
5 Click Export.
6 Select a folder in which to save the file, and then press Save.

Importing files
Import KPIs, custom fields, inbox item files, Flex SQL statements, copied screens, task plans, job plans,
and custom reports created using the Export Configuration feature.

To import files:

1 Select Administration > System Configuration > Import Configuration.
2 On the Import tab, click Browse, and then select the file to import from the file location.

Note: Click View File Contents to view the file details.

3 Click Import.

Uploading documents in a batch for import configuration
Upload multiple documents that belong to a specific organization.

To upload documents in a batch for import configuration:

1 Select Administration > System Configuration > Import Configuration.
2 Click the Batch Document Upload tab.
3 Specify the Organization to which the uploaded documents will belong.
4 Click Add.
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5 Select the files to upload, and then click Upload.
6 Click Refresh. All records are removed from the grid.

Exporting base configuration
Export a large number of configuration items to specially formatted files.

To export base configuration:

1 Select Administration > System Configuration > Configuration Manager.
2 Select one of the following options:

• Save on Client
Select to save the files on the client's machine. Path is automatically populated on the server
where the file will be initially saved.

Note: The export process may take a while to successfully process and the system could timeout
during the process. If this happens, click the Status tab to check the results of the import.

• Save on Server
Select to save the files on the server.

Email Address
Specify the email address to which to have email notifications sent when the configuration
process is complete.

Include file in Email
Select to receive a second email with the file attached. Path is automatically populated on the
server where the file will be initially saved.

Note: Click Select All to select all of the export options.

3 Specify this information:

User Groups and Permissions
Select to export user groups and their permissions, including hyperlinks, screen designer changes,
and menus.

Export Single User Group
Specify a single user group to export. Only permissions for this user group will be included in the
export file.

Status Authorizations
Select to export status authorizations.

Users
Select to export users and their related organizations, including personal Dataspies and report
filters.
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Organizations
Select to export organizations.

Multi-org Security
Select to export multi-org security.

Install Parameters
Select to export install parameters.

Closing Codes
Select to export closing codes.

Trades
Select to export trades.

Audit Setup
Select to export audit setup.

Screens and Reports
Select to export screens and reports, including changes made to existing screens and any new
screens. New reports are not included.

Departments
Select to export departments.

Locales
Select to export locales.

Category
Select to export categories.

Reliability Ranking
Select to export reliability ranking values.

Custom Fields
Select to export custom fields, including classes.

Flex SQL
Select to export Flex SQL.

Updated Text
Select to export updated text.

System Codes
Select to export system codes.

Mobile
Select to export Infor EAM Mobile configuration settings.

Include Translations
Select to include translations in the export.
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Messenger Setup
Select to export messenger setup.

KPIs and Inboxes
Select to export KPIs and Inboxes.

Account Detail Setup
Select to export account detail setup.

eRecord Setup
Select to export eRecord Setup.

Web Service Prompts
Select to export web service prompts.

Call Center Setup
Select to export call center setup.

Data Collection Setup
Select to export data collection setup.

eRecord Setup
Select to export eRecord Setup.

Email Setup
Select to export email setup.

Alerts Setup
Select to export alerts setup.

4 Click Export.
5 Select the folder in which to save the file, and then click Save.

Importing base configuration
Import files created by the Configuration Manager.

To import base configuration:

1 Select Administration > System Configuration > Configuration Manager.
2 Click the Import Base Configuration tab.
3 Select one of the following options:

• Do Not Wait for File to be Imported
Select to execute the import without waiting for the system to complete the process.

Note: To check the results of the Import, click the Status tab.
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• Wait for File to be Imported
Select to execute the import while waiting for completion.

Note: The import process may take a while to successfully process and the system could timeout
during the process. If this happens, click the Status tab to check the results of the import.

4 Specify this information:

File Location
Specify the location of the file created during the Export process. Click Browse to locate the file.

Note: Click View File Contents to view the contents of the file.

Notification Email Address
Specify the email address to which the system sends email notification once the process is complete.

5 Click Import.

Viewing the status of imports and exports
View the status of all imports and exports performed on the system as well as the history of imports
and exports.

To view the status of imports and exports:

1 Select Administration > Setup > Configuration Manager.
2 Click the Status tab.

Note:  File Path is a hyperlink that can be used to download an export file once it has been
successfully created.

3 Select the record for which to view status details, and then click View Status Details.
4 Select the group for which to view error details, and then click View Error Details.
5 View the error details.
6 Click Close.
7 Click Close.

Screen designer
Modify the page layout of record view, detail view, and list-detail view pages. You can move fields,
modify the display type of fields, and rename field labels.
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Using screen designer keyboard shortcuts
Keyboard shortcuts are keys or key combinations for system functions. The following keyboard shortcuts
allow easy access to screen designer functions while in designer mode.

Table 1: Screen designer keyboard shortcuts

ShortcutFunction

ALT+ESwitch to screen designer mode

CTRL+SSave layout

CTRL+GOpen group selection

ALT+WSwitch to preview mode to view layout of screen
with hidden fields removed, and without saving
changes on the screen/returning to normal mode

CTRL+IExit screen designer mode

Displaying pages in screen designer mode
Modify the page layout of record view, detail view, and list-detail view pages. You can move fields,
modify the display type of fields, and rename field labels.

To display pages in designer mode:

1 Open any record view, detail view, or list-detail page.
2 Click Screen Designer.
3 Specify this information:

Copy from Group
Select the group from which to copy the screen layout.

Save to Group
Select the group to which to save the screen layout.

Note: To save the screen layout to multiple user groups, click Advanced.

4 Click Continue.

Moving fields in screen designer mode
Move fields from one container to another container or move fields within the same container. In designer
mode, a container is indicated by a red dotted line.

Note: Only custom fields associated to a * Class and * Organization can be moved to another block.
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To move fields:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Click the field to move, and then drag the field to the desired location.

Note: When dragging a field to the desired location, the field is always inserted below the field onto
which it was placed.
To move a field to the first field position, you must drag the field onto the current first field, and then
move the current first field down.

3 Click Save.

Modifying field display properties
Change the display properties for fields as necessary. The system uses five field properties: Required,
Protected, Optional, Hidden, and Not Available.

To modify field display properties:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the field to modify.

Note: All five of the field properties are NOT available for all fields.

3 Choose one of the following field property options:

• Required
Select to indicate that the field is required.

• Protected
Select to indicate that the field is read-only.

• Optional
Select to indicate that the field is not required.

• Hidden
Select to indicate that the field is not shown in detail mode but is always displayed in list view
and is still available.

• Not Available
Select to indicate that the field should not be displayed in detail or list views.

4 Click Save.
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Modifying field labels
Change the labels used for fields as necessary.

Note: Changes to field labels apply to ALL user groups.

To modify field labels:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the field to modify, and then select Edit Field Names.

Note: When the state of a field is changed to Not Available, Protected, or Hidden, the system
clears any default value that was previously defined for the field.

3 Modify the current field label as necessary.
4 Click Done.

Modifying block display properties
A block of fields is indicated by a title in red and a blue line separating a group of fields from other
groups of fields. In the example below, the blocks of fields are titled Equipment Details, Tracking Details,
Part Association, Hierarchy, and Custom Fields. Hide entire blocks of fields as necessary.

To modify block display properties:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click inside the block to modify (NOT inside a red container).
3 Choose one of the following block property options:

• Show Block
Select to display the entire block of fields.

• Hide Block
Select to hide the entire block of fields.

4 Click Save.

Modifying block labels
Change the labels used for blocks of fields as necessary.

Note: Changes to block labels apply to ALL user groups.

To modify block labels:
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1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the block to modify.
3 ChooseEdit Block Name.
4 Modify the current block label as necessary.
5 Click Done.

Modifying link and generic button display properties
Change the display properties for links and generic buttons as necessary. Generic buttons are those
that are common across many forms, such as Submit and Clear.

To modify link and generic button display properties:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the link or button to modify.
3 Choose one of the following link or button property options:

• Enable Link/Button
Select to enable the link or button.

• Disable Link/Button
Select to disable the link or button.

• Edit Link/Button Name
Select to edit the link or button label name.

4 Click Save.

Modifying function button display properties
Change the display properties for function buttons as necessary. Function buttons are those that perform
a procedure or open a popup, such as Create WO on the Assets form.

To modify function button display properties:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the button to modify.
3 Choose one of the following button property options:

136 | Infor EAM System Administrator Guide

 

Interface configuration



Show Button
Select to display the button.

•

• Hide Button
Select to hide the button. If you select to hide a button, the right-click option is still available.

• Not Available
Select to disable the button. If you select to make a button Not Available, then both the right-click
option and the button are hidden.

4 Click Save.

Modifying link and button labels
Change the labels used for links and buttons as necessary.

Note: Changes to link and button labels apply to ALL user groups.

To modify link and button labels:

1 Display the selected page in designer mode.
See "Displaying pages in screen designer mode" on page 133.

2 Right-click the link or button to modify.
3 Choose Edit Link/Button Name.
4 Modify the current link or button label as necessary.
5 Click Done.

Defining grids
Create a new grid or copy an existing grid and modify the grid definition. A grid can be added to the
menu as a new screen or as a tab on another form.

Note: To define grids that all users can see, you must be logged in as the R5 user.

To define grids:

1 Select Administration > Screen Configuration > Grid Designer.
2 Click New Record.
3 Specify this information:

Grid Name
Specify the name of the grid, and then specify a description in the adjacent field.
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Note: Names of List type grids must be six characters in length, with ‘U’ as the second letter. Names
of Tab type grids must be three characters in length and begin with 'X'.

Copy From
Specify an existing grid to copy. Description, Grid Type, Parent Screen, Parent Screen description,
FROM Clause, WHERE Clause, and SELECT Statement are automatically populated.

Grid Type
Choose one of the following options:

• List View
• Tab
• Alert Management

Parent Screen
Specify the parent screen for the grid if the new grid will be added as a tab on an existing form if
Grid Type is selected. The parent screen description is automatically populated.

FROM Clause
Specify the FROM Clause for the grid, including each table and table alias.

SELECT Statement
Speciy the SELECT Statement for the grid. On the Record View page, fields can be selected only
from the lookup. To modify the fields selected or to add fields and functions expressions individually,
click the Fields tab.

WHERE Clause
Specify the WHERE Clause for the grid, including parameters as necessary.

Custom Field Table
Specify the custom field table used for the dataspy lookup for the grid if custom field selection is
enabled.

Active
Active is selected if the grid has been validated on the Validation page.

4 Optionally, select the Enable Custom Field Selection in Dataspy check box to enable custom
field selection in the dataspy for the grid.

5 Optionally, select the Mobile Grid check box to set the grid as a Mobile grid on the Record View
page.

6 Optionally, select the GIS WO Attribute Mapping Grid check box to allow work order fields defined
on this grid to be associated to GIS event attributes, which enables EAM work order data to be
synchronized in the GIS map display.

Note: This feature is only available when using LRS (Linear Referencing System) enabled map
services.
The Map Attributes popup on the Infor EAM toolbar inside the ArcMap application is used to associate
work order UDG fields to GIS event attributes.
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7 Click Save Record.

Defining fields for grids
Define fields for grids to modify the SELECT statement for the grid. Fields in the SELECT statement
can be true fields or function calls (including parameters).

To define fields for grids:

1 Select Administration > Setup > Grid Designer.
2 Select the grid for which to add fields, and then click the Fields tab.
3 Click Add Field.
4 Specify this information:

Field
Specify the field to add to the grid.

Note: Lookup Dataspies allow you to choose the following:

• fields from the tables in the FROM clause
• any fields in the whole database including any you created
• functions

Alias
Specify the alias for the field.

Note: Field Alias can include only letters, numbers, and '_'. The same Field can be added twice
if it appears in two different tables, but only with a different field alias each time.

Header Location
Choose one of the following options to display a field in the header section above the grid:

• None
• Code
• Description
• Header 1
• Header 2
• Header 3

Field Label
Specify the label for the field.

Data Type
Choose one of the following options:

• Upper Case
• Mixed Case
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• Numeric
• Date
• Currency
• Decimal
• Date/Time
• Duration
• Time
• Boolean
• Long
• Dependent

Lookup Entity
Specify the entity used to populate the Dataspy lookup for the field. The system automatically
populates entity description.

Lookup Query
Specify the query used to populate the Dataspy lookup for the field. The system automatically
populates Lookup Query Text.

Grid Key
Select to identify the field as a key field for the grid.

5 Click Submit.

Note: To create a hyperlink to a screen for this field, click Add/Edit Hyperlinks.
See "Setting up hyperlinks" on page 142.

Defining parameters for grids
Map parameters to fields on parent screens for user-defined grids with Grid Type = Tab. This tab
shows both system parameters and user-defined parameters from SELECT and WHERE statements.

To define parameters for grids:

1 Select Administration > Setup > Grid Designer.
2 Select the grid for which to define parameters, and then click the Parameters tab.
3 Select a parameter to map to the parent screen. The system automatically populates

Parameter,System, andData Type.
4 Specify this information:

Parent Grid Field
Enter the parent screen field for the parameter. For example, map parameter :wonum to WO No.
on the Work Orders form when adding a new tab with child records to that form.

5 Click Submit.
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Defining validation for grids
Define a default Dataspy for a grid, and then mark the grid as active.

To define validation for grids:

1 Select Administration > Setup > Grid Designer.
2 Select the grid to validate, and then click the Validation tab.
3 Click Create Default Dataspy. The system validates the full query statement for the grid record

and creates the default dataspy for the new grid as "All records".
4 Specify this information:

Active
Select to validate the grid definition and make the grid available for use.

Note: If you unselect Active, the system saves the record and makes the grid inactive.

Defining and generating views
Use relational database views to expand the complexity and functionality of user defined grids in EAM.
Define these database views by specifying a unique view name and a SQL statement. Generate these
views to make them available for use with Grid Designer. Unlike user defined grids in EAM, views allow
you to use outer joins and unions to combine data from two or more tables.

To define and generate views:

1 Select Administration > Screen Configuration > Views.
2 Click New Record.
3 Specify this information:

View
Specify a unique code value to identify the view database record, and then specify a description
of the new record in the adjacent field.

View Name
Specify a unique which will be used as a reference on user defined grids. All view names must
begin with U5.

SQL Statement
Specify the SQL statement query to generate the searchable object or database view.

4 Click Save Record.
5 Click Generate to run the Test SQL process and generate the new database view. If the view is

generated successfully, the Active check box is selected, and the view is ready for use with Grid
Designer.
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Setting up hyperlinks
Create or edit hyperlinks to connect a form to another form. Hyperlinks allow access to related forms
or reports from a link on the original form.

To set up hyperlinks:

1 Open an Infor EAM form.

Note: You may also set up hyperlinks on the Fields tab of the Grid Designer page.

2 Select a record, and then click the Record View tab.
3 Click Screen Designer.
4 Right-click in a field, and then choose Hyperlink. The system automatically populates Source

Screen Name and Source Field Name.
5 Specify this information:

Hyperlink
Enter a unique name for the hyperlink.

Destination Screen Mode
Select to set hyperlink as query pages or to set hyperlinks to display in insert mode.

Destination Screen/Report
Enter the name of the hyperlink screen or report. The system automatically populates the destination
screen/report description.

Note: If you select a report for Destination Screen/Report, the system empties and protects
Default Dataspy. The system also selects Query for the Destination Screen Mode and protects
the Destination Screen Mode options.

Destination Field
Select the field for which to create a hyperlink.

Sequence Number
Enter the sequential order for the hyperlink.

Default Dataspy
Select the global dataspy for the hyperlink.

6 Click Submit.

Using screen designer for web service prompts
Modify the layout of screens and properties of web service prompt fields. In addition, you can select
the groups for which the changes apply. While tab sequence and display properties are established
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initially on the Fields page for Web Service Prompts, fields can be moved around the screen and
display types can be changed using the screen designer feature.

See the Infor EAM User Guide.

Note: Re-sequencing fields via screen designer may cause the prompt to function differently than the
administrator originally intended. Exercise caution when re-sequencing fields via screen designer.

The following functionality is specific to screen designer for web service prompts:

1 If you have access to the screen designer feature on system delivered screens, you also have
access to screen designer on web service prompt screens.

2 Make screen design changes with caution as certain changes can adversely affect the intended
behavior of the screen. For example, if you move a controlling organization or class/class organization
field to the bottom of a prompt, the system may not display any class-specific custom fields until the
entire prompt has been navigated.

3 Any field-level changes on the Web Service Prompt Definition form overwrite the corresponding
field on the Prompt form for all groups when the screen is next opened, regardless of changes
made via screen designer. For example, creating and updating prompt definitions impact the
corresponding screen for all user groups.

4 Hyperlinks are not available.
5 "User Defined Field Options" and "User Defined Field Lookup Values" right-click options are not

available.
6 The "Not Available" attribute is not available.
7 The "View Field Details" option is not available.
8 When editing field names, translating to other languages is not available.
9 Lookup Filters can be applied only to user defined fields. In addition, the user defined field must

have the lookup defined on the base screen for which the web service is related.
10 There is no web service prompt screen designer option for links and generic buttons as these cannot

be displayed on a web service prompt-based screen.

Defining web service prompts
Define web service prompts representing web services and fields rendered on the user-defined screen
using the Web Services Prompt Engine. System administrators can use web services to create
user-defined screens for use within Infor EAM. Web service prompts contain the definitions for these
screens.

The following rules apply to forms for which web service prompts are available:

• The system displays the functions of all system-delivered Infor EAM List View and Record View
pages.

• BSCOMM (Comments) is displayed.
• No user-created screens are available.
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The system displays all screens meeting the above criteria if a web service has not been specified;
otherwise, only screens related to the web service will be displayed.

To define web service prompts:

1 Select Administration > Web Service Prompt Engine > Web Service Prompts.
2 Click New Record.
3 Specify this information:

Web Service Prompt
Enter a unique code for the web service prompt, and then enter a description of the prompt in the
adjacent field.

Out of Service
Select to indicate the web service prompt is out of service.

4 Click Save Record.

Note: The system automatically creates a screen record whose code and description correspond
with the web service prompt. The user-defined screen can now be placed into the menu for one or
more user groups. These new screens are not visible on the Screens form.

Defining web services for web service prompts
Define the Infor EAM web services available for use on the user-defined screen representing the
selected web service prompt.

To define web services for web service prompts:

1 Select Administration > Web Service Prompt Engine > Web Service Prompts.
2 Select the web service prompt for which to define web services, and then click the Web Services

tab.
3 Click Add Web Service.
4 Specify this information:

Screen
Enter the screen for which to define web services details. The system automatically populates the
screen description.

Tab
Enter the tab to be specified for the selected screen. The system automatically populates the tab
description.

Note: Tab should be left blank if the web service is to be based on the Record View of the selected
Screen.
If the Comments Tab is selected, the system replaces the selected Screen with BSCOMM and
clears the Tab value because the insert, update, and delete Comment web services do not actually
reside on the Comments tab. These web services exist on the Comments pop-up (BSCOMM), a
screen within Infor EAM. Because Comments are generic and can apply to many screens, the
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Entity and Record for which the Comments are related need to be entered when inserting, updating,
or deleting Comments using the Web Service Prompt Engine. The system administrator can make
the Entity field ‘fixed’ via Field Type and supply the correct Entity value so that it is not necessary
to enter it with each Comment record. In addition, the Entity field can be ‘protected’ via Display
Type so that users can only enter Comments for the appropriate Entity.

Action Code
Select the action code for the selected screen, e.g., insert, update, delete.

Process Group
Enter the process group for the selected screen. Fields related to the lowest process group will be
displayed first on the Web Service Prompt Engine, and so on. The default value for this field is
based on the INCRLINO installation parameter.

Web Service
Enter the web service for the selected screen.

Note: The system defaults theWeb Service if only one Web Service exists for the Screen, Tab,
and Action Code.
If you enter the Web Service without entering Screen, Tab, and Action Code, the system populates
Screen,Tab, and Action Code when the Web Service is selected.

5 Click Submit. The system automatically creates a field record on the Fields tab for each controlling
organization in the selected web service. Controlling Org. will be selected for these records.

Note:  In determining the sequence for Controlling Org. for each process group/web service, the
system multiplies the value in the WSPFSEQ parameter by the web service process group. This
new parameter will be used as a multiplier to ensure adequate field sequence separation between
web services defined for the prompt allowing users to add the remaining prompt fields as necessary.
The default value for this parameter is 100.

Defining fields for web service prompts
Add, update, or delete fields for each web service that will be available on the Web Services Prompt.

Fields available for use will be those related to the web services defined on the Web Services page
of the Web Service Prompts form.

Note: This form contains no capability for defining language translations for field labels displayed.
When the prompt is executed, field labels display as entered on the Fields form for the selected web
service prompt. To display prompts in multiple languages, a separate Web Service Prompt must be
created for each language.

User defined fields are available for web service prompts. The fields display in a list of all fields under
the appropriate web service for some insert/update web services. These user defined fields inherit
properties from the associated reference form. Right-click in Screen Designer mode to define options
for user defined fields. When you highlight a user defined field in the grid, the system protects Field
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Type and Query Code. This information is defined on the base screen for which the web service is
related.

See the Infor EAM User Guide.

Entity lookup user defined fields show records for all organizations in the user's organization list when
a controlling organization is not available. A record cannot be submitted if the controlling organization
and the user defined field organization are in conflict.

To define fields for web service prompts:

1 Select Administration > Web Service Prompt Engine > Web Service Prompts.
2 Select the web service prompt for which to define fields for web services, and then click the Fields

tab.
3 Click Add Field.
4 Specify this information:

Process Group–Web Service
Specify the process group for which to add the web service field. Screen and Tab are automatically
populate.

Field
Specify the field to add to the process group. Available fields are based on the selected web service.

Field Label
Specify the name for the field. This information will be displayed as the field boiler text for the Web
Services Prompt Engine. The default Field Label is equivalent to the Field.

Field Type
Specify the field type based on the selected field and web service. The default Field Type is the
system-delivered type for the selected Field. However, you may change this value. The user-defined
Field Type is displayed on the Web Service Prompt Engine. You can change the default to one of
the following options:

• Alphabetic
• Computed
• Date
• Fixed
• Free format text
• Key Field
• Numeric
• Retrieved Field

Note:  Key Field is available only when an "update" or "delete" web service is selected. When
setting up a web service prompt that uses an update or delete web service, the system administrator
must create a Field for each key field the web service requires to uniquely describe a record. Field
Type should be Key Field. The web service prompt engine first prompts you to enter the key field
value(s) for the record to process, such as Equipment and Equipment Organization. For updating
web services, the system queries for the record to display the results. You may update and then
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submit the record. For deleting web services, after you enter all key field values, the system deletes
the record.
Retrieved Field is available only when an "insert" web service is chosen. When setting up a web
service prompt that uses an insert web service, one or more key field values must be retrieved from
a web service previously processed in the current prompt record. The administrator needs to create
a Field of type Retrieved Field for each of the key fields. For example, a web service prompt is
created that allows you to create a work order and an activity for the work order simultaneously.
You want the activity to be associated with the work order that is created in a previous process
group; however, the data will be entered into the web service prompt engine and processed
simultaneously. To ensure the activity is associated with the correct work order, the system must
first process the "insert" work order web service, then pass (retrieve) the work order number and
work order organization back to the create activity web service. This key field information, along
with other required activity data, is used to create the activity and relate it to the proper work order.
Retrieved Field (Field Type = Retrieved Field) records would be created for the activity work order
number and activity work order organization because the work order number and organization are
required to associate the activity.
Retrieve From Group–Web Service should be populated with the web service from which these
key field values are retrieved. In this example, they are retrieved from the "insert" work order web
service. Retrieve Field will be the key field in the retrieve from web service from which the data is
retrieved. In this example, WO Number is one of the retrieved fields. Another Field should be
created similarly to define how to retrieve the work order organization for use in creating the activity.
Field values can only be retrieved from web services with a lesser process group number. For
example, a value cannot be retrieved for use in the current web service unless a previous web
service was processed to provide the information.
Retrieved Field and Key Field are not available when Unmapped is checked.
Retrieved Field Type is not associated with the functionality available on the Retrieved Values
page.
If a field is defined as Checkbox, it appears as a checkbox on the Web Service Prompt Engine
page.

Display Type
Specify how the field will be displayed using the Web Service Prompt Engine. The default value
will be the system default for the selected field. The user can change the default to one of the
following options:

• Optional
• Required
• Hidden
• Protected

Note: If Field Type is Fixed or Computed, only Protected and Hidden will be available for Display
Type. If Field Type is Retrieved Field, only Hidden will be available for Display Type.

Sequence
Specify a numeric value for the sequence. Fields are displayed using the Web Service Prompt
Engine in ascending order by their Sequence. The default value provided by the system is based
on the INCRLIND parameter.
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Note: It is important to ensure that the web service prompt fields are displayed grouped together,
using the Web Service Prompt Engine, by Process Group–Web Service. The Sequence range
available is controlled for fields for the selected Process Group–Web Service. The Sequence
must not overlap with a Sequence associated with a previous or subsequent process group. For
example, web service prompt fields are grouped on the Web Service Prompt Engine by Process
Group–Web Service, then by Sequence.

Minimum Length
Specify the minimum number of characters for the field.

Maximum Length
Specify the maximum number of characters for the field.

Next Sequence
Specify the number at which to begin the next sequence.

Query Code
Specify the query code. The Query Code defines values available for selection in a list of values
field when a server connection is available. For example, the query and list of available values will
be based on the Infor EAM tables.

Mobile Query Code
Specify the mobile query code that defines a list of values that is available for the field.

Note: The mobile device uses the Query Code list of values if an application server connection
exists; otherwise, the Mobile Query Code list of values is used. For example, local data populates
the list of values.

Retrieve Field
Specify the name of the field from which to retrieve data. The system automatically populates
Retrieve From Group–Web Serviceand Retrieve Field X-Path.

Query Web Service
Specify the query web service. A Query Web Service applies only when defining key field for an
"update" web service. The Query Web Service is used to query the data in the record to display
to the user for possible updates.

Unmapped Field
Select if specified field is not mapped to any field in web service. The field value can then be
processed further by the Prompt as part of a calculation or retrieved values.

Use Previous Value
Select to use the previous field value.

If Data Is
Specify the Go To condition. This field describes the condition in which the system does not access
the field defined by Next Sequence but instead places focus on the Go To Sequence.

Pattern
Specify the pattern that should be met for the Go To condition.
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Go To
Specify the field sequence that the system will follow, versus Next Sequence, if the condition is
met.

Clear Previous Values Starting From Go To Target Field
Select to enable the system to carry forward values for fields with Use Previous Value selected,
when the prompt sequence is less than (<) the “Go To” target field sequence. For example, previous
values for prompt fields >= “Go To” target field sequence will be cleared. Otherwise, the system
will carry forward values for fields with Use Previous Value selected, when the prompt sequence
is less than (<) the “Go To” source field sequence. For example, previous values for prompt fields
<= “Go To” source field sequence will be cleared).

Retrieve From Group–Web Service
Specify the web service from which key field values will be returned and used in a subsequent
process group.

Computed Data
Specify the computed data for the field when Field Type is Computed.

Pattern Match
Specify a pattern for Field Type of Alphabetic for which entered data must match in order to be
valid.

Note: The following "wild card" characters are supported when defining a Pattern Match:

• . (period): single alphabetical characters, A through Z
• # (pound sign): any single number, 0 through 9
• _ (underscore): any single alphanumeric character, A through Z and 0 through 9
• % (percent): a string of alphanumeric characters
• , (comma): OR condition
• : (colon): THROUGHOUT condition
• ! Any character(s) or numbers(s): data entered should not match what follows the "!" NOT

condition.

See "Defining retrieved values for web service prompts" on page 150 for more information on
referencing the prompt field inside SQL statements contained within Query Code, Mobile Query
Code, and Computed.

5 Click Submit.

Note: To remove a field, select the field to remove, and then click Remove Field. Fields
corresponding to the Controlling Organization for a web service cannot be removed from this
page because they are critical to processing the web service. However, if the web service itself is
removed from the Web Service page, all related fields are automatically removed including
Controlling Organization.

Note: Errors are not displayed on this page if all necessary required, key, or retrieved fields are not
defined for the web service prompt to function properly using the Web Service Prompt Engine. An
error is displayed when the Web Service Prompt Engine processes records with insufficient prompt
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fields. An error is also displayed from the Web Service Prompt Engine if a next sequence is defined
that does not exist within the prompt definition.

Defining retrieved values for web service prompts
Create, edit, and delete retrieved values for a web service prompt. Values can be retrieved from the
database and automatically populated into the Destination field when you enter data into the Source
field. Using retrieved values saves data entry time and prevents potential key stroke mistakes.

A good example for using retrieved values would be when an employee regularly creates a work order
and activity for which they will complete. When the employee enters his or her user name for the work
order Created By field, the system can locate the employee associated with the entered user name
and populate that employee’s Trade on the activity automatically.

Note: Setting up retrieved values requires identifying the Source, the Destination, and the SQL
Statement used to query the information related to the supplied data. SQL statements can be defined
on the Queries screen.

To define retrieved values for web service prompts:

1 Select Administration > Web Service Prompt Engine > Web Service Prompts.
2 Select the web service prompt for which to define retrieved values, and then click the Retrieved

Values tab.
3 Click Add Retrieved Value.
4 Specify this information:

Source
Enter the source field sequence. The system automatically populates the source description.

Destination
Enter the field sequence for which to populate the retrieved data. The system automatically populates
the destination description.

Query Code
Enter the query code on which the retrieved value will be based. The system automatically populates
SQL Statement.

Note: The system allows referencing other prompt fields inside the user-defined SQL statement.
The syntax is ":<prompt sequence #>. For example, if you want to reference a prompt field whose
Sequence = "2" inside the ‘where’ clause of their SQL statement, enter ":2".

5 Click Submit.

Copying web service prompts
The copy web service prompt feature copies a web service prompt, including all details.
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To copy web service prompts:

1 Create a web service prompt.
See "Defining web service prompts" on page 143.

2 Right-click, and then select Copy Web Service Prompt.
3 Specify this information:

New Web Service Prompt
Enter the name for the new web service prompt. The system automatically populates the New Web
Service Prompt description.

4 Select the record types to copy, and then click Submit.

Note: Some exceptions apply to the header details copied.
Out of Service value is not copied.
If the detail record contains a Query Code or Mobile Query Code that is not valid at the time the
record is copied, the system does not copy the record.

Viewing log files
View and save Infor EAM log and configuration files. Saved files are copied to a specified location on
the local drive.

To view log files:

1 Select Administration > Setup > View Log Files.
2 Specify this information:

File Type
Choose one of the following options:

• All
• Log
• Configuration

Log Type
Choose one of the following options:

• Ejcron

• Session
• Session List
• Server
• Grid Query
• Apache
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• Report
• Axis

3 Click Display Files.
4 Select the files to save.

Note: If multiple files are selected, the files are automatically compressed and saved as one file.

5 Click Save.
6 Select the folder in which to save the file, and then click Save.
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4Data collection

The data collection module enables you to track the movement of goods for asset and maintenance
management. Define queries using existing Infor EAM data or SQL statements. Use transaction prompts
to define where and in what order the data collection module populates information in the system. View
scanner transactions to be processed and set up predefined jobs. Finally, correct transaction errors.

Note: This chapter describes Infor EAM functions that only a system administrator has rights to perform.

Overview
The data collection module speeds the system acquisition of business information by offering shortcuts
in the form of scanned input, minimized operator activity, and system-generated prompts to guide users
to accomplish a system function quickly. The data collection module reports on the movements and
activities of the organization’s equipment, including recording locations and modifications to equipment,
thus serving as an audit trail for an asset’s lifecycle. The data collection module can be a valuable tool
for businesses seeking to take charge of their serialized assets and to enhance their financial reporting
on difficult-to-manage item movements.

Defining queries
Define queries using existing Infor EAM data or SQL statements. Use SQL statements to define complex
validation queries or validation queries to multiple system tables.

Note:  Define this type of validation only if you are familiar with the Infor EAM data model and have a
good working knowledge of SQL.

To define queries:

1 Select Administration > Start Center Setup > Queries.
2 Click New Record.
3 Specify this information:
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Query
Specify the code for which to define a query.

SQL Statement
Specify the SQL statement.

Note: To verify the SQL Statement, click Test SQL. A message indicating the accuracy of the
statement is displayed.

Normal
Select if you want this query to appear in the Normal lookups.

Data Collection
Select if you want this query to appear in the data collection lookups for asset tracking.

Lookup
Select if you want this query to appear in all lookups.

KPI
Select if you want this query to appear in the KPI lookups.

Inbox
Select if you want this query to appear in the Inbox lookups.

Chart
Select if you want this query to appear in the Chart lookups.

Equipment Ranking
Select if you want this query to appear in the Equipment Ranking lookups.

4 Click Save Record.

Defining transaction prompts
Transaction prompts define where and in what order the data collection module populates information
in the system. You can validate incoming data at the field level, as well as at conditional navigation
between prompts.

Referring to the data collection diagram, determine what data to enter, in what sequence it should be
gathered, and how to group data for processing to Application Programming Interfaces (APIs). Define
data prompts for each barcode transaction type.

If you use GIS functionality, you will need to load GIS assets into the system at the system initialization.
Ensure that the GISOBJID is manually assigned for each asset you need to integrate during the system
initialization. These manually assigned GISOBJIDs must have values in a range of 0 to 100,000,000.
The GISOBJID Sequence Generator begins automatically numbering equipment records that are
created through Infor EAM or the GIS system with 100,000,001.
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Note: You cannot load a GIS asset into the system with a GISOBJID greater than 100,000,000.

For equipment audits, create scanner prompts with the Interface Type A (Equipment Audits) and L
(Equipment Audit Lines).

To define transaction prompts:

1 Select Administration > Data Collection > Monitor Interface.
2 Open the Transaction Type form.
3 Click New Record. Forms SQL Code is automatically populated.
4 Specify this information:

Transaction Type
Specify the transaction type for which to define prompts. The transaction type description is
automatically populated.

Line
Specify a unique code identifying the prompt/processing definition line within the scanning
transaction.

Data Type
Select one of the following options:

• Alphabetic
Select for alphabetic characters.

• Computed
Select for the system to automatically make a calculation.

• Date
Select for the system to prompt for data that has a time component.

• Fixed
Select to define a fixed value.

• Numeric
Select for numeric characters.

Prompt Description
Specify the prompt as it is to appear on the scanning device.

Choose one of the following options:

• Fixed for Data Type
Specify, for Fixed Data, the fixed data value for this prompt. For example, if equipment type will
always be Asset, enter A.
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• If you selected Computed for Data Type
Specify, for Computed Data, the SQL command string used for the calculation. Use TKD_
PROMPTDATA1, TKD_PTOMPTDATA2, etc., to see the relevant column on the tracking transaction
table.

• If you selected Alphabetic for Data Type
Specify, for Pattern Match, a pattern match. See Step #8 for more information about Pattern
Match.

• If you selected Date for Data Type
Specify, for Date Format Mask, a date format mask. The date format mask should match the
data that is being entered in the data collection upload columns.

Pattern Match
Specify the pattern matching to be performed by the scanner. Pattern characters can include the
following values:

• . (period)
Represents a single alphabetical character, A through Z

• # (pound sign)
Represents any single number, 0 through 9

• _ (underscore)
Represents any single alphanumeric character, A through Z and 0 through 9

• % (percent)
Represents a string of alphanumeric characters

• , (comma)
Represents an OR condition

• : (colon)
Represents a THROUGH condition

• Any character(s) or number(s)
Indicates that exact character or number in that position

• ! any character(s) or number(s)
Indicates data entered should not match what follows the "!"

Archive Column
Specify the column where the system archives transaction data.

Interface Type

• A (Equipment audits)
Indicates the equipment audit starting point and designates a batch number
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• ADI (Add Details Interface)
Adds comments to a record

• E (Events (work order) interface)
Creates and updates work orders and activities

• H (Booked hrs interface)
Books labor hours on a work order activity

• I (Inventory issues)
Tracks inventory transactions of assets or parts, such as issues, returns, store-to-store
movements, etc.

• IRI (Inspection results interface
Tracks inspection results

• L (Equipment audit lines)
Indicates the equipment audit data

• MANF (Manufacturers interface)
Tracks manufacturer information

• O (Equipments interface)
Tracks assets, hierarchies, and user attributes

• PART (Parts interface)
Creates and updates part information

• PURC (Purchase order interface)
Downloads, creates, and updates purchase orders

• R (P.O. receipt)
Receives assets and parts with or without a purchase order

• READ (Readings interface)
Records meter readings

• REQ (Requisition interface)
Creates and updates requisitions for Goods requested transactions

• S (Stocktake interface)
Enters physical inventory counts

• TOUS (Tool usage interface)
Tracks tool usage information

Group Sequence
Specify the sequence in which to group data collection transactions.

Upload Column
Specify the interface column in which to load the data.

Infor EAM System Administrator Guide | 157

 

Data collection



Action Code
Specify the action that the selected interface performs on this data.

Prompt Sequence
Specify the chronological order in which this prompt occurs. Do not skip sequence numbers.

Minimum Length
Specify the minimum number of characters required for the data to enter at the prompt. Enter
nothing or 0 to make this prompt optional.

Next Prompt
Specify the next prompt to display on the barcode scanner. The maximum number of digits is eight.

Maximum Length
Specify the maximum number of characters required for the data to enter at the prompt.

Dup. Previous Value
Select to duplicate the previous value of the prompt.

If Data Is
Specify branch conditions, as necessary. Branch conditions include the following values:

• != represents not equal
• < represents less than
• <= represents less than or equal to
• = represents equal to
• > represents greater than
• >= represents greater than or equal to

Note: Infor suggests that you prompt the user once and then use a calculated field for each
subsequent time.

Pattern
Specify the pattern of the data collected. You can enter only one pattern.

Go To
Specify the prompt to display if the result of If Data Is and Pattern is true.

Note: This field is used by Oracle Forms.

Query Code
Specify the query code that defines a lookup for this prompt.

LOV Entity
Specify the entity of the lookup.

Validate File
Specify the filename of an ASCII text file against which to validate entries. The filename must be
in DOS format. For example, you can enter a file containing a list of authorized employee codes.
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When you enter an employee code, the reader accesses the file and validates the scanned code
against the employee list.

Lookup Attached
Select to make the lookup defined by SQL Code available. If you do not select this field, data is
still validated against SQL Code, but the lookup is not available.

Not Available
Select to ensure data entered is not in the lookups.

Override
Select to allow users to enter non-valid data if Not Available is unselected or to specify valid data
if Not Available is selected.

Print Barcode Label
Select to print a barcode label.

Note: This field is used by Infor EAM Mobile.

5 Click Save Record.

Note: Click Validate to validate the transaction prompt.

Defining return transaction prompts
Define return prompts to create default values for specific prompts. For example, if creating an
inter-warehouse transfer issue with a prompt for requisition number, requisition line, and outstanding
quantity, set up a trigger to search and automatically populate outstanding quantity with a value. Define
triggers using SQL statements.

To define return transaction prompts:

1 Select Administration > Data Collection > Monitor Interface.
2 Open the Transaction Type form.
3 Select the transaction type for which to define return prompts, and then click the Return Prompts

tab.
4 Click Add Return Prompt.
5 Specify this information:

Source Prompt
Enter the number corresponding to the prompt sequence number that triggers the return prompt
when you leave or tab out of the field. The system automatically populates the source prompt
description.

Target Prompt
Enter the number corresponding to the target prompt sequence number that receives the default
value. The system automatically populates the target prompt description.
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Note:  Target Prompt must be greater than Source Prompt.

Query Code
Enter the code identifying the SQL statement that calculates the default value for the target prompt.
The system automatically populates SQL Statement.

6 Click Submit.

Entering data with the prompt machine
Enter data into the data collection module with the Prompt Machine form instead of a barcode scanner,
as necessary. Submit one or more transactions of a selected transaction type.

Note: You must tab through the prompt data fields. You cannot navigate through the form by performing
a left-mouse click on a specific field. The only field available for navigation in this manner (by performing
a left-mouse click) is Transaction Type.

To enter data with the prompt machine:

1 Select Administration > Data Collection > Prompt Machine.
2 Specify this information:

Transaction Type
Enter the transaction type for which to enter data. The system automatically populates the description
of the transaction type and displays the prompt data fields associated with the transaction type.

3 Click Add Transaction.
4 Enter data for the prompt data fields as necessary.
5 Click Add to List.
6 Click Process Transactions.

Note: If you tab from the current Prompt Data to a lower-numbered Prompt Data, the system
automatically adds the record to the Transactions list, completing the current transaction and
beginning a new transaction.

Viewing scanner transactions to be processed
View scanner transactions to be processed. The number of records available to view constantly changes
as new records are processed through the system interface.

Note: View and correct any errors on the Error Correction page.

To view scanner transactions to be processed:

1 Select Administration > Data Collection > Monitor Interface.
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2 View the transaction information.

Setting up jobs
Set up predefined jobs. View and modify jobs. Disable jobs to stop their next scheduled executions or
restart previously stopped jobs.

Note: The JobCacheRefreshInterval tag in MPConfiguration.xml controls how often the job information
is monitored for changes. By default, the JobCacheRefreshInterval tag checks the jobs every 15 minutes.

To set up jobs:

1 Select Administration > Data Collection > Job Setup.
2 Select the job to set up.
3 Specify this information:

Active
Select to enable the job to start at the Next Run date and time.

Note: If you unselect the Active check box, the system disables the next execution of the job.

4 View the schedule pattern using Month, Day of Month, Day of Week, Hour, and Minute. The
schedule patterns are typically numeric, but can also include the following characters:

DescriptionSymbol

Matches all days, months, hours, and minutes,
e.g., an asterisk in Day of Week indicates that

* (asterisk)

the system performs the job every day of the
week.

Separates lists of days, months, hours, and
minutes, e.g., 31, 12, 0, 0 represents 12:00 A.M.
on December 31.

, (comma)

Specifies a range, e.g., 10-12 equals hours 10,
11, and 12.

- (hyphen)

Specifies increments, e.g., 0/15 minutes equals
minutes 0, 15, 30, and 45.

/ (backslash)

Indicates the last, e.g., Day of Month=L equals
the last day of the month.

L

See the table below for an example of a schedule pattern:
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DescriptionMinuteHourDay of WeekDay of
Month

Month

Run 5 minutes past midnight,
every day.

50***

Run at 10:00 P.M. on each
weekday.

0221-5**

Run each hour, every day.00-23/1***

Run at 1:00 A.M. on the last
day of each calendar quarter.

01*L3-12/3

5 Click Submit.Next Run date and time are automatically populated.

Correcting scanner transaction errors
Correct transaction errors by correcting data prompt values, and then submit the changes to the system
database. Save the updated record to resubmit it to the interface for reprocessing. The system
automatically reprocesses the correct record when saved.

Note: If a transaction error does not exist for an interface transaction, the system protects all fields.

To correct scanner transaction errors:

1 Select Administration > Data Collection > Monitor Interface.
2 Select the record for which to correct transaction errors, and then click the Error Correction tab.
3 Enter corrections to the data prompt values to correct the transaction error.
4 Click Save Record.
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5GIS administration

This chapter provides installation requirements and procedures for integrating Infor EAM with GIS.

This chapter documents procedures completed in both theInfor EAM and ESRI GIS systems. As a
result, section headings include (Infor EAM) or (ESRI), if applicable, to identify in which system the
task should be performed.

Note: See "Setting Up Menus for User Groups" on page 88 for information on granting access to the
GIS Map Search form within Infor EAM.
If you have purchased the GIS module and need to install ESRI, see ESRI’s GIS installation
documentation.
The Infor EAM-GIS integration supports both the ArcIMS and the ArcGIS server platforms. However,
certain aspects of the integration differ slightly between the ArcIMS and ArcGIS platforms. The
differences are noted where appropriate within this guide.

Software requirements and pre-installation checklist
• If you previously installed Infor EAM GIS Toolkit in a location other than C:\inforEAM\GIS, e.g.,

you modified the SETUP.BAT file supplied on the Infor EAM GIS Toolkit CD, contact Infor Technical
Support.

• Install Infor EAM GIS Extensions to integrate Infor EAM with ESRI.
See "Installing or upgrading Infor EAM GIS extensions" on page 164 procedures to install Infor EAM
GIS Extensions or to upgrade a previously installed version of the Infor EAM GIS Toolkit to the Infor
EAM GIS Extensions.

• If you are upgrading from a previously installed version of the Infor EAM GIS Extensions or are
reinstalling to a new location, the Installation Wizard automatically backs up user-created files from
the toolbar and help directories. The Installation Wizard saves the toolbar.bak and help.bak directories
in the original installation location.

ESRI PRODUCT VERSION 10.0
Infor EAM supports connectivity with ArcGIS 9.3.1 SP1 and ArcGIS 10.0 SP1. Anytime you upgrade
your ArcGIS installation to v10.0 SP1 you are required to perform following steps on the EAM application
server for the GIS integration to work correctly:
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1 Open \depconfig\extended_properties.xml.
2 Specify the version number of the ArcGIS server in <gis><version/></gis> tags. E.g., To support

ArcGIS server version 10.0, the tags will look like this:

                        <gis>
                               <version>10.0</version>
                        </gis>

3 Perform redeployment on EAM.
Note: By default, Infor EAM provides support for ArcGIS 9.3.1 SP1.

Installing or upgrading Infor EAM GIS extensions
To install or upgrade Infor EAM GIS Extensions:

1 Insert the Infor EAM GIS Extensions CD into the proper drive.
2 Choose the folder specific to your version of ArcGIS:

• 9.3
Select this folder if you have ArcGIS 9.3.1 SP1 installed on your machine. Execute the
GIS93101WN201110.exe file.

• 10
Select this folder if you have ArcGIS 10.0 SP1 installed on your machine. Execute the
GIS10WN201110.exe file.

Note: See "Software requirements and pre-installation checklist" on page 163.

3 Click Next.
4 Select I accept the terms of the license agreement if you agree to the terms, and then click Next.
5 Verify that the required applications are installed, and then click Next.
6 Select Install New Infor EAM GIS Extensions to install Infor EAM GIS Extensions for the first time

or to upgrade to Infor EAM GIS Extensions from a previous version, and then click Next.

Note: Select Add or Remove Infor EAM GIS Extensions if you have already installed or upgraded
to this version of Infor EAM GIS Extensions but want to add or remove individual extensions from
your configuration.

7 Select the extensions to install. See the following information:

Note: Configuration and Help are required selections.

• Create Equipment
Select to install Infor EAM equipment creation within ESRI.
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• Create Work Order
Select to install the Create Work Order popup.

• Events
Select to install the Infor EAM Events popup.

• Map Feature Attributes
Select to install the Map Feature Attribute popup.

• Synchronize Records
Select to install the Synchronize Records popup.

• Synchronize Attributes
Select to install the Synchronize Atrributes popup.

• Data Filter
Select to install the Data Filter popup.

8 Click Next.
9 Enter the directory in which to install the Infor EAM GIS Extensions, and then click Next.
10 Review the settings information, and then click Next.
11 Click Finish.

Note: If the Infor EAM GIS Extensions are not visible by default in ArcMap, choose Tools >
Customize > Toolbars from the menu bar, and then select Infor EAM GIS Extensions.

Understanding GIS integration
Both Infor EAM and ESRI’s GIS should reflect an accurate representation of your company assets.
Link Infor EAM equipment records and GIS features with a GIS object identification number (GIS ID in
Infor EAM GISOBJID in ESRI).

Note: Both SDE connection and direct connection are supported for the Infor EAM to ESRI GIS
integration.

Define user preferences to control how ESRI responds when a user creates new equipment records
within Infor EAM and how Infor EAM responds when a user creates new features within ESRI.

ESRI and Infor EAM create and synchronize corresponding equipment/features based on field mappings
and GIS profiles. The field mappings and GIS profiles ensure the systems populate accurate attribute
data while creating features/equipment.

Field mappings, which are defined at the layer level, allow users to move or copy specific data from
one feature to its corresponding equipment record or vice-versa, e.g., map the DISTRICT attribute in
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ESRI to the Organization field in Infor EAM. The system populates the equipment record’s Organization
with the data contained in the DISTRICT attribute for the feature.

See "Defining field mappings for attributes (Esri)" on page 178.

Equipment profiles, which serve as equipment templates, can be related to GIS layers. If an attribute
value will be the same for all features in a layer, then the profile can be used to populate this equipment
value, e.g., if the Organization of the GIS profile is Org 1, all equipment/features created based on that
profile belong to Org 1.

See these topics:

• "Defining preferences for the creation of Infor EAM equipment (ESRI)" on page 181
• "Defining preferences for the creation of GIS features (Infor EAM)" on page 182

Note: During equipment/feature creation, if there are both field mappings and a GIS profile, the system
populates fields based on the mappings first. If you do not define a mapping for a field, the system
populates the field based on the information defined on the related GIS profile.
If a field mapping for an attribute exists, the system always populates the equipment field based on
the data of the attribute, even if the attribute value is empty and the GIS profile value contains data.
The Infor EAM-GIS integration supports both the ArcIMS and the ArcGIS server platforms. However,
certain aspects of the integration differ slightly between the ArcIMS and ArcGIS platforms. The
differences are noted where appropriate within this guide.

Defining equipment for features defined prior to
integration
If you are integrating ESRI and Infor EAM for the first time, move multiple GIS features to Infor EAM
through data collection.

Every GIS feature for which you create a corresponding Infor EAM equipment record must have a
GISOBJID number.

Note: If you need to integrate a GIS feature with Infor EAM that does not have a GISOBJID field for
its layer, you must manually create the field.
See "Creating GISOBJID fields for layers manually (ESRI)" on page 166.
After you manually create the GISOBJID field for each layer you need to integrate with Infor EAM,
manually enter a GISOBJID number for each feature within the layer. numbers that you manually enter
must be less than 100,000,000.

Creating GISOBJID fields for layers manually (ESRI)
Infor EAM automatically generates GIS ID numbers once the two systems are fully integrated, but you
must manually enter a GISOBJID number in the attribute table of every GIS feature that you want to
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move to Infor EAM prior to integrating the systems. For every layer containing GIS features that need
to be integrated with Infor EAM manually create a GISOBJID field.

To create GISOBJID fields for layers manually:

1 Open ArcMap to an existing map.
2 Select the layer for which to add a GISOBJID field.
3 Right-click the layer, and then choose Open Attribute Table.
4 Click Options, and then select Add Field.
5 Specify this information:

Name
Enter GISOBJID.

Note: Enter the name of attribute column headers using all uppercase letters. The system only
searches column headers in all uppercase letters when performing a search based on a GIS Filter.
See the Infor EAM GIS User Guide.

Type
Select Long Integer.

Note: Enter a precision of 9.

6 Click OK.

Configuring the geoprocessing service for the ArcGIS server
The Infor EAM-GIS integration supports both ArcIMS and ArcGIS Server. When integrating Infor EAM
and GIS using ArcIMS server, you must create an Image Service on the ArcIMS Server. See ESRI
documentation for more information. If you are integrating Infor EAM and GIS using ArcGIS Server,
you must create a Map Service, Geocoding services, and also a Geoprocessing Service. See ESRI
documentation for more information on creating these services. You must create the Geoprocessing
service using the InforTools.tbx toolbox located in the \arcgisserver\ directory of the Infor EAM GIS
product CD.

See "Modifying the GIS installation parameters (Infor EAM)" on page 169 for more information on enabling
communications with these mapping services.

Configuring for ArcGIS server version 10.0
To configure the Geoprocessing Service for the ArcGIS server:

1 Open the ArcCatalog application.
2 Locate the GIS Servers menu, and then select your GIS server.
3 Right-click the server, and then choose Add New Service.
4 Specify this information:
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Name
Specify the GIS Service name, e.g., InforTools.

Type
Select Geoprocessing Service.

Description
Specify a description for the GIS service as necessary.

Startup Type
Select Automatic, and then click Next.

Execution Type
Select Syncronous.

Toolbox
Locate the InforTools.tbx file on your ArcGIS server.

Note: InforTools.tbx is included on the Infor EAM GIS product CD.

Jobs Directory
Specify the location of the ArcGIS jobs directory.

Output Directory
Specify the location of the ArcGIS output directory.

Maximum Number of Records Returned by Server
Specify the maximum number of records to be returned by the ArcGIS server when running a job.

5 Click Next.
6 Select Enable Web Access, and then click Next.

Note: The value displayed in the URL field is the value that must be entered for the GISGPSRV
installation parameter.

7 Complete the remaining steps of the Add GIS Service process as necessary, and then click Finish.

Configuring for ArcGIS server versions 10.1 and 10.2
To configure the Geoprocessing Service for ArcGIS server versions 10.1 and 10.2:

1 Open ArcMap 10.1/10.2 session.
2 Navigate to InforTools.tbx, and expand the plus icon that appears in the file. The BufferTool popup

is displayed.

Note: Locate the InforTools.tbx file on your ArcGIS server in the Catalog window of Arc Map.

3 Right-click on the BufferTool, and then click Open.
4 Click OK on the BufferTool popup.
5 Select the Geoprocessing - Results menu item from the main menu of the ArcMap 10.1/10.2.
6 Select the latest execution result from the Results window, right-click the selection, and then select

the Share As - Geoprocessing Service menu item and publish the geoprocessing service. See ESRI
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ArcGIS documentation for information if errors are encountered while publishing the Geoprocessing
service.

Configuring Infor EAM and ESRI's ArcMap
Configure Infor EAM and ESRI to best meet the specific needs of your company.

Configuring ArcMap for equipment creation (ESRI)
Configure ArcMap to to allow auto-creation of Infor EAM equipment records from within ESRI’s GIS.

To configure ArcMap for equipment creation:

1 Select Tools > Extensions.
2 Select Infor EAM Create Asset Editor Extension, and then click Close.

Modifying the GIS installation parameters (Infor EAM)
Modify the GIS installation parameters in Infor EAM before using GIS.

Note: To display GIS parameters only, select GIS in Dataspy.

To modify the GIS installation parameters:

1 Select Administration > Security > Install Parameters.
2 Select the following parameters and modify as necessary:

Configuration parameters
DescriptionParameter

Specify the ArcIMS platform. Acceptable values are SHAPEFILE and
SDE.

GISAIMSP

Specify theArcIMS version. For example, enter 9.2 if this is the installed
version of ArcIMS.

GISAIMSV
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DescriptionParameter

Specify the connection type between the Infor EAM web server and the
ArcIMS server by entering a value of TCP, HTTP, or HTTPS. If no value
is specified, a TCP connection is assumed.

Note: Used only for ArcIMS server.

GISCONTP

GIS geoprocessing service (AGS only).
See"Configuring the geoprocessing service for the ArcGIS server" on
page 167.

GISGPSRV

ArcIMS server name (and domain if required).GISHOST

Format of map image returned from ArcGIS Server. Acceptable values
are BMP, GIF, JPG (default), PNG, and PNG24.

Note: Used only for ArcIMS server.

GISIMGFM

Port number on which the rcIMS service mentioned in the GISSERV
install parameter is accessed.

Note: Used only for ArcIMS server.

GISPORT

Name of the default Image Service setup on the ArcIMS server or Map
Service URL on ArcGIS Server.

GISSERV

Specify the GIS server type. Acceptable values are IMS (default) and
AGS.

GISSRVTP

GIS map file for service identified by GISSERV. Used for viewing
nearest address, e.g., reverse geocoding.

Note: GISSVAXL supports HTTP, fully qualified file paths, and UNC
file paths. The system requires this to load the XML of the AXL and re-

GISSVAXL

trieve the geocoding definitions. Such information is not available via
ArcXML responses.
You do not need to specify a value for GISSVAXL if you are using Ar-
cGIS.

Enter http://your.infor.com.server/attachments/giswo/tenantid/.
Use http://your.infor.com.server /attachments/giswo/default/ if no

URLGIS

tenant id exists. This value is used when displaying and printing map
attachments of the work order.
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Search-related parameters
DescriptionParameter

Maximum number of advanced buffer layers allowed in an advanced
search. The default is 3.

GISABLC

Name of the Address Layer in the Image Service setup in the GISSERV
install parameter.

Note: When ArcGIS Server is being used and a geocoding process is
established, the system does not use this parameter as this information

GISADDR

is contained within the geocoding service described by parameter
GISGEOSV. If geocoding is not being used with ArcGIS Server, the
system uses this information when performing searches.

Name of the Zone Column in the attributes of the Zone Layer. This pa-
rameter is used for non-geocoded, zone-only searches.

Note: When ArcGIS Server is being used and a geocoding process is
established, the system does not use this parameter as this information

GISCCCOL

is contained within the geocoding service described by parameter
GISGEOSV. If geocoding is not being used with ArcGIS Server, the
system uses this information when performing searches.

Name of the Zone Layer in the Image Service setup as the GISSERV
install parameter. This parameter is used for non-geocoded, zone-only
searches.

Note: When ArcGIS Server is being used and a geocoding process is
established, the system does not use this parameter as this information

GISCITY

is contained within the geocoding service described by parameter
GISGEOSV. If geocoding is not being used with ArcGIS Server, the
system uses this information when performing searches.

Name of the Zone Column in Attributes of the Address Layer. This pa-
rameter is used for non-geocoded address searches.

Note: When geocoding is used, the system does not use this parameter
as this information is contained within the geocoding service described

GISSTCOL

by parameter GISGEOSV or GISSERV, depending on whether ArcGIS
Server or ArcIMS is used.

Default equipment layer nameGISEQUIP

ArcIMS: Name of the secondary address for geocoding layers. (See
GISSERV for the default Image Service setup). Values should be sep-

GISGEOSV

arated by commas and can identify layers of different services (eg.
Layer2, Layer3, Service2.Layer1). ArcGIS Server: Name of the
geocoding service(s). Values should be separated by commas.
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DescriptionParameter

Specify the maximum number of geocoding match candidates. The
default is 100.

GISGMAXC

Specify the minimum geocoding score that the system should display
in the Matching Addresses popup. The default is 20. Separate multiple

GISGMIN

geocoding score values with a comma. The first value listed is the score
for GISSERV and subsequent entries are values for each GISGEOSV.

Specify the separator for searching for intersection addresses. The
defaults are &, |, and @. Values should be separated with a space.

Note: When ArcGIS Server is being used and a geocoding process is
established, the system does not use this parameter as this information

GISINTRS

is contained within the geocoding service described by parameter
GISGEOSV. If geocoding is not being used with ArcGIS Server, the
system uses this information when performing searches.

Set to Global to display a single map in Infor EAM based on GIS instal-
lation parameters. Set to Organization to display maps based on Or-

GISMAPS

ganization. Set to Department to display maps based on Department.
Department Security must be enabled when set to Department.

Specify the radius, in meters, used for viewing the nearest address.
The default value is 1500.

GISNARAD

Name of the Street Column in Attributes of the Address Layer

Note: When geocoding is used the system does not use this parameter
as this information is contained within the geocoding service described

GISSTCOL

by parameter GISGEOSV or GISSERV, depending on whether ArcGIS
Server or ArcIMS is used.

Factor (%) of default extent by which the map search result will be en-
larged. The default is 2.

GISZOFCT

Highlighted line parameters
DescriptionParameters

Specify the color of the highlighted lines in the GIS map by entering an
RGB color of 0 to 255.

GISLNCOL

Specify the width of highlighted lines in the GIS map, or enter LAYERDE-
FINED.

Note:  For more information about the LAYERDEFINED value, see
"Customizing map symbols" on page 175.

GISLNWID
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DescriptionParameters
If ArcGIS Service is being used and the value for this parameter is
LAYERDEFINED the color information will come from the map’s MXD
symbology definition versus the GISLNCOL.

Highlighted point parameters
DescriptionParameters

Specify the color of the highlighted points in the GIS map by entering
an RGB color of 0 to 255.

GISPTCOL

Specify the point type. Valid values for ArcIMS: STAR, CIRCLE, CROSS,
SQUARE, TRIANGLE, RASTERMARKER, or LAYERDEFINED. Valid

GISPTTYP

values for ArcGIS Server: CIRCLE, CROSS, SQUARE, DIAMOND, X,
RASTERMARKER, or LAYERDEFINED. Default is CIRCLE.

Note: If ArcGIS Service is being used and the value for this parameter
is LAYERDEFINED the color information will come from the map’s MXD
symbology definition versus the GISPTCOL.

Specify the width of the highlighted point used in the GIS map.GISPTWID

Highlighted polygon parameters
DescriptionParameters

Specify the fill color used for highlighted polygons in the GIS map by
entering an RGB color of 0 to 255.

GISPLYCL

Specify the color used for the boundary of highlighted polygons in the
GIS map by entering an RGB color of0 to 255.

GISPLYBC

Specify the fill type of highlighted polygons in the GIS map by entering
a value of HORIZONTAL, BDIAGONAL, CROSS, DIAGCROSS, FDI-
AGONAL or VERTICAL.

GISPLYFT

Specify the transparency level of the color fill of highlighted polygons
in the GIS map.

Note: If you are using ArcGIS Server, you do not need to specify a
value for GISPLYTR because the system does not support the ability
to highlight a polygon using a transparent image.

GISPLYTR
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Markup line and point parameters
DescriptionParameters

Specify the color of the GIS markup line. The defaults are 255, 55, and
155.

GISMLCOL

Specify the width of the markup line. The default is 4.GISMLWID

Specify the color of the markup point. The default is 255, 55, and 155.GISMPCOL

Specify the type of the markup point. Valid values for ArcIMS: CIRCLE,
STAR, CROSS, SQUARE, TRIANGLE, or RASTERMARKER. Valid

GISMPTYP

values for ArcGIS Server: CIRCLE, CROSS, SQUARE, DIAMOND, X,
or RASTERMARKER. Default is CROSS.

Specify the width of the markup point. The default is 15.GISMPWID

Selected feature parameters
DescriptionParameters

Specify the highlight color of selected features. The defaults are 248,
138, and 29.

GISSFCLR

Linear equipment label parameters
DescriptionParameters

Specify how the system should display boundary labels for linear
equipment (referred to as ‘routes’ in GIS). Acceptable values are L, N,
and A. The default is L.
L to display boundary labels for the longest path (in the event of multiple
route paths).

GISDREL

N to display no boundary labels.
A to display boundary labels for all paths (in the event of multiple route
paths).
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Text marker label parameters
DescriptionParameters

Specify the font color of the text marker label.GISTFNTC

Specify the font style of the text marker label by entering BOLD,
BOLDITALIC, ITALIC, REGULAR, OUTLINE, or UNDERLINE. The
default is BOLD.

GISTFNTS

Specify the font size of the text marker label. The default is 10.GISTFNTZ

Specify the font of the text marker label. The default is Arial.GISFONT

Specify the color with which to highlight the text marker label.GISTGCLR

Specify the color with which to outline the text marker label.GISTOCLR

Specify the print mode for the text marker label by entering ALLUPPER,
ALLLOWER, NONE, or TITLECAPS. The default is ALLUPPER.

GISTPRMD

Specify the point color of the text label.GISTLPCL

Specify the point type of the text label by entering CIRCLE, STAR,
CROSS, SQUARE, TRIANGLE or RASTERMARKER.

Note: For more information about the RASTERMARKER value, see
"Customizing map symbols" on page 175.

GISTLPTP

Specify the width of the point used in the text label.GISTLPWD

Overview map parameters
DescriptionParameters

Specify the image service to display within the overview map. The default
is the value from GISSERV.

GISOVSV

Specify the size of the overview map. The number you enter represents
a percentage of the width of the current map. The default is 25.

GISOVSZ

Customizing map symbols
Infor EAM provides basic symbols for use as map markers; however, you can customize your map
symbols with the RASTERMARKER or LAYERDEFINED installation parameter values.
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Define unique symbols with the RASTERMARKER value. The RASTERMARKER value allows you to place
user-defined images on the ArcIMS server, and the system identifies features based on your user-defined
image.

The LAYERDEFINED value allows you to display symbols based on those defined in ArcIMS from the
layer’s renderer symbology. The system maintains the displayed images even when you highlight
features on the map, e.g., if you highlight manholes and transformers on your map, the system displays
the renderer’s distinct images for manholes and transformers, but highlights the images according to
the color specified in the image’s corresponding color installation parameter.

GISLNWID is LAYERDEFINED. Then use MxD symbology for color versus GISLNCOL.

GISPTTVP->GISPLOL.

Note: Images must be set up as follows: IMS images must see the GIS server and AGS images must
see the Infor EAM server.

Granting interface permissions for data filter grids (Infor
EAM)
Users can filter Infor EAM data within ESRI using the Data Filter popup. Grant interface permissions
to each of the filterable grids.

To grant interface permissions for data filter grids:

1 Select Administration > Security > User Groups.
2 Select the user group for which to grant interface permissions, and then click the Interface

Permissions tab. See the following table of functions in order to grant user group access to the
grids accessible by the GIS data filter:

3 Change this information:

Grants Access ToFunction

Equipment gridBEGEQ

Equipment and related cost details gridBEGEQC

Equipment and related event details gridBEGEQE

Work order and related activity details gridBEGWAC

Work order and related equipment details gridBEGWEQ

4 Select a function listed in the table above.
5 Specify this information:

Query
Select to allow users to retrieve records.

176 | Infor EAM System Administrator Guide

 

GIS administration



6 Click Submit.

Defining Infor EAM user information (ESRI)
Define Infor EAM user information in GIS so that you can create Infor EAM equipment records from
within GIS.

Infor EAM user information must be defined for each GIS client machine. After defining user information
in GIS’s ArcMap, you can define preferences for the creation of Infor EAM equipment records and
create them within ArcMap.

To define Infor EAM user information in GIS:

1 Open ArcMap to an existing map.
2 Click ArcEditor.
3 Specify this information:

User
Enter a valid Infor EAM user name.

Note: If you are working in a multi-tenant environment, enter username@tenantID, e.g., if your
username is SMITHB and your tenant ID is dsmp1, enter SMITHB@dsmp1.

Password
Enter the user’s Infor EAM password.

Confirm Password
Re-enter the user’s Infor EAM password.

Organization
Enter the organization under which the user logs in to Infor EAM.

Style
Select the style sheet to apply to Infor EAM popups in ArcMap. The system applies the selected
style sheet to the popup immediately.

Note: The system provides three stylesheets: Default, Blue, and Gray. To create a custom style
sheet, open DEFAULT.XSS located in C:\inforEAM\GIS\TOOLBAR\STYLES and make changes
to the file as necessary. Do not save your changes to the original DEFAULT.XSS file; instead, save
the style sheet under a new name to the same location. The newly created style sheet appears as
an option in the dropdown list for Style.

Infor EAM URL
Enter the URL address for the Infor EAM server to which ArcMap should connect, e.g.,
http://<yourserver.yourcompany>/axis/...services/EWSConnector.

Tenant
Enter the tenant ID if you are working in a multi-tenant environment.
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4 Click Submit. ArcMap saves the record on the user’s machine in
C:\inforEAM\GIS\CONF\EWSUSER.XML.

Note: The system automatically creates this file if it does not already exist.

Defining field mappings for attributes (Esri)
Define field mappings for attributes stored within Esri’s GIS and Infor EAM at the layer level. The fields
are populated based on the mappings during equipment/feature creation and synchronization.

Note: To define field mappings, you must have OEGGMP permissions.

During equipment/feature creation, the fields are populated based on the mapping relationship, e.g.,
to create an equipment record based on an existing feature, map data from a GIS Attribute to an Infor
EAM Attribute. Infor EAM populates the field with the data contained in ESRI’s GIS. You can also define
field mappings based on constant values, e.g., enter a GIS Value of HYDRANT and map it to the
category field in Infor EAM. During equipment creation, the system always populates the category field
with HYDRANT.

During synchronization, the system accesses field mappings to ensure corresponding equipment
records and features reflect accurate data. If there is a discrepancy in data, the system copies data
from one system to the other.

Note: You do not have to define field mappings for a feature’s layer, location X, or location Y. These
values are automatically populated in the EAM equivalent fields during creation and synchronization.
You may, however, define additional field mappings for these GIS attributes if you want the values of
these fields copied into other EAM fields.
You may map more than one GIS Attribute to a single Infor EAM Attribute and vice-versa. During
creation and synchronization, the system concatenates the data into the single field based on the
Sequence and Delimiter.
Likewise, you can map an Infor EAM Attribute that contains concatenated data into more than one GIS
Attribute and vice-versa. During creation and synchronization, the data is parsed based on the
Sequence. If the system must parse data because one field is mapped to multiple fields, it verifies that
the number of fields to which to map data matches the instances of concatenated data in the source
field. If it does not, the data is not synchronized. If, however, the source field in the owner system
contains a null value, the null value is copied to the multiple fields in the other system, overwriting any
data that those fields originally contained.

Identify a Source system, which controls creation, and an Owner system, which controls synchronization.
The data is mapped from the Source system during equipment/feature creation. The data is copied
from the Owner system during synchronization. See the following example.

You define the following field mapping for the Hydrant layer:

OwnerSourceInfor EAM AttributeGIS Attribute

Infor EAMGISDescriptionADDRESS
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During synchronization of the Hydrant layer, the system discovers that a feature with the ADDRESS
attribute of 156 Main Street does not have a corresponding Infor EAM equipment record. The system
creates an equipment record and automatically populates its description field with 156 Main Street
because Esri’s GIS is the Source.

Later, you update the same equipment record’s description to 256 Main Street in EAM. During the next
synchronization of the Hydrant layer, the system updates the GIS feature’s ADDRESS attribute to 256
Main Street because Infor EAM is the Owner of this attribute.

Note: The system only compares attribute data for EAM and GIS if the attribute has a defined field
mapping and the Action is set to Copy.

To define field mappings for attributes:

1 Open ArcMap to an existing map.

Note: The map must contain an integrated layer to access the Map Feature Attributes popup.

2 Click Display Map.
3 Select the layer for which to define field mappings.
4 Click Add Mapping.
5 Specify this information:

Type
Specify the mapping type for the record as Equipment or Work Orders.

Infor EAM Grid
If you selected Work Orders as the value for Type, specify the EAM user defined grid to use for
mapping. The fields available for mapping are based upon the EAM grid selected here.

Note: The user defined grid must be Active and have the GIS WO Attribute Mapping Grid check
box selected to show in this lookup.
Type and Infor EAM Grid fields only display when an event layer is selected to define field mappings.

Source
Select the system from which data should be mapped during equipment/feature creation. Choose
one of the following options:

• GIS
Select to map data from GIS when creating new equipment records based on an existing GIS
feature.

• Infor EAM
Select to map data from Infor EAM when creating new features based on an existing Infor EAM
equipment record.

• Both
Select to apply this mapping when creating new equipment records/features regardless of which
system the object originally resides. The system maps data from Infor EAM when creating new
features and maps from ESRI’s GIS when creating new equipment records.
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6 Select the attribute (GIS Attribute or Infor EAM Attribute) from which data should be mapped or
enter the value ( GIS Value of Infor EAM Value) that should be mapped. The attribute or value
should coincide with the source system, e.g., if you selected GIS as the Source system, select a
GIS Attribute of GIS Value to map.

Note: If you select Layer, Location X, Location Y, or Feature Length as the GIS Attribute from
which to map data, the system automatically populates Source as GIS, Action as Copy, and Owner
as GIS.

7 Select the attribute (GIS Attribute or Infor EAM Attribute) to which data should be mapped.
See the following table to understand the relationship between Mapped From and Mapped To, e.g.,
if you select a GIS Attribute in Step 6, you must enter an Infor EAM Attribute in Step 7:

Mapped ToMapped From

Infor EAM AttributeGIS Attribute

Infor EAM AttributeGIS Value

GIS AttributeInfor EAM Attribute

GIS AttributeInfor EAM Value

Note: For linear features, map the GIS Attribute feature length to the Infor EAM Attribute equipment
length, and then map the GIS Attribute for the feature’s unit of measure to the Infor EAM Attribute
equipment length unit of measure to enable linear equipment capabilities in Infor EAM. You must
create your own GIS attribute in ESRI for the feature’s unit of measure.

8 Specify this information:

Action
Choose one of the following options:

• Copy
Select to copy the attribute data from the Source system.

• Move
Select to move the attribute data from the Source system. After the move is completed, the
data will only exist in one system.

Note: If you select Move, the system protects Owner. Defining an Owner implies the data
exists in both systems.

Owner
Select the system that controls synchronization when a discrepancy exists between a corresponding
feature and equipment record. Data is copied from the Owner system to the field of the other
system.

Sequence
Select the sequence number of the mapping. If you select any number other than 1, the system
enables Delimiter.
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Note: You must select a Sequence number greater than 1 in the event that you map more than
one GIS attribute to a single attribute within Infor EAM, e.g., if you map HYDRANT and HYDRANT_ID
from GIS to Asset EAM within , the system must know which data to list first in the EAM Asset field.

Delimiter
Specify the delimiter value to use in the event that you map more than one GIS attribute to a single
EAM Attribute.

9 Click Submit.

Defining preferences for the creation of Infor EAM
equipment (ESRI)
Define preferences for Infor EAM equipment records that you create from within the GIS system. When
you define preferences, specify the equipment profile that GIS should use to create the Infor EAM
equipment record when you create features in the related GIS layer.

Note: When creating equipment records, the system populates fields based on field mapping. If there
is no mapping available for a field, the system populates the field based on the GIS profile.

Based on the information you enter in the Infor EAM Preferences popup, GIS can automatically create
an Infor EAM equipment record in the same layer as its corresponding GIS feature whenever you define
a new GIS feature. The system will not create an Infor EAM equipment record if the layer of the GIS
feature is not listed in the preferences file.

Note: If you want to save an existing preference file in a different location, relocate the file, and then
enter the new file path in Path To Preferences.

To define preferences for the creation of Infor EAM equipment:

1 Open ArcMap to an existing map.
2 Click ArcEditor.
3 Click the Preferences tab.
4 Specify this information:

Path To Preferences
Enter the file path in which to store the Infor EAM preferences.

Note: ArcMap saves all files as .XML files.

5 Click Add Preference.
6 Specify this information:

Profile
Enter the Infor EAM equipment profile that ArcMap should use to create Infor EAM equipment
records. The system automatically populates Profile Org.
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Layer
Select the GIS layer in which Infor EAM equipment records should appear.

Auto-create
Select if you want GIS to automatically create corresponding Infor EAM equipment records for
features that you create within GIS.

Default
Select if this preference record is the default preference record.

Note: Each profile can have only one default preference record per layer. You cannot select more
than one record containing the same layer as a default record.

7 Click Submit.

Defining preferences for the creation of GIS features
(Infor EAM)
Define preferences for GIS features that you create from within Infor EAM. When you define preferences,
specify the equipment profile related to the layer in which you intend to create the new GIS feature.
The system retrieves the default Layer, Location X, and Location Y based on the preference.

Note: When creating features, the system populates attribute data based on field mapping. If there is
no mapping available for an attribute, the system populates the attribute data based on the GIS profile.

Also specify how Infor EAM retrieves data for the creation of GIS features. There are three ways to
populate data for the creation of GIS features from within Infor EAM: Auto-create, Prompt, and Manual.

Auto-create
If you specify the preference for the creation of GIS features as Auto-Create, when users select a GIS
profile when defining new Infor EAM equipment, the system automatically generates a GIS ID and
populates the default Layer, Location X, and Location Ybased on the preference.
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6Fleet management configuration

This chapter provides procedures for configuring the fleet management module.

For more information on the American Trucking Association’s Vehicle Maintenance Reporting System
(VMRS) and defining VMRS in the system, see the Infor EAM User Guide.

For more information on fleet management reports, see the Infor EAM User Guide.

To access Infor EAM Databridge functions within Infor EAM, you must first set up Databridge menus
for user groups.

See "Setting Up Menus for User Groups" on page 88.

Understanding fleet configuration
Use the Fleet Configuration page to personalize the vehicle ticketing, maintenance, and billing process
for pool, loaner, and/or assignment fleets of vehicles. First, create billing parameters to configure the
point at which vehicle tickets are billed. Next, set up billing schedules to determine the billing end dates
for the period billing process, and create exceptions to include in bills when needed. Next, grant
authorizations to specific user groups for specific vehicle types. Finally, identify fuel, maintenance, and
billing categories.

You must also define cost codes, employees, and assets for use in the fleet management module. The
cost codes, employees, and assets are not a part of the fleet management module.

Creating parameters for fleet configuration
Set up parameters to determine the Vehicle Ticket form behavior and how the vehicle usage will be
billed.

To create parameters for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Specify this information:
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Update Ticket PM Details
Choose one of the following options:

• At Issue
Select to update the PM details on the vehicle ticket when a vehicle is issued.

• At Return
Select to update the PM details on the vehicle ticket when a vehicle is returned.

• Issue and Return
Select to update the PM details on the vehicle ticket when a vehicle is issued and returned.

Note: Previous and next PM details are updated on the ticket of the specified time(s).

Min. Hours Billed
Enter the minimum number of hours to be billed. For example, if the Min. Hours Billed is four hours
and the vehicle is returned after two hours, the customer will be billed for the minimum amount of
four hours.

Offshift Billing Hours
Enter the number of hours if the usage includes any time outside of the billing start and end time.
For example, if the normal billing hours are from 8:00 AM to 5:00 PM, any hours before 8:00 AM
and after 5:00 PM will be considered offshift billing hours. Vehicles issued or returned outside the
billing hours are billed accordingly. The offshift billing hours are billed once every 24-hour period.

Prompt When No Billing Code
Select to provide a warning message from the vehicle ticket if the system cannot find a billing code
or markup code on the vehicle ticket at the time the vehicle is issued.

Billing Start Time
Select the time, in hours, at which the normal billing hours for the day should start, and then enter
the time, in minutes, at which the normal billing hours should start in the adjacent field.

Billing End Time
Select the time, in hours, at which the normal billing hours for the day should end, and then enter
the time, in minutes, at which the normal billing hours should end in the adjacent field.

Note: If both Billing Start Time and Billing End Time are empty, the system selects a 24-hour
billing cycle. Billing Start Time must be before Billing End Time.

Round Billing Hrs. Up
Select to round the billing hours to the nearest ¼, ½, or whole hour.

Note: If you do not want to round the ticket billing hours up, do not enter a value for Round Billing
Hrs. Up.

Pool
Select to indicate that the fleet customer and cost code on the vehicle record needs to be updated
with the ticket values when a pool ticket is created.
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Loaner
Select to indicate that the fleet customer and cost code on the vehicle record needs to be updated
with the ticket values when a loaner ticket is created.

Assignment
Select to indicate that the fleet customer and cost code on the vehicle record needs to be updated
with the ticket values when an assignment ticket is created.

3 Click Save Record.

Note:  If the process fails to run automatically as scheduled, click Run Billing Process to manually
run the billing process. The system generates customer bills, beginning with the earliest Period
End Date specified on the Billing Schedules page of the Fleet Configuration form that is past
due.
See "Setting up billing schedules for fleet configuration" on page 185.
You cannot manually run the billing process unless the Process Start Date/Time on the Billing
Schedules page is before the current system date and time; the period has not been billed; Billed
on the Billing Schedules page is unselected; and the billing process for the record is not currently
running or the billing process for the record is running but has been running for longer than 30
minutes.

Setting up billing schedules for fleet configuration
Set up billing schedules to determine what transactions are billed and when they will be created. At
the end of the billing schedule, generate customer bills that correspond with the billing schedule Period
End Date.

See "Creating parameters for fleet configuration" on page 183 for more information on running the billing
process.

To set up billing schedules for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Click the Billing Schedules tab.
3 Click Add Billing Schedule.
4 Specify this information:

Period End Date
Enter the date at which the billing period will end, e.g., 6/25/05.

Period Description
Enter a description of the billing period, e.g., June 2005.

Process Start Date
Enter the date at which to start the billing process for the selected billing period.

Note: The Process Date/Start Time must be greater than the Period End Date.
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Process Start Time
Enter the time in hours and minutes at which to start the billing process.

5 Click Submit.

Note: If the billing process is currently running for the period, the system selects In Process. The
system selects Billed after the billing process has been run for the billing schedule.
See "Creating parameters for fleet configuration" on page 183.
You can manually select Billed to create a starting point for the first billing process.

Creating exceptions for fleet configuration
Create exception codes, and then associate fees with the exception codes that will be included in bills.
For example, create an exception code that charges customers for low amounts of fuel in returned
vehicles, and then associate a $50 fee for that specific exception. Exception codes are associated with
vehicle tickets on the Exceptions page of the Vehicle Ticket form.

To create exceptions for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Click the Exception Codes tab.
3 Click Add Exception.
4 Specify this information:

Exception
Enter the exception to be applied to vehicle tickets, and then enter a description of the exception
in the adjacent field.

Organization
Enter the organization to which the exception belongs if you use multi-organization security.

Billing Amount
Enter the set fee to associate with the exception during the billing process.

Standard WO
Enter a standard work order that can be used to create work that corrects the exception condition
for the vehicle ticket.

Out of Service
Select to prevent the exception from being displayed in the lookups.

5 Click Submit.
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Granting vehicle ticket authorizations for fleet configuration
Grant vehicle ticket authorizations to define appropriate privileges to user groups for pool, loaner, and
assignment vehicle ticket types. Associate specific user groups with specific vehicle ticket types, and
then grant authorizations for the user group to insert, delete, and/or update vehicle ticket records of
that type.

Note: You can only grant vehicle ticket authorizations if the installation parameter VTTAUTH is set to
ON. Contact your system administrator for more information.

To grant vehicle ticket authorizations for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Click the Vehicle Ticket Authorizations tab.
3 Click Add Authorization.
4 Specify this information:

Ticket Type
Select the vehicle ticket type with which to associate a user group.

User Group
Enter the user group to which to grant vehicle ticket authorizations.

Insert
Select to give the user group authorization to insert new vehicle ticket records.

Update
Select to give the user group authorization to update existing vehicle ticket records.

Delete
Select to give the user group authorization to delete existing vehicle ticket records.

5 Click Submit.

Tracking fuel costs for fleet configuration
Track fuel costs and separate fuels costs from other costs by associating part classes that identify fuel
parts in inventory. The system bills any parts of the selected class that are issued to vehicles as fuel.
Costs related to this billing category are displayed on the bill.

To track fuel costs for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Click the Fuel tab.
3 Click Add Part Class.
4 Specify this information:
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Part Class
Enter the part class that identifies fuel parts in inventory. The system automatically populates the
part class description in the adjacent field. The system automatically populates Part Class Org.

5 Click Submit.

Tracking maintenance costs for fleet configuration
Track maintenance costs for fleet configuration by entering work order types that identify maintenance
or non-maintenance related costs for the billing process. Costs related to both maintenance and
non-maintenance billing categories are displayed on the bill.

To track maintenance costs for fleet configuration:

1 Select Work > Fleet > Fleet Configuration.
2 Click the Maintenance tab.
3 Click Add WO Type.
4 Specify this information:

WO Type
Select the work order type for which to track maintenance costs.

Maintenance
Select to indicate that the costs are maintenance costs.

Note: If you select Maintenance, the costs associated with work orders of this type will display on
the Billing History page of the Fleet Customers form under Maintenance. If you unselect
Maintenance, the costs associated with work orders of the specified work order type will display
as non-maintenance costs.
See "Viewing Billing Histories for Fleet Customers" on page 196

5 Click Submit.

Creating fleet billing codes
Create billing codes to determine the normal fees that customers are billed for vehicle usage through
the ticketing process. Together, billing codes and markup codes, when associated with specific fleet
customers, determine the total rates for specific fleet billing categories.

To create fleet billing codes:

1 Select Work > Fleet > Fleet Billing Codes.
2 Click New Record.
3 Specify this information:
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Organization
Enter the organization to which the fleet billing code belongs if you use multi-organization security.

Code
Enter a fleet billing code, and then enter a description of the fleet billing code in the adjacent field.

Class
Enter the class to which the fleet billing code belongs. The system automatically populates Class
Org.

Out of Service
Select to prevent the fleet billing code from being displayed in the lookups.

4 Click Save Record.

Setting up rates for fleet billing codes
Set up rates for fleet billing codes. Specify particular rates for particular dates by setting up start dates
and end dates for the rates. For example, a usage rate might fluctuate during different times of the
year. Set up usage rates for usage charges, mileage rates for mileage charges, and insurance rates
for insurance charges.

To set up rates for fleet billing codes:

1 Select Work > Fleet > Fleet Billing Codes.
2 Select the fleet billing code for which to set up rates, and then click the Rates tab.
3 Click Add Rate. The system automatically populates all currency fields.
4 Specify this information:

Start Date
Enter the start date of the rate.

End Date
Enter the end date of the rate.

Note:  Start Date must be on or before the End Date.

Usage Rate Type
Choose one of the following options:

• Hourly
Select to bill usage charges by the hour.

• Billing Period
Select to bill usage charges according to the billing period.

• Usage Charge
Enter the usage charge for the rate, if the rate is a usage rate.
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Note: To set up a usage rate, you must enter both a Usage Rate Type and a Usage Charge.

Mileage Charge
Enter the mileage charge for the rate, if the rate is a mileage rate.

Insurance Charge
Enter the insurance charge for the rate, if the rate is an insurance rate.

5 Click Submit.

Creating fleet markup codes
Create fleet markup codes. Markup codes are used to charges additional fees above and beyond the
normal fees, i.e., profit margin. Together, billing codes and markup codes, when associated with specific
fleet customers, determine the total rates for fleet billing categories.

To create fleet markup codes:

1 Select Work > Fleet > Fleet Markup Codes.
2 Click New Record.
3 Specify this information:

Organization
Enter the organization to which the fleet markup code belongs if you use multi-organization security.

Code
Enter a fleet markup code, and then enter a description of the fleet markup code in the adjacent
field.

Class
Enter the class to which the fleet markup code belongs. The system automatically populates Class
Org.

Out of Service
Select to prevent the fleet markup code from being displayed in the lookups.

4 Click Save Record.

Setting up rates for fleet markup codes
Set up rates for fleet markup codes. Specify particular rates for particular dates by setting up start dates
and end dates for the rates. A markup can be expressed as a flat rate or a flat percentage. For example,
select to mark up the cost of fuel by 20 USD (per inventory UOM) or by 50 percent.
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Note: You cannot enter a markup charge and a markup percentage for the same markup code.

To set up rates for fleet markup codes:

1 Select Work > Fleet > Fleet Markup Codes.
2 Select the fleet markup code for which to set up rates, and then click the Rates tab.
3 Click Add Rate.
4 Specify this information:

Start Date
Enter the start date of the rate.

End Date
Enter the end date of the rate.

Note:  Start Date must be on or before End Date.

Fuel
Enter the markup amount for fuel charges.

Labor
Enter the markup amount for labor charges.

Parts
Enter the markup amount for parts charges.

Contract Labor
Enter the markup amount for contract labor charges.

Pool Mileage
Enter the markup amount for mileage charges on pool tickets.

Loaner Mileage
Enter the markup amount for mileage charges on loaner tickets.

Assignment Mileage
Enter the markup amount for mileage charges on assignment tickets.

Pool Usage
Enter the markup amount for usage charges on pool tickets.

Loaner Usage
Enter the markup amount for usage charges on loaner tickets.

Assignment Usage
Enter the markup amount for usage charges on assignment tickets.

Insurance
Enter the markup amount for insurance charges.
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Fuel %
Enter the markup percentage for fuel charges.

Labor %
Enter the markup percentage for labor charges.

Parts %
Enter the markup percentage for parts charges.

Contract Labor %
Enter the markup percentage for contract labor charges.

Pool Mileage %
Enter the markup percentage for mileage charges on pool tickets.

Loaner Mileage %
Enter the markup percentage for mileage charges on loaner tickets.

Assignment Mileage %
Enter the markup percentage for mileage charges on assignment tickets.

Pool Usage %
Enter the markup percentage for usage charges on pool tickets.

Loaner Usage %
Enter the markup percentage for usage charges on loaner tickets.

Assignment Usage %
Enter the markup percentage for usage charges on assignment tickets.

Insurance %
Enter the markup percentage for charges on insurance tickets.

5 Click Submit.

Setting up fleet customers
Set up fleet customers to use throughout the Fleet Management system. Set up billing details to
determine the costs for which the customer is billed.

To set up fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Click New Record.
3 Specify this information:

Organization
Enter the organization to which the fleet customer belongs if you use multi-organization security.
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Fleet Customer
Enter the name of the fleet customer, and then enter a description of the fleet customer in the
adjacent field.

Class
Enter the class to which the fleet customer belongs. The system automatically populates Class
Org.

Billable
Select if the customer will be billed.

Note: You must select Billable to generate bills for the customer.

Out of Service
Select to prevent the fleet customer from being displayed in the lookups.

Bill for No Charges
Select to print a bill by default when the bill is for $0.

Maintenance Labor
Select to bill for maintenance labor.

Maintenance Contract Labor
Select to bill for maintenance contract labor.

Maintenance Parts
Select to bill for maintenance parts.

Fuel
Select to bill for fuel.

Mileage
Select to bill for mileage.

Usage
Select to bill for usage.

Non-maintenance Labor
Select to bill for non-maintenance labor.

Non-maintenance Contract Labor
Select to bill for non-maintenance contract labor.

Non-maintenance Parts
Select to bill for non-maintenance parts.

Insurance
Select to bill for insurance.

Exceptions
Select to bill for exceptions.
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4 Click Save Record.

Associating cost codes with fleet customers
Associate cost codes with fleet customers to correctly display transaction costs on fleet bills.

To associate cost codes with fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Select the fleet customer with which to associate cost codes, and then click the Cost Codes tab.
3 Click Add Cost Code.
4 Specify this information:

Cost Code
Enter the cost code with which to associate the fleet customer. The system automatically populates
the cost code description.

5 Click Submit.

Note: You can only associate a cost code with one fleet customer.

Associating billing codes with fleet customers
Associate billing codes with fleet customers. By associating a specific billing code with a specific fleet
customer, you determine the rate for a specific billing category. Together billing codes and markup
codes, when associated with specific fleet customers, determine the total rates for fleet billing categories
such as usage and mileage.

To associate billing codes with fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Select the fleet customer with which to associate billing codes, and then click the Billing Codes

tab.
3 Click Add Code.
4 Specify this information:

Billing Code
Enter the billing code with which to associate the fleet customer. The system automatically populates
the billing code description.

Markup Code
Enter the markup code with which to associate the fleet customer. The system automatically
populates the markup code description.

Note: You must enter a Billing Code and/or a Markup Code.
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Equipment Type
Select the equipment type with which to associate the fleet customer.

Equipment Class
Enter the equipment class with which to associate the fleet customer. The system automatically
populates the equipment class description and Equip. Class Org.

Equipment Category
Enter the equipment category with which to associate the fleet customer. The system automatically
populates the equipment category description.

Maintenance Labor
Select to bill for maintenance labor.

Maintenance Contract Labor
Select to bill for maintenance contract labor.

Maintenance Parts
Select to bill for maintenance parts.

Fuel
Select to bill for fuel.

Mileage
Select to bill for mileage.

Usage
Select to bill for usage.

Non-maintenance Labor
Select to bill for non-maintenance labor.

Non-maintenance Contract Labor
Select to bill for non-maintenance contract labor.

Non-maintenance Parts
Select to bill for non-maintenance parts.

Insurance
Select to bill for insurance.

Exceptions
Select to bill for exceptions.

5 Click Submit.
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Viewing billing histories for fleet customers
Views all previously generated bills, or view a specific billing cycle by entering a Period End Date.
Fleet bill charges are summarized to the unique fleet customer cost code and vehicle level. Charges
are displayed by the following categories: Usage, Mileage, Maintenance, Non-maintenance, Fuel,
Insurance, and Exceptions. The system also displays a total charge for each bill line, a subtotal, which
summarizes the charges for all bill lines by category, an adjustment line, which summarizes all
adjustments entered for previous bills that are included in the selected bill, grand totals of each of the
charge categories, and a total bill charge. You can also select to print bills and view current charges.

Note: When filtering the billing histories, Subtotals and Totals may change because they are relative
to the specific fleet bill lines in the grid. Adjustments totals will not change, as they are related to the
entire bill.

To view billing histories for fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Select the fleet customer for which to view billing history, and then click the Billing History tab.
3 Specify this information:

Period End Date
Enter the period end date for which to view a bill for a specific fleet customer. The system
automatically populatesBill No. Click Current Charges to view billing details from the current billing
period’s start date through the system date (today). If a past period needs to be billed, the system
cannot display current period data. ClickPrint Bill to print the bill. You must enter a Period End
Date to print the bill. You cannot print current charges.

4 View the billing history.

Viewing fleet bill transactions for fleet customers
View individual transaction information for specific billing categories. For example, select Usage as the
Category, and then click View Transactions. The system displays the specific usage transactions that
make up the usage subtotal for the selected line. This includes usages charges and usage markup
charges.

To view fleet bill transactions for fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Select the fleet customer for which to view fleet bill transactions, and then click the Billing History

tab.
3 Specify this information:

Period End Date
Specify the period end date for which to view fleet bill transactions for a specific fleet customer,
and then select the bill line for which to view bill transactions for fleet customers. Bill No. is
automatically populated.

Select the fleet bill line for which to view fleet bill transaction for fleet customers.
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Note: You must enter a Period End Date and select a bill line to view fleet bill transactions. You
cannot view fleet bill transactions for current charges.

4 Choose one of the following options for Category:
DescriptionOption

Select to show usage charges only.Usage

Select to show mileage charges only.Mileage

Select to show maintenance labor charges only.Maintenance Labor

Select to show maintenance parts charges only.Maintenance Parts

Select to show non-maintenance labor charges only.Non-maintenance Labor

Select to show non-maintenance parts charges only.Non-maintenance Parts

Select to show fuel charges only.Fuel

Select to show insurance charges only.Insurance

Select to show exception charges only.Exceptions

5 Click View Transactions.
6 View the charges for the specific transaction category.

Viewing fleet bill adjustment transactions for fleet customers
View individual adjustment transaction information for specific billing categories. For example, select
Usage as the Category, and then click View Adjustment Transactions. The system displays the
specific usage adjustment charges that make up the entire bill. This includes usages adjustment charges
and usage markup charges. The system displays all adjustments related to the bill and category.

To view fleet bill adjustment transactions for fleet customers:

1 Select Work > Fleet > Fleet Customers.
2 Select the fleet customer for which to view fleet bill adjustment transactions, and then click the

Billing History tab.
3 Specify this information:

Period End Date
Specify the period end date for which to view fleet bill adjustment transactions for a specific fleet
customer, and then select the bill line for which to view fleet bill adjustment transactions for specific
customers.
You must specify a Period End Date to view fleet bill adjustment transactions. You cannot view
fleet bill adjustment transactions for current charges.

Category
Choose one of the following options:
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DescriptionOption

Select to show usage charges only.Usage

Select to show mileage charges only.Mileage

Select to show maintenance labor charges only.Maintenance Labor

Select to show maintenance parts charges only.Maintenance Parts

Select to show non-maintenance labor charges only.Non-maintenance Labor

Select to show fuel charges only.Fuel

Select to show insurance charges only.Insurance

Select to show exception charges only.Exceptions

4 Click View Adjustment Transactions.
5 View the charges for the specific adjustment transaction category.

Replacing fleet cost codes
Replace non-billable cost codes on all fleet transactions that will be billed to a fleet customer on the
next bill. Replace cost codes on transactions before bills are generated and sent to the general ledger.

First, search cost codes for non-billable cost codes that are associated with at least one fleet transaction
(work order, inventory transaction, vehicle ticket, or ticket adjustment) that will be billed in the next
scheduled billing period and are not currently locked for replacement by another user. Next, replace
existing code values with new cost code values for the appropriate transactions.

Note: You must have query privileges on the Fleet Cost Code Search & Replace form for the cost
code organization in order to search and replace cost codes.

To replace fleet cost codes:

1 Select Work > Fleet > Fleet Cost Code Search & Replace.
2 Click Search. The system calculates the number of transactions associated with the non-billable

cost code for the current period.

Note: The system only displays non-billable cost codes that are associated with at least one fleet
transaction that will be billed in the next scheduled billing period and are not currently locked for
replacement by another user. You cannot search and replace cost codes for billed transactions.
You cannot search and replace cost codes for periods that are past due and un-billed.

3 Specify this information:

New Cost Code
Enter a new cost code for every Current Cost Code that must be replaced.
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Remove
Select to remove the record from the grid.
See "Viewing cost code errors" on page 199.

Note: To remove all of the transactions at once, select Remove. To unselect all the line items at
once, unselect Remove.

4 Click Replace.

Note: You must enter New Cost Codes before clicking Replace.

Viewing cost code errors
View all errors that occurred during the cost code search and replace process.

To view cost code errors:

1 Select Work > Fleet > Fleet Cost Code Search & Replace.
2 Select the record for which to view cost code errors, and then click the Errors tab.
3 View the cost code error information.
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7Archiving management

Archive work orders, purchase orders, stock transactions, electronic records, and audit trail records.

Archiving records
Archive work orders, purchase orders, stock transactions, electronic records, and audit trail records.

Note: During the archive process archived items are removed from normal view. The items are added
to separate archive tables.
Archived items will no longer be available for reports or budgets.

To archive records:

1 Select Administration > Setup > Archive Records.
2 Click New Record.
3 Specify this information:

Archive Through
Specify the date through which to archive.

4 Optionally, select the Work check box to archive work orders where System Status=C and Date
Completed <=Archive Through, and then specify the Work Order Type to further filter the available
work records for archiving.
The following are archived in connection to work order and work order activities:

Archived Items

Qualifications

Schedules

Additional charges

Material Lists with Event

Pick Lists for the WO

Booked hours
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Archived Items

Quotations with Services for the WO

Purchase Orders with Direct Materials for WO Activities

Repair Parts

Calculated costs for the WO

Costs

Instruments (Calibration)

Standards (Calibration)

Systems (VMRS)

Test Points (Calibration)

Aspects (Inspection)

Points (Inspection)

Linear References

Account Details

Matched invoices for POs

Requisitions with WO on header

Quotations that reference the Requisition

Receipts for Direct Materials for WO Activities

Dock Receipts for Direct Materials for WO Activities

Issues/Returns for WO Activities

Supplier Evaluations for WO Activities

Warranty Claims for WO Activities

Reservations for WO Activities

Tools requested for WO Activities

Tool Usage for WO Activities

Customer Contracts for the WO

Customer Invoices with lines for the WO

Fixed payments for the customer contract

Dispatches for standing WO Activities

Note: Only those with a Status of Approved or Completed are archived.

5 Select the Purchasing check box to archive purchasing transactions.
The following are archived related to archived invoices:
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Archived Items

Invoices with Matched or Cancelled status

Lines

Extra charges and discounts

Extra charges for costs tab

Invoice allocations

Account details

The following are archived related to archived purchase orders:

Archived Items

PO Headers-Order clauses, lines, extra charges, revisions

Blanket Orders

Booked Hours

Dock receipts

Packing slips

Invoices

Order Tracking

Supplier Evaluation

The following are archived related to archived requisitions:

Archived Items

Requisitions headers with Approved or Cancelled status

Lines

WOs

WO repair parts referencing the Requisition/Requisition line

Warranty claims referencing the Requisition/Requisition line

Transactions

The following are archived related to archived quotations:

Archived Item

Quotation headers and lines

6 Select the Stock Transactions check box to archive stock transactions with a Status of Approved
or Cancelled.
The following are archived related to stock transactions:
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Archived Items

Issues/Returns

Price Correction

Manual Price Type Change

Return for Repair

Stocktake with Approved or Cancelled status

7 Select the Audit Trail check box to archive the audit trail, a history of changed records.
8 Select the Electronic Records check box to archive electronic records.

The following shared tables are archived related to archived work orders, work order transactions,
purchasing transactions, and stock transactions.

Archived Items

Descriptions

Audit Trail Records

Electronic Signatures

Event Addresses

Documents

Comments

Custom Fields

Associated Parts

Permits

Account Details

Note: Select a value from 0 to 23 for the ARCHTIME install parameter to schedule a time for the
archive process to run between 12:00 AM and 11:00 PM, e.g., for 12:00 AM, select 0 and for 11:00
PM, select 23.
Set the ARCHTIME to null to let the archive process run immediately on clicking Start.

9 Click Start to begin the archive process.
10 The archive record is saved.

Note: Click Status to view the number of records archived.
Click Stop to halt the archive process. This will stop the process but will not cancel the process.
The current archive record will finish before stopping. The transactions already archived will not roll
back.
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Viewing archive results
To view archive results:

1 Select Administration > Setup > Archive Records.
2 Click the tab corresponding to the archive results you wish to view.
3 View the archive results.
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8Basic module data creation

Setting up basic module data is a simplified initial setup process. These options can also be defined
as installation parameters.

For more detailed information regarding installation parameters and initial setup, see the Infor EAM
System Administrator Guide.

Defining administration setup
Define administration setup options to format the module to your specifications.

To define administration setup:

1 Select Administration > Administration Setup.
2 Specify this information:

Line Number Increment (INCRLINO)
Enter the value by which to increase the line number when automatic line numbering is activated.

Minimum Password Length (PASSMINL)
Enter the minimum number of characters allowed for a system password.

Password Duration Days (SECUPWEP)
Enter the number of days in the password expiration period.

Reuse Password Days (SECUPWRP)
Enter the number of days before a user can reuse an expired password.

Infor EAM CD Key (CDKEY)
Enter the Infor EAM CD Key.

Infor EAM Consumer Reports CD Key (CDKEY)
Enter the Infor EAM Consumer Reports CD key.

Infor EAM Report Author CD Key
Enter the Infor EAM Report Author CD key.

Infor EAM System Administrator Guide | 207

 

 



Infor EAM Requestor CD Key (CDKEY)
Enter the Infor EAM Requestor CD key.

Infor EAM Barcoding CD Key (7IBCDKEY)
Enter the Infor EAM Barcoding CD key.

User Lock Attempts (SECUVIOL)
Enter the number of consecutive password violations that can occur before a user is locked out of
the system. The system administrator must unlock the user.

Mixed Case Passwords (PASSUPER)
Select Yes or No to indicate whether the system allows mixed case for password verification. If
NO, the system does not use mixed case in password verification. If YES, the system uses mixed
case in password verification.

Tab Save Behavior (TABSAVE)
Select Insert to return to Insert Mode after modifying a record on List/Detail tabs. Select Update to
stay in Update Mode after modifying a record.

Database Name (DBNAME)
Enter your database name, i.e. "Production," "Development," or "Test."

Company Name (OURCOMP)
Enter the name that appears on reports.

Report Attachment Upload Directory (ADRDOCUP)
Enter the document upload directory.

Application Server URL (APPURL)
Enter the URL path for the application server.

E-mail Sender (SMTPSEND)
Enter the name of the e-mail sender used by Infor EAM.

E-mail Server (SMTPSERV)
Enter the name or IP address of the SMTP e-mail server.

Conversion Database Tablespace
Enter a separate data tablespace for all conversion data.

Conversion Index Tablespace
Enter a separate index tablespace for all conversion data.

Web User Authentication Method
Select the method for authenticating an Infor EAM web user. Select Standard to use the credential
defined on the user's records in Infor EAM. Select LDAP to use the credential defined in the LDAP
provider configured for Infor EAM deployment. Select External to use an external authentication
service configured for Infor EAM deployment.
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Web Service Authentication Method
Select the method for authenticating an Infor EAM Connector web service user. Select Standard
to use the credentials defined on the user's records in Infor EAM. Select LDAP to use the credential
defined in the LDAP provider configured for Infor EAM deployment. Select External to use an
external authentication service configured for Infor EAM deployment.

Mobile User Authentication Method
Select the method for authenticating an Infor EAM Mobile user. Select Standard to use the credentials
defined on the user's records in Infor EAM. Select LDAP to use the credential defined in the LDAP
provider configured for Infor EAM deployment. Select External to use an external authentication
service configured for Infor EAM deployment.

Databridge Authentication Method
Select the method for authenticating an Infor EAM Databridge user. Select Standard to use the
credentials defined on the user's records in Infor EAM. Select LDAP to use the credential defined
in the LDAP provider configured for Infor EAM deployment. Select External to use an external
authentication service configured for Infor EAM deployment.

Enable/Disable KPI Driver
Click to enable or disable KPI driver.

Enable/Disable E-mail Driver
Click to enable or disable e-mail driver.

3 Click Save Record.

Defining equipment setup
Define equipment setup options to format the module to your specifications.

To define equipment setup:

1 Select Administration > Equipment Setup.
2 Specify this information:

Auto-number Assets (AUTOANUM)
Select Yes or No to indicate whether the system automatically generates asset numbers.

3 Click Save Record.

Defining equipment statuses for equipment setup
Define statuses for equipment. Equipment status indicates the state of the equipment listed.

To define equipment statuses for equipment setup:
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1 Select Administration > Equipment Setup.
2 Click the Equipment Statuses tab.
3 Click Add Status.
4 Specify this information:

Status
Enter a user code for the equipment status, and then enter a description in the adjacent field.

System Status
Enter the system status. The system automatically populates the system status description.

System Default
Select to set the system default to the current code.

5 ClickSubmit.

Defining equipment types for equipment setup
Define types for equipment. Equipment types indicate the use of the equipment listed.

To define equipment types for equipment setup:

1 Select Administration > Equipment Setup.
2 Click the Equipment Types tab.
3 Click Add Type.
4 Specify this information:

Type
Enter a user code for the equipment type, and then enter a description in the adjacent field

System Type
Enter a code for the system type.

• A (Assets)
• C (Category)
• L (Location)
• S (System)

System Default
Select to set the system default to the current code.

5 Click Submit.
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Defining equipment criticality for equipment setup
To define equipment criticality for equipment setup:

1 Select Administration > Equipment Setup.
2 Click the Equipment Criticality tab.
3 Click Add Code.
4 Specify this information:

Code
Enter a user code for the equipment criticality, and then enter a description in the adjacent field.

System Default
Select to set the system default to the current code.

5 Click Submit.

Defining purchasing setup
Define purchasing setup options to format the module to your specifications.

To define purchasing setup:

1 Select Administration > Purchasing Setup.
2 Specify this information:

Allow Over Receipt (OVERRECV)
Choose one of the following options to indicate whether the system allows for items to be purchased
over the receipt limit:

• If Yes, allow to receive more than ordered.
• If No, do not allow to receive more than ordered.

Auto-populate Quantity to Receive (RECVAUTO)
Select Yes or No to indicate whether the system automatically populates the quantity to receive on
the PO Receipt form

Default PO Receipt Description (DOCKDESC)
Enter the default PO receipt description.

Default Purchase Order Description (PORDDESC)
Enter the default purchase order description. Changing the value does not affect existing data.

Default Requisition Description (REQDESC)
Enter the default requisition description.

3 Click Save Record.
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Defining expense types for purchasing setup
Define expense types for purchasing. Expense types indicate the use of the expense listed.

To define expense types for purchasing setup:

1 Select Administration > Purchasing Setup.
2 Click the Expense Types tab.
3 Click Add Type.
4 Specify this information:

Type
Enter a user code for the expense type, and then enter a description in the adjacent field.

System Default
Select to set the system default to the current code.

5 Click Submit.

Defining requisition statuses for purchasing setup
Define statuses for requisitions. These statuses indicate the state of the requisitions.

To define requisition statuses for purchasing setup:

1 Select Administration > Purchasing Setup.
2 Click the Requisition Statuses tab.
3 Click Add Status.
4 Specify this information:

Status
Enter a code for the requisition status, and then enter a description in the adjacent field.

System Type
Enter one of the following system types:

• A (Approved)
• C (Cancelled)
• R (Awaiting Approval)
• U (Unfinished)

System Default
Select to set the system default to the current code.

5 Click Submit.
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Defining purchase order and transaction statuses for purchasing
setup
Define statuses for purchase orders and transactions. These statuses indicate the state of the purchase
orders and transactions.

To define purchase order and transaction statuses for purchasing setup:

1 Open the Purchasing Setup form.
2 Click the PO and Transaction Statuses tab.
3 Click Add Status.
4 Specify this information:

Status
Enter a user code for the purchase order and transaction status, and then enter a description in
the adjacent field.

System Type
Enter one of the following system types:

• A (Approved)
• C (Cancelled)
• R (Awaiting Approval)
• U (Unfinished)

System Default
Select to set the system default to the current code.

5 Click Submit.

Defining materials setup
Define materials setup options to format the module to your specifications. These options were formerly
defined as installation parameters.

To define material setup:

1 Select Administration > Materials Setup.
2 Specify this information:

Automatically Associate Parts (AUTOPART)
Select Yes or No to indicate whether the system automatically updates the Parts Associated list
for equipment.
See the Infor EAM User Guide.

Infor EAM System Administrator Guide | 213

 

Basic module data creation



Note: Update the Parts Associated list for approved lines on a receipt. If AUTOPART is set to
AUTO, the system verifies whether the received part is associated with an equipment’s Parts
Associated list when a purchase order receipt is approved for a work order. If the received part is
not associated with the equipment’s Parts Associated list, the system adds the part to the list using
the quantity of the transaction as the Parts Associated quantity.
If the part is already associated on the Parts Associated list, the system updates the quantity of the
part on the Parts Associated list to the transaction quantity if the transaction quantity is greater than
the existing quantity on the Parts Associated list. If the transaction quantity is not greater, then the
system does not make any updates. This association applies to issues, not just receipts.

Auto-number Parts (AUTOPNUM)
Select Yes or No to indicate whether the system automatically generates part numbers.

Default Transaction Description (TRANSDESC)
Enter the default transaction description.

3 Click Save Record.

Defining work setup
Define work setup options to format the module to your specifications.

To define work setup:

1 Select Administration > Work Setup.
2 Specify this information:

Book Days (COMDAYS)
Enter the number of days during which you can book hours on closed work orders. Infor recommends
a minimum value of 1. Changing the value does not affect existing data.

Issue Days (ISSDAYS)
Enter the number of days for which issues can be made after you close a work order. Valid values
are any non-negative numbers. Changing the value does not affect existing data.

Return Days (RTNDAYS)
Enter the number of days that parts can be returned to the store after the work order has been
closed. Valid values are any non-negative numbers. Changing the value does not affect existing
data.

Tool Days (TOOLDAYS)
Enter the number of days to update tool usage costs after completion of a work order.

Non-Work Order Days (NPRDAYS)
Enter the number of days for which you can book past nonproductive hours, which is labor performed
without a work order. Changing the value does not affect existing data.
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Cascade Work Order Status (EVTCASCD)
Select Yes or No to indicate whether changing a parent work order’s status to Closed or Cancelled
causes the status of child work orders also to change.

Enforce Work Order Dates (BOOKDATE)
Select Yes or No to indicate whether to enforce date constraints when booking hours. If set to No,
the system ignores the constraints. If set to Yes, the system enforces the constraints.

Note: Setting this parameter OFF may result in inconsistencies within your booked hours data.

3 Click Save Record.

Defining work order priorities for work setup
Define work order priorities. These priorities indicate the order in which work orders should be completed.

To define work order priorities for work setup:

1 Select Administration > Work Setup.
2 Click the Work Order Priorities tab.
3 Click Add Code.
4 Specify this information:

Code
Enter a user code for the work order priority, and then enter a description in the adjacent field.

System Default
Select to set the system default to the current code.

5 Click Submit.

Defining work order statuses for work setup
Define work order statuses. These statuses indicate the state of existing work orders.

To define work order statuses for work setup:

1 Select Administration > Work Setup.
2 Click the Work Order Statuses tab.
3 Click Add Status.
4 Specify this information:

Status
Enter a user code for the work order status, and then enter a description in the adjacent field.

• A (Approved)
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• C (Cancelled)
• R (Awaiting Approval)
• U (Unfinished)

System Status
Enter a code for the system status. The system automatically populates the system status description.

System Default
Select to set the system default to the current code.

5 Click Submit.

Defining work order types for work setup
Define work order types. These types indicate the condition of existing work orders.

To define work order types for work setup:

1 Select Administration > Work Setup.
2 Click the Work Order Types tab.
3 Click Add Type.
4 Specify this information:

Type
Enter a user code for the work order type, and then enter a description in the adjacent field.

System Type
Enter a code for the system type.

• A (Assets)
• C (Category)
• L (Location)
• S (System)

System Default
Select to set the system default to the current code.

5 Click Submit.
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AInstallation parameters

The tables in this appendix display a list of parameters for Infor EAM and the add-on products available
for Infor EAM including the installation code, an example of a valid parameter value, and a description
of how the system uses the code.

Note: This chapter describes Infor EAM functions that only a system administrator has rights to perform.

Understanding installation parameters
During the Infor EAM installation process, installation parameters enable different modules/system
components and establish many default values for your system, such as multi-organization security,
part pricing, etc. Part of the installation process involves running scripts that set these default values
in the Infor EAM database, and many of the scripts contain values known as installation codes or
parameters.

This appendix contains a complete listing of all the installation parameters used for Infor EAM broken
down by modules, as well as codes related to add-on modules and other advanced system features.

Many of the parameters set during installation are "fixed," which means that once the parameter is set,
the value/setting of the parameter cannot be changed or modified. Fixed parameters are also designated
in the tables below.

Unless otherwise indicated, all non-fixed parameters can be set as necessary following the Infor EAM
installation to tailor your system environment.

See "Defining installation parameters" on page 15.

Barcode parameters
Barcoding is an add-on module for both Infor EAM (Oracle Forms) and/or Infor EAM that enables you
to design and print barcode labels for assets, parts, work orders, etc.

Set values for barcode parameters according to the following table.
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For more information on setting values for parameters, see "Defining installation parameters" on page
15.

FixedDescriptionExampleCode

YesThis code indicates the prefix of the bar-
code bin.

BBARCODB

YesThis code indicates the prefix of the bar-
code lot.

LBARCODL

YesThis code indicates the prefix of the serial
number of the barcode equipment.

NBARCODN

YesThis code indicates the prefix of the bar-
code equipment.

OBARCODO

YesThis code indicates the prefix of the bar-
code part.

PBARCODP

YesThis code indicates the prefix of the bar-
code store.

SBARCODS

YesThis code indicates the prefix of the bar-
code physical inventory.

VBARCODV

YesThis code indicates the prefix of barcode
of work order and activity.

WBARCODW

NoSingle-character filler between a work or-
der and activity bar code

#BARFILL

Base parameters
Base parameters are related to core system components and features that must be set for Infor EAM
(Oracle Forms) and Infor EAM to work properly. Base parameters also include settings for Databridge.

Set values for base parameters according to the following table.

For more information on setting values for parameters, see "Defining installation parameters" on page
15.

FixedDescriptionExampleCode

NoEnables the BAIM trace utility. Set the pa-
rameter to Yes to enable the trace function-

No$BTRACE

ality. Set the parameter to No to disable the
trace functionality. The default value for this
parameter is No and should only be set to
Yes at the request of a customer support
technician.
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FixedDescriptionExampleCode

NoFinancial Parameter for Category code for
type SF

1$CATSF

NoFinancial Parameter for Category code for
type SH

1$CATSH

NoFinancial Parameter for Category code for
type ST

1$CATST

NoIdentifies the trace file directory created on
the Infor EAM server for the insertion of
trace files for local transactions

F:\BAIMTRACE$LTRCDIR

The value used in this parameter should be
from the perspective of someone looking at
a command prompt on the server. Do not
use the value of a mapped drive.

NoParameter for Requisition Number from Infor
EAM to be sent to APPS

YES$REQNUM

NoIdentifies the trace file directory created on
the Oracle Applications server for the inser-
tion of trace files for remote transactions

F:\BAIMTRACE$RTRCDIR

You must only specify a value for $RTRCDIR
for implementations in a distributed environ-
ment. The value used in this parameter
should be from the perspective of someone
looking at a command prompt on the server.
Do not use the value of a mapped drive.

NoUnit of Measure for Service types to be sent
to APPS

EA$
SERVUOM

NoFinancial Parameter for Line type for type
SF

1$SFLTYPE

NoFinancial Parameter for Line type for type
SH,ST

1$STLTYPE

NoThis code indicates whether the Databridge
Add PO (Outbound) transaction is activated.

Y@ADDPO

NoThis code indicates whether the Databridge
Add Requisition transaction is activated.

Y@AD-
DREQ

NoThis code indicates whether the Databridge
Cancel PO (Outbound) transaction is activat-
ed.

Y@CANPO

NoThis code indicates whether the Databridge
Cancel requisition lines for Cancel PO (In-
bound) transaction is activated.

N@CAN-
PORL
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FixedDescriptionExampleCode

NoThis code indicates whether the Databridge
Cancel Requisition transaction is activated.

Y@CAN-
REQ

NoThis code indicates whether the Databridge
Change PO (Outbound) transaction is acti-
vated.

Y@CHGPO

NoThis code indicates whether the Databridge
Change Requisition activated.

Y@CHGREQ

YesDatabridge DUNS+4 partner ID2@DBPID

NoIndicates whether the Databridge Receive-
PO transaction will support on-dock receipts.

N@DOCK-
REC

Set to Y to enable on-dock receipts for the
ReceivePO transaction.

NoInfor EAM is integrated with Infor HMS. En-
ter YES if integrated. Enter NO if not integrat-
ed.

NO@HMSINT

NoThis code indicates whether the Databridge
Load Payable (Outbound) transaction is
activated.

Y@LDPAY

NoThis code indicates whether to automatically
create an activity when INFOREAM.ACT tag
is null.

N@NEWACT

NoThis code indicates whether to automatically
create a new part when ITEM tag is null.

N@NEW-
PART

NoThis code indicates whether the Databridge
Sync Item (Outbound) transaction exports
temporary parts.

N@NIT-
MOUT

NoThis code indicates whether the Databridge
Receive PO (Outbound) transaction is acti-
vated.

Y@PORECV

NoThis code indicates whether the Databridge
Sync Item (Outbound) transaction is activat-
ed.

Y@SYNCITM

NoThis code indicates whether the Databridge
Sync Proj Info (Outbound) transaction is
activated.

Y@SYNCPRJ

NoThis code indicates whether the Databridge
Sync Reservation transaction is activated.

Y@SYN-
CRES

NoThis code indicates whether the Databridge
Sync Maint Order transaction is activated.

Y@SYNC-
WO
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FixedDescriptionExampleCode

NoThis code indicates whether the Databridge
Update Invy (Outbound) transaction is acti-
vated.

Y@UPDINV

NoThis code indicates whether the Databridge
Update person time (Outbound) transaction
is activated

Y@UP-
DPTM

NoNumber of concurrent queues1~
QUEUES~

NoThis code indicates the interval time (in
seconds) for the BDRV driver.

15~SLEEP~

NoThis code indicates the interval time (in
seconds) for BDRV queue 0.

86400~SLEEPB0

NoThis code indicates the interval time (in
seconds) for TDRV queue 0.

3600~SLEEPT0

NoInfor EAM CD key000-0000-00000-XXXX7IACDKEY

NoInfor EAM Barcode module CD key000-0000-00000-00007IBCDKEY

NoInfor EAM Reports Consumer CD Key000-0000-00000-XXXX7ICCDKEY

NoInfor EAM Mobile CD key000-0000-00000-000A7IMCDKEY

NoInfor EAM Reports Author CD Key000-0000-00000-XXXX7IPCDKEY

NoInfor EAM Mobile CD key000-0000-00000-000C7IWCD-
KEY

NoThis code indicates whether accounting in-
formation is to be upgraded to use the DR/

YESACCOUNT

CR format (YES) or uses * for all accounts
(NO).

NoIndicates whether you are using the Infor
EAM Advanced Reporting or another report-

YESADVREPT

ing product. Set to YES to indicate that you
are using the Advanced Reporting Module.
Set to NO if you are using another reporting
product or Crystal Clear Reporting.

NoIndicates the maximum allowable SQL score
for Alert Management grid Dataspies.

250AMSG-
COST

NoSpecifies the width and height of the image
displayed on the header of the application
in widthxheight format.

25x25APPLGWH

Determines the image displayed on the
header of the application. Specify the URL

http://google.com/image.gifAPPLOGO

Infor EAM System Administrator Guide | 221

 

Installation parameters



FixedDescriptionExampleCode
location of the image to display it. Leave
blank to use the default image.

Note:  If a value is specified, Infor strongly
recommends also setting a value for AP-
PLGWH.

NoDetermines the application name displayed
on the login page and the header of the ap-
plication.

Infor EAMAPPNAME

1 To display the default application name,
leave blank.

2 To exclude or not display an application
name, enter a hyphen.

3 To display an alternate application name,
specify it.

NoThis code indicates the time of day at which
the archiving process runs. Values are in

2ARCHTIME

24-hour time (0-23). The default is ‘2’ (2:00
A.M.) Leave this value blank to execute the
archiving process immediately.

NoThis code indicates whether Infor EAM
stores error records from the data collection

NOARCREC

module in table R5ARCINTERRORS. If set to
YES, the system stores the records in
R5ARCINTERRORS. If set to NO, the system
does not store the records.

NoDefault depreciation method: This code indi-
cates the default depreciation method for

SLASDEP-
TYP

asset depreciation. However, you can also
set the depreciation method at the organiza-
tion level.
SL= straight line
SYD=sum of years digits
DDB=double declining balance
UOO= units of output

-This code indicates whether Infor EAM auto-
matically generates asset numbers.

NOAU-
TOANUM

NoThis code indicates whether the system au-
to-generates knowledge base article codes.
Valid values are ‘YES’ and ‘NO.’

NOAUTOKB-
NM
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NoMaximum number of retries in the BDRV
driver.

5BRETRIES

NoThis code indicates whether cascading oc-
curs for cost code changes made on the

YESCASCADE

equipment forms (Asset, Position, System)
to the Equipment tab of the PM form.

NoCD key code. Enter the number from the
CD label in MP5SET.SQL when installing
the Infor EAM Oracle database.

000-00A0-00000-B0C0CDKEY

NoInfor EAM Requestor CD key code.000-00A0-00000-B0C0CD-
KEYREQ

NoThis code indicates whether Infor EAM will
create an electronic record and/or require

NOCGMPON-
LY

an electronic signature for work performed
on cGMP equipment. To configure electronic
records and signatures for cGMP equipment,
you must set this parameter to YES and set
up electronic records and signatures for the
EVNT entity.
If CGMPONLY is set to YES and you have
configured electronic records/signatures for
the EVNT entity, Infor EAM will only create
an electronic record and/or require an elec-
tronic signature for any work orders created
for cGMP equipment.
If CGMPONLY is set to NO and you have
configured electronic records and signatures
for the EVNT entity, Infor EAM will create
electronic records and/or require an electron-
ic signature for all work performed on any
equipment.

NoSelect Yes to add all common Org.'s to the
new users, and to attach a new common

*CMOR-
GALL

Org. to all users. Select No if you don't want
to add all common Org.'s to the new users,
and you do not want to attach a new com-
mon Org. to all users. Select * to add *
common Org.'s to the new users, and to at-
tach a new * common Org. to all users.

NoCSV Export date format. This is the java
format of the date fields to be exported.

YYYY-MM-DDCSV-
DATEF
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NoThis code identifies your database, such as
‘Production’, ‘Development’ or

ProductionDBNAME

‘TEST’. The install parameter also supports
the use of four standard variables: MP5US-
ER, :MP5DFLTORG, :MP5GROUP, and :
MP5ORG.

NoThis code defines the default value for Find
Caller By on Service Request. 1 = E-mail,

4DEF-
CALLR

2 = Customer, 3 = Name, 4 = Phone. Valid
values are 1, 2, 3, and 4.

NoBase currency. All rates for other currencies
refer to this default currency. Do not change

EURDEFCURR

this setting once in use. After you set this
default, you cannot change it without intro-
ducing inconsistencies to the database.

YesBase language. Infor EAM uses this param-
eter during installation. Do not change this

FRDEFLANG

setting once in use. After installation, you
cannot change this value because Infor EAM
cannot retrieve certain system records in an
alternative language.

YesDefault Organization value for entities with
multi-organization security set to OFF.

*DEFORG

NoDual currency. EUR indicates whether to use
the triangular conversion method to convert

EURDUAL-
CURR

currency amounts to and from EURO curren-
cy.

NoENX Suite Host URL (e.g. http://server-
name:8080/enxsuite)

ENXHOST

NoURL path for the EPAK server. This path
will be used to display EPAK content for Infor
EAM.

http://www.google.com/?what=yesEPAKURL

NoNumber of months for which to (re)calculate
Energy Star readings. For example, if the

3ES-
MONTHS

current month is May and the number of
months is set to 3, then readings will be
created for February, March, and April.

NoThis code indicates whether the user must
enter a Certification Number and Certifi-

OFFFAAMOD

cation Type for electronic signatures, which
are required by the Federal Aviation Admin-
istration (FAA) for electronic signatures.
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Certification numbers and types are associ-
ated with employee records on the Qualifi-
cations tab of the Employee form.

NoThis number determines the number of mil-
liseconds after which the performance of

999999FLXAUDIT

Flex statements will be audited if the state-
ment takes longer.

NoPrint front page code. This code indicates
the default value for Include Front Page on

YESFRONTPG

the Print dialog box. The default value for
this parameter is YES.
If the parameter is set to YES, Include Front
Page is selected by default. If the parameter
is set to NO, Include Front Page is unselect-
ed by default.

NoSQL score for Dataspys100GRID-
COST

YesThis code indicates whether the installation
is hosted.

-HOSTED

NoSet to ON to display the HTML editor bar on
the Comments page. Set to OFF to hide
the HTML editor bar.

OFFHTML-
COMM

NoURL of the Infor Document Manager appli-
cation server.

IDM URL(e.g. https://server-
name:8080/ca/)

IDMSRVR

NoSQL score for inbox queries. The setting of
this parameter determines whether or not

100INBXS-
COR

the system will allow inbox queries to run
that do not have a sufficient score.

NoIncrement value. Enter the value by which
to increase the line number when automatic
line numbering is activated.

1INCRLINO

NoIndicates whether to use the inspection type
C, F, V in Infor EAM Mobile. Valid values are
YES or NO.

NOINSPCFV

YesInstallation code. Infor EAM uses it for sev-
eral internal checks. Do not change this

YD04O5VXVXY2INSTCODE

code.Infor EAM will not function if you mod-
ify this code.

NoKeep boiler texts. A + value indicates Infor
EAM will not overwrite user-adapted boiler-
texts when you upgrade the system.

+KEEPBOT
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NoSQL score for KPI queries.100KPISCOR

NoEnter, in days, how often the KPI driver
(KDRV) checks for data to process. Must
be a positive integer.

1KPISLEEP

NoEnables the LDAP server component for
Infor EAM.

OFFLDAP-
PATH

NoThe URL identifying the location of the LDAP
servlet.

http://myserver.mycompany.com:
8080/oc4jldap/LDAPAuth

LDAPSERV

NoThis code stores the login authentication
method used for the Infor EAM Connec-

STDLGNCON

tor(web services) users. Set to STDto use
the credential defined on user records within
EAM. Set to LDAP to use the credential de-
fined in the LDAP provider configured for
the EAM deployment. Set to EXT to use an
external authentication service configured
for the EAM deployment.

NoThis code stores the login authentication
method used for Databridge users. Set to

STDLGNDBR

STDto use the credential defined on user
records within EAM. Set to LDAP to use the
credential defined in the LDAP provider
configured for the EAM deployment. Set to
EXT to use an external authentication ser-
vice configured for the EAM deployment.

NoSpecifies the text displayed on the login
page. This message can include html tags.

LGNDISCL

NoThis code stores the login authentication
method used for EAM web users. Set to STD

STDLGNEAM

to use the credential defined on user records
within EAM. Set to LDAP to use the creden-
tial defined in the LDAP provider configured
for the EAM deployment. Set to EXT to use
an external authentication service configured
for the EAM deployment.

NoDetermines the image displayed on the login
page. Specify a URL location of the image

http://www.google.com/image.gifLGNLOGO

to display it. Leave blank to use the default
image.

NoThis code stores the login authentication
method used for Infor EAM Mobile users.

STDLGNMOB

Set to STDto use the credential defined on
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user records within EAM. Set to LDAP to use
the credential defined in the LDAP provider
configured for the EAM deployment. Set to
EXT to use an external authentication ser-
vice configured for the EAM deployment.

NoThis code identifies the number format to
use based on the geographic location of

NAMERICALOCALE

your organization/enterprise. The setting for
this code specifies that Infor EAM use the
geographic standard for the specified locale
regarding the use of decimals and commas
in numeric data for all numeric fields. Valid
values are NAMERICA, EUROPE, and ASI
Use the credential defined on user records
within EAM.

NoSpecify the full package Java class name
of the customer implementation for multi-
factor authentication.

No default valueMFA-
CLASS

NoSpecify a suffix that will be appended to the
document file name when uploaded from

DATETIMEMOB-
DOCUL

the mobile device to the Infor EAM server.
This is done to better ensure uniqueness
and help prevent files from being overwritten
on subsequent uploads. Valid values are
acceptable using comma separation. Default
is DATETIME.

NoThis code indicates the Infor EAM Mobile
organization downloading mode. Set

NOMOBORG

MOBORG to YES for multiple organization
mode, or NO for single organization mode.

NoSet to ON to enable the ability to enter an
authentication code in addition to the pass-

OFFMULTIFAC

word on the login screen. Custom configura-
tion is required to enable this option. Set to
OFF to hide the additional field and only re-
quire user name and password.

YesThis code indicates whether Multi-organiza-
tion Security (MOS) is activated. You cannot
turn off MOS.

YESMULTI-
ORG

NoThis code indicates whether a code and or-
ganization are separated with parentheses

NOOM-
BARFMT

in Infor EAM Barcode. Valid values are YES
or NO.
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NoThis code indicates whether users open the
main menu by hovering or clicking. Set to H

HOPEN-
MENU

to default the system to open the menu
drop-down when the user hovers the mouse
over the main menu bar. Set to C to default
the system to open the menu drop-down
when the user clicks on the main menu bar.
Navigation inside the menu defaults to hover
regardless of this setting.

NoCustomer name that appears on reports.
Modify this code as necessary.

Your companyOUR-
COMP

NoIndicates the minimum number of characters
allowed for a system password.

6PASSMINL

NoIndicates the minimum number of non-al-
phanumeric characters required for a pass-
word.

0PASSMAN

NoIndicates the minimum number of lowercase
characters required for a password.

0PASSMNLR

NoIndicates the minimum number of numerical
characters required for a password.

0PASSMNNB

NoIndicates the minimum number of uppercase
characters required for a password.

0PASSM-
NUP

NoDetermines if the Password Reset option
will be displayed on the Login screen. If en-

YESPASSRSET

abled, the system will require the user to
enter a valid User ID for which to reset the
password. If an email address is specified
for the User ID, then the user's password
will be reset to a random value and also set
to expired. This will require the user to
change their password as soon as they login
using the system generated password. This
option will only work for full EAM users, Infor
EAM Requestor users and Mobile users.

NoIndicates whether the User ID can be used
as their password. Valid values are YES or
NO.

YESPASSSAID

NoIndicates whether system allows mixed case
for password verification. If set to YES, the

YESPASSU-
PER

system does not use mixed case in pass-
word verification. If set to NO, the system
uses mixed case in password verification.
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NoIndicates the number of days a PM Forecast-
ing session in which forecasting has not

30PMFS-
NDEL

been started or a WO Labor Scheduling
session in which labor has not been started
will be saved. Sessions where forecasting
or labor scheduling have begun will be
saved until the session is Cancelled or Ap-
proved.

NoIndicates the number of Infor EAM Mobile
prompts displayed. If set to SINGLE, the

MULTIPLEPRMD-
SPLY

system displays Infor EAM Mobile Prompt
in Single Field mode. If set to MULTIPLE,
the system displaysInfor EAM Mobile
Prompt in Multiple Fields mode.

NoThis code indicates whether both electronic
signature and snapshot are required for PM
Revision Control.

PM-
RVSIGN

ES = both electronic signature and snapshot
required
ER = only snapshot

NoName of the product installed. You can
modify this code as necessary.

Infor EAMPROD-
NAME

NoName of the products used. Values are as
follows:

D7IPROD-
UCTS

EXTSQL, If you are using Infor EAM for SQL
Server only
EXTORCL, If you are using Infor EAM (Ora-
cle) only
D7I, If you are using the Forms interface
only
BOTH, If you are using both Forms interface
and Extended interface

NoThis code sets the default value for the Op-
erator field on the Quick Filter portion of the

BQUICKDEF

Search Bar and Dataspies. Set QUICKDEF
to B for Begins with and C for Contains. Ap-
plies to text fields only.

NoSet to YES to designate the system to re-
fresh the data when users return to the List

YESREFRSH-
LV

View page from the Record View page or
any other tab. Set to NO to designate the
system to not refresh the List View page.
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NoThis code indicates whether to print reports
on the server printer (YES) or on the client
printer (NO).

Note: Infor EAM always treats this parame-
ter as set to NO.

NOREP-
BATCH

NoThe name of the default Oracle report serv-
er. Do not use underscores (_) or numbers
in the name.

rep78REPSERV

NoThe amount of time in minutes a report is
kept in cache for reuse.

10REPSTOL

NoTime out setting for Infor EAM Mobile Real-
time web service request, (in seconds).

20RMTMOUT

NoEquipment safety warning for Infor EAM
Mobile.
See Infor EAM Mobile documentation.

NOSAFE-
WARN

NoControls whether a screen with caching
Enabled will open to the List View or to the

OFFSCN-
CACHL

last tab selected prior to leaving the screen.
Set to ON to return to the List View. Set to
OFF to return to the last tab selected.

YesThis code determines the transaction date
Infor EAM uses for recording/approving a

NOSDATE

physical inventory in the R5TRANSACTIONS
table and the R5TRANSLINES table. For
example, if you start your count on Monday
and finish it on Wednesday, this parameter
determines which date is recorded. If YES,
the system records the start date. If NO,Infor
EAM uses the date the count is approved.

NoNumber of days in the password expiration
period. You can change this value.

30SECUP-
WEP

NoNumber of days before a user can reuse an
expired password. You can change this
value.

180SECUP-
WRP

NoNumber of consecutive password violations
that can occur before a user is locked out

5SECUVIOL

of Infor EAM. You can change this value.
The system administrator can also unlock
the user.

NoMust be set to support multiple application
servers.

15SESINTVL
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The value specified for this parameter repre-
sents a number in minutes.
If a session remains inactive for the number
of minutes specified for this install parame-
ter, the system will kill the session.

Note: The system actually doubles the value
specified for this parameter setting to create
a buffer to ensure that a valid session is not
killed.
Also, if a value of less than 5 is specified,
the system assumes a value of 5 minutes
as the setting for the parameter.

NoThis code indicates whether to show the
query fields on grids by default. Set

NOSHOWQURY

SHOWQURY to YES to show the query fields
on grids by default, or set to NO to hide the
query fields on grids by default.

YesSet SPECJS to YES to use the tenant speci-
fied language js file. Set SPECJS to NO to
use the common language js file.

NOSPECJS

NoService Request Portal Default ID. Enter the
Portal ID that will be used for guests. This

SRDFLTID

Portal ID must have an existing contact in-
formation record.

NoIdentifies the custom web style sheet and
associated images.

defaultSTYLECD

NoSet TABSAVE to INSERT to return to Insert
Mode after modifying a record on List/Detail

INSERTTABSAVE

tabs. Set TABSAVE to UPDATE to stay in
Update Mode after modifying a record.

NoTransaction description. Changing the value
does not affect existing data.

TransactionTRAN-
DESC

YesLanguage code of default user code. Do not
change this setting once in use.

ENUCOLANG

NoThis code identifies a separate index ta-
blespace for all conversion data uploaded.

UPLNXS

NoThis code identifies a separate data ta-
blespace for all conversion data uploaded.

UPLTBS

NoThis code indicates whether work order
barcodes are printed in WO#ACT format.
Valid values are YES or NO.

NOWO-
BARFMT
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NoThis code indicates the maximum number
of rows returned per block for web service
grid.

10000WSGRID-
SZ

NoTo set the X-FRAME-OPTIONS http header,
set this install parameter to one of the follow-

Null (disabled)XFR-
MOPTN

ing values: DENY, SAMEORIGIN, or ALLOW-
FROM someurl. Setting this value protects
against certain security vulnerabilities
(clickjacking) by preventing Infor EAM from
running in an iframe.

Infor EAM parameters
Infor EAM parameters are related only to Infor EAM and do not affect Infor EAM (Oracle Forms).

Set values for Infor EAM parameters according to the following table.

For more information on setting values for parameters, see "Defining installation parameters" on page
15.

FixedDescriptionExampleCode

NoAnalytics logging level. Valid values are: ERROR,
WARN, INFO, or DEBUG.

INFOANALOG

NoNumber of days to keep Analytics server log
records.

7ANALOGKP

NoNumber of days to keep Analytics synchronization
records.

180ANASYNKP

NoThis code indicates whether to save work automati-
cally when moving from tab to tab in Infor EAM.

YESAUTOSAVE

Valid values are YES and NO. If set to NO, then Infor
EAM displays a message prompting the user to save
their work when moving from tab to tab.

NoThis code indicates the status used by Infor EAM
when a work order is cancelled. You can choose
from any equivalent user statuses.

CANCCANCSTAT

NoCache size for grid query results500DBBUFSIZ

NoIndicates whether the data warehouse ETL driver
will populate the Booked Labor hours and Available
Labor data mart. Valid values are ON and OFF.

ONDWLABOR
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NoIndicates whether the data warehouse ETL driver
will populate the Daily Material transactions data
mart. Valid values are ON and OFF.

ONDWMATL

NoIndicates whether the data warehouse ETL driver
will populate the Purchase orders and order lines
data mart. Valid values are ON and OFF.

ONDWORDERS

NoIndicates whether the data warehouse ETL driver
will populate the Parts and Stores daily values data
mart. Valid values are ON and OFF.

ONDWPARTS

NoIndicates whether the data warehouse ETL driver
will populate the Daily Status Changes data mart.
Valid values are ON and OFF.

ONDWSTATUS

NoIndicates whether the data warehouse ETL driver
will populate the Warranty claims accumulating
values data mart. Valid values are ON and OFF.

ONDWWARNTY

NoIndicates whether the data warehouse ETL driver
will populate the Work orders accumulating and

ONDWWORK

daily values data mart. Valid values are ON and OFF
.

NoDefine which fields will display in equipment struc-
ture. Valid values are B, C, or D. Enter B to display

CEQUIPSTR

both the code and description. Enter C to display
only the code. Enter D to display only the descrip-
tion.

NoThis code indicates the status used by Infor EAM
when a work request is rejected. You can choose
from any equivalent user statuses.

REJREJSTAT

NoSpecifies how long in minutes that report temporary
data will remain.

240REPCLEAN

NoThe maximum number of records that can be re-
turned to the work order, requisition, and purchase
order reports in Infor EAM without causing an error.

100REPORTMX

NoThis code indicates the amount of time (in minutes)
to keep an Infor EAM report output file on the server
before deleting it.

1440REPPURGE

NoThis code indicates the amount of time (in seconds)
to wait for a report to finish executing before sending
it to the report queue.

120RTIMEOUT

NoDetermines whether lots are used for stock informa-
tion for parts in Infor EAM. The default setting for

YSHOWLOT

SHOWLOT is Y. If SHOWLOT is set to N, Extended
disables the Lot field and it is hidden on forms.
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NoThis code indicates the number of days to search
for similar requests. Infor EAM flags similar services
requests that are repeated.

5SRQREP

NoThis code indicates the time increment (in hours)
between each data warehouse ETL procedure up-
date. The default value is 24.

24WHSLEEP

NoThis code indicates the specific time at which to run
the data warehouse ETL update (based on the

2:00WHSTART

server time). Enter in the format HH:MM, where HH
is 24 hour time, MM is minutes. The default value
is 2:00 (2AM).

NoContains a comma separated list of supported
Language strings that are encrypted.

WSLSUPP

NoThe value specified for this parameter indicates the
length of time (in minutes) that the client can remain

15WTIMEOUT

idle/inactive before the server terminates the user’s
session for both Infor EAM (Oracle Forms) and Infor
EAM. After the server terminates the session in Infor
EAM (Oracle Forms), the system displays a mes-
sage indicating that the user’s session is being ter-
minated. After acknowledging the message, the
server shuts down the Infor EAM application.
After the server terminates the session in Infor EAM,
the form on which the user was working is still dis-
played. However, when the user tries again to use
the system, the system displays a message and
returns to the login screen.

GIS parameters
GIS functionality is a feature of Infor EAM only. All of the parameters listed in this section are used only
by Infor EAM for GIS Integration. You cannot integrate GIS with Infor EAM (Oracle Forms).

Set values for GIS parameters according to the following table.

See "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoThis code identifies the maximum number
of advanced buffer layers allowed. The de-
fault is 3.

3GISABLC
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NoName of the Address Layer in the Image
Service setup in the  GISSERV install pa-
rameter.

StreetsGISADDR

NoThis code indicates the ArcIMS platform.
Acceptable values are SHAPEFILE and SDE
.

SHAPEFILEGISAIMSP

NoThis code indicates the ArcIMS version.
Acceptable values are 4.01 and 9.0.

9.0GISAIMSV

NoDetermines the default ESRI base map that
will be used when displaying maps. The

StreetsGISBASEM

REST endpoint specified in parameter
GISSERV will overlay the base map. Valid
values are: Streets, Imagery, Imagery with
Labels, Terrain with Labels, Topograph-
ic, Light Gray Canvas, Dark Gray Can-
vas, Oceans, National Geographic, and
Open Streetmap.

NoThis code indicates the name of the City or
Zone Column in the attributes of the City or

GISCCCOL

Zone Layer. This parameter is used when
a user searches by specifying the City or
Zone name only.

NoThis code indicates the name of the City or
Zone Layer in the Image Service setup as

GISCITY

the GISSERV install parameter. This param-
eter is used when a user searches by
specifying the Zone name only.

NoType of GIS connection. This code indicates
the connection type between the Infor EAM

TCPGISCONTP

application server and the ArcIMS server.
Valid values are TCP, HTTP, or HTTPS. If
no value is specified, a TCP connection is
assumed.

NoThis code indicates the name of the Zone
Column in Attributes of the Address Layer.

GISCTCOL

NoIndicates the manner in which the system
should display boundary labels for linear

LGISDREL

equipment (referred to as "routes" in GIS).
Valid values are L, N, and A. The default is
L. If set to L, the system displays boundary
labels for the longest path (in the event of
multiple route paths).
If set to N, the system displays no boundary
labels.
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If set to A, the system displays boundary
labels for all paths (in the event of multiple
route paths).

NoDefault equipment layer name. This code
indicates the name of the Asset Layer in

HydrantGISEQUIP

the Image Service setup in the GISSERV
install parameter.

NoThis code indicates the name of the sec-
ondary Image Service setup on the ArcIMS

WATER_AXL2, WA-
TER_AXL3

GISGEOSV

server. See the explanation of the GISSERV
parameter later in this section for the default
Image Service setup. Separate values with
a comma to enter multiple geocode ser-
vices, e.g., Service2, Service3, Service4.

NoThis code indicates the maximum number
of geocoding match candidates. The default
is 100.

100GISGMAXC

NoThis code indicates the minimum geocoding
score that the system should display in the

20,0,100GISGMIN

Matching Addressess popup. The default
is 20. Separate multiple geocoding score
values with a comma. The first value listed
is the score for GISSERV and subsequent
entries are values for each GISGEOSV.

NoGIS server name. This code indicates the
host name (and domain if required) of the

gisoneGISHOST

machine running arcIMS. The URL must be
accessible from the Infor EAM server. Do
not include http:// in the URL.

NoIntersection address searching symbols
(default & | @). Values should be separat-
ed by a space.

& | @GISINTRS

NoGIS line RGB color (default 0,255,197).
This code indicates the color used for lines

0,255,197GISLNCOL

in the GIS map by entering an RGB color
of 0 to 255.

NoSpecify the width of highlighted lines in the
GIS map, or enter LAYERDEFINED.

Note: For more information about the LAY-
ERDEFINED value, see "Customizing Map
Symbols" in the Infor EAM User Guide.

4GISLNWID

NoSet to Global to display a single map in
Infor EAMbased on GIS installation param-

GlobalGISMAPS

eters. Set to Organization to display
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maps based on Organization. Set to De-
partment to display maps based on De-
partment. Department Security must be
enabled when set to Department.

NoSpecify the radius, in meters, used for
viewing nearest address. The default value
is 1500.

1500GISNARAD

NoGIS markup line RGB color (default 255,
55,155)

255,55,155GISMLCOL

NoGIS markup line width (default 4)4GISMLWID

NoGIS markup point RGB color (default 255,
55,155)

255,55,155GISMPCOL

NoSpecify the type of the markup point. Accept-
able values are CIRCLE, STAR,CROSS,
SQUARE, TRIANGLE, or RASTERMARKER.

Note: See "Customizing Map Symbols".

CROSSGISMPTYP

NoGIS markup point width (default 15)15GISMPWID

NoSpecify the image displayed within the
overview map. The default is the default
extent of the current map.

WATER_AXL_OVGISOVSV

NoSpecify the size of the overview map. The
number you enter represents a percentage

25GISOVSZ

of the width of the current map. The default
is 25.

NoGIS polygon boundary RGB color (default
255,0,0). This code indicates the color

255,0,0GISPLYBC

used for the boundary of highlighted poly-
gons in the GIS map by entering an RGB
color of 0 to 255.

NoGIS polygon fill RGB color (default 0,255,
197). This code indicates the fill color used

0,255,197GISPLYCL

for highlighted polygons in the GIS map by
entering an RGB color of 0 to 255.

NoGIS polygon fill type. This code indicates
the fill type of highlighted polygons in the

CROSSGISPLYFT

GIS map. Valid values are HORIZONTAL, ,
BDIAGONAL, CROSS, DIAGCROSS, FDIAG-
ONAL, or VERTICAL.

NoGIS polygon fill transparency (default 1.0
). This code indicates the transparency

1GISPLYTR

level of the color fill of highlighted polygons
in the GIS map.
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NoGIS server port. This code indicates the
port number on which the ArcIMS service

5300GISPORT

mentioned in the GISSERV install parameter
is accessed.

NoGIS point RGB color (default 0,255,197).
This code indicates the color used for points

0,255,197GISPTCOL

in the GIS map by entering an RGB color
of 0 to 255.

NoThis code indicates the point type in the
GIS map. Valid values are STAR, CIRCLE,

CIRCLEGISPTTYP

CROSS, SQUARE, TRIANGLE, RASTERMARK-
ER, or LAYERDEFINED.

Note: See "Customizing map symbols" on
page 175.

NoGIS point width (default 15). This code indi-
cates the width of the point used in the GIS
map.

15GISPTWID

NoDetermines if the following temporary layers
should be cleared when Select By map tool

ONGISSBCTL

is used: address labels, sketches, nearest
addresses, and measurements.
Note: Highlights and selections temporary
layers will always be cleared. ON will clear
temporary layers. OFF will not clear tempo-
rary layers.

NoDetermines layers in which features will be
selected when the Select By map tool is

OFFGISSBLR

used. ON will only select features in the
buffer layers chosen in the Search window.
OFF will select features in all visible layers.

NoThis code indicates the name of the primary
Image Service setup on the ArcIMS server.

WATER_AXL1GISSERV

NoThis code indicates the selected feature
highlight color (default 248,138,29).

248,138,29GISSFCLR

NoThis code indicates the name of the Street
Column in Attributes of the Address Layer

GISSTCOL

that is used for non-geocoded address
searches.
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NoGIS map file for service identified by GIS-
SERV. Used for viewing nearest address,
e.g., reverse geocoding.
Note:  GISSVAXL supports HTTP, fully
qualified file paths, and UNC file paths. The

GISSVAXL

system requires this to load the XML of the
AXL and retrieve the geocoding definitions.
Such information is not available via Ar-
cXML responses.

NoSpecify the RGB font color of the text
marker label. Default values are 0,0,0.

0,0,0GISTFNTC

NoThis code indicates the font style of the text
marker. Valid values are BOLD,

BOLDGISTFNTS

BOLDITALIC, ITALIC, REGULAR, OUT-
LINE, or UNDERLINE.

NoThis code indicates the font size of the text
marker label. The default value is 10.

10GISTFNTZ

NoThis code indicates the font of the text
marker label. The default value is Arial.

ArialGISTFONT

NoThis code indicates the RGB color with
which to highlight the text marker label.
Default values are 255,255,125.

255,255,125GISTGCLR

NoThis code indicates the RGB point color of
the text label. Default values are 0,0,0.

0,0,0GISTLPCL

NoThis code indicates the point type of the
text label. Valid values are CIRCLE (de-

CIRCLEGISTLPTP

fault), STAR, CROSS, SQUARE, TRIANGLE,
or RASTERMARKER.

Note: For more information about the
RASTERMARKER value, see "Customizing
map symbols" on page 175 .

NoThis code indicates the width of the point
used in the text label.

15GISTLPWD

NoThis code indicates the RGB color with
which to outline the text marker label. De-
fault values are 255,255,0.

255,255,0GISTOCLR

NoThis code indicates the print mode for the
text marker. Valid values are ALLUPPER,
ALLLOWER, NONE, or TITLECAPS.

ALLUPPERGISTPRMD
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NoThis code indicates the default percentage
factor by which the map search result will
be enlarged. The default value is 2.

2GISZOFCT

NoGIS map PDF directory. This value is used
when displaying and printing map attach-
ments of the work order.

http://shotgundemo. inforE-
AM.net/ attachments/gis-
wo/default/

URLGIS

Materials parameters
Materials parameters are related to assets, inventory, and pricing features that must be set for Infor
EAM (Oracle Forms) and Infor EAM to work properly.

Set values for materials parameters according to the following table.

For more information on setting parameter values, see "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoThis code indicates whether to associate an asset with parts tracked
by asset during receipts (R) or during creation of a purchase order
(P).

PASSETASS

NoThis code determines whether the system automatically updates
the Parts Associated list.

AUTOAUTOPART

Update the Parts Associated list for approved lines on a receipt. If
AUTOPART is set to AUTO, the system verifies whether the received
part is associated with an equipment’s Parts Associated list when
a purchase order receipt is approved for a work order. If the received
part is not associated with the equipment’s Parts Associated list,
the system adds the part to the list using the quantity of the transac-
tion as the Parts Associated quantity.
If the part is already associated on the Parts Associated list, then
the system updates the quantity of the part on the Parts Associated
list to the transaction quantity if the transaction quantity is greater
than the existing quantity on the Parts Associated list. If the trans-
action quantity is not greater, then the system does not make any
updates. Also applies to issues, not just receipts.

NoThis code indicates whether Infor EAM automatically generates part
numbers.

NOAUTOP-
NUM

NoThis code indicates whether Infor EAM automatically creates records
in tables R5STOCK and R5INSTOCK (+) for data collection.

YesAUTOSTOK

NoThis code indicates whether the stock management fields (e.g., re-
order level, min/max, order level, etc.) should be copied from the

YESDEFSTOCK
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highest-level parent store to the child store when a stock record is
created in the child store.

NoDetermines the default line type for requisitions. Specify a user
status equivalent to the system status of PS (Stock Parts), PD (Direct

PSDEFRQTP

Purchase), or RE (External Repair) for the PLTP entity. The system
automatically defaults the line type to the specified user status.
If DEFRQTP is null or if you enter an invalid value, the system auto-
matically defaults the line type of requisitions to the system status
of PS.

NoBase unit of measure for transactions, such as store issues and
returns. Changing this default will not affect existing data. However,

EADEFUOM

Infor strongly recommends using EA (Each) or PEC (Piece, e.g., in-
dividual part) as the base unit of measure because of the part-by-
asset mechanism.

NoDelete materials list. Valid values are Y and N. Y implies that Infor
EAM will remove the temporary material lists upon completion of

YDELTMATL

the related work order. Y also indicates that after completion, the
estimated material costs will no longer include data from the tempo-
rary material lists. N implies that Infor EAM will not remove the
temporary material lists.

NoLot number generation. This code indicates how Infor EAM should
generate lot numbers. Valid values are T (each receipt), P (only

PLOTNRG

parts that are tracked by lot), or - (no lot numbers; lot number * is
always used). It is possible to change this parameter in a live instal-
lation; however, Infor strongly recommends determining a lot-num-
bering policy before entering data. Changing the value does not
affect existing data.

NoThis code indicates whether parent equipment status changes of I
(Installed) or D (Withdrawn) will be cascaded to the child equipment.

AOBSTCASC

If set to A the system will cascade parent equipment status changes
to all children. If set to D the system will only cascade parent
equipment status changes to dependent children.

NoIndicates whether you can receive more parts than the number of
parts originally ordered. If set to YES, you can receive more parts

YESOVER-
RECV

than the number ordered. If set to NO, you cannot receive more
parts than the number originally ordered.

NoThis code indicates whether Infor EAM receives direct on-dock
materials directly to stores or against a work order.

STOREDRCPTTO

NoThis code indicates whether Infor EAM can issue multiple work or-
ders against the same pick list.

YESPICKONCE

For example, if this parameter is set to YES and you have a pick list
associated with a work order and the pick list includes four items
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for which you only issue one item for the pick list, you can no longer
issue items against that pick list again. If the parameter is set to NO
, you can still issue against the remaining three items on the pick
list.

NoThis code indicates whether requisitions and unapproved purchase
order totals are included in cost summaries for project reports. If

OFFPLNDRQPO

the value is ON, then Infor EAM includes the cost of requisitions or
unapproved purchase orders in the calculation of the total displayed
in Planned throughout Infor EAM, as well as estimated work order
costs that are not yet linked to a requisition or purchase order.
If the value is OFF, Infor EAM does not include the cost of requisi-
tions or unapproved purchase orders in the calculation of the total
displayed in Planned throughout Infor EAM. The value for Planned
is calculated based only on estimated work order costs.
Purchase orders with Approved status are displayed in On Order
throughout Infor EAM until they are Received. However, after pur-
chase orders are received, the purchase order costs are displayed
as Actual and used in the calculation of Estimate to Complete.
Infor EAM calculates Estimate to Complete for project costs based
on the following formula:
Current Estimate to Complete – (Planned + Actual)

NoAuto status for the DOST entity for full PO receipts. Specify a user
status equivalent to the system status A (Approved) for the DOST

APOSTALLR

entity, and the system automatically changes the purchase order
status to the specified value when all the lines on the purchase order
are fully received or cancelled.
If the purchase order header status is already set to the status de-
fined in this parameter, then the system does not modify the pur-
chase order status.

Note: If you have set the POSTALLR parameter, then the processing
rules associated with the POSTALLR parameter overrides the rules
for the POSTRECV parameter.

NoAuto status for the DOST entity for PO receipts. Specify a user status
equivalent to the system status A (Approved) for the DOST entity,

APOSTRECV

and the system automatically changes the purchase order status
to the specified value when one or more lines on the purchase order
are partially received.
When a RECV transaction is approved for a part associated to a
purchase order, the system updates the purchase order header
status to the specified status.
If the purchase order header status is already set to the status de-
fined in this parameter, then the system does not modify the pur-
chase order status.
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Note: If you have set the POSTALLR parameter, then the processing
rules associated with the POSTALLR parameter override the rules
for the POSTRECV parameter.

YesPrice level. This code indicates whether prices must be kept at part
level (same part prices for all stores) or at store level (part can have

PPRICELEV

different prices in different stores). Valid values are P and S. You
cannot change this setting once in use.

NoPricing updates. This code determines when Infor EAM updates
average unit price and last purchase price. Valid values are I

RPRICETIM

(calculate new price at invoice approval) or R (calculate new price
at receiving approval on basis of PO prices.) Inconsistencies in data
will occur if you change this value. After a change, some prices will
still be based on the old mechanism while others will be based on
the new mechanism. Over time (usually the amount of time required
for a complete inventory turnover), a shift will take place from the
old mechanism to the new.
If the price type of a stock record in the R5STOCK table is LIFO or
FIFO, Infor EAM calculates pricing updates when you approve a
receipt regardless of the setting of this parameter. However, if the
setting of this parameter is I, Infor EAM calculates pricing updates
again when you approve an invoice and/or credit/debit note.
Infor strongly discourages changing this setting.

NoPrice type. This code determines the default value for Price Type
when creating stores and indicates the manner in which Infor EAM

APRICETYP

prices storeroom materials at the store level. Valid values are A for
Average price, FIFO for First in first out, L for Last price, LIFO for
Last in first out, and S for Standard price.
LIFO or FIFO pricing is a time-based pricing method; therefore,
you should only set PRICETYP to FIFO or LIFO on the store record
if you have selected to keep prices at store level. (See PRICELEV
earlier in this section.)
Infor EAM strongly discourages changing the price type because
inconsistencies in data may occur. (See PRICETIM earlier in this
section.)

NoBudget tracking for projects. This code indicates whether Cost Area,
Cost Center, and Code of Accounts are displayed and enabled

ONPROJTRCK

on the Budgets tab of the Project form. Cost Area, Cost Center,
and Code of Accounts enable you to track project costs and bud-
gets more precisely by associating cost areas, cost centers, and
codes of accounts with budget codes, as well as enabling project
and financial managers to access more detailed information about
project budgets on project reports.
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Cost Area , Cost Center , and Code of Accounts are linked to
the PRCA (Cost areas), PRCC (Cost codes), and PCOA (Code of
accounts) entities. You can define cost areas, cost codes, and codes
of accounts as user codes as necessary based on your project
budget tracking preferences on the System Codes form. See
"Defining system codes" on page 16.

NoThis code indicates whether the system should automatically popu-
late the quantity to receive on purchase order receipts. If RECVAUTO

YESRECVAUTO

is set to YES, the system automatically populates the Receipt Qty.
(UOM) on the Active Lines page of the PO Receipts form with the
outstanding quantity for each line on a purchase order receipt. If
RECVAUTO is set to NO, a value must be manually entered for the
receipt quantity for each line on the receipt.

NoDefault requisition description. Changing this value does not affect
existing data.

RequisitionREQDESC

NoThis code indicates whether price calculations should be performed
when receiving internally repaired spare parts.

NORPPRCCAL

NoAuto-status for the RQST entity for full PO receipts. Specify a user
status equivalent to the system status A (Approved), and the system

ARQSTALLR

automatically changes the requisition status to the specified value
when all lines are fully received or cancelled for a PO receipt.
When a RECV transaction is approved for a part associated to a
purchase requisition via a purchase order (the system does not
consider receipts for store to store requisitions) and all of the requi-
sition lines on the requisition are fully received or cancelled, then
the system updates the requisition header status to the specified
status.
If the requisition header status is already set to the value defined
by this parameter, then the system does not modify the status.
Likewise, if all the lines on a requisition are cancelled and none of
the lines have been received, then the system does not consider
the setting of this parameter.

NoAuto-status for the RQST entity for PO receipts. Specify a user status
equivalent to the system status A (Approved), and the system auto-

ARQSTRECV

matically changes the requisition status to the specified value when
one ore more lines are partially received for a PO receipt.
When a RECV transaction is approved for a part associated to a
purchase requisition via a purchase order (the system does not
consider receipts for store to store requisitions), then the system
updates the requisition header status to the specified status.
If the requisition header status is already set to the value defined
by this parameter, then the system does not modify the status.
Likewise, if all the lines on a requisition are cancelled and none of
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the lines have been received, then the system does not consider
the setting of this parameter.

NoThis code indicates whether Infor EAM should generate a warning
message to check whether you need to create a work order for a

YESRRISSWAR

spare that has failed when you issue a repairable spare part on the
Issue/Return Parts issues form.

NoThe RTNANY parameter indicates whether you can return a greater
quantity of a part than the original issue quantity of the part, and/or

YesRTNANY

whether or not the system allows you to return a part to a different
store than the store from which it was issued.
If RTNANY is set to YES, you return any quantity of any parts to any
store for which there is a part record on the Stores tab of the Parts
form (the system only requires that a part record exists for the part
in the store, not that a bin-stock record exists for the part in the
store).
If RTNANY is set to NO, you cannot return a greater quantity of a part
than the original issue quantity. The system only allows you to return
the quantity of the part that was originally issued to that entity to the
same store, bin, and lot.
When issuing a part, you issue to an entity (work order, equipment,
etc.) from a store. When returning a part, you return from an entity
(work order, equipment, etc.) to a store.
For example, if RTNANY is set to NO and if you issue 20 parts to a
work order for a piece of equipment on the work order, you can
only return those parts from the work order. You cannot return the
part directly from the equipment. The RTNANY parameter indicates
whether you can return a greater quantity of a part than the original
issue quantity of the part.
If RTNANY is set to YES, you can return a greater quantity of a part
than the original issue quantity. If RTNANY is set to NO, you cannot
return a greater quantity of a part than the original issue quantity.

NoThis code indicates whether to show the expected quantity for Infor
EAM Mobile physical inventory.

NOSHOWQTY

NoPhysical inventory discrepancies. This code indicates how Infor
EAM handles physical inventory discrepancies for parts tracked by

2STTKDISC

asset when signing off physical inventories on the Physical Inven-
tory form. Valid values are 1, 2, or 3, with 2 being the default value.
You can change this value.
If the value is 1, Infor EAM ignores physical inventory discrepancies
for parts tracked by asset. If the value is 2, Infor EAM ignores
physical inventory discrepancies for parts tracked by asset, but
prints the discrepancies on the sign-off document. If the value is 3
, Infor EAM disables signing off stocktakes for parts tracked by asset.

Infor EAM System Administrator Guide | 245

 

Installation parameters



Miscellaneous parameters
Miscellaneous parameters affect settings that are not specific to any module.

Set values for miscellaneous parameters according to the following table.

For more information on setting parameter values, see "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoObject audit control rowRUNNING 10 JUNE 2004 14:12~ADRV~

NoBatch interface error driverRUNNING 10 JUNE 2004 14:12~BDRV0~

NoBatch interface driver 1RUNNING 10 JUNE 2004 14:12~BDRV1~

NoKPI scoresRUNNING 10 JUNE 2004 14:12~KDRV~

NoMail data driverRUNNING 10 JUNE 2004 14:12~MDRV~

NoTracking data error driverRUNNING 10 JUNE 2004 14:12~TDRV0~

NoTracking data driver 1RUNNING 10 JUNE 2004 14:12~TDRV1~

Purchasing parameters
Purchasing parameters are related to purchasing and requisitions that must be set for Infor EAM (Oracle
Forms) and Infor EAM to work properly.

Set values for purchasing parameters according to the following table.

For more information on setting parameter values, see "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoDetermines the default line type for purchase orders.
Specify a user status equivalent to the system status

PSDEFPOTP

of PS (Stock Parts) or PD (Direct Purchase) for the
PLTP entity. The system automatically defaults the
line type of purchase orders to the specified user
status.
If DEFPOTP is null or if you enter an invalid value, the
system automatically defaults the line type of purchase
orders to the system status of PS.

NoManual exchange rate update. Setting this parameter
to YES will enable users to manually enter exchange
rate fields.

NOEXRTUPDT

NoInclude adjusted charges in the base price. This code
indicates whether Infor EAM automatically includes

MEXTCHG

adjusted charges, such as a discount or an additional
charge, when entering information on the Extra
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charges/Discounts dialog box. If the value is Y, Infor
EAM automatically selects Include for all the items on
the Extra charges/Discounts dialog box and does not
allow you to unselect it. If the value is N, Infor EAM
automatically unselects Include for all the items on
the Extra charges/Discounts dialog box and does not
allow you to select it. If the value is M, Infor EAM auto-
matically unselects Include for all the items on the
Extra charges/Discounts dialog box and enables you
to select or unselect it as necessary.

YesUpdates part price for stock for credit and debit notes.
This code indicates how Infor EAM handles updating

OINCREDIT

part prices for approved credit and debit notes. Valid
values are O (Off), P (Partial), orF (Full), with O being
the default value. You can change this value.
If the Value is O, Infor EAM does not update part
prices upon approval of a credit or debit note.
If the Value is P, Infor EAM applies the credit amount
in the calculation of Average Price for a part upon
approval of a credit note. When the credit amount is
greater than the value of the part in stock, Infor EAM
applies a portion of the value of the credit amount, up
to the value of the part in stock, in the calculation of
the average price. By setting the value to P, the calcu-
lation of the average price might result in an average
price of 0 for a part, but it also ensures that the aver-
age price cannot be less than 0. The remaining value
of the credit amount that is not used in the calculation
of the average price is stored as a Credit Balance for
the part in stock.
If you are using LIFO/FIFO as your pricing method,
Infor EAM applies credit amounts similarly to the
manner it does if the setting is Pregardless of the
setting you specify for this parameter; however, Infor
EAM stores the unused credit amount in the IVL_
LOSTCREDIT column of the R5INVOICELINES table,
rather than storing the credit amount as a Credit Bal-
ance for the part in stock.
If the value is F, Infor EAM applies the credit amount
in the calculation of Average Price for a part upon
approval of a credit note when the credit amount is
less than the value of the part in stock. Setting the
value to F ensures that the calculation of the average
price for a part can never result in a value of 0.

NoThis code indicates the number of days after comple-
tion that invoice allocations can be applied to a work
order.

60INVADAYS
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NoSet INVALLOC  to YES to track unallocated invoice
differences. Set INVALLOC  to NO to apply all invoice
differences to the stock record.

NOINVALLOC

NoInvoice description. Changing the value does not af-
fect existing data.

InvoiceINVDESC

NoThis code indicates the default inventory replenish-
ment method to use for maintaining stock levels. Valid

-INVMETH

values are (M) for Min/Max, (-) for Reorder level, or
(+) for On demand. The default setting for this param-
eter is Reorder level.

NoThis code indicates whether the supplier’s catalog will
be updated upon approval of an invoice.

NOINVUPCAT

NoLimit level. This code indicates if Infor EAM should
check the value for orders/requisitions on the header

LLIMITLEV

level (H) or line level (L). Changing the value does not
affect existing data.

NoAutomatic approval of matched invoices. This code
indicates whether Infor EAM automatically approves

NOMATCHAPP

invoices for which the cost of all invoice lines has been
matched with the cost of the purchase order lines
associated with the invoice lines within range of toler-
ance specified for Match Tolerance Absolute or Match
Tolerance % on the Organization form. If the value is
set to YES Infor EAM automatically assigns A, Ap-
proved status for invoices for which all invoice lines
have been matched with associated purchase order
lines within the specified range of tolerance. If the
value is NO, then all invoices must be manually ap-
proved.

NoMatch tolerance. This code indicates the tolerated
difference (in percentage) between the sum of the

0MATCHTOL

invoice lines and the amount specified on the invoice
header. Valid values are any non-negative numbers.
Changing the value does not affect existing data.
Note: The MATCHTOL installation parameter is no
longer active for Infor EAM (Oracle Forms) or Infor
EAM, because users no longer enter a voucher total.
Instead, the voucher total is now calculated based on
the total invoice costs.

NoThis code indicates whether Infor EAM allows multi-
currency order lines.

YESPOCURR

NoPurchase order description. Changing the value does
not affect existing data.

OrderPORDDESC
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NoThis code indicates which exchange rate Infor EAM
uses for receipt or return of goods. PO= exchange

PORCPTCURR

rate of purchase order; RCPT= the active exchange
at time of receipt/return transaction approval.

URL parameters
URL parameters designate locations and directories for schemas, servlets, documents, etc. that must
be set for many Infor EAM (Oracle Forms) and Infor EAM add-ons and features to work properly.

Set values for URL parameters according to the following table.

For more information on setting parameter values, see "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoDocument upload path for Infor EAM
Advanced Reporting. The value

http://ADR-
DOCUP

specified identifies the path from the
advanced report server to the docu-
ment upload directory. Must be a valid
URL and can be either http:// or
file :// protocol.
The path is necessary to add attach-
ments of type "U" (upload) to the
Work Order and Purchase Order re-
ports.

NoThe schema connect string for Discov-
erer

myoracleuser/ mypassword@ my-
database

DISCSCH

NoThe URL of the Discoverer viewerhttp://myserver.mycompany.com/discov-
erer/viewer

DISCVURL

NoContains the full path to the online
help

http://myserver.mycompany.comONLMAN

NoThis install parameter is the absolute
URL of the directory where the OPS
setup stores the images.

OPIMGURL

NoDocument upload path for Crystal
Clear Reporting. The value specified

http://mycompany. myserver.com/doc-
uments/PDFS

RPT-
DOCUP

identifies the path from the Crystal
Clear Report Server to the document
upload directory. Must be a valid URL
and can be either an http:// or file://
protocol.
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NoName of the mail sender, which is
used in replying to messages

mailid@yourcompany.comSMTPSEND

NoSMTP mail servermail.yourcompany.comSMTPSERV

NoThe URL of the web data collection
upload file servlet.

http://myserver.mycompa-
ny.com/servlet/WscanUpload

WD-
CUPURL

Work parameters
Work parameters are related to work orders, budgets, and project management features that must be
set for Infor EAM (Oracle Forms) and Infor EAM to work properly.

Set values for work parameters according to the following table.

For more information on setting parameter values, see "Defining installation parameters" on page 15.

FixedDescriptionExampleCode

NoInfor EAM Caller Login for Service Requests CD
key

7ISCDKEY

This code determines whether the Remove
Equipment hyperlink on the Equipment page of

YAUTODMEC

the Work Orders form breaks the association be-
tween the parent work order and a multiple
equipment child work order or whether the system
also deletes the multiple equipment child work
order.
Valid values are Y or N . By default the parameter
is set to Y, which means that the system deletes
the related multiple equipment child records.

NoThis code indicates whether to automatically close
all released minor PMs at release of the major
PMs (YES/NO).

NOAUTOPMCL

NoIndicates whether to enforce date constraints
when booking hours. If set to OFF, the system

ONBOOKDATE

ignores the constraints. If set to ON, the system
enforces the constraints.
Note: Setting this parameter OFF may result in
inconsistencies within your booked hours data.
Setting BOOKDATE to OFF enables you to book
labor hours for a date that is earlier than Date
reported. By enabling you to book the hours
without any date restrictions based on the Date
reported field, you can leave the value for Date
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reported as is and still book hours for work that
has already been completed.

NoBooking hours. Valid values are ON and OFF.
When booking hours, if the value is ON, Infor

OFFBOOPLAN

EAM gets the trade rate from the activity on which
hours are booked. If the value is OFF, Infor EAM
gets the rate from the employee table. Changing
this value will not affect existing data. If you
change this parameter and open work orders
exist on which hours have already been booked,
inconsistencies will arise. Close work orders be-
fore changing BOOPLAN.

NoDetermines if calibration standards that have
overdue PM work orders can be used to perform
a calibration.
If CALSTD is set to YES, equipment with overdue
PM work orders are available for selection as a
calibration standard.

YESCALSTD

If CALSTD is set to NO, equipment with overdue
PM work orders are not available for selection as
a calibration standard.

NoCascade equipment Location changes to PM
equipment records. If set to YES cascade
changes. If set to NO, do not cascade changes.

NOCASCLOC

NoNumber of days during which you can book hours
on closed work orders. Infor recommends a min-

14COMDAYS

imum value of 1. Changing the value will not af-
fect existing data.

NoThis code indicates whether the system allows
multiple active warranties. If set to Yes (+), more

*COVDUPAC

than one active warranty on a certain equipment
can be specified. If set to No(-), only one active
warranty on a certain equipment can be specified.

NoThis code indicates whether the duration fields
are display-only. If set to Yes (+), the duration

+COVDURUP

fields can be entered manually. If set to No (-),
the duration fields are display-only.

NoNumber of days from current date used to calcu-
late labor availability in daily scheduling

7DSCHAVAI

NoIf code is set to ON, Infor EAM checks for dupli-
cate and repeated service requests.

ONDUPCHECK

NoEvent cascade. This code indicates whether
changing a parent work order’s status to Closed

NEVTCASCD
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or Cancelled causes the status of child work or-
ders to also change.

NoThis code indicates whether Revision control is
activated for inspections.

NOINRVCTRL

NoThis code identifies the status used to create work
orders from inspection forms. You can choose
user codes equivalent to type R (Released).

LINSWOST

NoIssue days. This code indicates the number of
days for which issues can be made after you

0ISSDAYS

close a work order. Valid values are any non-
negative numbers. Changing the value will not
affect existing data.

NoThis code indicates whether work order type au-
thorization is activated. Work order type authoriza-

NOJTAUTH

tion limits which users can update, insert, or
delete work orders based on the type of work or-
der.

NoNonproductive days. This code indicates the
number of days for which you can book past

14NPRDAYS

nonproductive hours, which is labor performed
without a work order. Note that this parameter
may interfere with closed periods data. Changing
the value will not affect existing data.

EITHERThis code determines the level at which planning
will be performed. If JOB is selected then planning

JOBPLANLEV

can only be done at the job level. If TASK is se-
lected then planning can only be done at the task
level. If EITHER then planning can be done on
either tasks or jobs.

NoIndicates whether to enable the following PM
nesting enhancements. Valid values are YES or
NO.
If YES is selected:

YESPMNEST

The system adjusts the due date forward for
nested, more frequent work orders with a status
of Awaiting release or Bypassed whenever a work
order is Completed.
The system adjusts the due date forward for more
frequent PM work orders when attempting to re-
lease the work order if it is nested with a Complet-
ed less frequent work order.
If NO is selected:
The system adjusts the due date forward for
nested, more frequent work orders with a status
of Bypassed whenever a work order is completed.
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The system changes the status of more frequent
PM work orders to Released when attempting to
release the work order and it is nested with a
Completed less frequent work order.

NoThis code indicates whether Infor EAM can gen-
erate new fixed PM work orders with a due date

PMCRPAST

in the past. Valid values are YES and NO. The
default setting is NO.
If the value is set to YES, Infor EAM creates the
next PM work order with a due date that reflects
the calculated work order due date and the PM
frequency, even if the next due date is in the past.
If the value is NO, Infor EAM always creates the
PM work order with a future due date.

NoPM Revision Control. This code indicates whether
you can create a new revision only from an ap-
proved revision.

NOPMRVCAPP

NoPM Revision Control. This code indicates whether
components of a PM depend on the PM itself.

NOPMRVCDEP

NoPM Revision Control. This code indicates whether
users can approve lines only from their own de-
partments.

YESPMRVCRES

NoPM Revision Control. This code indicates whether
PM Revision Control is activated.

NOPMRVCTRL

NoThis code indicates the starting date used when
calculating the next due date of a variable PM

CPMWODATE

work order. Set to C for completion date, PB for
calibration Performed By date, or RB for calibra-
tion Reviewed By date.

NoPM Status. This code indicates the status of a
PM work order when generated from a PM

APPMSTAT

schedule. Valid values are A for Awaiting Release
and R for Released. Changing the value will not
affect existing data.

NoThis code identifies the status used to create work
orders on the Project form.

LPROJWOST

NoReopen PMs. This code indicates whether a PM
work order can be reopened.

NOREOPENPM

NoNumber of days after completing a work order
that a requisition can be created against it.

-999REQDAYS

NoIndicates whether to display the Qty. Completed
on work orders for internally repaired repairable

NORSPCOMP

spare parts. If set to NO, the system does not
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display Qty. Completed. If set to YES, the system
displays Qty. Completed and restricts internal
repair receipts to completed repairs.

NoReturn days. This code indicates the number of
days that parts can be returned to the store after

14RTNDAYS

the work order has been closed. Valid values are
any non-negative numbers. Note that this param-
eter may interfere with closed periods data.
Changing the value will not affect existing data.

NoSet to SCHPAST is set to YES to allow schedul-
ing in the past. Set SCHPAST to NO to prevent
scheduling in the past.

NOSCHPAST

NoThe user status of a work order after you have
scheduled an activity. You can select any status.

SCHSTAT

NoThis code determines whether job plan informa-
tion is visible in the product. If YES then the Job

YESSHOWJOB

Plan screen, tabs, and fields will be visible in the
product. If NO then this information will not be
visible. The default value is NO.

NoThis code indicates whether to automatically close
an associated service request when a work order
is closed. Valid values are YES and NO.

NOSRCLOSE

NoThis code identifies the number of days to update
tool usage costs after completion of a work order.

3TOOLDAYS

NoDetermines if the work order planned parts list is
updated to include direct requisition and PO line

NUPWOMATL

parts if they are not already planned. If 'N', the
work order planned parts list is not updated. If 'Y',
the work order planned parts list will be updated.
If 'P', choose if the work order planned parts list
gets updated as lines you add to requisitions and
POs.

NoDetermines whether the system uses vehicle
ticket type authorization. Valid values are ON and
OFF.

OFFVTTAUTH

NoComments code. Infor EAM uses this code to
determine who has authority to change comments

YESWFFTAUTH

in the Comments grid for work orders on the
(WXDONE) form. If the installation parameter is
set to NO, all users can change comments; if the
installation parameter is set to YES, only users
who can reopen work orders have permission to
change comments.
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NoThis code indicates whether a work order can be
closed if purchase requisitions and purchase or-

NOWOCLPOUT

ders are still outstanding. If set to YES, work or-
ders with outstanding requisitions and purchase
orders may be closed.
Note: This parameter may affect purchase order
generation if you allow work orders to be closed
for which there are existing open requisitions.

NoQualification enforcement for work. Valid values
are ON and OFF. When scheduling work, if the

ONWOQUAL

value is ON, Infor EAM determines whether an
employee is eligible to perform work by comparing
the qualifications associated with a work order
activity with the qualifications associated with
employees on the Employees form. Infor EAM
enables you to assign any employee with the
necessary qualifications/training to perform the
work.
When scheduling work, if the value is OFF, Infor
EAM does not check qualifications for work
scheduling, and any authorized users can perform
work regardless of any qualifications associated
with work order activities.

NoWork day hours. This code indicates the default
number of hours in a working day. Infor EAM uses

8WORKDAY

this value on the Activities tab of the Work Orders
form to calculate the required number of people
when an estimated number of hours and the du-
ration is specified. Changing the value will not
affect existing data.

NoThis code identifies the user status for work or-
ders when updated by the Generate/Release

LWORKWOST

WOs form. The work order must have the system
status R.
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BOrganization options

The tables in this appendix display a list of the organization options for Infor EAM multi-organization
security (MOS). The tables are organized by corresponding modules for the organization options.

For more information on multi-organization security (MOS) and adding options for organizations, see
"Implementing multi-organization security (MOS)" on page 77.

Base options
See the following table for Base options:

Default
Value

Valid
Values

FixedModuleValidation
Type

DescriptionCode

'-'BaseFree TextValue for the Documoto Ten-
ant Encrypted Key (tek).

DOCUMKEY

'-'BaseFree TextURL for the Documoto Serv-
er.

DOCUMURL

'-'BaseFree TextValue for the Documoto user-
name.

DOCUMUSR

Call Center options
See the following table for Call Center module options:
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Default
Value

Valid ValuesFixedModuleValidation
Type

DescriptionCode

NONO, SCHED
BOTH

'-'Call CenterCodeCascades the scheduled
dates for case tasks automat-
ically based on the previous
tasks and tasks duration.

CASECASC

ALLALL, ASSOCI-
ATED

'-'Call CenterCodeDetermines which equip-
ment displays. If set to ALL
, all equipment is displayed.

SREQDSP

If set to ASSOCIATED, only
equipment associated to the
contact is displayed.

Equipment options
See the following table for Asset Management module options:

Default
Value

Valid ValuesFixedValidation
Type

DescriptionCode

FOUNDFOUND, NOT-
FOUND, BLOCK

‘-‘CodeDetermines resolution of the asset
when the asset inventory session
is approved, and the Observed

AINVAPP

Physical/Bin Location is NULL. If
FOUND, then system sets the
Resolution of the asset to "Asset
Found". If NOTFOUND, system sets
the resolution of the asset to "Asset
Not Found". If BLOCK, the system
does not allow approving the ses-
sion if any unresolved assets exist.

1001, 999999'-'IntegerDetermines the threshold at which
the equipment generation process

GENEQMAX

starts in asynchronous (back-
ground) mode. If Generate Count
is higher than this setting, the pro-
cess runs asynchronous and the
process is queued. Otherwise the
process runs synchronous and the
user must wait for the process to
finish.

NOYES, NO'-'CodePrevents the start of the equipment
generation process when warnings

GENEQWRN

still exist. If set to YES the system
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Default
Value

Valid ValuesFixedValidation
Type

DescriptionCode

asks the user to start the generation
process and ignore the warnings. If
set to NO, the system does not al-
low the user to start the generation
process.

NOYES, NO, WARN-
ING

'-'CodePrevents the equipment generation
process from creating PM work or-
ders if PM revision control is active.

GENEQPMR

If set to YES, the system generates
PM work orders without asking for
approval. If set to NO, the system
will not generate PM work orders.
If set to WARNING, the system
raises a warning message during
the Preview generation.

OFFOFF, I, D, ID‘-‘CodeDetermines if the system should
maintain a structure record between

SRSTSYNC

the header equipment and the seg-
ment or the route, if a record is in-
serted or deleted on the Segments
or Routes tab of the equipment
screens. If set to I, a structure
record will be created at insert. If
set to D, the structure record will be
removed at delete. If set to ID, the
structure is maintained both at in-
sert and delete. If set to OFF, the
system will do nothing.

YESNO'-'CodeDetermines the default value of the
Include in Move check box on the

WSSELECT
YES,

Associations tab of the Workspace
Moves screen. Set to YES to default
the selection of the check box. Set
to NO to unselect the check box by
default.

Materials options
See the following table for Materials module options:
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Default
Value

Valid ValuesFixedModuleValidation
Type

DescriptionCode

NOYES, NO, KITS
ONLY

'-'MaterialsCodeAllows the issuing of parts to
employee. If the value is NO,
parts may not be issued to Em-

ISSTOEMP

ployees. If the value is YES, all
parts may be issued to employ-
ees. If the value is KITS ONLY,
only parts tracked as kits may
be issued to employees.

'-'MaterialsFree TextProvide a default value for Kit
Lot Description on Build Kit
screen.

KITLDESC

NOYES, NO'-'MaterialsCodeIF YES, default Part Pulled
checkbox to selected on the

KITPPULD

Build Kit screen. If NO, default
the Part Pulled checkbox to un-
selected.

YESYES, NO'-'MaterialsCodeIf NO, the system will not permit
issuing a part that has expired

LOTIEXPL

(Lot Expiration Date). If YES,
the system will allow issuing a
part that has expired.

Purchasing options
See the following table for Purchasing Management module options:

Default
Value

Valid ValuesFixedModuleValidation
Type

DescriptionCode

NOYES, NO'-'Purchas-
ing

CodeIf set to YES, the system by-
passes system rules for valida-
tion and processing of invoic-

IVBYPASS

es from external systems.
This option is valid for ION in-
tegrations.

NOYES, NO'-'Purchas-
ing

CodeIf YES, Revision Reason is
required when creating a new
revision of a PO.

POREVRSN
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Work options
See the following table for Work Management module options:

Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

'-'Free
Text

Specifies the status to automatically assign to
the work order after the assignment status of
the last activity is Completed, and all other

ACTCALL

activities are Completed. If left blank, or if the
value entered is not a valid value for the sys-
tem code R (Released), the work order status
will not change.

TRADETRADE,
NOTE

'-'CodeDetermines what is displayed inside the Activ-
ity dropdowns. Set to TRADE to display the
description of the trade associated to the activ-

ACTINFO

ity. Set to NOTE to display the note associated
to the activity.

NOYES, NO'-'CodeDetermines whether or not the system copies
the task plan description to the activity note

ACTNOTE

fields. Set to YES to copy the task plan descrip-
tion, and set to NO to prevent the copy.

NOYES, NO'-'CodeSelects the preferred supplier of a task plan
or job plan on the work order activity, on the

ACTSUPP

job, or on the plan labor record if Hired Labor
is selected. If set to YES, the supplier is popu-
lated if still blank and a preferred supplier was
found. If set to NO, the supplier remains blank
and must be manually selected.

NOYES, NO'-'CodeWhen using Retrieve PO Service Lines on the
Book PO Labor screen, Hours Worked is auto-

BKPLAU-
TO

matically populated for Hours for Service (ST)
and Contractor Hire (SH) is automatically
populated with the labor hours remaining to
be booked for the selected line.

ONON, OFF,
WARNING,

'-'CodeDetermines whether during approval of a cus-
tomer contract, the system checks if equip-

CCDUPL-
CI

WARNING-
CC

ment, projects, or work orders are already used
on another active contract with overlapping
periods. If ON, the system does not allow the
use of the same equipment or projects more
than once. If set to OFF, the system does not
perform this check. If set to WARNING, the
system asks the user what to do. If set to
WARNING-CC, the system also considers the
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

charge categories on the other contract and
only asks the user if those overlap as well.

900, 999999'-'IntegerNumber of days after which no customer invoic-
es will be generated. For Customer Contracts

CCFIDAYS

this is after the End Date. For Rentals after the
Completed Date. The system will change the
Status of the contract or the rental to Finished
for this purpose.

1001, 999999'-'IntegerEstablishes the threshold at which the cus-
tomer invoice regeneration process starts in

CCGEN-
MAX

asynchronous (background) mode. If the
number of contract items multiplied with the
number of charge definitions associated to the
contract is higher than this setting the process
runs asynchronous and the process will be
queued. Otherwise the process runs syn-
chronous and the user must wait for the pro-
cess to finish.

OFFON, OFF'-'CodeDetermines if follow-up activities are automat-
ically generated when signing Reviewed By.

CHCKL-
FUP

NP, N, OFF'-'CodeControls how Regulatory checklist items,
marked for Repairs can be completed. If set

CHCKL-
REG

to N, a valid resolution (or) a combination of a
valid resolution and follow-up activity is re-
quired. If set to P, a NULL resolution is al-
lowed, along with a follow-up activity. If set to
OFF, items can be completed without a resolu-
tion or follow-up activity.

NOYES, NO'-'CodeDetermines if the checklist must be renum-
bered based on the route attached to the work

CHCKLSEQ

order. If set to YES, the system renumbers the
checklist items.

OFFFULL,
GROUP,
OFF

'-'CodeIf FULL, the system displays the full tree
structure in the closing code lookup with all the
levels in the hierarchy. If GROUP, system dis-
plays just one level of the hierarchy. If OFF,

CLGROUP

the closing code lookup operates with no group
or hierarchy.

PP, S, B'-'CodeDetermines if standard work order tools and
PM schedule tools are used to plan, schedule,

COPY-
TOOL

or plan and schedule tools for work orders. Set
to P to copy tool records only to the Plan Tools
tab for work order. Set to S to copy tool records
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

only to the Schedule Tools tab for work order.
Set to B to create a tool schedule record for
the planned hours for each day the activity
runs.

CPRQCPRQ,
EMRS

'-'CodeDetermines which lookup will be used to cate-
gorize capital planning requests. If set to
CPRQ, the system will use the default Capital

CPRC-
CLOV

Request Categorization Codes. If set to EMRS,
the system will use EMRS codes instead.

NOYES, NO'-'CodeDetermines fi the follow-up work order can
have multiple activities with different From

FLUPF-
PTP

Points and To Points. If set to YES, the system
allows it. If set to NO, the system does not al-
low it and one follow-up work order will be
created for each activity with a unique From
and To Point combination.

WODM, WO'-'CodeDetermines the type of follow-up a checklist
will generate. If set to DM, deferred mainte-

FLUP-
TYPE

nance activities will be created. If set to WO,
a work order will be generated.

3651, 999999'-'IntegerDetermines the frequency of lockout/tagout
(LOTO) reviews, or number of days from the

LOTOR-
FRQ

current date after which a LOTO review will be
required. It is applied to the Date Review Re-
quired during the review of LOTO records.

YESYES, NO'-'CodeDetermines if a review of lockout/tagout (LO-
TO) records is required. If set to YES, the

LOTOR-
REQ

system requires approval by a reviewer for
deletion of LOTO records. If set to NO, the
records can be deleted without review.

YESYES, NO'-'CodeDetermines if anew revision of isolation point
requires review of lockout/tagout (LOTO)

LOTOR-
REV

records. If set to YES, during the revision ap-
proval, the system resets the review data of
the LOTO records that reference the isolation
point for equipment and locations. If set to NO,
the system does nothing.

NOYES, NO'-'CodeDetermines if new revision of isolation point
updates lockout/tagout (LOTO) records. If set

LOTO-
SYNC

to YES, during revision approval, the system
applies the new isolation point data to the LO-
TO records that reference the isolation point
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

for equipment and locations. If set to NO, the
system does nothing.

CC, H, B'-'CodeDetermines which equipment to copy to route-
based PM work orders. Select C for route

MEROUT-
WO

equipment only, H for header equipment only,
or B to have both header and route equipment
copied.

NOYES, NO'-'CodeDetermines the automatic update of the status
of the associated nonconformities at the clos-

NON-
CASKP

ing of work orders. If set to YES, set any unfin-
ished reinspection (observation is 2 or higher)
to skipped, if the record was not updated. If
set to NO, the system will prevent the closing
of the work order.

NOYES, NO'-'CodeDetermines the automatic update of the status
of the associated nonconformities at the clos-

NON-
CAAPP

ing of work orders. If set to YES, set any unfin-
ished observation to approved, if the record
was created for the work order or if it was up-
dated. If set to NO, the system will prevent the
closing of the work order.

NOYES, NO,
WARNING

'-'CodePrevents the completion of operator checklists
where checklist items exist that have follow-up
selected, but for which no follow-up work or-

OC-
CLFLUP

ders has been created. If set to YES, the sys-
tem prevents the completion of the operator
checklist. If set to WARNING, the user receives
a warning message but will be allowed to
continue and complete the operator checklist.
If set to NO the system will not perform the
check.

NOYES, NO'-'CodeDetermines if the follow-up work order can
have multiple activities with different From

OCFUF-
PTP

Points and To Points. If set to YES, multiple
points are allowed. If set to NO, multiple points
are not allowed and one follow-up work order
will be created for each activity with a unique
From Point and To Point combination.

WODM, WO'-'CodeDetermines the type of follow-up is generated
from a checklist. If set to DM, deferred mainte-

OCFU-
TYPE

nance activities will be created. If set to WO,
a follow-up work order will be created.
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

OFFON, OFF'-'CodeDetermines if follow-up activities are automat-
ically generated when signing Reviewed By.

OPCKL-
FUP

NP, N, OFF'-'CodeControls how Regulatory checklist items,
marked for Repairs can be completed. If set

OPCKL-
REG

to N, a valid resolution (or) a combination of a
valid resolution and follow-up activity is re-
quired. If set to P, a NULL resolution is al-
lowed, along with a follow-up activity. If set to
OFF, items can be completed without a resolu-
tion or follow-up activity.

DEACTDEACT,
DEL, NO

'-'CodeDetermines if the system cleans up permits
after work order changes. If set to NO, the
system does nothing. If set to DEACT, the

PERM-
CLEA

system deactivates permits that are not refer-
enced anymore. If set to DEL, the system
deletes the permit references from the work
order.

NOYES, NO'-'CodeDetermines deactivation of mandatory permits.
If set to YES, mandatory permits on the work

PER-
MMAPD

order can be deactivated. If set to NO, deacti-
vation is not allowed.

3651, 999999'-'IntegerDetermines frequency of permit reviews. Indi-
cates the number of days from the current date

PERMR-
FRQ

after which a permit review will be required. It
is applied to the Date Review Required during
the review of permit records.

YESYES, NO'-'CodeDetermines if permit review is required. If set
to YES, deletion of permit requires approval

PERMR-
REQ

by a reviewer. If set to NO, permit records can
be deleted without review.

YESYES,NO'-'CodeDetermines if new revision of permit requires
review of permit records. If set to YES, during

PERMR-
REV

revision approval the system resets the review
data of the permit records that reference that
permit for equipment, locations, categories,
PM schedules, and standard work orders. If
set to NO, the system does nothing.

NOYES, NO'-'CodeDetermines if new revisions of permits update
permit records. If set to YES, at revision ap-

PERMSYNC

proval the system applies new permit data to
the permit records that reference that permit
for equipment, locations, categories, PM
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

schedules, and standard work orders. If set to
NO, the system does nothing.

YESYES, NO'-'CodeDetermine the auto creation of permits to work
(PTW). If set to YES, permit to work is automat-

PTWAUTO

ically created for work orders that require them.
If set to NO, the creation is a manual process.

SYNCMANUAL,
SYNC

'-'CodeWhen entering a conflicting permit to work
record, the system creates a second conflict
record attached to the conflicting PTW refer-

PTWCON-
FL

encing back to the PTW for which the conflict
was created. This option controls how the
second record is created. If set to MANUAL,
the system creates this second conflict record
but leaves the resolution blank and flags the
conflicting PTW that un-assessed conflicts
exist. If set to SYNC, the system sets the res-
olution based on the selection for the originat-
ing conflict and will not flag the conflicting
PTW.

ACTIVEACTIVE,
ALL

'-'CodeDetermines which permit to work automatically
expires if Valid Until occurs in the past. If set
to ACTIVE, only active permits expire. If set to

PTWEX-
PIR

ALL, any permit not closed or cancelled ex-
pires.

YESYES, NO'-'CodeLimits the number of open permits to work per
work order. If set to YES, only one open PTW

PTWLIMIT

is allowed at any one moment. If set to NO,
there is no constraint on the number of open
permits to work.

NOYES, NO'-'CodeCreates permits to work for multiple equipment
child work orders. If set to YES, the permit to

PTWMEC

work is created for MEC work orders. If set to
NO, the permit to work will still be created, but
will be attached to the multiple equipment work
order, i.e., the parent.

YESYES, NO'-'CodeDetermines if PM work orders are included in
the reliability calculations. If set to YES, PM

RDRVPM

work orders are included in the reliability calcu-
lations if the appropriate closing code is en-
tered. If set to NO, PM work orders are exclud-
ed from the calculations.

NY, N'-'CodeIf Y, the system creates multiple equipment
child (MEC) type work orders for each route

ROUTEEOB
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

equipment when route based PM work orders
are released. They will be related to the parent
job.

3651, 999999'-'IntegerDetermines frequency of safety reviews . Indi-
cates the number of days from the current date

SAFER-
FRQ

after which a safey review will be required. It
is applied to the Date Review Required during
the review of safety records.

YESYES, NO'-'CodeDetermines if safety review is required. If set
to YES, deletion of safety records requires

SAFER-
REQ

approval by a reviewer. If set to NO, safety
records can be deleted without review.

YESYES, NO'-'CodeDetermines if new revision of hazard and pre-
caution requires review of safety records. If

SAFER-
REV

set to YES at revision approval the system re-
sets the review data of the safety records that
reference the hazard or precaution for equip-
ment, locations, categories, parts, PM sched-
ules and standard work orders. If set to NO,
the system does nothing.

NOYES, NO'-'CodeDetermines if a new revision of precautions
updates safety records. If set to YES, at revi-

SAFESYNC

sion approval the system applies the new
precaution data to the safety records that ref-
erence that precaution for equipment, loca-
tions, categories, parts, PM schedules, and
standard work orders. If set to NO, the system
does nothing.

YESYES, NO'-'CodeDetermines if temporary material lists are dis-
played in material lists lookups. If set to YES,

TEMP-
MATL

the material lists are displayed. If set to NO,
the material lists are not displayed in lookups.

ROUTEROUTE,
SEGMENT

'-'CodeDetermines the level at which MEC work or-
ders will be created after using the Trace
Route feature. If set to ROUTE, the MEC work

TRACELEV

orders will be created for the selected routes.
If set to SEGMENT, work orders will be created
for the segments attached to the selected
routes.

NOYES, NO'-'CodeDetermines if booking hours across midnight
is allowed. If set to YES, two booked labor

WOBKMIDN

records are created. If set to NO, an error
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Default
Value

Valid
Values

FixedValidation
Type

DescriptionCode

message displays stating booking hours across
midnight is not allowed.

NOYES, NO,
WARNING

'-'CodePrevents the closing of work orders for existing
checklist items for which Follow-up is selected
but for which no follow-up work order is creat-

WOCLFLUP

ed. If set to YES, the system prevents the
closing of the work order. If set to WARNING,
the system sends the user a warning message
but the user will be allowed to continue and
close the work order. If set to NO, the system
does not perform the check.

WODM, WO'-'CodeDetermines what kind of follow-up a checklist
will generate. If set to DM, deferred mainte-

WOFU-
TYPE

nance activities will be created. If set to WO,
follow-up work orders will be created.

NOYES, NO'-'CodeDetermines if the follow-up work order can
have multiple activities with different From

WOFUF-
PTP

Points and To Points. If set to YES, it is al-
lowed. If set to NO, this is not allowed and one
follow-up work order will be created for each
activitiy with a unique From Point and To Point
combination.

CR, C'-'Free
Text

Specify a work order user status with a system
status of R or C. The system automatically set
the New Status on the Work Order Quick Close
screen to this value.

WOQC-
STAT
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CDefault screen locations

The tables in this appendix display a list of the default navigation paths for Infor EAM.

Note:  The tables represent the default location of the screens as delivered with the Infor EAM product.
Your system administrator may have modified the locations of screens. Please consult your system
administrator if you cannot find a screen in the default navigation path.

Navigating default screen locations
Infor delivers all screens in default locations across the system. However your system administrators
may change the default navigation path of screens for your organization. To find the default,
out-of-the-box location of a screen in Infor EAM consult the tables below. The screens are organized
by module in the tables.

Administration menu
This table shows the default navigation path for the Administration menu screens and the tab or pop-up
name included on each screen:

Tab or pop-up nameDefault navigationScreen

OptionsAdministration > Administration SetupAdministration Setup

Special-Calls CognosAdministration > Advanced Reports AuthorAdvanced Reports Author
Author URL

List ViewAdministration > System Configuration > Alert Man-
agement

Alert Management
Record View
Before SQL
After SQL
Grid Parameters
Work Order Alerts
E-mail Alerts
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Tab or pop-up nameDefault navigationScreen
Exceptions
History
Comments
Documents

List ViewAdministration > Setup > Archive RecordsArchive Records
Record View
Work
Purchasing
Stock Transactions
Call Center
Audit Trail
Electronic Records

Not applicable (Stand-alone L/D)Administration > Custom Fields > Associate Custom
Fields

Associate Custom Fields

TablesAdministration > Security > Audit SetupAudit Setup
Comments and Custom Fields

List ViewAdministration > Start Center Setup > Chart SetupChart Setup
Record View
User Groups

Record ViewAdministration > Setup > ClassesClasses
Custom Fields

Not applicable (Stand-alone L/D)Administration > Security > Closing PeriodsClosing Periods

Export Base ConfigurationAdministration > System Configuration > Configura-
tion Manager

Configuration Manager
Import Base Configuration
Status

List ViewAdministration > Setup > Cost CodesCost Codes
Record View
Comments
Documents

Not applicableAdministration > Crystal Clear Report StatusCrystal Clear Report Sta-
tus

Not applicable (Stand-alone L/D)Administration > Custom Fields > Custom FieldsCustom Fields

Not applicableStart > Programs > Internet Explorer > Enter the URL
provided by your system administrator > Customer
Login

Customer Login

Not applicableNote: This screen can only be accessed by using the
Customer Request Login screen.

Customer Request

List ViewAdministration > Data Collection > DC Transaction
Prompts

DC Transaction Prompts
Record View
Return Prompts

List ViewAdministration > Setup > DocumentsDocuments
Record View
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Tab or pop-up nameDefault navigationScreen
Where Used
Comments
Documents

Not applicable (Stand-alone L/D)Administration > E-mail Messenger > E-mail Notifica-
tion Setup

E-mail Notification Setup

List ViewAdministration > E-mail Messenger > E-mail Tem-
plates

E-mail Templates
Record View

Not applicable (Stand-alone L/D)Administration > E-mail Messenger > E-mail ViewerE-mail Viewer

List ViewAdministration > Enterprise Search Setup > Enter-
prise Search Setup

Enterprise Search Setup
Record View
Repositories
Repository Columns

OptionsAdministration > Equipment SetupEquipment Setup
Equipment Types
Equipment Statuses
Equipment Criticality

List ViewAdministration > Security > eRecords SetupeRecords Setup
Record View

Export KPIsAdministration > System Configuration > Export
Configuration

Export Configuration
Export Inbox Items
Export Custom Fields
Export Flex SQL
Export Custom Reports
Export Alerts
Export User Defined Grids
Export Web Service Prompts
Export Copied Screens
Task Plans

Record ViewAdministration > Screen Configuration > Extensible
Framework

Extensible Framework

List ViewAdministration > Screen Configuration > Flex Busi-
ness Rules

Flex Business Rules
Record View

Administration > ENX Suite Screens > General Set-
tings

General Settings

Not applicable (Stand-alone)Administration > Enterprise Search Setup > Generate
Enterprise Search Definitions

Generate Enterprise
Search Definitions

List ViewAdministration > GL Process SchedulesGL Process Schedules
Record View

Not applicable (Stand-alone L/D)Administration > Screen Configuration > Global Text
Changes

Global Text Changes

List View/Record ViewAdministration > Screen Configuration > Grid Design-
er

Grid Designer
Fields
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Tab or pop-up nameDefault navigationScreen
Parameters
Validation

ImportAdministration > System Configuration > Import
Configuration

Import Configuration
Batch Document Upload

List ViewAdministration > Start Center Setup > Inbox SetupInbox Setup
Record View
User Groups
Ranges
Users

List ViewAdministration > Security > Install Parameter SetupInstall Parameter Setup
Record View

List ViewAdministration > Security > Install ParametersInstall Parameters
Record View

Not applicable (Stand-alone L/D)Administration > Data Collection > Job SetupJob Setup

List ViewAdministration > Start Center Setup > KPI SetupKPI Setup
Record View
Ranges
User Groups
Children
History
Users

List ViewAdministration > System Configuration > LanguagesLanguages
Record View
Error Text
Menu Text
Code Descriptions Text
Boiler Text
Comments

List ViewAdministration > System Configuration > LocalesLocales
Record View

OptionsAdministration > Materials SetupMaterials Setup

Not applicableAdministration > Overview > Menu Structure and
Permissions

Menu Structure and Per-
missions

List ViewAdministration > System Configuration > Mobile
Devices

Mobile Devices
Record View

OptionsAdministration > Mobile SetupMobile Setup

List View/Record ViewAdministration > Data Collection > Monitor InterfaceMonitor Interface
Error Correction

Not applicable (Editable Grid)Administration > Security > Multi-org SecurityMulti-org Security

My AccountMain header drop-down on the left-hand paneMy Account
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Tab or pop-up nameDefault navigationScreen

Not applicableNote: This screen can only be accessed by using the
Service Request Login screen.

My Service Requests

List ViewAdministration > Security > OrganizationsOrganizations
Record View
Comments
Enterprise Locations
Fiscal Years
Options

List ViewAdministration > System Configuration > PrintersPrinters
Record View

Not applicable (Stand-alone L/D)Administration > Data Collection > Prompt MachinePrompt Machine

OptionsAdministration > Purchasing SetupPurchasing Setup
Expense Types
Requisition Statuses
PO and Transaction Statuses

List ViewAdministration > Start Center Setup > QueriesQueries
Record View

List ViewAdministration > Setup > RegionsRegions
Record View
Comments
Historical Temperatures
Actual Temperatures
Documents
Temperature Analysis Chart

Not applicable (Stand-alone L/D)Administration > Setup > Report Organization
Structure

Report Organization
Structure

List ViewAdministration > Setup > ReportsReports
Record View
Parameters
Text
Comments

List ViewAdministration > Security > Roles SetupRoles Setup
Record View

List ViewAdministration > Screen Configuration > Screen
Setup

Screen Setup
Record View
Comments
Types
Classes
WO Equipment Types
Operator Checklist
Field Filters

List ViewAdministration > Screen Configuration > ScreensScreens
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Tab or pop-up nameDefault navigationScreen
Record View
Text
Fields to Remember
Tabs
Comments
Custom Tabs
Dataspies

Chart SetupAdministration > Start Center SetupStart Center Setup
Inbox Setup
KPI Setup
Queries

Not applicable (Stand-alone L/D)Administration > Security > Status AuthorizationsStatus Authorizations

Not applicable (Stand-alone L/D)Administration > Setup > System CodesSystem Codes

List ViewAdministration > Screen Configuration > User De-
fined Screens

User Defined Screens
Record View
Fields

List ViewAdministration > Security > User GroupsUser Groups
Record View
Menus
Screen Permissions
Users
WO Authorizations
Mobile Menus
Charts
Comments
Documents
Inbox
Interface Permissions
KPI
Mobile Settings
Scanner Menus
Store Security
iProcure Security

List ViewAdministration > Security > User SetupUser Setup
Record View
Comments
Organizations
Addresses
Department Security
Documents
Inboxes
KPIs
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Tab or pop-up nameDefault navigationScreen

Not applicable (Stand-alone List)Administration > System Configuration > View Log
Files

View Log Files

Not applicable (Stand-alone List)Administration > Screen Configuration > ViewsViews

List ViewAdministration > Screen Configuration > Web Service
Prompts

Web Service Prompts
Record View
Web Services
Fields
Retrieved Values

OptionsAdministration > Work SetupWork Setup
Work Order Types
Work Order Statuses
Work Order Priorities

Equipment menu
This table shows the default navigation path for the Equipment menu screens and the tab or pop-up
name included on each screen:

Tab or pop-up nameDefault navigationScreen

ParametersEquipment > Asset Inventory > Asset InventoryAsset Inventory
Inventory Results

List ViewEquipment > AssetsAssets
Record View
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear Overview
Linear References
Linear Where Used
LOTO
Keys
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Tab or pop-up nameDefault navigationScreen
Material Usage
Meters
Nonconformities
Nonconformities Analysis
OEE Metrics
Open Repairs
Open Work Orders
Parts Associated
Permits
Purchase Orders
Rankings
Ranking Survey
Reliability Calculations
Reliability Growth
Reservations
Resources
Routes
Route Parents
Safety
Segments
Segment Parents
Service Codes
Service Delivery Matrix
Structure
Structure Details
Suppliers
Supplier Service Codes
Test Points
Top 10 Breakdown
Warranties
Warranty Claims
Work Order Repair Costs Chart
Workspaces

Not applicable (Stand-alone L/D)Equipment > Process > Batch Meter ReadingsBatch Meter Readings

List ViewEquipment > Process > Batch Update Reliability Ranking
Values

Batch Update Reliability
Ranking Values Record View

Comments
Reliability Survey
Equipment
Documents

List ViewEquipment > Setup > CategoriesCategories
Record View
Comments
Calibration
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Tab or pop-up nameDefault navigationScreen
Documents
Parts Associated
Permits
Safety
Test Points

List ViewEquipment > Additional Features > Change NoticesChange Notices
Record View
Comments
Lines
Assets
Locations
Addresses
Documents
Parts Associated

Not applicable (Stand-alone)Equipment > Process > Child Equipment ReplacementChild Equipment Replace-
ment

List ViewEquipment > Setup > Closing CodesClosing Codes
Record View
Classes

Not applicable (Stand-alone)Equipment > Setup > Closing Code HierarchyClosing Code Hierarchy

List ViewEquipment > Additional Features > Nonconformities >
Condition Score Matrix Setup

Condition Score Matrix
Setup Record View

Comments

List ViewEquipment > Setup > DepartmentsDepartments
Record View
Addresses
Comments
Documents
Structure
Tools

Not applicable (Stand-alone)Equipment > Additional Features > Energy Star > Energy
Star Message Viewer

Energy Star Message
Viewer

Not applicable (Stand-alone)Equipment > Additional Features > Energy Star > Energy
Star Setup

Energy Star Setup

List ViewEquipment > Equipment Configuration > Equipment
Configurations

Equipment Configurations
Record View
Comments
Configurations Associated
Structure
PM Schedules
Where Used
Calibration
Depreciation
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Tab or pop-up nameDefault navigationScreen
Documents
Maintenance Patterns
Meters
Parts Associated
Permits
Safety
Test Points
Warranties

List ViewEquipment > Procurement Evaluation > Equipment
Evaluations

Equipment Evaluations
Record View
Comments
Equipment Equivalency
Cost Analysis
Documents

List ViewEquipment > Equipment Configuration > Equipment
Generation

Equipment Generation
Record View
Details
Preview

List ViewEquipment > Additional Features > Equipment Opera-
tional Status

Equipment Operational
Status Record View

Comments
Work Orders
Documents

Not applicableEquipment > GIS Map SearchGIS Map Search

List ViewEquipment > Additional Features > Key ManagementKey Management
Record View
Locks
Transactions
Ring Keys

List ViewEquipment > Linear Direction SetupLinear Direction Setup
Record View

List ViewEquipment > Setup > LocationsLocations
Record View
Comments
Events
Costs
Structure
Structure Details
Addresses
Documents
LOTO
Material Usage
Meters
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Tab or pop-up nameDefault navigationScreen
Nonconformities
Operator Checklists
Open Work Orders
Parts Associated
Permits
RCM
Safety
Service Codes
Service Delivery Matrix
Suppliers
Supplier Service Codes

List ViewEquipment > MapsMaps
Record View
Comments
Parameters
Documents

List ViewEquipment > Setup > MetersMeters
Record View
Comments
Documents

List ViewEquipment > Additional Features > Nonconformities >
Nonconformities

Nonconformities
Record View
Comments
Documents
Translations
Observations
Documents

List ViewEquipment > Additional Features > Nonconformities >
Nonconformity Observations

Nonconformity Observa-
tions Record View

Comments
Documents
Checklist

List ViewEquipment > Additional Features > Nonconformities >
Nonconformities Setup

Nonconformities Setup
Record View
Comments
Documents
Status Dependencies

List ViewEquipment > Additional Features > Nonconformities >
Nonconformity Types

Nonconformity Types
Record View
Comments
Documents
Translations
Parts
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Tab or pop-up nameDefault navigationScreen
EMRS
Material Types

List ViewEquipment > Additional Features > Asset Management
Policy > Objectives

Objectives
Record View
Comments
Energy Targets
CPRs (Plans)
Documents

List ViewEquipment > Operational StatusOperational Status
Record View
Work Orders

List ViewEquipment > Additional Features > Asset Management
Policy > Policies

Policies
Record View
Comments
Strategies
Documents

List ViewEquipment > PositionsPositions
Record View
Comments
Events
Costs
PM Schedules
Structure
Structure Details
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Energy Star Ratings Chart
Fuel Costs
Keys
LOTO
Linear Overview
Linear References
Linear Where Used
Material Usage
Meters
Nonconformities
Nonconformities Analysis
OEE Metrics
Operator Checklists
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Tab or pop-up nameDefault navigationScreen
Open Work Orders
PM Repair Costs Chart
Parts Associated
Permits
Purchase Orders
Rankings
Ranking Survey
Reliability Calculations
Reliability Growth
Reservations
Resources
Routes
Route Parents
Safety
Segments
Segment Parents
Service Codes
Service Delivery Matrix
Suppliers
Supplier Service Codes
Test Points
Top 10 Breakdown
Warranties
Warranty CLaims
Work Order Repair Costs Chart
Workspaces

List ViewEquipment > Setup > ProfilesProfiles
Record View
Comments
Documents
Parts Associated
Permits

List ViewEquipment > Setup > Reliability RankingReliability Ranking
Record View
Comments
Decision Tree
Ranks
Equipment
Documents

Not applicableEquipment > Additional Features > Reservation Calen-
dar

Reservation Calendar

List ViewEquipment > Setup > Risk Matrix SetupRisk Matrix Setup
Record View
Comments
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Tab or pop-up nameDefault navigationScreen
Consequences
Documents

Record ViewEquipment > Sets/ConsistsSets/Consists
Equipment

List ViewEquipment > Additional Features > Asset Management
Policy > Strategies

Strategies
Record View
Comments
Objectives
Structure

List ViewEquipment > SystemsSystems
Record View
Comments
Events
Costs
PM Schedules
Structure
Structure Details
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Energy Star Ratings Chart
Fuel Costs
LOTO
Linear Overview
Linear References
Linear Where Used
Keys
Material Usage
Meters
Nonconformities
Nonconformities Analysis
OEE Metrics
Open Work Orders
Operator Checklists
PM Repair Costs Chart
Parts Associated
Permits
Purchase Orders
Rankings
Ranking Survey
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Tab or pop-up nameDefault navigationScreen
RCM
Reservations
Resources
Routes
Route Parents
Safety
Segments
Segment Parents
Service Codes
Service Delivery Matrix
Suppliers
Supplier Service Codes
Test Points
Top 10 Breakdown
Warranties
Warranty Claims
Work Order Repair Costs Chart
Workspaces

List ViewEquipment > Warranty > WarrantiesWarranties
Record View
Comments
Equipment
Parts
Components
Documents
VMRS Codes
Warranty Claim vs. Settlement Chart

List ViewEquipment > Warranty > Warranty ClaimsWarranty Claims
Record View
Comments
Activities
Claim Lines
Addresses
Documents

List ViewEquipment > Additional Features > WorkspacesWorkspaces
Record View
Comments
Documents
Employees
Equipment
Furnishings
Translations

List ViewEquipment > Additional Features > Workspace MovesWorkspace Moves
Record View
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Tab or pop-up nameDefault navigationScreen
Comments
Documents
Translations
Associations

Materials menu
This table shows the default navigation path for the Materials menu screens and the tab or pop-up
name included on each screen:

Tab or pop-up nameDefault navigationScreen

Add PartsMaterials > Create Requisition > Add Parts

Note: This screen is not directly selectable. When you click on
the Add Parts button from the Create Requisition screen, this
screen will display.

Add Parts

Not applicableMaterials > Kits > Breakup KitBreakup Kit

Not applicableMaterials > Kits > Build KitBuild Kit

ParametersMaterials > Process > Calculate EOQCalculate EOQ
Preview

List ViewMaterials > Setup > CommoditiesCommodities
Record View
Comments
Documents
Fuels

Create RequisitionMaterials > Create RequisitionCreate Requisition

List ViewMaterials > Setup > CurrenciesCurrencies
Record View
Exchange Rates
Comments
Documents

List ViewMaterials > Setup > Greenhouse GasesGreenhouse Gases
Record View
Comments
Documents

ParametersMaterials > Process > Generate ABC AnalysisGenerate ABC Analy-
sis Preview

ParametersMaterials > Process > Generate RequisitionsGenerate Requisitions
Preview
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Tab or pop-up nameDefault navigationScreen

List ViewMaterials > Transactions > Internal Repair ReceiptsInternal Repair Re-
ceipts Record View

Comments
Parts
Documents

List ViewMaterials > Setup > iProcure VendorsiProcure Vendors
Record View
Infor EAM Suppliers

Not applicableMaterials > Transactions > Issue/Return PartsIssue/Return Parts

List ViewMaterials > Setup > LotsLots
Record View
Comments
Bins Per Store
Documents

Not applicableMaterials > Overview > Manufacturer Part NumbersManufacturer Part
Numbers

List ViewMaterials > Setup > ManufacturersManufacturers
Record View
Comments
Parts
Addresses
Documents

List ViewMaterials > Transactions > Non-PO ReceiptsNon-PO Receipts
Record View
Comments
Parts
Documents

List ViewMaterials > Setup > Part Condition TemplatesPart Condition Tem-
plates Record View

Comments
Conditions

Not applicable (Stand-alone L/D)Materials > Setup > Part Hierarchy CodesPart Hierarchy Codes

List ViewMaterials > Transactions > Part InspectionsPart Inspections
Record View
Comments
Documents

Not applicable (Stand-alone)Materials > Overview > Part Number HistoryPart Number History

Not applicable (Stand-alone)Materials > Overview > Part ReservationsPart Reservations

List ViewMaterials > Part RequisitionsPart Requisitions
Record View
Documents
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Tab or pop-up nameDefault navigationScreen
Parts

List ViewMaterials > Part Warranty ClaimsPart Warranty Claims
Record View
Parts
Imported Parts

List ViewMaterials > PartsParts
Record View
Comments
Stores
Stock
Suppliers
Transactions
Prices
Stock Value
Contracts
Documents
Greenhouse Gases
Kit Template
Manufacturers
Nonconformity Types
Overview
PO History
Parts Associated
Purchase Orders
Repair Details
Requisitions
Reservations
Safety
Sales Prices
Substitutes
Usage
Where Used

List ViewMaterials > Transactions > Physical InventoryPhysical Inventory
Record View
Comments
Parts

List ViewMaterials > Pick TicketsPick Tickets
Record View
Comments
Parts
Documents

List ViewMaterials > Transactions > PO ReceiptsPO Receipts
Record View

286 | Infor EAM System Administrator Guide

 

Default screen locations



Tab or pop-up nameDefault navigationScreen
Comments
Packing Slip
Active Lines
Processed Lines
Documents

Quick Store-to-Store TransferMaterials > Transactions > Quick Store-to-Store TransferQuick Store-to-Store
Transfer

List ViewMaterials > Setup > Reasons for ReturnReasons for Return
Record View
Comments
Documents

Requisition DetailsMaterials > View Requisitions > Requisition Details

Note: This screen is not directly selectable. When you select a
record from the View Requisitions screen, this screen will open.

Requisition Details

List ViewMaterials > RequisitionsRequisitions
Record View
Comments
Parts
Services
Documents
Transactions
eRecords
Addresses
Account Details
Open Repairs

Review/Approve RequisitionsMaterials > Review/Approve RequisitionsReview/Approve Req-
uisitions

List ViewMaterials > Setup > Store GroupsStore Groups
Record View
Comments
Transfer Fees

List ViewMaterials > Transactions > Store-to-Store IssuesStore-to-Store Issues
Record View
Comments
Parts
Addresses
Documents

List ViewMaterials > Transactions > Store-to-Store ReceiptsStore-to-Store Re-
ceipts Record View

Comments
Parts
Addresses
Documents
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Tab or pop-up nameDefault navigationScreen

List ViewMaterials > Store-to-Store RequisitionsStore-to-Store Requisi-
tions Record View

Comments
Parts
Addresses
Documents

List ViewMaterials > Setup > StoresStores
Record View
Comments
Bins
Stock
Transactions
Addresses
Documents
Overview
Reservations
Stock in Transit
Stockouts
Taxes

Not applicableMaterials > Overview > Supplier Part NumbersSupplier Part Numbers

List ViewMaterials > Transactions > Supplier ReturnsSupplier Returns
Record View
Comments
Parts
Documents

List ViewMaterials > Setup > SuppliersSuppliers
Record View
Comments
Parts
Contacts
Addresses
Account Numbers
Commodities
Documents
Equipment
Fuel Mix
PO History
Rates
Service Code Exclusions
Service Codes
Services

List ViewMaterials > Setup > Tax CodesTax Codes
Record View
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Tab or pop-up nameDefault navigationScreen
Rates
Comments
Documents

List ViewMaterials > Setup > Tax Rate TypesTax Rate Types
Record View
Comments
Documents

List ViewMaterials > Setup > Tax RatesTax Rates
Record View
Values
Comments
Documents

List ViewMaterials > Setup > Units of MeasureUnits of Measure
Record
Comments
Conversion
Documents

View RequisitionsMaterials > View RequisitionsView Requisitions

Operations menu
This table shows the default navigation path for the Operations menu screens and the tab or pop-up
name included on each screen:

Tab or pop-up nameDefault navigationScreen

List ViewOperations > Analytics Variable SetupAnalytics Variable Setup
Record View
Attributes

List ViewOperations > Budgets > Budget Calendar TypesBudget Calendar Types
Record View
Comments
Documents

List ViewOperations > Budgets > Budget GroupsBudget Groups
Record View
Comments
Items
Documents

List ViewOperations > Budgets > Budget StructuresBudget Structures
Record View
Comments
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Tab or pop-up nameDefault navigationScreen
Documents

List ViewOperations > Budgets > Budget TermsBudget Terms
Record View
Comments
Periods
Documents

List ViewOperations > Budgets > BudgetsBudgets
Record View
Details

List ViewOperations > Setup > Bulletin Board NoticesBulletin Board Notices
Record View

List ViewOperations > Setup > Calendar GroupsCalendar Groups
Record View
Calendar Periods
Comments
Documents

List ViewOperations > Call CenterCall Center
Record View
Comments
WO Comments
Documents

List ViewOperations > Setup > Call Center SetupCall Center Setup
Record View
GIS Attributes
Equipment Usability Codes
Documents

List ViewOperations > Case ManagementCase Management
Record View
Tasks
Checklist
eRecords
Event Log
Documents
Comments
Translations

List ViewOperations > Case Management TasksCase Management Tasks
Record View
Comments
Documents
Checklist

List ViewOperations > Setup > Contact InformationContact Information
Record View
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Tab or pop-up nameDefault navigationScreen
Equipment

List ViewOperations > Setup > Customer SurveysCustomer Surveys
Record View
Questions
Triggers
Results
Long Translations
Documents
Comments
Translations

List ViewOperations > Data Warehouse Run LogData Warehouse Run Log
Details
Errors

Not applicable (Stand-alone L/D)Operations > Data Warehouse Run ParametersData Warehouse Run Param-
eters

Not applicableOperations > Setup > Event Log Type FilterEvent Log Type Filter

List ViewOperations > Setup > Knowledge Base ArticlesKnowledge Base Articles
Record View
Service Delivery Matrix Equipment

Not applicableOperations > OverviewOverview

List ViewOperations > Setup > ProvidersProviders
Record View
Comments
Documents

List ViewOperations > Setup > Service CategoriesService Categories
Record View
Comments
Documents

List ViewOperations > Setup > Service CodesService Codes
Record View
Comments
Layers
Sales Prices

Purchasing menu
This table shows the default navigation path for the Purchasing menu screens and the tab or pop-up
name included on each screen:
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Tab or pop-up nameDefault navigationScreen

Not applicable (Stand-alone L/D)Purchasing > Assets for POAssets for PO

List ViewPurchasing > Blanket OrdersBlanket Orders
Record View
Comments
Parts
Partial Order
Services
Users
Addresses
Clauses
Documents

Not applicable (Stand-alone L/D)Purchasing > Contracts > Clauses of Contract ClassesClauses of Contract
Classes

List ViewPurchasing > Setup > Credit CardsCredit Cards
Record View
Comments
Users
Addresses

List ViewPurchasing > Setup > Delivery AddressesDelivery Addresses
Record View

ParametersPurchasing > Process > Generate POsGenerate POs
Preview

Not applicable (Stand-alone L/D)Purchasing > Invoice AllocationsInvoice Allocations

Invoice Lines per BuyerPurchasing > Overview > Invoice Lines per BuyerInvoice Lines per Buyer

List ViewPurchasing > Invoice VouchersInvoice Vouchers
Record View
Comments
Lines
Costs
Documents
Utility Bills

List ViewPurchasing > PO Revision HistoryPO Revision History
Record View
Comments
Parts
Services
Clauses

List ViewPurchasing > Setup > PO TermsPO Terms
Record View
Comments
Documents

List View (editable)Purchasing > Process > PO UpdatePO Update
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Tab or pop-up nameDefault navigationScreen

List ViewPurchasing > Purchase OrdersPurchase Orders
Record View
Comments
Parts
Services
Documents
Clauses
Transactions
eRecords
Translations
Tracking
Addresses
Account Details
Open Repairs

List ViewPurchasing > Setup > Purchasing ClausesPurchasing Clauses
Record View
Comments
Children
Documents

List ViewPurchasing > Contracts > Purchasing ContractsPurchasing Contracts
Record View
Comments
Parts
Part Discounts
Order Discounts
Documents

Not applicable (Stand-alone L/D)Purchasing > Contracts > Purchasing Contract TextPurchasing Contract
Text

List ViewPurchasing > Quotes > QuotationsQuotations
Record View
Comments
Parts
Services
Addresses
Documents
eRecords

List ViewPurchasing > Quotes > Requests for QuotationsRequests for Quotations
Record View
Comments
Suppliers
Parts
Clauses
Services
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Tab or pop-up nameDefault navigationScreen
Selection
Addresses
Documents
Purchasing
eRecords

Work menu
This table shows the default navigation path for the Work menu screens and the tab or pop-up name
included on each screen:

Tab or pop-up nameDefault navigationScreen

List ViewWork > Customer Contracts > AdjustmentsAdjustments
Record View
Comments
Documents

Exclude WO TypesWork > Additional Features > Advanced Mainte-
nance Planning Configuration

Advanced Maintenance Plan-
ning Configuration Status Change Triggers

List ViewWork > Additional Features > Asset Management
Services > AMS-Approve Customer Charges

AMS-Approve Customer
Charges Record View

List ViewWork > Additional Features > Asset Management
Services > AMS-Customer Contracts

AMS-Customer Contracts
Record View
Comments
Fixed Charges
Documents

List OnlyWork > Additional Features > Asset Management
Services > AMS-Customer Invoice Lines Overview

AMS-Customer Invoice Lines
Overview

List ViewWork > Additional Features > Asset Management
Services > AMS-Customer Invoices

AMS-Customer Invoices
Record View
Comments
Lines
Documents

List ViewWork > Additional Features > Service Request >
AMS-Customers

AMS-Customers
Record View
Comments
Properties
Callers
Charges
Contracts
Documents
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Invoices

List ViewWork > Additional Features > Asset Management
Services > AMS-Pricing Schedules

AMS-Pricing Schedules
Record View
Comments
Custom Trade Rates
Custom Part Charges
Additional Charges
Documents
WO Criteria

List ViewWork > Revision Control > Approval ListsApproval Lists
Record View
Comments
Approvers
Documents

ParametersWork > Process > Approve Inspection ResultsApprove Inspection Results
Preview

List ViewWork > Inspections > AspectsAspects
Record View
Comments
Prompts
Documents

List ViewWork > Verticals > Healthcare > Assets HealthcareAssets Healthcare
Record View
Comments
Events
Costs
PM Schedules
Structure
Account Details
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
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Reliability Survey
Resources
Service Delivery Matrix
Test Points
Warranties

Not applicable (Stand-alone L/D)Work > Process > Book Labor By EmployeeBook Labor By Employee

Not applicable (Stand-alone)Work > Process > Book PO LaborBook PO Labor

List OnlyWork > Additional Features > Calibration ResultsCalibration Results

List ViewWork > Projects > CampaignsCampaigns
Record View
Comments
Campaign Events
Equipment
Work Orders
Documents
eRecords

List ViewWork > Additional Features > Capital Planning Re-
quests

Capital Planning Requests
Record View
Comments
Documents

List ViewWork > Inspections > ConditionsConditions
Record View
Comments
Documents

List ViewWork > Contract Management > Contract TemplatesContract Templates
Record View
Comments
WO Criteria
Sales Prices
Clauses
Charge Definitions
Discounts
Documents

Record ViewWork > Contractor PortalContractor Portal

List ViewWork > Contract Management > CustomersCustomers
Record View
Comments
Contracts
Addresses
Documents

List ViewWork > Contract Management > Customer Con-
tracts

Customer Contracts
Record View
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Tab or pop-up nameDefault navigationScreen
Comments
Charge Definitions
WO Criteria
Commodities
Adjustments
Clauses
Contract Items
Discounts
Documents
Sales Prices

List ViewWork > Contract Management > Customer InvoicesCustomer Invoices
Record View
Comments
Contract Items
Generation Errors
Invoice Details
Documents

List ViewWork > Fuel Management > DepotsDepots
Record View
Comments
Tanks
Pumps
Tank/Pump
Documents
Transactions

List ViewWork > WO Planning > Deferred MaintenanceDeferred Maintenance
Record View
Parts

List ViewWork > Setup > EmployeesEmployees
Record View
Comments
Rates
Availability Exceptions
Addresses
Documents
Outstanding Issues
Properties
Qualifications
Transactions
Transfers
Types

List ViewWork > Verticals > Hospitality > FacilitiesFacilities
Record View
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Tab or pop-up nameDefault navigationScreen
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
Reliability Survey
Resources
Service Delivery Matrix
Test Points
Warranties

List ViewWork > Inspections > FindingsFindings
Record View
Comments
Classes
Documents

List ViewWork > Additional Features > Fleet > Fleet Billing
Codes

Fleet Billing Codes
Record View
Comments
Rates
Documents

List ViewWork > Additional Features > Fleet > Fleet BillsFleet Bills
Record View
Comments
Billing Details
Pool/Loaner Adjustments
Assignment Adjustments
Documents

ParametersWork > Additional Features > Fleet > Fleet Configu-
ration

Fleet Configuration
Billing Schedules
Exception Codes
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Tab or pop-up nameDefault navigationScreen
Vehicle Ticket Authorizations
Fuel
Maintenance

Cost CodesWork > Additional Features > Fleet > Fleet Cost
Code Search & Replace

Fleet Cost Code Search & Re-
place Errors

List ViewWork > Additional Features > Fleet > Fleet Cus-
tomers

Fleet Customers
Record View
Comments
Cost Codes
Billing Codes
Billing History
Addresses
Documents

List ViewWork > Additional Features > Fleet > Fleet Markup
Codes

Fleet Markup Codes
Record View
Rates
Comments
Documents

List ViewWork > Additional Features > Fleet > Fleet Vehicle
Tickets

Fleet Vehicle Tickets
Record View
Comments
Exceptions
Billing Adjustments
Documents

List ViewWork > Inspections > FormulasFormulas
Record View
Parameters
Comments

List ViewWork > Fuel Management > Fuel Physical InventoryFuel Physical Inventory
Record View
Comments
Tanks

Fuel IssuesWork > Fuel Management > Fuel IssuesFuel Issues

Fuel ReceiptsWork > Fuel Management > Fuel ReceiptsFuel Receipts

List ViewWork > Fuel Management > FuelsFuels
Record View
Comments
Depot/Tank
Documents
Transactions

ParametersWork > Additional Features > Advanced Mainte-
nance Planning > Generate Production Requests

Generate Production Requests
WO Preview
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Tab or pop-up nameDefault navigationScreen
Production Request Preview

ParametersWork > Process > Generate WOsGenerate WOs
Preview

List ViewWork > Permit to Work > HazardsHazards
Record View
Comments
Documents
Precautions
Where Used

List ViewWork > Verticals > Hospitality > Incident RequestsIncident Requests
Record View
Comments
WO Comments
Documents

List ViewWork > Service Request > Information RequestsInformation Requests
Record View
Comments
Documents

List ViewWork > Permit to Work > Isolation PointsIsolation Points
Record View
Comments
Documents
Permit to Work

List ViewWork > Job PlansJob Plan
Record View
Instructions
Qualifications
Sales Prices
Checklist
Prices
Plan Labor
Plan Parts
Plan Tools
Estimated Costs
Suppliers
Documents
eRecords

List ViewWork > Permit to Work > Lockout BoxesLockout Boxes
Record View
Comments
Documents

List ViewWork > WO Planning > Material ListsMaterial Lists
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Tab or pop-up nameDefault navigationScreen
Record View
Comments
Parts
Documents

List ViewWork > WO Planning > Maintenance PatternsMaintenance Patterns
Record View
Comments
Sequences
Equipment
Work Orders
Documents

Not applicable (Stand-alone)Work > Mechanic's WorkbenchMechanic's Workbench

List ViewWork > Inspections > MethodsMethods
Record View
Comments
Documents

List ViewWork > Inspections > Monitored DataMonitored Data
Equipment Details
Points
Aspects
Aspect Points
Point Conditions
Results

Not applicable (Stand-alone)Work > Additional Features > Operator ChecklistOperator Checklist

List ViewWork > Permit to Work > PermitsPermits
Record View
Permit Body
Documents

List ViewWork > Permit to Work > Permit to WorkPermit to Work
Record View
Comments
Documents
Safety
LOTO
Checklist
Conflicts
Event Log
eRecords

List ViewWork > Permit to Work > Permit to Work SetupPermit to Work Setup
Record View
Comments
Documents
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Tab or pop-up nameDefault navigationScreen

List ViewWork > Inspections > Point TypesPoint Types
Record View
Comments
Documents

ParametersWork > WO Planning > PM ForecastingPM Forecasting
Preview
Forecasting

List ViewWork > WO Planning > PM PlansPM Plans
Record View
PM Schedules
Activities
Equipment
Comments
Documents

List ViewWork > WO Planning > PM SchedulesPM Schedules
Record View
Comments
Activities
Equipment
Permits
Work Orders
Documents
Resources
Safety
Sales Prices
Jobs
Plan Labor
Plan Parts
Estimated Costs
Plan Tools
Translations
eRecords
Breakdown Linear Work

List ViewWork > WO Planning > PM Work PackagesPM Work Packages
Record View
Comments
Equipment
Employees
Documents

List ViewWork > Permit to Work > PrecautionsPrecautions
Record View
Comments
Documents
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Tab or pop-up nameDefault navigationScreen

List ViewWork > Additional Features > Advanced Mainte-
nance Planning > Production Requests

Production Requests
Record View
Comments
Resources
Work Orders
Documents

List ViewWork > Projects > ProjectsProjects
Record View
Comments
Budgets
Work Orders
Costs
Documents
Purchase Orders
Sub-projects
User Authorization

List ViewWork > Projects > Project BudgetsProject Budgets
Record View
Comments
Documents

Not applicableWork > Service Request > PropertiesProperties

List ViewWork > Verticals > Healthcare > Properties Health-
care

Properties Healthcare
Record View
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
Reliability Survey
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Tab or pop-up nameDefault navigationScreen
Resources
Service Delivery Matrix
Test Points
Warranties

Not applicableWork > Service Request > Property InformationProperty Information

List ViewWork > Setup > QualificationsQualifications
Record View
Comments
Documents

List View (editable)Work > Process > Release Individual PM WOsRelease Individual PM WOs

List ViewWork > Contract Management > Reservation Re-
quests

Reservation Requests
Record View
Comments

List ViewWork > Contract Management > ReservationsReservations
Record View
Comments
Adjustments
Charge Definitions
Documents

Not applicable (Stand-alone)Work > Contract Management > Review Reservation
Requests

Review Reservation Requests

Not applicable (Stand-alone L/D)Work > Additional Features > Operator Checklist >
Review Operator Checklists

Review Operator Checklist

Not applicableWork > Review Work RequestsReview Work Requests

List ViewWork > Revision Control > Revision ApprovalRevision Approval
Approvers
Parent PMs

List OnlyWork > Revision Control > Revision Control HistoryRevision Control History

Work OrdersWork > Revision Control > Revision Control SetupRevision Control Setup
Hazards
Isolation Points
Nonconformities
Precautions
Permits

List ViewWork > Verticals > Hospitality > RoomsRooms
Record View
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
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Tab or pop-up nameDefault navigationScreen
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
Reliability Survey
Resources
Service Delivery Matrix
Test Points
Warranties

List ViewWork > WO Planning > RoutesRoutes
Record View
Comments
Equipment
Documents
Inspection Points

List ViewWork > Service Request > Service CodesService Codes
Record View
Documents

Accessed via a special URL.Service Request Portal

Accessed via a special URL.Service Request Portal - Create
Request

List ViewWork > Service RequestsService Requests
Record View
Comments
Log Entries
Book Hours
Issue Parts
Closing
Book & Close
Documents
Work Order Details

List ViewWork > Setup > ShiftsShifts
Record View
Days
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Tab or pop-up nameDefault navigationScreen
Employees
Comments
Documents

List ViewWork > Projects > ShutdownsShutdowns
Record View
Comments
Equipment
Documents

List ViewWork > WO Planning > Standard WOsStandard WOs
Record View
Comments
Activities
Children
Documents
Permits
Safety
Sales Prices
Tools

List ViewWork > Setup > SupervisorsSupervisors
Record View
Comments
Documents

List ViewWork > Verticals > Healthcare > Systems HealthcareSystems Healthcare
Record View
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
Addresses
Calibration
Depreciation
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
Reliability Survey
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Tab or pop-up nameDefault navigationScreen
Resources
Service Delivery Matrix
Test Points
Warranties

List ViewWork > WO Planning > Task PlansTask Plan
Record View
Instructions
Checklist
Documents
Prices
Jobs
Plan Labor
Plan Parts
Plan Tools
Estimated Costs
Qualifications
Sales Prices
Suppliers

List ViewWork > Setup > ToolsTools
Record View
Outstanding Issues
Transactions
Comments
Documents

List ViewWork > Setup > TradesTrades
Record View
Rates
Comments
Documents
Qualifications
Supplier Rates

List OnlyWork > Overview > Unreturned CoresUnreturned Cores

List ViewWork > Verticals > Hospitality > VehiclesVehicles
Record View
Comments
Events
Costs
PM Schedules
Structure
Actual Consumption
Addresses
Calibration
Depreciation
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Tab or pop-up nameDefault navigationScreen
Design Consumption
Documents
Energy Star Ratings
Fuel Costs
Linear References
Material Usage
Meters
Parts Associated
Permits
Purchase Orders
Reliability Survey
Resources
Service Delivery Matrix
Test Points
Warranties

Not applicableWork > Work RequestsWork Requests

List ViewWork > Setup > VMRS CodesVMRS Codes
Record View
Comments
Documents
Translations
Nonconformity Types

ParametersWork > WO Planning > WO Daily SchedulingWO Daily Scheduling
Equipment Preview
WO Activity Preview
Employee Preview
Daily Scheduling
Shift Scheduling

ParametersWork > WO Planning > WO Load BalancingWO Load Balancing
Preview
Balance Load

Not applicableWork > WO Planning > WO SchedulingWO Scheduling

Work Order Quick CloseWork > WO Quick CloseWO Quick Close

Not applicableWork > WO Quick EntryWO Quick Entry

List View (editable)Work > Process > WO UpdateWO Update

List ViewWork > Verticals > Healthcare > Work Orders
Healthcare

Work Orders Healthcare
Record View
Comments
Activities
Book Labor
Closing
Parts
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Tab or pop-up nameDefault navigationScreen
Cost Summary
Additional Costs
Book Vendor Hours
Calibration
Children
Customer Requests
Documents
Equipment
Inspections
Meter Readings
Monitored Data Results
Part Failures
Permits
Plan Tools
Purchasing
Qualifications
Repair Parts
Resources
Schedule Labor
Schedule Tools
Service Request Details
Survey Equipment
Tools Usage

List ViewWork > Work OrdersWork Orders
Record View
Comments
Activities
Book Labor
Closing
Parts
Cost Summary
Additional Costs
Book Vendor Hours
Calibration
Checklist
Children
Customer Requests
Documents
Equipment
Inspections
Meter Readings
Monitored Data Results
Nonconformities
Part Failures
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Tab or pop-up nameDefault navigationScreen
Permits
Plan Tools
Purchasing
Qualifications
Related Work Order History
Related Work Orders
Repair Parts
Resources
Safety
Schedule Labor
Schedule Tools
Service Request Details
Survey Equipment
Tools Usage
Jobs
Plan Labor
Repairs
Linear Overview
Part Failures

List ViewWork > Verticals > Hospitality > Work Orders Hos-
pitality

Work Orders Hospitality
Record View
Comments
Activities
Book Labor
Closing
Parts
Cost Summary
Additional Costs
Book Vendor Hours
Calibration
Children
Customer Requests
Documents
Equipment
Inspections
Meter Readings
Monitored Data Results
Part Failures
Parts Associated
Permits
Plan Tools
Purchasing
Qualifications
Repair Parts
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Tab or pop-up nameDefault navigationScreen
Resources
Schedule Labor
Schedule Tools
Service Request Details
Survey Equipment
Tools Usage

Not applicableWork > Work RequestsWork Requests
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Index

A
account details  46

defining 46
administration  269

default screen navigation 269
administration setup 207

defining 207
alert management  59, 61–67, 127

creating alerts 59
creating e-mail alerts 64
creating parameters 65
defining after SQL 62
defining before SQL 61
defining exceptions 66
exporting 127
mapping additional fields for work order alerts 64
previewing grids 62
viewing history 67
work order alerts 63

alerts 59
managing 59

ArcGIS  167–168
configuring geoprocessing service for version 10.0
167
configuring the geoprocessing service 167
configuring the geoprocessing service versions 10.1
and 10.2 168

archiving 201, 205
records 201
viewing results 205

ArcMap 169
configuring Infor EAM and ESRI 169

associations 37
documents 37

auditing  48–50
administering comments and custom field flags 49
attributes for tables 48
purging records 49
setting up audit triggers 48
viewing audits for fields 50
viewing trigger status values 48

audits 50
viewing 50

B
batch  128

uploading documents for import configuration 128
boiler text 29

displaying where used 29
business rules 50

defining Flex SQL statements 50

C
capital request categorization codes 47

defining 47
charts 85, 121–122

adding to user groups 85
associating with user groups 122
setting up 121

classes  39–40
associating custom fields 40
defining 39

classes and custom fields 40
defining 40

closing periods 34
defining 34

code-structure combinations 45
columns  74

defining repositories for enterprise searches 74
configuration 72, 123, 127–129, 131

export and import 123
exporting base 129
exporting screens 127
exporting task plans and job plans 128
importing base 131
Oracle Forms report for Infor EAM 72

cost codes 29, 194
associating with fleet customers 194
defining 29

custom fields 25–27, 40, 49, 124
administering comments, audit flags 49
associating classes 40
defining 25
entities 27
exporting 124
lookup values 26

custom reports  126
exporting 126

custom screens 20
defining URL parameters 20

custom tabs 20
defining for screens 20

customers 194
associating cost codes with fleet customers 194

D
data collection  153

data flow 153
overview 153

database views 141
defining 141

Dataspy 22
associating to users on screens 22
viewing for screens 22
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documents 36–38, 128
accessing external 38
defining 36
removing association 37
uploading in a batch for import configuration 128

E
e-mail 52–53, 55–56, 58

creating 53
notification conditions 53, 56
parameters 53, 55
purging records 53, 55
selecting multiple recipients 53
templates, Messenger 52
viewing 58

electronic records 107–110
cGMP 110
creating records and signatures 107
defining 108
signing 109

enterprise  72–74
defining repository columns for searches 74
generating search definitions 74
setting up repositories for searches 73
setting up searches 72

enterprise locations 79
organizations 79

entities 16
definition 16

equipment  166, 275
default screen navigation 275
defining features defined prior to integration GIS 166

equipment criticality 211
defining for equipment setup 211

equipment setup 209–211
defining 209
defining equipment criticality 211
defining equipment statuses 209
defining equipment types 210

equipment statuses 209
defining for equipment setup 209

ESRI 166, 177–178, 181
creating GISOBJID fields for layers manually 166
defining field mappings for attributes GIS 178
defining Infor EAM user informatio 177
defining preferences for the creation of Infor EAM
equipment 181

export configuration  123–129
alerts 127
base 129
custom fields 124
custom reports 126
Flex SQL statements 125
inbox items 124
KPIs 123
screens 127
task plans and job plans 128

export configuration  (continued)
user defined grids 126
web service prompts 125

extensible framework  74
customizing 74

F
field filters  41

setting up for screens 41
fields 21, 23, 133–135

defining for user defined screens 23
modifying display properties 134
modifying labels 135
moving 133
remembering for forms 21

fiscal years 77, 80
defining 77, 80

fleet codes 188–190, 198
creating billing codes 188
creating markup codes 190
replacing cost codes 198
setting up rates for billing codes 189
setting up rates for markup codes 190

fleet configuration 183, 185–188
creating exceptions 186
granting vehicle ticket authorizations 187
setting up billing schedules 185
tracking fuel costs 187
tracking maintenance costs 188
understanding 183

fleet customers 192, 194, 196–197
associating with billing codes 194
associating with cost codes 194
setting up 192
viewing billing histories 196
viewing fleet bill adjustment transactions 197
viewing fleet bill transactions 196

flex SQL 50, 123, 125
defining business rules 50
export and import configuration 123
exporting statements 125

G
GIS 163–169, 175–176, 178, 181–182, 234

configuring ArcMap for equipment creation ESRI 169
configuring geoprocessing for ArcGIS server versions
10.1 and 10.2 168
configuring geoprocessing service for the ArcGIS
server 167
configuring Infor EAM and ESRI's ArcMap 169
configuring the geoprocessing service for the ArcGIS
server 167
creating GISOBJID fields for layers manually ESRI
166
customizing map symbols 175
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GIS (continued)
defining equipment for features defined prior to
integration 166
defining field mappings for attributes ESRI 178
defining preferences for the creation of GIS features
Infor EAM 182
defining preferences for the creation of Infor EAM
equipment ESRI 181
granting interface permissions for data filter grids
Infor EAM 176
install parameters 234
installing or upgrading Infor EAM GIS extensions 164
modifying installation parameters 169
software requirements and pre-installation checklist
163
understanding integration 165

global text changes  28
defining 28

grid designer  139, 141
defining fields 139
defining validation 141

grids 137
defining 137

H
hyperlinks 142

setting up 142

I
import configuration  128

importing files 128
uploading documents in a batch 128

importing  128
files 128

inboxes 104, 113–115, 124
associating users 104
associating with user groups 115
associating with users 115
defining entries 113
defining ranges 114
exporting items 124
personalizing 113

installation parameters 15–16, 52, 169, 217–218, 232, 
240, 246, 249–250

barcode 217
base 218
defining 15
defining for Messenger 52
GIS 169
Infor EAM 232
materials 240
miscellaneous 246
purchasing 246
setting up 16
understanding 217

installation parameters (continued)
URL 249
work 250

installing or upgrading Infor EAM GIS extensions 163–
164

software requirements and pre-installation checklist
163

integration 165
understanding GIS 165

interface configuration 142
setting up hyperlinks 142

interface permissions 83, 176
granting for data filter grids GIS 176
granting for user groups 83

iProcure security 94
administering for user groups 94

J
JavaScript  74

customizing extensible framework 74
job plans  128

exporting 128
jobs 161

setting up 161

K
KPIs 104, 116, 118–121, 123

associating users 104
associating with users 119
defining 116
defining ranges 118
defining structures 120
exporting 123
personalizing 116
viewing history 121

L
languages 30–34

adding new 30
boiler text records 32
code description text records 33
error text records 33
installing 31
making available 31
menu text tab records 34
refreshing installed 32
selecting 30

LDAP roles 105
locales 35

creating 35
log files 151

viewing 151
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M
maps 175

customizing symbols GIS 175
materials  284

default screen navigation 284
materials setup 213

defining 213
menu structures 95

viewing for user groups 95
menus 91, 269, 275, 284, 289, 291, 294

administration screens 269
copying 91
equipment screens 275
materials screens 284
operations screens 289
purchasing screens 291
work screens 294

Messenger 52
installation parameters 52
setting up 52

Mobile 95
setting up menus in EAM 95

modifying 136–137
designer 136–137

multi-organization security 77, 81
activating 77, 81
implementing 77

N
navigating 269

Infor EAM default screen locations 269

O
operations  289

default screen navigation 289
operator checklists  44

specifying for screen setup 44
Oracle Forms reports 71–72

configuring Infor EAM 71
creating the configuration for Infor EAM 72

organizations  71, 77–78, 80, 103, 257–261
adding options 80
associating users 103
creating report structures 71
defining 77–78
list of base options 257
list of Call Center options 257
list of Equipment options 258
list of Materials options 259
list of Purchasing options 260
list of Work options 261

Overview screen 123
modifying 123

P
parameters 140, 183, 217–218, 232, 234, 240, 246, 249–
250

barcode 217
base 218
creating for fleet configuration 183
defining for grid designer 140
GIS 234
Infor EAM 232
materials 240
miscellaneous 246
purchasing 246
understanding 217
URL 249
work 250

permissions 95
viewing for user groups 95

printers 38
setting up 38

prompts 160
entering data 160

purchasing 291
default screen navigation 291

purchasing setup 211–213
defining 211
defining expense types 212
defining purchase order and transaction statuses 213
defining requisition statuses 212

Q
queries 141, 153

defining 153
defining views 141

R
records 201, 205

archiving 201
viewing archive results 205

regions 68–70
creating codes 68
getting actual temperatures 70
purging temperature records 70
recording actual temperatures 69
temperatures 69

reports  71
creating organization structures 71
temperature analysis chart 71

repositories  73–74
defining for enterprise searches 74
setting up for enterprise searches 73

return transaction prompts 159
defining 159
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S
scanner 92–93, 160, 162

adding main menu folders 92
adding sub-menu folders 93
correcting transaction errors 162
setting up for user groups 92
viewing transactions to be processed 160

screen designer 132–133, 135–136, 142
displaying pages 133
keyboard shortcuts 133
modifying block display properties 135
modifying block labels 135
modifying function button display properties 136
web service prompts 142

screen setup  41–42
setting up classes 42
setting up field filters 41

screens 17, 20, 22–23, 43–44, 123, 127, 269, 275, 284, 
289, 291, 294

administration 269
associating Dataspies to users 22
creating and modifying 17
creating user defined 22
default navigation 269
defining custom tabs 20
defining fields for user defined screens 23
equipment 275
exporting 127
materials 284
modifying the Overview screen 123
operations 289
purchasing 291
setting up types 43
setting up work order equipment types 44
viewing associated Dataspies 22
work 294

searches  72–74
defining repository columns for enterprise 74
generating enterprise definitions 74
setting up enterprise 72
setting up repositories for enterprise 73

security filters 87
creating 87

SQL statements 61–62, 141
defining after statements for alerts 62
defining before statements for alerts 61
defining relational database views 141

Start Center 104, 113–116, 118–121, 124
associating inboxes with users 115
associating KPIs with users 119
associating users with inboxes 104
associating users with KPIs 104
defining inbox ranges 114
defining KPI ranges 118
defining KPI structures 120
exporting inbox items 124
personalizing 113

Start Center (continued)
personalizing charts 121
personalizing KPIs 116
personalizing the inbox 113
setting up charts 121
setting up inbox entries 113
viewing KPI history 121

status 132
imports and exports 132

status change authorizations 111
granting permissions 111

system codes 16
defining 16

T
task plans  128

exporting 128
text 19

changing on specific screens 19
transaction prompts  154

GIS 154

U
URL 20

defining parameters for custom screens 20
user defined grids  126

exporting 126
user defined screens 22–23

creating 22
defining fields 23

user group menus 88–91
adding main menu folders 90
adding sub-menu folders 90
changing label names 90
changing screen tab orders 91
hiding menu items 89
showing menu items 89
understanding options 88
viewing form-level help 91

user groups 82–88, 92, 94–96, 115, 119, 122
adding charts 85
adding inboxes 84
adding KPIs 84
administering iProcure security 94
assigning KPIs 119
associating inboxes 115
associating to charts 122
creating 82
defining status authorizations 94
granting screen-level permissions 87
interface permissions 83
setting default values in mobile 96
setting up 82
setting up menus 88
setting up Mobile menus in EAM 95
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user groups (continued)
setting up scanner menus 92
store transaction permissions 86
viewing menu structure and permissions 95
work order authorization permissions 85

users 22, 83, 98, 103–104, 115, 119
associating existing Dataspies on screens 22
associating inboxes 115
associating KPIs 104, 119
associating with inboxes 104
associating with organizations 98, 103
creating 98
setting up 98
viewing 83

V
viewing 199

cost code errors 199
views 141

defining relational database 141

W
web service prompts  125, 142–145, 150

copying 150
defining 143
defining fields 145
defining retrieved values 150
defining web services 144
designer 142
exporting 125

work  294
default screen navigation 294

work orders 63–64
creating alerts 63
mapping additional fields for alerts 64

work setup 214–216
defining 214
defining work order priorities 215
defining work order statuses 215
defining work order types 216
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