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1M3 Business Engine BODs Installation
Overview

• "What is an M3 BE BOD?" on page 5

• "About This Guide" on page 6

• "Knowledge Prerequisites" on page 6

• "System Requirements" on page 6

• "Process Overview " on page 6

What is an M3 BE BOD?
M3 Business Engine Business Object Document (M3 BE BOD) is a solution that is designed to achieve
a standardized interoperability between systems used within a company’s infrastructure. M3 BE BODs
are based on an Infor standardized subset of the architecture set by Open Application Group Integration
Specification (OAGIS). A BOD contains a pre-defined business message structure as well as an
information to tell the receiver what information that is included. The BOD structure also allows for a
standardized two-way communication between sender and receiver to be able to communicate status
and error conditions. Thanks to the use of this global architecture, Infor achieves a common
understanding of both usage and content of the created BODs. Systems that has adopted the standard
can easily be integrated to each other without the need for the, otherwise normally needed, modifications
and projects to create the technical integration.

Infor systems, that has adopted this standard, uses Infor ION as the common mechanism to transport
BODs throughout the company infrastructure.This means that any system connected to ION can listen
to BODs sent by any other system, and in this way can be synchronized easily with the item information,
for instance, controlled by another system, that is the System Of Record (SOR). Thanks to the use of
the standardized transportation, none of the systems that consumes or creates BODs need to be aware
of the other participants of the infrastructure.This none-awareness eliminates a large hurdle in achieving
an integration that otherwise requires a large project to solve and thus further simplifies the work to
integrate systems.
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About This Guide
This guide provides information on installing and configuring M3 BE Business Object Documents (M3
BE BODs), including configuration guidelines for incoming and outgoing partner agreements.

Knowledge Prerequisites
Installing and configuring M3 BE BODs should be performed by consultants who have previous
experience in the following products (listed in the order of priority):

• installing and configuring messages in M3 Enterprise Collaborator (MEC)

• using MEC Mapping Manager and the Partner Administarion Tool.

• installing and configuring applications in the Lawson Grid

• installing and configuring the M3 Business Engine and M3 Foundation

System Requirements
The following software components must be installed before installing this product.

NotesComponent

For detailed information, refer to M3 Business Engine and M3
Foundation Installation Guide.

M3 Business Engine

For detailed information, refer to M3 Business Engine and M3
Foundation Installation Guide.

M3 Foundation

For detailed information, refer to Lawson Grid Installation Guide.Lawson Grid

For detailed information, refer to M3 Enterprise Collaborator Server
and Client Tools Installation Guide.

M3 Enterprise Collaborator

For the complete list of required software components, refer to the M3 Business Engine BODs Release
Notes.

Process Overview

NotesTask
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See instructions in "Installing M3 Business Engine
BODs" on page 8 .

Verify the pre-installation
requirements

1

See instructions in "Installing M3 Business Engine
BODs" on page 8.

Download and Deploy M3 BE BODs2

See instructions in "Post Installation" on page 12 .Complete the post-installation steps3

See instructions in "Generic Partner Agreement
Configuration Settings" on page 22 .

Configure partner agreements4

See instructions in "Data Translations Settings for
Business Messages" on page 35 .

Set up data translation, when
applicable

5
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2Installing M3 Business Engine BODs

• "Downloading M3 BE BODs" on page 8

• "Installing Rules Packages in EventHub " on page 9

• "Importing M3 BE BODs into M3 Enterprise Collaborator Mapper Tool" on page 9

• "Deploying M3 BE BODs in M3 Enterprise Collaborator (MEC)" on page 10

Before you start Use the following verification checklist before start installing M3 BE BODs in the M3
Enterprise Collaborator (MEC) Mapping Manager.
• Verify that the required fixes for the latest version of M3 BE BODs are installed. For the complete

list of fixes, refer to the M3 Business Engine BODs Release Notes.

Information about how to install fixes can be found in the respective product installation guides,
available on the product download pages.

• Verify your Partner Administration Tool and MEC Mapping Manager Installation. For further
information, refer to the M3 Enterprise Collaborator Server and Client Tools Installation Guide.

• Verify that you have the latest version of the EventHub installed. For further information about the
installation, refer to the Lawson Grid Extensions Installation and Administration Guide, available
on the product download pages.

• Verify that MEC and EventHub is running on the same Grid.

Important: Installing M3 BE BODs are based on common mapping processes in the M3 Enterprise
Collaborator Mapping Manager. It is recommended to review the following documents prior or during
the installation process:
• M3 Enterprise Collaborator Mapping Manager User Guide

• M3 Enterprise Collaborator Partner Admin Tool User Guide

Downloading M3 BE BODs
The following components available on the download page will be required for your installation.
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ContainsProduct nameDownload page

M3BEBOD_[version nr].
zip

Mappings and rules for M3 BE
BODs

Business Object Documents (BODs)
for M3 Business Engine

Note: Save and unpack the installation file before proceeding with the installation.

Installing Rules Packages in EventHub

Proceed with the following steps to install Rules Packages in Event Analytics.
___1 In the Lawson Grid, open the Grid Management pages, and navigate to your EventHub installation.

___2 Open the Management Pages for EventHub and navigate to Event Analytics > Rules Package.

___3 Browse to the folder where the downloaded Rules Packages are located.

Select the rules package (with extension name of .rulespack) to install.

___4 Click Install selected file.You can follow the installation stages at the Install result dialog.

___5 After installation is complete, the installation results are shown.

___6 To install further rules packages, navigate to Main Page and repeat the installation process above.

___7 To verify the installation, navigate back to Event Analytics page. The installed rules packages
are displayed as different sessions, in status started.

Important: The rules are activated by default.You need to stop the rules until they are ready to
be used.

Importing M3 BE BODs into M3 Enterprise Collaborator Mapper
Tool

Proceed with the following steps to add the compressed BOD mapping file (called *.zap) into a M3
Enterprise Collaborator (MEC) Mapping Project.

❏ Creating a New MEC Mapping Project

Start Eclipse and navigate to File > New > Other.•

• Choose MEC Mapping – MEC Mapping Project… Click Next.
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• On New Mapping Project window, type the project name M3BE[version nr]_BOD_[version
nr] and click Finish.

• Verify that the newly created project is listed in the Package Explorer tab on the left pane.

Note: You can create several MEC Mapping Projects and later select the project where
you want to place your Mappings.

❏ Importing Mappings

In Eclipse, navigate to File > Import.•

• Select MEC Mapping > Archive File. Click Next.

• On Import Mapping window, click Browse to select the folder location of the target project,
and to navigate to the compressed BOD mapping file (called *.zap), respectively. Click
Finish.

A Successful archive file import is shown in the Package Explorer tree view. Repeat the steps above
until all Mappings are imported into the M3 Enterprise Collaborator Mapping Manager.

Deploying M3 BE BODs in M3 Enterprise Collaborator (MEC)

To use a mapping, save it first to the M3 Enterprise Collaborator database associated with the MEC
Server, and then deploy it to the MEC Server.

Before you start
• Verify the following connectivity settings for MEC Mapping:

• MEC Database Connectivity Settings

• MEC Server Connectivity Settings

For detailed instructions, refer to the M3 Enterprise Collaborator Manager User Guide.

• Ensure that you have defined the location of a Map Generator associated with the MEC Server.
For further instructions on MapGen Server Configuration settings, refer to the M3 Enterprise
Collaborator Administration Guide.

___1 In Eclipse, navigate to Package Explorer.

___2 Navigate to a mapping by selecting a project and expanding the tree view.

Open the mapping by double-clicking the .map file from the expanded tree view.

The mapping is displayed in the Mapping Editor in a compressed state. The schemas are shown
in hierarchical tree view.

___3 To Save the mapping, right-click on the Mapping Editor view > Mapping Database > Save.
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Select the MEC database where to save the mapping. Click Finish

___4 To Publish the mapping, right-click on the Mapping Editor view > Server > Publish.

___5 Select the server location where to publish the mappings. Click Next.

___6 Select the MEC database server where to publish the mappings. Click Finish.

___7 At the Publish Mapping Progress dialog, the publishing results are displayed. Click OK.

For further information and instructions, refer to the M3 Enterprise Collaborator Mapping Manager User
Guide.
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3Post Installation

After installing and deploying M3Business Engine BODs, you need to set up and configure the partner
agreements in the M3 Enterprise Collaborator Partner Admin Tool.

• "Target and Target Groups Overview" on page 12

• "Creating XML Targets for M3 BE Outbound Messages" on page 12

• "Creating XML Target Groups" on page 14

• "Setting MECEventHubSubcriber Channel Objects" on page 15

• "Managing EventHub Subscribtions " on page 18

• "Creating Partner Agreement Folder Structure" on page 20

Target and Target Groups Overview
A target is a unique path to a single XML element, a single XML attribute, or a single position-based
field in a flat file that is used for message detection. The XML element and XML attribute is defined by
its absolute XPath.

A target group is a group of XML or flat targets used for message detection. There are two different
target groups, the XML targets and Flat File targets. When detecting a message envelope you have
one target group that corresponds to the envelope.

The XML targets included in the target group defines all elements and/or attributes in the XML envelope
that are used for detection.You can use any element in the XML document for detection, however,
you do not need to use an envelope.

In flat file targets you can detect on several position-based fields in one or more records. These
position-based fields are defined by the flat targets included in the target group. These records are
delimited by record separators such as CRLF.

Creating XML Targets for M3 BE Outbound Messages

To add new XML targets in Partner Admin Tool, follow these steps:
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Note: XML targets and target groups are generic for all M3 BE outbound messages. For detailed
information about XML targets and target groups for inbound messages, see "Partner Agreement
Settings when M3 BE is SOR" on page 22 and "Partner Agreement Settings when M3 BE is not SOR"
on page 29.

___1 In Partner Admin Tool, click Manage > Detections.

___2 Navigate to Targets tab > XML tab > New.

___3 On Create new target window, enter a unique Name, Description, and Path information.

Create the following XML targets (recommended target names and path information):

Important: Default Namespace URI fields should be left blank for all targets.

The Path for the XML element should start with a slash ("/").

• hub:1_publisher

hub:1_publisherName

Event Hub event publisherDescription

/EventData/PublisherPath

Default Namespace URI

• hub:2_documentname

hub:2_documentnameName

Event Hub event document nameDescription

/EventData/DocumentNamePath

Default Namespace URI

• hub:4_elementname01

Note: hub:3_ is saved for future use. Default Namespace URI should be left blank.

hub:4_elementname01Name

Event Hub event document element name #01Description

/EventData/Document/ElementData/Name[1]Path
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Default Namespace URI

• hub:5_elementvalue01

hub:5_elementvalue01Name

Event Hub event document element value #01Description

/EventData/Document/ElementData/Value[1]Path

Default Namespace URI

___4 Click OK to save your new XML target.The new XML target is now listed in the XML tab contents.

Creating XML Target Groups

Use this procedure to create and arrange XML target groups.
___1 In Partner Admin Tool, click File > Manage > Detections.

___2 Navigate to Target Groups tab > XML tab > Create group.

___3 Create the following Target Groups:

AnalyticsHubValue01

AnalyticsHubValue02

___4 Click Create to store the new XML target groups in the MEC database.

___5 Go to Target Groups > XML tab and select a Target Group from the Available Target Groups
panel.

For target group AnalyticsHubValue01, add the following required targets from the Unused
Targets pane to the Targets for Selected group pane.

• hub:1_publisher

• hub:2_documentname

• hub:4_elementname01

• hub:5_elementvalue01

For target group AnalyticsHubValue02, add the following required targets from the Unused
Targets pane to the Targets for Selected group pane.

• hub:1_publisher

• hub:2_documentname
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• hub:4_elementname01

• hub:5_elementvalue01

• hub:6_elementname02

• hub:7_elementvalue02

Click Save.

___6 On Partner Admin Tool menu, click File > Manage > Detection.

___7 Click on Detection Order tab.

___8 With the help of the directional buttons, move the target groups in the following order from the
Unused panel to the Used panel.

• AnalyticsHubValue02

• AnalyticsHubValue01

Setting MECEventHubSubcriber Channel Objects

The MECEventHubSubscriber channel is used to receive events (messages) that are published by
other application through the Event Hub application. To be able to use MECEventHubSubscriber you
need to add subscriptions. Subscriptions are predicates indicating that a subscriber is to receive a
particular event.

For more information, see the EventHub topic in Lawson Grid Administration Guide.

Important: MEC and EventHub must be running on the same Grid.

___1 To set up new receive channels, navigate to Manage > Communication > Receive tab > New in
Partner Admin Tool.

___2 Set the following properties for each M3 BE BOD receive channel below.

• MECEventHubSubscriber Channel settings: Subscriber channels

Note: The name of the receive channel is used later in partner agreement set up. Add a
unique, descriptive name to the receive channel.

MEC-M3_In_[BE Env
Name]_NonOrdered

MEC-M3_In_[BE Env
Name]_Ordered

Name

EventHub SubscriberEventHub SubscriberProtocols
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MEC-M3_In_[BE Env
Name]_NonOrdered

MEC-M3_In_[BE Env
Name]_Ordered

Name

Default value: 0Default value: 0DetectionOverride

Indicates if a channel is fixed to a
particular detection group.

Default value: 0Default value: 1Ordered

Activates message ordering.

Default value: 1Default value: 1PersistFlag

Activates persistance.

33Priority

Sets the Prioritization of messages
received into this channel (1-3)

Default value: anyDefault value: anyRunOnHost

Set to which host to run the channel.

Default value: 0Default value: 1SetVariationId

Set a variation id on all incoming
messages

Default value: 0

(disables this feature)

Default value: 0

(disables this feature)

StopTimeOut

Number of milliseconds MEC waits
during a stop before terminating the
channel

• MECEventHubSubscriber Channel settings: IONDbIn channels

Note: The name of the receive channel is used later in partner agreement set up. Add a
unique, descriptive name to the receive channel.

ION_In_[BE Env Name]_
NonOrdered

ION_In_[BE Env Name]_
Ordered

Name

IONDbInIONDbInProtocols
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ION_In_[BE Env Name]_
NonOrdered

ION_In_[BE Env Name]_
Ordered

Name

Default value: 5010BatchSize

The maximum number of
messages to process at
each run

Default value: 50

All inbound NonSync BODs

Acknowledge.BillOfMaterials,

All inbound BODs with
variation ID

Sync.BillOfMaterials

BODTypes

A comma separated list of
Bod types to handle in this
instance

Show.BillOfMaterials,

Process.ItemMaster,

Process.CustomerPartyMaster,

Process.BillToPartyMaster,

Process.PayFromPartyMaster,

Process.SalesOrder,

Process.ShipToPartyMaster

The JDBC connection uri

Example:

The JDBC connection uri

Example:

ConnectionUri

jdbc:sqlserver://host:port;
databaseName=DB_name

jdbc:sqlserver://
host:port;
databaseName=DB_
name

50005000DelayTime

Default value: 10000

The JDBC driver class

Example:

The JDBC driver class

Example:

DriverClass

com.microsoft.sqlserver.jdbc.
SQLServerDriver

com.microsoft.
sqlserver.jdbc.
SQLServerDriver

01Ordered

Indicates if a channel
processes messages in an
ordered way (0 or 1)
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ION_In_[BE Env Name]_
NonOrdered

ION_In_[BE Env Name]_
Ordered

Name

Database passwordDatabase passwordPassword for ION in/out
DB

Database userDatabase userUsername for ION in/out
DB

___3 When created, click OK on the dialog and mark the Enabled checkbox to make the channels
available for further edit.

Managing EventHub Subscribtions

Use this procedure to set up EventHub Subscribtions and to define the order M3 Enterprise Collaborator
should handle the incoming BODs.
___1 In Partner Admin Tool, navigate to Manage > EventHub Subscriptions > New and set up the

following EventHub Subscriptions for M3 BE BODs.

Important: The name of a subscription must match the name in the rule.

Example: In case

Event $OOHEAD_Create = new Event("SyncSalesOrder", EventOperation.CREATE)

the name of the subscription should be EventAnalytics:SyncSalesOrder.

M3 [Noun Mapping].ShowName

M3 Show[Noun Mapping]Description

EventAnalytics:Show[Noun Mapping]Subscription

M3 [Noun Mapping].SyncName

M3 Sync[Noun Mapping]Description

EventAnalytics:Sync[Noun Mapping]Subscription

M3 [Noun Mapping].AcknowledgeName
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M3 Acknowledge[Noun Mapping]Description

EventAnalytics:Acknowledge[Noun Mapping]Subscription

M3 [Noun Mapping].ProcessName

M3 Process[Noun Mapping]Description

EventAnalytics:Process[Noun Mapping]Subscription

Note: For complete list of M3 BE BODs with Noun mapping names, see "List of Available Noun
Mappings" on page 39 as a reference.

Agreement names and EventHub subscription names for outbound BODs are also available in
the installation package as separate .txt.

For detailed instructions about EventHub subscription channel set up, refer to the M3 Enterprise
Collaborator Partner Admin Tool User Guide.

___2 After creating each subscription, assign the subscriptions to the MECEventHubSubcriber channel
by editing the Subscription. Double-click on the EventHub subscriptions to assign them to the
correct receive channel.

Important: Each subscription should be associated with only one subscriber channel. See
recommended settings below.

Channel AssignmentEventHub subscription

MEC-M3_In_[BE environment name]_
Ordered

M3 [Noun Mapping].Sync

MEC-M3_In_[BE environment name]_
NonOrdered

M3 [Noun Mapping].Show

M3 [Noun Mapping].Acknowledge

M3 [Noun Mapping].Process

Note: For [BE environment name], use the name of the corresponding M3 BE environment.

For complete list of M3 BE BODs with Noun mapping names, see "List of Available Noun
Mappings" on page 39 as a reference. Agreement names are also available in the installation
package, in the M3BEBODs_[ver]_Agreement_names.txt file.
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Creating Partner Agreement Folder Structure

A Partner Agreement contains the agreement information between you and your partners. This
agreement information is needed by M3 Enterprise Collaborator (MEC) to send and receive business
messages between you and your partners.

Use this procedure to create and manage partner agreements for M3 BE BODs in Partner Admin tool.
___1 To create a new group, open Partner Admin Tool > Agreement View tab.

___2 Right-click the Agreement area or the node within which you want to create a new group.

___3 Click Insert Group and name the newly created folder according to the recommendations below.

Tip: It is recommended to set up the following folder names and structure:

• M3BE

• InitialLoad - for partner agreements used for initial load agreements.

• ION - for partner agreements where the System of Records is M3 BE

• Application - for partner agreements where the System of Records is the application (and
not M3 BE)

___4 Add group control properties:

Applicable forValueControl Properties
Name

InitialLoadAgreementsChange Value to the lid for the receiving
application.

ionToLogicalId

Application
Value is according to ION Connection Point

lid://infor.[application name].[environment name]

Important: This value is case sensitive and
must exactly match the Logical ID value in ION
Connect.

InitialLoadAgreements

ION

lid://infor.m3be.[BE environment name]ionFromLogicalid

___5 To create a new agreement, right-click a node and click Insert Agreement. The newly created
agreement appears on the right panel.

Insert the following partner agreements for the ION and other, application specific folder:
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Partner agreementsFolder

M3BE_Out_Show[Noun Mapping]InitialLoadAgreements

M3BE_Out_Sync[Noun Mapping]ION

M3BE_In_Process[Noun Mapping]

M3BE_Out_Acknowledge[Noun Mapping]

M3BE_In_Sync[Noun Mapping]Application

M3BE_Out_Process[Noun Mapping](for BODs where M3 BE is not
SOR) M3BE_In_Acknowledge[Noun Mapping]

For complete list of M3 BE BODs with Noun mapping names, see "List of Available Noun
Mappings" on page 39 as a reference. Agreement names are also available in the installation
package, in the M3BEBODs_[ver]_Agreement_names.txt file.
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4Generic Partner Agreement Configuration
Settings

• "Partner Agreement Settings when M3 BE is SOR" on page 22

• "Partner Agreement Settings when M3 BE is not SOR" on page 29

Partner Agreement Settings when M3 BE is SOR

Use the settings below as a reference to configure partner agreements in MEC Partner Admin tool
where M3 BE is the System of Record. Depending on integration scenarios and the purposes to use
M3 BE BODs, ýou need to setup only those partner agreements that you are planning to use.
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Before you start
___1 In Partner Admin Tool, go to Manage > Detections > Targets tab > XML tab > New > Create new

target and specify the following targets (valid for all inbound BODs):

ExamplesGeneral

ION:ProcessCustomerPartyMasterTenantIdION:[Verb][Noun]TenantIdName

ION BOD ProcessCustomerPartyMaster
TenantID

ION BOD [Verb][Noun]
TenantID

Description

/ProcessCustomerPartyMaster/DataArea/
Process/TenantID

/[Verb][Noun]/DataArea/[Verb]/
TenantID

Path

http://schema.infor.com/InforOAGIS/2http://schema.infor.com/
InforOAGIS/2

Default
Namespace URI

For nouns with data on different Divisions set the AccountingEntity target as well.

ExamplesGeneral

ION:ProcessCustomerPartyMasterAccountingEntityION:[Verb][Noun]
AccountingEntity

Name

ION BOD ProcessCustomerPartyMaster
AccountingEntity

ION BOD [Verb][Noun]
AccountingEntity

Description

/ProcessCustomerPartyMaster/DataArea/Process/
AccountingEntityID

/[Verb][Noun]/DataArea/
Process/ AccountingEntity

Path

http://schema.infor.com/InforOAGIS/2http://schema.infor.com/
InforOAGIS/2

Default
Namespace
URI

Note:  AccountingEntity can be targeted on the ID tag as well.

___2 Go to Target Groups tab and create the ION[Verb][Noun] Target Group. Add the previoulsy
created targets to this group.

___3 Add Target Group ION[Verb][Noun] to the list of available detections under Detection Order tab.

Use the settings below as a reference to configure partner agreements in MEC Partner Admin tool
where M3 BE is the System of Record.

For complete list of M3 BE BODs with Noun mapping names, see "List of Available Noun Mappings"
on page 39 as a reference. Agreement names are also available in the installation package, in the
M3BEBODs_[ver]_Agreement_names.txt file.

___1 Basic
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Name of the noun mapping, see "List of Available Noun Mappings"
on page 39.

Name

Description for the agreement (Optional)Description

Creator of the agreement (Optional)Creator

General information (Optional)Email

___2 Detection

Choose Target Group AnalyticsHubValue01 and specify the following values:

Target ValueTarget XPathTarget Name

EventAnalytics/EventData/Publisherhub:1_publisher

[Verb][Noun Mapping]/EventData/DocumentNamehub:2_documentname

CONO/EventData/Document/ElementData/
Name[1]

hub:4_elementname01

[M3 BE Company number]/EventData/Document/ElementData/
Value[1]

hub:5_elementvalue01

For M3BE_In_Process[Noun], set up the following detection:

Choose Target Group IONProcess[Noun] and specify the following values:

ION:Process[Noun Mapping]TenantIDTarget Name

/Process[Noun Mapping]/DataArea/Process/TenantIDTarget XPath

M3 BE Company numberTarget Value

Important: If you leave an empty target value, the agreement will not be detected.

___3 Applicable Processes

The table below lists the available processes for Partner Agreement Settings when M3 BE is
SOR.

To modify a process, right-click the selected process area.
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NotesProcess Name

To enable MEC to handle several messages parallel, Check Order can be
added. If not specified, all messages will be handled in a sequence.

Check Order

• To specify Check Order, click Add and insert the following value for
the first Primary Key Xpath:

/EventData/Document/ElementData[1]/Value

• To differentiate each agreement (BOD), add as many Primary Key
Xpath to the Partner agreement as the number of key fields in the
corresponding master table in M3 BE:

/EventData/Document/ElementData[2]/Value

/EventData/Document/ElementData[3]/Value

/EventData/Document/ElementData[4]/Value

For the number of Primary Key XPaths, see "List of Available Noun
Mappings" on page 39

Archives a message in the MEC Archive folder (recommended).Archive

API Reference: set to API reference for M3 BE environment

Schema Location: enter the schema location for the mapping (see next
table)

XML transform

Note: For incoming process mappings, use the matching acknowledge
schema.

Important: Mark the Delete empty elements during transformation checkbox

Mapping: enter the file name for the mapping (see next table)

Envelope template: XML Declaration

Envelope encoding: UTF-8

Apply Envelope

Archives a message in the MEC Archive folder (recommended).Archive

This process will validate the outgoing XML-file with the schema in the XML
transform step (optional).

Validate

Choose the ION_Out channel (with IONDbOut protocol) for M3 BE
environment.

Send

Use the processes in the specified order (see below) to confgure the listed BOD types.

Tip: Schema location and Mapping names are also available in the installation package, in
M3BEBODs_[ver]_Schema_locations.txt and in M3BEBODs_[ver]_Mappings.txt, respectively.

M3 Business Engine BODs Installation and Configuration Guide | 25



Applicable processes in
order

ContentAgreement Name

1. Check OrderSchema Location:M3BE_Out_
Sync[Noun] 2. Archivehttp://schema.infor.com/[ver]/InforOAGIS/

BODs/Developer/Sync[Noun].xsd 3. XML transform
Mapping name: 4. Apply Envelope
M3BE14_[M3 BE Suite name]_Out_ION_
Sync[Noun]_[ver nr separated by
underscore]

5. Archive

6. Validate

7. Send

1. XML transform

2. Apply Envelope

Schema Location:

http://schema.infor.com/[ver]/InforOAGIS/
BODs/Developer/Show[Noun].xsd

M3BE_Out_
Show[Noun]

3. Send
Mapping name:

M3BE14_[M3 BE Suite name]_Out_ION_
Show[Noun]_[ver nr separated by
underscore]

1. Archive

2. XML transform

Schema Location:

http://schema.infor.com/[ver]/InforOAGIS/
BODs/Developer/Acknowledge[Noun].xsd

M3BE_In_
Process[Noun]

3. Apply Envelope
Mapping name: 4. Archive
M3BE14_[M3 BE Suite name]_Out_ION_
Process[Noun]_[ver nr separated by
underscore]

5. Validate

6. Send

Note: For M3BE_In_
ProcessItemMaster, use only
the following processes:

1. Archive

2. XML transform
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Applicable processes in
order

ContentAgreement Name

1. ArchiveSchema Location:M3BE_Out_
Acknowledge[Noun] 2. XML transformhttp://schema.infor.com/[ver]/InforOAGIS/

BODs/Developer/Acknowledge[Noun].xsdImportant: Valid
only for nouns
using batch entry
in M3 BE.

3. Apply Envelope

4. Archive

5. Validate

6. Send

Mapping name:

M3BE14_[M3 BE Suite name]_Out_ION_
Acknowledge[Noun]_[ver nr separated by
underscore]

___4 Error Handling

Important: Error Handling is only applicable for incoming partner agreements.

NotesProcess NameOrder

Crt ConfirmBOD1

Choose the ION_Out channel (with IONDbOut protocol)
for M3 BE environment.

Send2

API Reference: set to API reference for M3 BE
environment

XML transform3

Schema Location:  not specified

Mapping:  M3BE14_[M3 BE Suite name]_Error_Out_
Acknowledge[Noun]_[ver nr separated by underscore]

Envelope template: XML Declaration

Envelope encoding: UTF-8

Apply Envelope4

Choose the ION_Out channel (with IONDbOut protocol)
for M3 BE environment.

Send5

___5 When the partner agreement setup is completed, reload the agreement information for the MEC
Server in Grid > MEC Management Pages > Reload.

❏ M3 BE Settings for ProcessItemMaster

In order to receive and process M3BE_In_ProcessItemMaster, partner settings must be configured
in MMS865 for M3 BE.

Important: These steps are only valid for M3BE_In_ProcessItemMaster.
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___1 Set a valid Item type with Template item and Item numbering rule according to the following:

• CRS040 – Item type

The item type should be set with status 10 in CRS040/E

• MMS001/MMS002/MMS003 – Template item

• MWS050 and MWS051 – Item Numbering rule

___2 In MMS865/B, use the following settings:

Leave blankWhs

Set to IMsg

Set to the ION componentID of the system that sends the
ProcessItemMaster.

Partner

Currently, only PLM is valid.

Set to BODMsg type

___3 In MMS865/E, use the following settings:

Set to the M3 user that is managing the partner settings for
this record

Partner manager

Set to the item type that will control which data is the default
per item and how the item numbering is done.

Default Item type

❏ M3 BE Settings for CustomerStructure

In order to receive and process the following partner agreements, you must create a specific
template customer in M3 BE.

M3BE_In_ProcessCustomerPartyMaster•

• M3BE_In_ShipToPartyMaster

• M3BE_In_BillToPartyMaster

• M3BE_In_PayFromPartyMaster

___1 In CRS610 create the new customer IONCUST with following settings:

Customer Type = 0

___2 Fill in all mandatory fields and make sure that status is set to 20.

Important:  Do not add an Invoice recipient or Payer.
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Partner Agreement Settings when M3 BE is not SOR

Use the settings below as a reference to configure partner agreements in MEC Partner Admin tool
where M3 BE is not the System of Record. Depending on integration scenarios and the purposes to
use M3 BE BODs, ýou need to setup only those partner agreements that you are planning to use.

Before you start
___1 In Partner Admin Tool, go to Manage > Detections > Targets tab > XML tab > New > Create new

target and specify the following targets (valid for all inbound BODs):

ExamplesGeneral

ION:SyncBillOfMaterialsTenantIdION:[Verb][Noun]TenantIdName

ION BOD SyncBillOfMaterials
TenantID

ION BOD [Verb][Noun] TenantIDDescription

/SyncBillOfMaterials/DataArea/Sync/
TenantID

/[Verb][Noun]/DataArea/[Verb]/
TenantID

Path

http://schema.infor.com/InforOAGIS/
2

http://schema.infor.com/
InforOAGIS/2

Default
Namespace URI

For nouns with data on different Divisions set the AccountingEntity target as well.

ExamplesGeneral

ION:SyncBillOfMaterialsAccountingEntityIdION:[Verb][Noun]
AccountingEntity

Name

ION BOD SyncBillOfMaterials
accountninEntity

ION BOD [Verb][Noun]
AccountingEntity

Description

/SyncBillOfMaterials/DataArea/
BillOfMaterials/BillOfMaterialsHeader/
DocumentID/ID[@accountingEntity]

/[Verb][Noun]/DataArea/
Process/ AccountingEntity

Path

http://schema.infor.com/InforOAGIS/2http://schema.infor.com/
InforOAGIS/2

Default
Namespace
URI

Note:  AccountingEntity can be targeted on the ID tag as well.

___2 Go to Target Groups tab and create the ION[Verb][Noun] Target Group. Add the previoulsy
created targets to this group.

___3 Add Target Group ION[Verb][Noun] to the list of available detections under Detection Order tab.
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Use the settings below as a reference to configure partner agreements in MEC Partner Admin tool
where M3 BE is not the System of Record.

For complete list of M3 BE BODs with Noun mapping names, see "List of Available Noun Mappings"
on page 39 as a reference. Agreement names are also available in the installation package, in the
M3BEBODs_[ver]_Agreement_names.txt file.

___1 Basic

Name of the mapping, see "List of Available Noun Mappings" on
page 39.

Name

Description for the agreement (Optional)Description

Creator of the agreement (Optional)Creator

General information (Optional)Email

___2 Detection

Choose Target Group ION[Verb][Noun] and specify the following values:

Target ValueTarget XPathTarget Name

[M3 BE Division]/[Verb][Noun]/DataArea/[Noun]/
[Noun]Header/DocumentID/
ID[@accountingEntity]

ION:Sync[Noun]AccountingEntityId

[M3 BE Company
number]

/[Verb][Noun]/DataArea/Sync/
TenantID

ION:Sync[Noun]TenantId

For M3BE_Out_Process[Noun], set up the following detection:

Choose Target Group AnalyticsHubValue01 and specify the following values:

Target ValueTarget XPathTarget Name

EventAnalytics/EventData/Publisherhub:1_publisher

Process[Noun]_update/EventData/DocumentNamehub:2_documentname

CONO/EventData/Document/ElementData/
Name[1]

hub:4_elementname01

M3 BE Company number/EventData/Document/ElementData/
Value[1]

hub:5_elementvalue01
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Important: If you leave an empty target value, the agreement will not be detected.

___3 Applicable Processes

The table below lists the available processes for Partner Agreement Settings when M3 BE is not
SOR.

To modify a process, right-click the selected process area.
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NotesProcess
Name

Default Namespace: http://schema.infor.com/InforOAGIS/2Check Order

Default Namespace Prefix: dns

To enable MEC to handle several messages parallel, Check Order can be
added. If not specified, all messages will be handled in a sequence.

• To specify Check Order, click Add and insert the following value for the
first Primary Key Xpath:

Xpath: /dns:Sync[Noun]/dns:DataArea/dns:Sync/
dns:TenantID

No Attribute Existing:  Leave blank

Xpath: /dns:Sync[Noun]/dns:DataArea/dns:[Noun]/
dns:[Noun]Header/dns:DocumentID/dns:ID

No Attribute Existing:  schemeName

Xpath: /dns:Sync[Noun]/dns:DataArea/dns:[Noun]/
dns:[Noun]Header/dns:DocumentID/dns:ID[@location]

No Attribute Existing:  schemeName

Xpath: /dns:Sync[Noun]/dns:DataArea/dns:[Noun]/
dns:[Noun]Header/dns:DocumentID/
dns:ID[@accountingEntity]

No Attribute Existing:  schemeName

VID Xpath: /dns:Sync[Noun]/dns:DataArea/dns:[Noun]/
dns:[Noun]Header/dns:DocumentID/dns:ID[@variationID]

VID No Attribute Existing:  schemeName

• To differentiate each agreement (BOD), add as many Primary Key Xpath
to the Partner agreement as the number of key fields in the corresponding
master table in M3 BE:

/EventData/Document/ElementData[2]/Value

/EventData/Document/ElementData[3]/Value

/EventData/Document/ElementData[4]/Value

Archives a message in the MEC Archive folder (recommended).Archive

API Reference: set to API reference for M3 BE environment

Schema Location:  not specified

XML transform

Mapping: enter the file name for the mapping (see table below)
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NotesProcess
Name

Envelope template: XML DeclarationApply
Envelope Envelope encoding: UTF-8

Archives a message in the MEC Archive folder (recommended).Archive

Choose the ION_Out channel (with IONDbOut protocol) for M3 BE
environment.

Send

Use these processes in the specified order (see below) to confgure processes for the listed BOD
types.

Tip: Schema location and Mapping names are also available in the installation package, in
M3BEBODs_[ver]_Schema_locations.txt and in M3BEBODs_[ver]_Mappings.txt, respectively.

Applicable processes in
order

ContentName

1. Check OrderSchema LocationM3BE_In_Sync[Noun]

2. Archivehttp://schema.infor.com/[ver]/
InforOAGIS/BODs/Developer/
Sync[Noun].xsd

3. XML transform

Mapping name

M3BE14_[M3 BE Suite name]_In_
ION_Sync[Noun]_[ver nr separated
by underscore]

1. Archive

2. XML transform

Schema Location

http://schema.infor.com/[ver]/
InforOAGIS/BODs/Developer/
Process[Noun].xsd

M3BE_Out_Process[Noun]

3. Apply Envelope

4. Archive
Mapping name

5. Send
M3BE14_[M3 BE Suite name]_Out_
ION_Process[Noun]_[ver nr
separated by underscore]
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Applicable processes in
order

ContentName

1. ArchiveSchema LocationM3BE_In_
Acknowledge[Noun] 2. XML transformhttp://schema.infor.com/[ver]/

InforOAGIS/BODs/Developer/
Acknowledge[Noun].xsd

Mapping name

M3BE14_[M3 BE Suite name]_In_
ION_Acknowledge[Noun]_[ver nr
separated by underscore]

___4 Error Handling

Important: Error Handling is only applicable for incoming partner agreements.

NotesProcess NameOrder

Crt ConfirmBOD1

Choose the ION_Out channel (with IONDbOut
protocol) for M3 BE environment.

Send2

___5 When the partner agreement setup is completed, reload the agreement information for the MEC
Server in Grid > MEC Management Pages > Reload.
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5Data Translations Settings for Business
Messages

M3 Business Message Data Translations is a function that translates soft coded M3 BE data to standards
that can be understood by external systems, such as ION.

Note: Data translation is not needed when the M3 BE data is entered according to internationally
acknowledged standards (ISO, X-12 EDI, etc.).

You can set M3 Business Message Data Translations in CRS881 and CRS882 in M3 BE.

• CRS881 stores the header data for information that should be translated. This is generated via
MBMTRNUpdate in MEC Utilities client, available from your MEC installation.

• CRS882 stores the actual translation data. The date must be manually entered into M3 BE.

Entering or Editing Translation Data

Follow these steps below to set up data translation in CRS882 in M3 BE.

For data that is valid for the entire M3 BE company, data must be entered in company / *blank division.
If data is different per division, enter data for specific company / division.

Important: The translation data information must be entered for the correct company/division.

___1 Run the MEC client tool MBMTrnUpdate.cmd for the valid API reference to populate CRS881
with correct header data.

___2 Open CRS881 and filter on Msg standard ION to show all possible records generated from the
delivered BODs.

Data elementParent elementI/OMessage

UOMCodeGenericIGeneric

CountryCodeGenericIGeneric
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Data elementParent elementI/OMessage

CountryCodeGenericOGeneric

CurrencyGenericOGeneric

UOMCodeGenericOGeneric

languageCodeGenericOGeneric

CodeBillOfMaterialsHeader/statusIBillofMaterials

unitcodeBillOfMaterialsLine/quantityIBillofMaterials

CodeBillOfMaterialsHeader/statusOBillofMaterials

unitcodeBillOfMaterialsLine/quantityOBillofMaterials

CodeBillOfMaterialsLine/statusOBillofMaterials

___3 Select and right-click a business message and choose Related Options > Translate CTRL+11.

CRS882 opens.

___4 In CRS882/B1, enter the M3 BE data and Message Data

___5 Click "Create" or select Options > Create

• For Translation of Language Codes, add one record for each of the languages you want
to translate in CRS882-panel for Company / *blank division.

• The M3 BE data field should contain the M3 language code.

• The Message data field should contain the corresponding language code according to
ISO 639-1 standard.

• For Translation of Unit Of Measures, add one record for each of Unit of Measures you want
to translate in CRS882-panel for Company / *blank division.

• The M3 BE data field should contain the M3 BE Unit of Measure.

• The Message data field should contain the corresponding Unit Of Measure Code according
to X-12 EDI standard.

Note: Data translation settings must be performed for both incoming and outgoing messages.

• For Translation of Country Codes, add one record for each country code you want to
translate in CRS882-panel for Company / *blank division.

• The M3 BE data field should contain the M3 BE Unit of Measure.

• The Message data field should contain the corresponding Country Code according to
ISO 3166-1 standard.
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Note: Data translation settings must be performed for both incoming and outgoing messages.

• For Translation of Currency, add one record for each Currency you want to translate in
CRS882-panel for Company / *blank division.

• The M3 BE data field should contain the M3 BE Currency.

• The Message data field should contain the corresponding Currency code according to
ISO 4217 standard.

___6 In CRS882/E, enter the Name and Description. Press Next.

Repeat these steps for each M3 BE BOD where data translation is applicable.

M3 BE Data Translation Settings for SyncBillOfMaterials
Use these settings below to set up data translation for SyncBillOfMaterials in CRS882.

Msg standard: ION

Business msg: BillOfMaterials

Parent element: BillOfMaterialsHeader/Status/

Data element: Code

Name

for messages sent from
M3

Name

for messages sent to M3

Message dataM3 BE data

naPreliminaryPending10

PreliminaryPreliminaryInactive10

ReleasedReleasedActive20

naReleasedOpen20

BlockedBlockedDeleted90
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6Data Export via M3 Business Engine BODs:
Initial Load Scenario

Data Export via M3 BE BODs: Initial Load Scenario
To populate another system connected to ION, use the non-event driven scenario for initial load for
M3BE_Out_Show[Noun Mapping].

___1 In M3 BE, BE programs create a request event on the master table for the specific noun (see
"List of Available Noun Mappings" on page 39 as a reference). After that, the normal architecture
for BODs are used.

___2 To initiate a initial load for a noun, use MI-program – EVS002MI in MI-Test or via M3-API-WS
http://<serveraddress>:port/m3api-rest/execute/EVS002MI/Initiate?FILE=<file>

Important: Initial Load for large tables (with more than 10.000 records) takes long time. It is
recommended to run only one table a time. Ensure to have enough disk space in the MEC DB
to expand during initial load

___3 To start an export of data, use the MI transaction Initiate with the following parameters:

MandatoryFILE

It is the master table for a specific BOD, see "List of Available Noun Mappings"
on page 39 as a reference.

Number of actionsNOAL

To be used for testing purposes and to limit the number of requests for the
FILE.
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AM3 Business Engine BOD Nouns

List of Available Noun Mappings
List of Available Noun Mappings where M3 BE is System of Records (SOR)

File (Table) for M3BE_
Out_Show[Noun
Mapping]

Number of
Primary
Key
XPaths

Noun MappingName

CMNDIV4AccountingBookDefinitionM3BE_Out_
Sync[Noun
Mapping] CSYTAB2AccountingChart

CMNDIV2AccountingEntityM3BE_Out_
Show[Noun
Mapping]

CSYTAB4AccountingJournal

FFASMA4AssetMaster

OCUSMA2BillToPartyMaster

CIDMAS2CarrierParty

FCHACC4ChartOfAccounts

CSYTAB5CodeDefinitionDeliveryTerms

FCHACC5CodeDefinitionDimension

CSYTAB5CodeDefinitionGeneralCode

CSYTAB5CodeDefinitionPaymentTerms

CSYTAB5Currency

CCURRA5CurrencyExchangeRateMaster

OCUSMA2CustomerPartyMaster

OCHEAD4CustomerReturn

CSYPER5FinancialCalendar
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File (Table) for M3BE_
Out_Show[Noun
Mapping]

Number of
Primary
Key
XPaths

Noun MappingName

MITTRA6InventoryAdjustment

MITTKV3InventoryCount

MITTRA6InventoryHold

OINVOH5InvoiceCustomerOrder

MITMAS2ItemMaster

MITWHL2Location

OCUSMA2PayFromPartyMaster

FPLEDG9PayableTransaction

CMNUSR3Person

MPHEAD2PurchaseOrder

OOQUOH5Quote

FSLEDG9ReceivableTransaction

MPLIND5ReceiveDelivery

CIDMAS2RemitToPartyMaster

OOHEAD2SalesOrder

DCONSI2Shipment

MHDISH3ShipmentDelivery

CIDMAS2ShipFromPartyMaster

OCUSMA2ShipToPartyMaster

FBAKEY2SourceSystemGLMovement

FGLEDG5SourceSystemJournalEntry

CIDMAS2SupplierPartyMaster
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File (Table) for M3BE_
Out_Show[Noun
Mapping]

Number of
Primary
Key
XPaths

Noun MappingName

not applicablenot
applicable

BillToPartyMaster

CustomerPartyMaster

M3BE_In_
Process[Noun
Mapping]

ItemMaster
M3BE_Out_
Acknowledge[Noun
Mapping]

PayFromPartyMaster

SalesOrder

ShipToPartyMaster

List of Available Noun Mappings where M3 BE is not System of Records

Noun MappingName

M3BE_Out_Process[Noun Mapping]

BillOfMaterialsM3BE_In_Acknowledge[Noun Mapping]

M3BE_In_Sync[Noun Mapping]
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